Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
dev-libs/libxml +icu oder -icu
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Tinitus
Veteran
Veteran


Joined: 20 Sep 2004
Posts: 1628

PostPosted: Thu Mar 07, 2013 4:17 pm    Post subject: dev-libs/libxml +icu oder -icu Reply with quote

Hallo,

was macht man, wenn chromium + icu braucht und viele andere Pakete -icu brauchen. Ist das nur zur Build Zeit wichtig? Also im laufenden Betrieb ohne Belang?
Soll heißen erst baue ich ein Paket manuell mit und dann eines ohne bzw. umgekehrt?
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 2284
Location: Germany

PostPosted: Thu Mar 07, 2013 5:03 pm    Post subject: Reply with quote

Hm nein, durch passendes setzen der USE-Flags sollte der chromium installation eigentlich nichts im Wege stehen.
Worum geht es denn konkret? Poste am besten mal dein emerge Kommando und dessen Output - darin sollte normal ersichtlich sein was benötigt wird.
Back to top
View user's profile Send private message
Tinitus
Veteran
Veteran


Joined: 20 Sep 2004
Posts: 1628

PostPosted: Thu Mar 07, 2013 5:56 pm    Post subject: Reply with quote

chromium braucht +icu kdenlive z.B. braucht -icu

als Kommando:

Code:
emerge --update --deep --newuse world -pv


Code:
Calculating dependencies... done!

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

net-libs/libnice:0

  (net-libs/libnice-0.1.3-r1::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (net-libs/libnice-0.1.2::gentoo, installed) pulled in by
    >=net-libs/libnice-0.1.0[gstreamer] required by (net-libs/farsight2-0.0.31::bleeding-edge, installed)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


emerge: there are no ebuilds built with USE flags to satisfy "dev-libs/libxml2[icu]".
!!! One of the following packages is required to complete your request:
- dev-libs/libxml2-2.9.0-r2::gentoo (Change USE: +icu)
(dependency required by "www-client/chromium-25.0.1364.152" [ebuild])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])

 * IMPORTANT: 13 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


Dann setze ich auf +icu
Code:

Calculating dependencies... done!

emerge: there are no ebuilds built with USE flags to satisfy "dev-libs/libxml2:2[!icu?]".
!!! One of the following packages is required to complete your request:
- dev-libs/libxml2-2.9.0-r2::gentoo (Change USE: -icu)
- dev-qt/qtwebkit-4.8.4::gentoo (Change USE: +icu)
(dependency required by "dev-qt/qtwebkit-4.8.4" [ebuild])
(dependency required by "kde-base/kde-l10n-4.9.5" [installed])
(dependency required by "app-cdr/k3b-2.0.2-r4[linguas_de]" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 2284
Location: Germany

PostPosted: Thu Mar 07, 2013 7:15 pm    Post subject: Reply with quote

Tinitus wrote:
Code:
(dependency required by "dev-qt/qtwebkit-4.8.4" [ebuild])

Ah ok, schau mal ob die Info aus http://wiki.gentoo.org/wiki/Qt/FAQ
zunächst weiterhilft. (siehe dort unter "qt-webkit vs chromium block because of icu")
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 2284
Location: Germany

PostPosted: Fri Mar 08, 2013 10:24 am    Post subject: Reply with quote

Chromium fordert das dev-libs/libxml2 mit icu USE gebaut wird:
chromium.ebuild wrote:
Code:
RDEPEND="...
dev-libs/libxml2[icu]
...
Sprich, da geht kein Weg dran vorbei wenn du chromium nutzen möchtest.

Sofern aber auch dev-qt/qtwebkit installiert ist, oder als Abhängigkeit gefordert ist, dann muss auch qtwebkit mit icu Use gebaut werden.

Deine Ausgabe
Quote:
Code:
- dev-libs/libxml2-2.9.0-r2::gentoo (Change USE: -icu)
- dev-qt/qtwebkit-4.8.4::gentoo (Change USE: +icu)
ist in etwa so zu verstehen:
"Baue libxml2 ohne icu
(was du ja aber nicht willst, da vom gewünschten chromium gefordert)
oder
baue auch qtwebkit mit icu"

Sprich wenn du beide mit USE=icu baust sollten beide zufrieden sein :)
Setze am besten in der
/etc/portage/package.use
Code:
dev-libs/libxml2 icu
dev-qt/qtwebkit gstreamer icu
(gestreamer nur sofern gewünscht)
Damit sollte der chromium installation dann eigentlich nichts mehr im Wege stehen.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 2284
Location: Germany

PostPosted: Fri Mar 22, 2013 7:20 am    Post subject: Reply with quote

Ist das wirklich nicht hinzubekommen?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum