Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Sound is muted after booting a fresh gentoo installation
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
jonasstein
n00b
n00b


Joined: 03 Mar 2013
Posts: 31

PostPosted: Sun Mar 03, 2013 1:31 pm    Post subject: Sound is muted after booting a fresh gentoo installation Reply with quote

Hi,
my fresh Gentoo installation with gnome windowmanager mutes the soundcard on startup. The user has to unmute it manually after each reboot.
How can I get an unmuted soundcard after reboot?
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 31980
Location: 56N 3W

PostPosted: Sun Mar 03, 2013 1:45 pm    Post subject: Reply with quote

hathill,

You need to save the alsa settings across reboots.
Add alsasound to your default runlevel, then start the alsasound service.

When you shut down now, your settings will be saved.
When alsasound starts after your next boot, the settings will be restored.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
jonasstein
n00b
n00b


Joined: 03 Mar 2013
Posts: 31

PostPosted: Sun Mar 03, 2013 3:32 pm    Post subject: Reply with quote

I tried
Code:
# rc-update add alsasound default

but this seemed not to be sufficiant.

How can I save settings?
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 31980
Location: 56N 3W

PostPosted: Sun Mar 03, 2013 3:38 pm    Post subject: Reply with quote

jonasstein,

rc-update add alsasound default
is correct but it does not start the service, so at shutdown, you settings were not saved.

Now that you have rebooted and set up your mixer settings again, it should work on subsequent boots.
The alsasound service will have started on this boot.

Thats why I suggested that you start alsasound manually before shutdown.

Does
Code:
/etc/init.d/alsasound start
produce a waring about alsasound already being started?
It should - or an error message about why it could not be started.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
jonasstein
n00b
n00b


Joined: 03 Mar 2013
Posts: 31

PostPosted: Sun Mar 03, 2013 7:30 pm    Post subject: Reply with quote

Yes, there is a warning:
Code:
# /etc/init.d/alsasound start
 * WARNING: alsasound has already been started
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 31980
Location: 56N 3W

PostPosted: Sun Mar 03, 2013 7:40 pm    Post subject: Reply with quote

jonasstein,

It should save your settings when you shut down and restore them when you start up.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
jonasstein
n00b
n00b


Joined: 03 Mar 2013
Posts: 31

PostPosted: Sun Mar 03, 2013 9:34 pm    Post subject: Reply with quote

now it works. Thank you.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum