Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
srt subtitles in mkv only displayed by vlc (! mplayer, xbmc)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
DawgG
l33t
l33t


Joined: 17 Sep 2003
Posts: 600

PostPosted: Thu Feb 28, 2013 7:36 pm    Post subject: srt subtitles in mkv only displayed by vlc (! mplayer, xbmc) Reply with quote

i have an mkv-file with srt-subs inside it, but subs are only recognized/displayed by vlc, NOT (s)mplayer or xbmc (the latter one is the one i mainly use on this htpc).
Code:
mkvinfo file.mkv
---SNIP---
|  + Audio track
|   + Abtastrate: 48000
|   + Kanäle: 6
| + Ein Track
|  + Tracknummer: 3 (Track-ID für mkvmerge & mkvextract: 2)
|  + Track UID: 1570255949
|  + Tracktyp: subtitles
|  + Flag für Paketbündelung: 0
|  + Codec-ID: S_TEXT/UTF8
|+ EbmlVoid (Größe: 1135)
|+ Cluster


but the same file:
Code:
midentify file.mkv
ID_VIDEO_ID=0
ID_AUDIO_ID=0
ID_AID_0_LANG=eng
ID_CLIP_INFO_NAME0=creation_time
ID_CLIP_INFO_VALUE0=2013-02-28\ 18:53:42
ID_CLIP_INFO_N=1
ID_FILENAME=file.mkv
ID_DEMUXER=lavfpref
ID_VIDEO_FORMAT=H264
ID_VIDEO_BITRATE=0
ID_VIDEO_WIDTH=1280
ID_VIDEO_HEIGHT=720
ID_VIDEO_FPS=23.976
ID_VIDEO_ASPECT=1.7778
ID_AUDIO_FORMAT=8192
ID_AUDIO_BITRATE=384000
ID_AUDIO_RATE=48000
ID_AUDIO_NCH=6
ID_START_TIME=0.00
ID_LENGTH=2980.73
ID_SEEKABLE=1
ID_CHAPTERS=0
ID_VIDEO_CODEC=ffh264
ID_AUDIO_BITRATE=384000
ID_AUDIO_RATE=48000
ID_AUDIO_NCH=2
ID_AUDIO_CODEC=ffac3
ID_EXIT=EOF

last week the srt-subs in this file were displayed by xbmc; since then i made some updates (but nothing regarding anything with subtitles) and recompiled xbmc, mplayer and vlc; the USEFLAGS were not changed and revdep-rebuild turned up nothing. vobsub-subtitles are still displayed correctly.
Code:
emerge --info
Portage 2.1.11.52 (default/linux/amd64/13.0/desktop, gcc-4.6.3, glibc-2.16.0, 3.8.0-gentoo x86_64)
=================================================================
System uname: Linux-3.8.0-gentoo-x86_64-AMD_E-350_Processor-with-gentoo-2.2
KiB Mem:     7634104 total,   3758876 free
KiB Swap:          0 total,         0 free
Timestamp of tree: Thu, 28 Feb 2013 18:15:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
app-shells/bash:          4.2_p42
dev-lang/python:          2.7.3-r3, 3.2.3-r2
dev-util/cmake:           2.8.7-r3
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.7 (virtual/os-headers)
sys-libs/glibc:           2.16.0
Repositories: gentoo x-portage
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"


so, what's going on? how can i get the subtitles to be displayed again in xbmc (and mplayer)?
_________________
DUMM KLICKT GUT.
Back to top
View user's profile Send private message
syn0ptik
Apprentice
Apprentice


Joined: 09 Jan 2013
Posts: 246

PostPosted: Fri Mar 01, 2013 4:57 am    Post subject: Reply with quote

what's your mplayer version?
Back to top
View user's profile Send private message
trippels
Tux's lil' helper
Tux's lil' helper


Joined: 24 Nov 2010
Posts: 91
Location: Berlin

PostPosted: Fri Mar 01, 2013 11:59 am    Post subject: Reply with quote

Same thing here with mplayer.
mplayer2 works fine for embedded subs though.
Back to top
View user's profile Send private message
DawgG
l33t
l33t


Joined: 17 Sep 2003
Posts: 600

PostPosted: Fri Mar 01, 2013 5:04 pm    Post subject: Reply with quote

same thing here. (s)mplayer does not recognize any subs at all, (s)mplayer2 does. i really am certain that last week i watched the same files with xbmc WITH subs. and i used the same version of mkvtoolnix to mux the subs into the files. i checked some older files which i definitely watched with mplayer and xbmc-12-rc1 and the srt-subs muxed into the mkv-files were dipslayed and they are not recogniced by these current versions: MPlayer 1.1-4.6.3 smplayer-0.8.3 xbmc-12

both times the same file; i put the --> <-- in there
Code:
ice@medi ~ $ midentify2 file.mkv
ID_VIDEO_ID=0
ID_AUDIO_ID=0
ID_AID_0_LANG=eng
--> ID_SUBTITLE_ID=0 <--
ID_SID_0_LANG=eng
ID_FILENAME=file.mkv
--> ID_DEMUXER=mkv <--
ID_VIDEO_FORMAT=avc1
ID_VIDEO_BITRATE=0
ID_VIDEO_WIDTH=1280
ID_VIDEO_HEIGHT=720
ID_VIDEO_FPS=23.976
ID_VIDEO_ASPECT=1.7778
ID_AUDIO_FORMAT=8192
ID_AUDIO_BITRATE=0
ID_AUDIO_RATE=48000
ID_AUDIO_NCH=6
ID_START_TIME=0.00
ID_LENGTH=2980.73
ID_SEEKABLE=1
ID_CHAPTERS=0
ID_VIDEO_CODEC=ffh264
ID_AUDIO_BITRATE=384000
ID_AUDIO_RATE=48000
ID_AUDIO_NCH=2
ID_AUDIO_CODEC=ffac3
ID_EXIT=EOF


Code:
ice@medi ~ $ midentify file.mkv
ID_VIDEO_ID=0
ID_AUDIO_ID=0
ID_AID_0_LANG=eng
ID_CLIP_INFO_NAME0=creation_time
ID_CLIP_INFO_VALUE0=2013-02-23\ 17:09:19
ID_CLIP_INFO_N=1
ID_FILENAME=file.mkv
--> ID_DEMUXER=lavfpref <--
ID_VIDEO_FORMAT=H264
ID_VIDEO_BITRATE=0
ID_VIDEO_WIDTH=1280
ID_VIDEO_HEIGHT=720
ID_VIDEO_FPS=23.976
ID_VIDEO_ASPECT=1.7778
ID_AUDIO_FORMAT=8192
ID_AUDIO_BITRATE=384000
ID_AUDIO_RATE=48000
ID_AUDIO_NCH=6
ID_START_TIME=0.00
ID_LENGTH=2980.73
ID_SEEKABLE=1
ID_CHAPTERS=0
ID_VIDEO_CODEC=ffh264
ID_AUDIO_BITRATE=384000
ID_AUDIO_RATE=48000
ID_AUDIO_NCH=2
ID_AUDIO_CODEC=ffac3
ID_EXIT=EOF


so i guess i just found out it's (maybe) got sth to do with ffmpeg. i'll look into into it. anybody got a clue?
_________________
DUMM KLICKT GUT.
Back to top
View user's profile Send private message
DawgG
l33t
l33t


Joined: 17 Sep 2003
Posts: 600

PostPosted: Fri Mar 01, 2013 5:15 pm    Post subject: solved for mplayer Reply with quote

should have rtfmed a little sooner....
mplayer's demuxer can be set with
Code:
mplayer -demuxer +mkv file.mkv
(the + enforces the selected demuxer)
Code:
ice@medi ~ $ midentify -demuxer +mkv file.mkv
ID_VIDEO_ID=0
ID_AUDIO_ID=0
ID_AID_0_LANG=eng
-->ID_SUBTITLE_ID=0<--
ID_SID_0_LANG=eng
ID_SID_0_LANG=eng
ID_FILENAME=file.mkv
-->ID_DEMUXER=mkv<--
ID_VIDEO_FORMAT=avc1
---SNIP---


now i gotta find this setting for xbmc.
_________________
DUMM KLICKT GUT.
Back to top
View user's profile Send private message
trippels
Tux's lil' helper
Tux's lil' helper


Joined: 24 Nov 2010
Posts: 91
Location: Berlin

PostPosted: Fri Mar 01, 2013 8:20 pm    Post subject: Reply with quote

You can set
Code:
[extension.mkv]
demuxer=mkv

in your .mplayer/config.
But this will break smplayer (when you resume a video the screen will be blank).
Back to top
View user's profile Send private message
foux
Tux's lil' helper
Tux's lil' helper


Joined: 04 Jul 2004
Posts: 84
Location: Rennes, France

PostPosted: Sun Mar 03, 2013 3:14 pm    Post subject: Reply with quote

trippels wrote:
You can set
Code:
[extension.mkv]
demuxer=mkv

in your .mplayer/config.
But this will break smplayer (when you resume a video the screen will be blank).


I've got the exact same problem. DId you manage to solve it?
Back to top
View user's profile Send private message
trippels
Tux's lil' helper
Tux's lil' helper


Joined: 24 Nov 2010
Posts: 91
Location: Berlin

PostPosted: Mon Mar 04, 2013 12:38 pm    Post subject: Reply with quote

foux wrote:
trippels wrote:
You can set
Code:
[extension.mkv]
demuxer=mkv

in your .mplayer/config.
But this will break smplayer (when you resume a video the screen will be blank).


I've got the exact same problem. DId you manage to solve it?


No, unfortunately not.
For now I've just disabled the "General->Media Settings->Remember setting for all files" option.
Back to top
View user's profile Send private message
foux
Tux's lil' helper
Tux's lil' helper


Joined: 04 Jul 2004
Posts: 84
Location: Rennes, France

PostPosted: Mon Mar 04, 2013 12:41 pm    Post subject: Reply with quote

I solved the problem by masking ffmpeg-1.0.4 and going back to the previous version, but that's quite and ugly way of solving the matter...
Back to top
View user's profile Send private message
j-kidd
Apprentice
Apprentice


Joined: 20 Feb 2003
Posts: 213

PostPosted: Fri Mar 08, 2013 11:51 pm    Post subject: Reply with quote

Thanks for the workaround, foux. Downgrading to ffmpeg-0.10.6 works for me. I can't stand to use VLC or SMPlayer2 :P
Back to top
View user's profile Send private message
j-kidd
Apprentice
Apprentice


Joined: 20 Feb 2003
Posts: 213

PostPosted: Mon Mar 18, 2013 4:55 am    Post subject: Reply with quote

Not fixed in ffmpeg-1.2...
Back to top
View user's profile Send private message
trippels
Tux's lil' helper
Tux's lil' helper


Joined: 24 Nov 2010
Posts: 91
Location: Berlin

PostPosted: Tue Mar 19, 2013 7:38 am    Post subject: Reply with quote

j-kidd wrote:
Not fixed in ffmpeg-1.2...


Someone should file a bug for this issue or it will never get fixed.
Back to top
View user's profile Send private message
j-kidd
Apprentice
Apprentice


Joined: 20 Feb 2003
Posts: 213

PostPosted: Mon Apr 08, 2013 4:38 am    Post subject: Reply with quote

Problem with smplayer seems to be my own fault. After making sure the "libass" USE flag is enabled for ffmpeg, embedded subtitles now work fine in smplayer.

As for XBMC, this pull request looks promising:

https://github.com/xbmc/xbmc/pull/2525

Relevant thread:

http://forum.xbmc.org/showthread.php?tid=148702&pid=1384608#pid1384608
Back to top
View user's profile Send private message
nebojsa42
n00b
n00b


Joined: 09 Jan 2011
Posts: 2

PostPosted: Fri May 24, 2013 10:11 pm    Post subject: Reply with quote

I can confirm that xbmc problem is fixed by applying patch https://github.com/Alphix/xbmc/commit/e79c8dbe78ad970f74c7af8f19ab8037cf43ae07 on top of media-tv/xbmc-12.2
I am using media-video/ffmpeg-1.0.7.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum