Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problemas con nvidia-drivers ... (solventado)
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
Luciernaga
Guru
Guru


Joined: 05 Apr 2006
Posts: 378
Location: LANDETE (Cuenca)

PostPosted: Thu Feb 28, 2013 2:57 pm    Post subject: Problemas con nvidia-drivers ... (solventado) Reply with quote

Saludos:
LLevo unos dias mosca perdido con los problemas de instalación de los drivers de Nvidia ...
Pregunto:
¿Conocen si existen problemas con los controladores Nvidia de Gentoo ...?
En mi caso no se quieren instalar ... la versión última que emerge pretende instalar es la 310.xx
Creo haber compilado el núcleo (3.7.9-gentoo) correctamente, la configuración en /etc/portage/make.conf esta hecha como siempre, es decir con el flag nvidia en la variable USE= y con la línea VIDEO_CARDS="nvidia"
Xorg se ejecuta correctamente con startx con el módulo VESA, pero los controladores nVidia no se quieren instalar ...
He leído e impreso el manual referente a la instalación de los controladores Nvidia y hecho pruebas de enmascaramiento, pero el resultado es el mismo, emerge no los instala ...
¿Qué puede pasar ...?
_________________
Soy como una diminuta luciérnaga, perdido en la inmensa oscuridad del universo.


Last edited by Luciernaga on Fri Mar 15, 2013 11:37 am; edited 1 time in total
Back to top
View user's profile Send private message
i92guboj
Moderator
Moderator


Joined: 30 Nov 2004
Posts: 9830
Location: Córdoba (Spain)

PostPosted: Thu Feb 28, 2013 3:42 pm    Post subject: Re: Problemas con nvidia-drivers Reply with quote

No das mucha información concreta, así que sólo podemos hacer apuestas.

No uso el driver de nvidia, pero no creo que funcione todavía con un kernel 3.8, así que eso es lo primero que deberías comprobar. Debes comprobar cual es el kernel que estás corriendo (uname -r) pero también a donde apunta el enlace /usr/src/linux, porque de ahí es de donde tu driver coge las cabeceras a la hora de compilar.

Si el problema no es ese, vas a tener que dar más información, empezando por pegar aquí el error exacto de compilación que arroja emerge.
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
Luciernaga
Guru
Guru


Joined: 05 Apr 2006
Posts: 378
Location: LANDETE (Cuenca)

PostPosted: Thu Feb 28, 2013 5:30 pm    Post subject: Reply with quote

Por partes:
El núcleo usado es el último liberado 3.7.9-gentoo
En /usr/src/linux es el único instalado puesto que la instalación de Gentoo es limpia y nueva.
En esta dirección esta el log http://pastebin.com/kTdzdqXq
Si algo más se necesita apuntarlo.
Gracias por responder, saludetes :)

PostData: he hecho todas las recomendaciones de este manual de instalación de nvidia ... https://wiki.gentoo.org/wiki/NVidia/nvidia-drivers
_________________
Soy como una diminuta luciérnaga, perdido en la inmensa oscuridad del universo.
Back to top
View user's profile Send private message
i92guboj
Moderator
Moderator


Joined: 30 Nov 2004
Posts: 9830
Location: Córdoba (Spain)

PostPosted: Thu Feb 28, 2013 7:34 pm    Post subject: Reply with quote

El kernel tiene que estar preparado al menos. Asumo que lo has compilado tú mismo, ¿es posible que luego hayas hecho make clean o algo por el estilo? Prueba a hacer make en el dir del kernel para ver que todo esté al día.
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
Luciernaga
Guru
Guru


Joined: 05 Apr 2006
Posts: 378
Location: LANDETE (Cuenca)

PostPosted: Thu Feb 28, 2013 7:39 pm    Post subject: Reply with quote

Efectivamente, lo he compilado con genkernel y cuidadosamente mirando los requerimientos del manual de nvidia que he puesto antes. Ahora mismo no puedo hacer el make pero mañana seguro ...
informaré ... gracias
_________________
Soy como una diminuta luciérnaga, perdido en la inmensa oscuridad del universo.
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 811

PostPosted: Thu Feb 28, 2013 8:10 pm    Post subject: Reply with quote

Creo que la versión 3.7 y superiores del kernel no son compatibles con nvidia-drivers-310.32 en gentoo. ¿Has comprobado si emerge --pretend te da alguna advertencia sobre esto?
Back to top
View user's profile Send private message
i92guboj
Moderator
Moderator


Joined: 30 Nov 2004
Posts: 9830
Location: Córdoba (Spain)

PostPosted: Thu Feb 28, 2013 8:53 pm    Post subject: Reply with quote

Según el ebuild, 3.7 debería ser compatible. Si usas otra versión "you are on your own" pero el ebuild no establece una dependencia obligatoria.
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 811

PostPosted: Fri Mar 01, 2013 12:29 am    Post subject: Reply with quote

i92guboj wrote:
Según el ebuild, 3.7 debería ser compatible. Si usas otra versión "you are on your own" pero el ebuild no establece una dependencia obligatoria.

No. Según el ebuild, <3.7 debería ser compatible.
Back to top
View user's profile Send private message
i92guboj
Moderator
Moderator


Joined: 30 Nov 2004
Posts: 9830
Location: Córdoba (Spain)

PostPosted: Fri Mar 01, 2013 8:51 am    Post subject: Reply with quote

quilosaq wrote:
i92guboj wrote:
Según el ebuild, 3.7 debería ser compatible. Si usas otra versión "you are on your own" pero el ebuild no establece una dependencia obligatoria.

No. Según el ebuild, <3.7 debería ser compatible.


Correcto. Gracias por la corrección. En realidad la línea que importa es esta:

Code:
if use kernel_linux && kernel_is ge 3 7 ; then


Lo miré con prisa y confundí "ge" con "gt" :roll:

En definitiva, hay que usar 3.6.x.
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
Luciernaga
Guru
Guru


Joined: 05 Apr 2006
Posts: 378
Location: LANDETE (Cuenca)

PostPosted: Fri Mar 01, 2013 2:52 pm    Post subject: Reply with quote

Quote:
En definitiva, hay que usar 3.6.x.


Es lo que estoy tratando de hacer, veamos ...
He enmascarado el núcleo 3.7.9-gentoo (echo "<sys-kernel/gentoo-sources-3.7.9" >> /etc/portage/package.mask) para poder descargar las fuentes 3.6.11 (emerge gentoo-sources) y compilar de nuevo, eliminar todo lo referente al núcleo 3.7.9 en /boot (rm /boot/*3.7.9-gentoo), recompilar todo con "emerge -DNav world" reeditar el make.conf y veremos que es lo que ocurre ... estoy en ello.

El problema que tengo en esta máquina es que hay ensambladas dos targetas de video nVidia GeForce 6600GT con sendos monitores ViewSonic 1280x1024 y para conseguir un pantallazo de 2560x1024 pixels necesito instalar el controlador nativo o el de Gentoo nvidia-drivers, porque tanto VESA como nouveau solo me soportan un monitor o pantalla y esto me fastidia un mogollón ...
Tengo instaladas otras distros en esta máquina, tales como Slackware 14, ArchLinux, Windows (7 y 8 ) y consigo hacer funcionar las dos pantallas y en la Gentoo tengo problemas hasta ahora ... veremos.
Saludetes :)
_________________
Soy como una diminuta luciérnaga, perdido en la inmensa oscuridad del universo.
Back to top
View user's profile Send private message
lluisparcet
Tux's lil' helper
Tux's lil' helper


Joined: 21 Sep 2004
Posts: 116
Location: Roses

PostPosted: Fri Mar 01, 2013 7:41 pm    Post subject: Reply with quote

Hola:

Efectivamente, yo también tenía el mismo problema con nvidia-drivers-310.3 y el kernel gentoo-sources-3.7.9 y gentoo-sources-3.7.10

Lo he solucionado usando nvidia-drivers-313.18, el driver que tenemos en la rama de pruebas, que se ha compilado e instalado sin mayores problemas y me funciona bien.

Luciernaga: Imagino que estas en la rama estable pero prueba a meter la línea (Sin las comillas) "x11-drivers/nvidia-drivers" en el fichero "/etc/portage/package.keywords" (Si el fichero no existe en tu sistema puedes crearlo) y luego prueba a instalar el driver de nvidia. Debería instalarte el 313.18 y a ver si te funciona. Creo que esto es mucho mas facil y rapido que lo que pretendes hacer ya que no creo que recompilando todo el sistema soluciones este problema.

Seguramente el driver 310.3 de nvidia debe tener algún problema pero no se cual, quizá alguien con mas experiencia que nosotros pueda aclararnos cual es.

Echale un vistazo a este post http://forums.gentoo.org/viewtopic-t-951692-start-0.html

Saludos.


Last edited by lluisparcet on Sat Mar 02, 2013 9:50 pm; edited 1 time in total
Back to top
View user's profile Send private message
Luciernaga
Guru
Guru


Joined: 05 Apr 2006
Posts: 378
Location: LANDETE (Cuenca)

PostPosted: Sat Mar 02, 2013 6:02 pm    Post subject: Reply with quote

Vamos a ver, por partes ...
En mi servidor de red el núcleo 3.6.11-gentoo me funciona perfectamente. Contiene 2 CPUs Intel Xeon, más 24GB memoria RAM, más una gráfica Nvidia 8400GT, más varias distros Linux (modo servidor) todo funcionando correctamente.
En mi máquina cliente de red (Phenom) el núcleo 3.6.11 y posteriores Gentoo me está dando problemas de todo tipo. Contiene 1 CPU AMD Phenom 2.5GHz versión B3, más 4GB de memoria RAM, más dos gráficas GeForce 6600GT con sendos monitores 1280x1024, más Windows, más Slackware 14.0, más Debian 6.0, más Fedora 18, más ArchLinux, funcionando correctamente todo menos Gentoo.
En otra máquina de 64bits (servidor de reten o respaldo por si falla el primero) estoy en ella, contiene una CPU Intel EM64T a 3.2GHz, más 4GB de memoria RAM, más gráfica Nvidia 9600GT, más 4 HDs iguales de 200GB cada uno montados en RAID 10, etc., Win funciona correctamente, y Linux estoy en ella ...

LLuis el enlace no furula ... toma nota de lo que me dices, tan pronto tenga resultados informaré ... (Qué tal per Roses, saps que vaix nexer a l'Empordá a Torroella de Fluviá, fa uns quans anys, ara ja estic jubilat)
Saludetes ;)
_________________
Soy como una diminuta luciérnaga, perdido en la inmensa oscuridad del universo.


Last edited by Luciernaga on Sun Mar 03, 2013 9:31 am; edited 1 time in total
Back to top
View user's profile Send private message
Luciernaga
Guru
Guru


Joined: 05 Apr 2006
Posts: 378
Location: LANDETE (Cuenca)

PostPosted: Sat Mar 02, 2013 8:10 pm    Post subject: Reply with quote

Toma castaña ...
Fuentes y núcleo 3.7.10-gentoo
Ahora estoy configurando el servidor de red e iptables me sale con esto:
Comando: iptables -t nat -F
Respuesta:
iptables v1.4.16.3: can't initialize iptables table 'nat': Table does not exist (do you need to insmod?)
Perhaps iptables or your kernel needs to be upgraded.


lalexe ... nunca me había sucedido nada igual con enésimas veces de haberlo configurado ...
¿Qué falla en el núcleo o lo que es lo mismo qué no he configurado en él?

?????????????
_________________
Soy como una diminuta luciérnaga, perdido en la inmensa oscuridad del universo.
Back to top
View user's profile Send private message
i92guboj
Moderator
Moderator


Joined: 30 Nov 2004
Posts: 9830
Location: Córdoba (Spain)

PostPosted: Sat Mar 02, 2013 8:32 pm    Post subject: Reply with quote

Un módulo del kernel se encarga de proveer esa tabla. Tienes que habilitarlo en la sección de netfilter.
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
lluisparcet
Tux's lil' helper
Tux's lil' helper


Joined: 21 Sep 2004
Posts: 116
Location: Roses

PostPosted: Sat Mar 02, 2013 9:59 pm    Post subject: Reply with quote

Tienes razón, el enlace que puse estaba mal, ya lo he arreglado.

Saludos

Luciernaga, És ben cert que el món és un mocador. Per Roses com sempre, poca gent ara a l'hivern, massa a l'estiu i segueix la tramontana de tant en tant.
Back to top
View user's profile Send private message
Luciernaga
Guru
Guru


Joined: 05 Apr 2006
Posts: 378
Location: LANDETE (Cuenca)

PostPosted: Sun Mar 03, 2013 9:49 am    Post subject: Reply with quote

i92guboj wrote:
Un módulo del kernel se encarga de proveer esa tabla. Tienes que habilitarlo en la sección de netfilter.


Jope ... estaba activado como módulo ({M}Netfilter Xtables support (required for ip_tables)) no entiendo como genkernel o quien sea no lo cargó, no obstante hay algo que me desconcierta en el manual porque en la sección 7.e. Módulos del Núcleo advierte sobre la necesidad de cargar automáticamente algún módulo editando el archivo /etc/conf.d/modules escribiendo en él el módulo necesitado, lo cual presenta un enigma de que o se cargan al compilar el kernel o hay que cargarlos mediante el citado archivo.
Bien, ante este dilema lo he cambiado a {*} permanente para comprobar si así funciona ... luego después de la compilación informaré ...
Por otro lado observo que Gentoo se está tornando muy dinámica al cambiarse continuamente su modus operandi o manera de ser, cosa que en otras distros es menos cambiante, sea como fuere la tengo como mi preferida, será que engancha ... jejejejeje
Saludetes ;)
_________________
Soy como una diminuta luciérnaga, perdido en la inmensa oscuridad del universo.
Back to top
View user's profile Send private message
i92guboj
Moderator
Moderator


Joined: 30 Nov 2004
Posts: 9830
Location: Córdoba (Spain)

PostPosted: Sun Mar 03, 2013 10:11 am    Post subject: Reply with quote

Perdona que no fuera ayer más específico, pero escribí desde el teléfono y me da una pereza increíble :lol:

La tabla NAT no es creada por el módulo Xtables, sino desde networking->netfilter->ip: netfilter...->ipv4 nat

No hay problema con tenerlas como módulos, siempre que tu kernel tenga el soporte para cargar módulos on-demand activo. Tampoco hace falta, por normal general, tocar /etc/conf.d/modules, porque iptables puede cargar lo que necesite sin problemas. Yo, de hecho, tengo casi todo lo relacionado con iptables construído como módulo, porque cada dos días sale uno nuevo y soy muy vago como para pararme a leer para que sirve cada uno :lol:
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
Luciernaga
Guru
Guru


Joined: 05 Apr 2006
Posts: 378
Location: LANDETE (Cuenca)

PostPosted: Sun Mar 03, 2013 9:18 pm    Post subject: Reply with quote

Vale ... solucionado ... perdona que no hubiera leído tu último mensaje i92guboj, lo he descubierto esta tarde por mi mismo al fallarme lo que apunté en mi anterior mensaje ...
Efectivamente, la tabla NAT está desactivada en este kernel y hay que activarla a mano, por lo que he regresado al Xtables a {M} y las cuatro líneas de la tabla NAT activadas como módulos residentes en IP: Netfilter Configuration tal como sigue:
<M> IPv4 NAT
<M> MASQUERADE target support
<M> NETMAP target support
<M> REDIRECT target support

Ya tengo conexión en la red local, tanto en todos los terminales como con conexión a WAN al recompilar el núcleo y reiniciar la máquina.
Muchas gracias por la ayuda, en cuanto al tema abierto en este hilo por los controladores Nvidia no lo cierro todavía ... informaré pronto ...
Saludetes :)
_________________
Soy como una diminuta luciérnaga, perdido en la inmensa oscuridad del universo.
Back to top
View user's profile Send private message
Luciernaga
Guru
Guru


Joined: 05 Apr 2006
Posts: 378
Location: LANDETE (Cuenca)

PostPosted: Wed Mar 06, 2013 12:27 pm    Post subject: Reply with quote

Pues no, referente al problema de los drivers de Nvidia algo he avanzado ...
Con el consejo de LLuis he logrado instalarlos en la máquina Phenom, ejecutado Xorg -configure, copiado xorg.conf en /etc/X11/ pero al ejecutar startx se cargan en modo VESA y no en modo Nvidia a pesar de tenerlo configurado para la resolución de Nvidia ...
Los controladores instalados son la versión 313,26
El sistema está perfectamente instalado y actualizado, el escritorio KDE completo, y demás aplicaciones todo instalado sin problemas, pero solo puedo visualizar una pantalla en baja resolución ...
??????????????
_________________
Soy como una diminuta luciérnaga, perdido en la inmensa oscuridad del universo.
Back to top
View user's profile Send private message
i92guboj
Moderator
Moderator


Joined: 30 Nov 2004
Posts: 9830
Location: Córdoba (Spain)

PostPosted: Wed Mar 06, 2013 1:45 pm    Post subject: Reply with quote

Por favor, pega /var/log/Xorg.0.log
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
Luciernaga
Guru
Guru


Joined: 05 Apr 2006
Posts: 378
Location: LANDETE (Cuenca)

PostPosted: Wed Mar 06, 2013 6:37 pm    Post subject: Reply with quote

Todo el sistema me funciona (creo) correctamente, pero las Xs solo van con VESA ...
Ahi pongo el Xorg.0.log
[ 637.488]
X.Org X Server 1.13.1
Release Date: 2012-12-13
[ 637.488] X Protocol Version 11, Revision 0
[ 637.488] Build Operating System: Linux 3.7.10-gentoo x86_64 Gentoo
[ 637.488] Current Operating System: Linux localhost 3.7.10-gentoo #1 SMP Mon Mar 4 18:46:35 CET 2013 x86_64
[ 637.488] Kernel command line: BOOT_IMAGE=/kernel-genkernel-x86_64-3.7.10-gentoo root=/dev/sdb5
[ 637.488] Build Date: 05 March 2013 11:05:24AM
[ 637.489]
[ 637.489] Current version of pixman: 0.28.0
[ 637.489] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[ 637.489] Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 637.490] (==) Log file: "/var/log/Xorg.0.log", Time: Wed Mar 6 19:30:24 2013
[ 637.490] (==) Using config file: "/etc/X11/xorg.conf"
[ 637.490] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[ 637.490] (==) ServerLayout "X.org Configured"
[ 637.490] (**) |-->Screen "Screen0" (0)
[ 637.490] (**) | |-->Monitor "Monitor0"
[ 637.490] (**) | |-->Device "Card0"
[ 637.490] (**) |-->Screen "Screen1" (1)
[ 637.490] (**) | |-->Monitor "Monitor1"
[ 637.491] (**) | |-->Device "Card1"
[ 637.491] (**) |-->Input Device "Mouse0"
[ 637.491] (**) |-->Input Device "Keyboard0"
[ 637.491] (==) Automatically adding devices
[ 637.491] (==) Automatically enabling devices
[ 637.491] (==) Automatically adding GPU devices
[ 637.491] (**) FontPath set to:
/usr/share/fonts/misc/,
/usr/share/fonts/TTF/,
/usr/share/fonts/OTF/,
/usr/share/fonts/Type1/,
/usr/share/fonts/100dpi/,
/usr/share/fonts/75dpi/,
/usr/share/fonts/misc/,
/usr/share/fonts/TTF/,
/usr/share/fonts/OTF/,
/usr/share/fonts/Type1/,
/usr/share/fonts/100dpi/,
/usr/share/fonts/75dpi/
[ 637.491] (**) ModulePath set to "/usr/lib64/xorg/modules"
[ 637.491] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[ 637.491] (WW) Disabling Mouse0
[ 637.491] (WW) Disabling Keyboard0
[ 637.491] (II) Loader magic: 0x810c00
[ 637.491] (II) Module ABI versions:
[ 637.491] X.Org ANSI C Emulation: 0.4
[ 637.491] X.Org Video Driver: 13.1
[ 637.491] X.Org XInput driver : 18.0
[ 637.491] X.Org Server Extension : 7.0
[ 637.492] (--) PCI:*(0:1:0:0) 10de:0140:1682:2118 rev 162, Mem @ 0xdc000000/67108864, 0xc8000000/134217728, 0xdb000000/16777216, BIOS @ 0x????????/131072
[ 637.492] (--) PCI: (0:6:0:0) 10de:0140:196d:0000 rev 162, Mem @ 0xf8000000/67108864, 0xd0000000/134217728, 0xfd000000/16777216, BIOS @ 0x????????/131072
[ 637.492] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[ 637.493] Initializing built-in extension Generic Event Extension
[ 637.493] Initializing built-in extension SHAPE
[ 637.493] Initializing built-in extension MIT-SHM
[ 637.493] Initializing built-in extension XInputExtension
[ 637.493] Initializing built-in extension XTEST
[ 637.493] Initializing built-in extension BIG-REQUESTS
[ 637.493] Initializing built-in extension SYNC
[ 637.493] Initializing built-in extension XKEYBOARD
[ 637.493] Initializing built-in extension XC-MISC
[ 637.493] Initializing built-in extension XINERAMA
[ 637.493] Initializing built-in extension XFIXES
[ 637.494] Initializing built-in extension RENDER
[ 637.494] Initializing built-in extension RANDR
[ 637.494] Initializing built-in extension COMPOSITE
[ 637.494] Initializing built-in extension DAMAGE
[ 637.494] Initializing built-in extension MIT-SCREEN-SAVER
[ 637.494] Initializing built-in extension DOUBLE-BUFFER
[ 637.494] Initializing built-in extension RECORD
[ 637.494] Initializing built-in extension DPMS
[ 637.494] Initializing built-in extension X-Resource
[ 637.494] Initializing built-in extension XVideo
[ 637.495] Initializing built-in extension XVideo-MotionCompensation
[ 637.495] Initializing built-in extension XFree86-VidModeExtension
[ 637.495] Initializing built-in extension XFree86-DGA
[ 637.495] Initializing built-in extension XFree86-DRI
[ 637.495] Initializing built-in extension DRI2
[ 637.495] (II) "glx" will be loaded. This was enabled by default and also specified in the config file.
[ 637.495] (II) LoadModule: "glx"
[ 637.495] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[ 637.513] (II) Module glx: vendor="NVIDIA Corporation"
[ 637.513] compiled for 4.0.2, module version = 1.0.0
[ 637.513] Module class: X.Org Server Extension
[ 637.513] (II) NVIDIA GLX Module 313.26 Wed Feb 27 13:10:40 PST 2013
[ 637.513] Loading extension GLX
[ 637.513] (II) LoadModule: "nvidia"
[ 637.513] (II) Loading /usr/lib64/xorg/modules/drivers/nvidia_drv.so
[ 637.514] (II) Module nvidia: vendor="NVIDIA Corporation"
[ 637.514] compiled for 4.0.2, module version = 1.0.0
[ 637.514] Module class: X.Org Video Driver
[ 637.535] (II) NVIDIA dlloader X Driver 313.26 Wed Feb 27 12:52:26 PST 2013
[ 637.535] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[ 637.540] (--) using VT number 7

[ 637.552] (II) Loading sub module "wfb"
[ 637.552] (II) LoadModule: "wfb"
[ 637.553] (II) Loading /usr/lib64/xorg/modules/libwfb.so
[ 637.562] (II) Module wfb: vendor="X.Org Foundation"
[ 637.562] compiled for 1.13.1, module version = 1.0.0
[ 637.562] ABI class: X.Org ANSI C Emulation, version 0.4
[ 637.562] (II) Loading sub module "ramdac"
[ 637.562] (II) LoadModule: "ramdac"
[ 637.562] (II) Module "ramdac" already built-in
[ 637.570] (WW) NVIDIA(0): The NVIDIA GeForce 6600 GT GPU installed in this system is
[ 637.570] (WW) NVIDIA(0): supported through the NVIDIA 304.xx Legacy drivers. Please
[ 637.570] (WW) NVIDIA(0): visit http://www.nvidia.com/object/unix.html for more
[ 637.570] (WW) NVIDIA(0): information. The 313.26 NVIDIA driver will ignore this
[ 637.570] (WW) NVIDIA(0): GPU. Continuing probe...
[ 637.570] (WW) NVIDIA(0): The NVIDIA GeForce 6600 GT GPU installed in this system is
[ 637.570] (WW) NVIDIA(0): supported through the NVIDIA 304.xx Legacy drivers. Please
[ 637.570] (WW) NVIDIA(0): visit http://www.nvidia.com/object/unix.html for more
[ 637.570] (WW) NVIDIA(0): information. The 313.26 NVIDIA driver will ignore this
[ 637.570] (WW) NVIDIA(0): GPU. Continuing probe...
[ 637.570] (EE) No devices detected.
[ 637.570]
Fatal server error:
[ 637.570] no screens found
[ 637.570] (EE)
Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
[ 637.570] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[ 637.570] (EE)


Saludetes :)

PostData: Al pegar el -log me doy cuenta de esto:
The 313.26 NVIDIA driver will ignore this GPU. Continuing probe...
_________________
Soy como una diminuta luciérnaga, perdido en la inmensa oscuridad del universo.
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 811

PostPosted: Wed Mar 06, 2013 7:53 pm    Post subject: Reply with quote

Utiliza las versiones 304 del driver. La 304.64 estable o la 304.84 en pruebas.
Back to top
View user's profile Send private message
i92guboj
Moderator
Moderator


Joined: 30 Nov 2004
Posts: 9830
Location: Córdoba (Spain)

PostPosted: Wed Mar 06, 2013 9:32 pm    Post subject: Reply with quote

Busca 'legacy' ahí y tú mismo tendrás la respuesta.
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
Luciernaga
Guru
Guru


Joined: 05 Apr 2006
Posts: 378
Location: LANDETE (Cuenca)

PostPosted: Sun Mar 10, 2013 9:24 am    Post subject: Reply with quote

Bueno, esto no rula ...
He estado unos días indispuesto y por eso la tardanza en responder.
Siguiendo vuestros consejos este es el resultado, que no se compilan ... ggrrrrrrrrrrr
 * Package: x11-drivers/nvidia-drivers-304.64
 * Repository: gentoo
 * Maintainer: jer@gentoo.org xarthisius@gentoo.org
 * USE: X abi_x86_64 acpi amd64 consolekit elibc_glibc kernel_linux multilib policykit tools userland_GNU
 * FEATURES: sandbox
* Determining the location of the kernel source code
* Found kernel source directory:
* /usr/src/linux
* Found kernel object directory:
* /lib/modules/3.7.10-gentoo/build
* Found sources for kernel version:
* 3.7.10-gentoo
* Gentoo supports kernels which are supported by NVIDIA
* which are limited to the following kernels:
* <sys-kernel/gentoo-sources-3.7
* <sys-kernel/vanilla-sources-3.7
*
* You are free to utilize epatch_user to provide whatever
* support you feel is appropriate, but will not receive
* support as a result of those changes.
>>> Unpacking source...
>>> Unpacking NVIDIA-Linux-x86_64-304.64.run to /var/tmp/portage/x11-drivers/nvidia-drivers-304.64/work
>>> Source unpacked in /var/tmp/portage/x11-drivers/nvidia-drivers-304.64/work
>>> Preparing source in /var/tmp/portage/x11-drivers/nvidia-drivers-304.64/work ...
* Converting /kernel/Makefile.kbuild to use M= instead of SUBDIRS= ...
 [ ok ]
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/x11-drivers/nvidia-drivers-304.64/work ...
>>> Source configured.
>>> Compiling source in /var/tmp/portage/x11-drivers/nvidia-drivers-304.64/work ...
* Preparing nvidia module
make -j2 HOSTCC=x86_64-pc-linux-gnu-gcc CROSS_COMPILE=x86_64-pc-linux-gnu- 'LDFLAGS=-m elf_x86_64' ARCH=x86_64 IGNORE_CC_MISMATCH=yes V=1 SYSSRC=/usr/src/linux SYSOUT=/lib/modules/3.7.10-gentoo/build CC=x86_64-pc-linux-gnu-gcc clean module
If you are using a Linux 2.4 kernel, please make sure
you either have configured kernel sources matching your
kernel or the correct set of kernel headers installed
on your system.

If you are using a Linux 2.6 kernel, please make sure
you have configured kernel sources matching your kernel
installed on your system. If you specified a separate
output directory using either the "KBUILD_OUTPUT" or
the "O" KBUILD parameter, make sure to specify this
directory with the SYSOUT environment variable or with
the equivalent nvidia-installer command line option.

Depending on where and how the kernel sources (or the
kernel headers) were installed, you may need to specify
their location with the SYSSRC environment variable or
the equivalent nvidia-installer command line option.

*** Unable to determine the target kernel version. ***

make: *** [select_makefile] Error 1
* ERROR: x11-drivers/nvidia-drivers-304.64 failed (compile phase):
* emake failed
*
* If you need support, post the output of `emerge --info '=x11-drivers/nvidia-drivers-304.64'`,
* the complete build log and the output of `emerge -pqv '=x11-drivers/nvidia-drivers-304.64'`.
* The complete build log is located at '/var/tmp/portage/x11-drivers/nvidia-drivers-304.64/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/x11-drivers/nvidia-drivers-304.64/temp/environment'.
* Working directory: '/var/tmp/portage/x11-drivers/nvidia-drivers-304.64/work/kernel'
* S: '/var/tmp/portage/x11-drivers/nvidia-drivers-304.64/work/'


Gentoo ya me está cansando, en esta máquina tengo instalados varios sistemas y todos funcionando correctamente, de modo que no es el hardware el culpable del desaguisado ... W7, W8, Kubuntu, Slackware, FreeBSD, y Gentoo está fallando estrepitosamente ...
Gracias por vuestra desinteresada ayuda. Saludetes :)
_________________
Soy como una diminuta luciérnaga, perdido en la inmensa oscuridad del universo.
Back to top
View user's profile Send private message
i92guboj
Moderator
Moderator


Joined: 30 Nov 2004
Posts: 9830
Location: Córdoba (Spain)

PostPosted: Sun Mar 10, 2013 9:52 am    Post subject: Reply with quote

Hasta donde yo sé, los drivers de nvidia no funcionan aún con los kernel 3.7, como el que estás usando (según la salida que has pegado arriba). Esto no es algo aislado, ni tiene que ver con Gentoo ni con ninguna distro en particular. Esto es así desde que existe el driver de nvidia, si piensas usar dicho driver tendrás que ir siempre unpar de releases por detrás en lo que a kernel se refiere. Eso, o usas nouveau (del cual desconozco su estado).

Si quieres un driver libre de alto rendimiento la única opción es amd/ati con el driver libre radeon, que va de perlas, opengl y 3d incluídos.
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum