Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
LVM not working and /lib64/rcscripts/ missing
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
tuner23
n00b
n00b


Joined: 18 May 2006
Posts: 68

PostPosted: Sat Feb 23, 2013 12:05 pm    Post subject: LVM not working and /lib64/rcscripts/ missing Reply with quote

Hy,

i have a problem with my system, so cannot boot propper anymore.

After an world update i wondered why lvm isn't starting anymore at boot.
Then, after some research i found out that lvm want's to start
Code:
 /lib64/rcscripts/addons/lvm.start.sh
,
which does not exist and also the whole directory
Code:
/lib64/rcscripts/


i tried reinstalling lvm, openrc and baselayout with no effects. Also a creation of the directory and reinstall didn't help.

so does someone know what the problem here is?

Also strange:
Code:
# equery f lvm2 | grep lvm-start
#

..and the /etc/init.d/lvm file:
Code:

...
run_addon() {
        local f=/lib64/rcscripts/addons/$1.sh
        if [ -r "$f" ]; then
                ( . "$f" )
        fi
}

start() {
        if [ ! -f /etc/init.d/sysfs ]; then
                eerror "The $SVCNAME init-script is written for baselayout-2!"
                eerror "Please do not use it with baselayout-1!".
                return 1
        fi

        run_addon lvm-start
}
...

so in the end the script does nothing?


My versions:
Code:
[I] sys-fs/lvm2
     Available versions:  ~2.01.13 2.02.67-r2 2.02.73 2.02.73-r1 2.02.88 ~2.02.95-r4 ~2.02.97 2.02.97-r1 ~2.02.98 {{clvm cman +lvm1 nolvmstatic readline selinux (+)static (+)static-libs +thin +udev}}
     Installed versions:  2.02.97-r1(12:45:19 23.02.2013)(lvm1 readline static-libs thin udev -clvm -cman -selinux -static)
     Homepage:            http://sources.redhat.com/lvm2/
     Description:         User-land utilities for LVM2 (device-mapper) software.

[I] sys-apps/openrc
     Available versions:  0.9.8.4 0.11.8 **9999 {{debug elibc_glibc kernel_FreeBSD kernel_linux ncurses newnet pam prefix selinux static-libs tools unicode}}
     Installed versions:  0.11.8(12:32:30 23.02.2013)(elibc_glibc kernel_linux ncurses pam unicode -debug -kernel_FreeBSD -newnet -prefix -selinux -static-libs)
     Homepage:            http://www.gentoo.org/proj/en/base/openrc/
     Description:         OpenRC manages the services, startup and shutdown of a host

[I] sys-apps/baselayout
     Available versions:  2.0.3 ~2.1 2.1-r1 ~2.2 {{build kernel_linux}}
     Installed versions:  2.1-r1(12:31:36 23.02.2013)(kernel_linux -build)
     Homepage:            http://www.gentoo.org/
     Description:         Filesystem baselayout and init scripts

[I] sys-fs/lvm2
     Available versions:  ~2.01.13 2.02.67-r2 2.02.73 2.02.73-r1 2.02.88 ~2.02.95-r4 ~2.02.97 2.02.97-r1 ~2.02.98 {{clvm cman +lvm1 nolvmstatic readline selinux (+)static (+)static-libs +thin +udev}}
     Installed versions:  2.02.97-r1(12:45:19 23.02.2013)(lvm1 readline static-libs thin udev -clvm -cman -selinux -static)
     Homepage:            http://sources.redhat.com/lvm2/
     Description:         User-land utilities for LVM2 (device-mapper) software.




thanks in advance,
antonios.
Back to top
View user's profile Send private message
tuner23
n00b
n00b


Joined: 18 May 2006
Posts: 68

PostPosted: Wed Feb 27, 2013 9:10 am    Post subject: Reply with quote

...and i also deleted all distfiles and recompiled system with no effects.

So what's the problem here?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum