Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Probleme mit "usbhid quirks"
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
3PO
l33t
l33t


Joined: 26 Nov 2006
Posts: 911
Location: Schwabenländle

PostPosted: Sun Feb 24, 2013 9:09 pm    Post subject: [SOLVED] Probleme mit "usbhid quirks" Reply with quote

Hallo Zusammmen,

Ich habe ein Gehäuse von Thermaltake mit einer imon Fernbedienung.

Das Problem ist nur, dass sich das Device mit usbhid verbindet, was es aber nicht soll.

dmesg
Code:
usb 1-1.2.1: New USB device found, idVendor=15c2, idProduct=30c0
usb 1-1.2.1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
usb 1-1.2.1: Product: SoundGraph.Inc
usb 1-1.2.1: Manufacturer: SoundGraph,Inc.---
input: SoundGraph,Inc.--- SoundGraph.Inc as /devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.2/1-1.2.1/1-1.2.1:1.0/input/input5
hid-generic 0003:15C2:30C0.0002: input,hidraw1: USB HID v1.11 Mouse [SoundGraph,Inc.--- SoundGraph.Inc] on usb-0000:00:1a.0-1.2.1/input0
input: SoundGraph,Inc.--- SoundGraph.Inc as /devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.2/1-1.2.1/1-1.2.1:1.1/input/input6
hid-generic 0003:15C2:30C0.0003: input,hidraw2: USB HID v1.11 Keyboard [SoundGraph,Inc.--- SoundGraph.Inc] on usb-0000:00:1a.0-1.2.1/input1
hid-generic 0003:15C2:30C0.0004: hiddev0,hidraw3: USB HID v1.10 Device [SoundGraph,Inc.--- SoundGraph.Inc] on usb-0000:00:1a.0-1.2.1/input2


Ich habe fogende Datei angelegt:

Code:
vdr01_64 ~ # cat /etc/modprobe.d/usbhid.conf
# options usbhid quirks=0x15c2:0x30c0:0x0003
options usbhid quirks=0x15c2:0x30c0:0x0004
options imon debug=1
vdr01_64 ~ #


Leider aber bleibt das ohne Wirkung. :(

Wie kann ich nun das Device "0003:15C2:30C0.0004" von hid-generic detachen?


Last edited by 3PO on Mon Feb 25, 2013 6:50 pm; edited 1 time in total
Back to top
View user's profile Send private message
firefly
Advocate
Advocate


Joined: 31 Oct 2002
Posts: 4107

PostPosted: Mon Feb 25, 2013 7:14 am    Post subject: Reply with quote

wie sind die beidne treiber (usbhid und hid-generic) in de rkernel config eingebaut? (Modul oder fest?)
_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.
Back to top
View user's profile Send private message
3PO
l33t
l33t


Joined: 26 Nov 2006
Posts: 911
Location: Schwabenländle

PostPosted: Mon Feb 25, 2013 4:58 pm    Post subject: Reply with quote

firefly wrote:
wie sind die beidne treiber (usbhid und hid-generic) in de rkernel config eingebaut? (Modul oder fest?)


So,

Code:
vdr01_64 ~ # grep -i hid /usr/src/linux-3.8.0-gentoo/.config
# CONFIG_BT_HIDP is not set
# HID support
CONFIG_HID=y
CONFIG_HID_BATTERY_STRENGTH=y
CONFIG_HIDRAW=y
# CONFIG_UHID is not set
CONFIG_HID_GENERIC=y
# Special HID drivers
CONFIG_HID_A4TECH=y
CONFIG_HID_ACRUX=m
# CONFIG_HID_ACRUX_FF is not set
CONFIG_HID_APPLE=y
# CONFIG_HID_AUREAL is not set
CONFIG_HID_BELKIN=y
CONFIG_HID_CHERRY=y
CONFIG_HID_CHICONY=y
CONFIG_HID_PRODIKEYS=m
CONFIG_HID_CYPRESS=y
CONFIG_HID_DRAGONRISE=y
CONFIG_HID_EMS_FF=m
CONFIG_HID_EZKEY=y
# CONFIG_HID_HOLTEK is not set
CONFIG_HID_KEYTOUCH=m
CONFIG_HID_KYE=y
CONFIG_HID_UCLOGIC=m
CONFIG_HID_WALTOP=m
CONFIG_HID_GYRATION=y
CONFIG_HID_TWINHAN=y
CONFIG_HID_KENSINGTON=y
CONFIG_HID_LCPOWER=m
# CONFIG_HID_LENOVO_TPKBD is not set
CONFIG_HID_LOGITECH=y
CONFIG_HID_LOGITECH_DJ=m
CONFIG_HID_MICROSOFT=y
CONFIG_HID_MONTEREY=y
CONFIG_HID_MULTITOUCH=m
CONFIG_HID_NTRIG=y
CONFIG_HID_ORTEK=y
CONFIG_HID_PANTHERLORD=y
CONFIG_HID_PETALYNX=y
CONFIG_HID_PICOLCD=m
CONFIG_HID_PICOLCD_FB=y
CONFIG_HID_PICOLCD_BACKLIGHT=y
CONFIG_HID_PICOLCD_LCD=y
CONFIG_HID_PICOLCD_LEDS=y
# CONFIG_HID_PRIMAX is not set
CONFIG_HID_ROCCAT=m
# CONFIG_HID_SAITEK is not set
CONFIG_HID_SAMSUNG=y
CONFIG_HID_SONY=y
# CONFIG_HID_SPEEDLINK is not set
CONFIG_HID_SUNPLUS=y
CONFIG_HID_GREENASIA=y
# CONFIG_HID_HYPERV_MOUSE is not set
CONFIG_HID_SMARTJOYPLUS=y
# CONFIG_HID_TIVO is not set
CONFIG_HID_TOPSEED=y
CONFIG_HID_THRUSTMASTER=y
CONFIG_HID_ZEROPLUS=y
CONFIG_HID_ZYDACRON=m
# CONFIG_HID_SENSOR_HUB is not set
# USB HID support
CONFIG_USB_HID=y
# CONFIG_HID_PID is not set
CONFIG_USB_HIDDEV=y
# I2C HID support
# CONFIG_I2C_HID is not set
CONFIG_USB_G_HID=m
# Hid Sensor IIO Common
vdr01_64 ~ #


also fest, ich hatte es aber auch schon modular versucht, ging aber auch nicht. :(

Es könnte aber auch sein, dass ich beim Kernelbauen einen Fehler gemacht habe.

Was passiert beim "make modules_install", wenn man ein Modul vorher schon als "fest" installiet hatte und es dann auf "modular" umstellt?
Wird das Modul dann mit "make modules_install" ersetzt, oder muss man es evtl. vorher von Hand entfernen?
Back to top
View user's profile Send private message
3PO
l33t
l33t


Joined: 26 Nov 2006
Posts: 911
Location: Schwabenländle

PostPosted: Mon Feb 25, 2013 6:50 pm    Post subject: Reply with quote

Problem gelöst! :)

Hier stand die Lösung: ;)

--> http://forums.gentoo.org/viewtopic-t-926996-highlight-configusbhid.html
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum