Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
vdr-xvdr-9999 failed
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
Sakarias
n00b
n00b


Joined: 12 May 2007
Posts: 28

PostPosted: Sat Feb 23, 2013 6:15 pm    Post subject: vdr-xvdr-9999 failed Reply with quote

I can't install vdr-xvdr-9999. I give error

>>> Source compiled.
>>> Test phase [not enabled]: media-plugins/vdr-xvdr-9999

>>> Install vdr-xvdr-9999 into /var/tmp/portage/media-plugins/vdr-xvdr-9999/image/ category media-plugins
xgettext -C -cTRANSLATORS --no-wrap --no-location -k -ktr -ktrNOOP --package-name=vdr-xvdr --package-version=0.9.9 --msgid-bugs-address='<see README>' -o po/xvdr.pot `find ./src -name *.c`
install -D libvdr-xvdr.so /var/tmp/portage/media-plugins/vdr-xvdr-9999/image//var/tmp/portage/media-plugins/vdr-xvdr-9999/work/vdr-xvdr-plugin/libvdr-xvdr.so.1.7.36
install: cannot stat 'libvdr-*.so.*': No such file or directory
!!! doins: libvdr-*.so.* does not exist
* ERROR: media-plugins/vdr-xvdr-9999 failed (install phase):
* doins failed
*
* If you need support, post the output of `emerge --info '=media-plugins/vdr-xvdr-9999'`,
* the complete build log and the output of `emerge -pqv '=media-plugins/vdr-xvdr-9999'`.
* The complete build log is located at '/var/tmp/portage/media-plugins/vdr-xvdr-9999/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/media-plugins/vdr-xvdr-9999/temp/environment'.
* Working directory: '/var/tmp/portage/media-plugins/vdr-xvdr-9999/work/vdr-xvdr-plugin'
* S: '/var/tmp/portage/media-plugins/vdr-xvdr-9999/work/vdr-xvdr-plugin'
* QA Notice: file does not exist:
*
* doins: libvdr-*.so.* does not exist

>>> Failed to emerge media-plugins/vdr-xvdr-9999, Log file:

How i can fix? I use vdr-1.7.36 from overlay vdr-devel
_________________
---
Sakarias
Back to top
View user's profile Send private message
KaZeR
Apprentice
Apprentice


Joined: 04 Feb 2004
Posts: 270
Location: Au fond, à droite.

PostPosted: Sun Feb 24, 2013 1:27 pm    Post subject: Reply with quote

Same here!

I temporarily solved the problem by downgrading my client's xvdr plugin :

Code:

emerge --unmerge xbmc-xvdr-plugin
git clone git://github.com/pipelka/xbmc-addon-xvdr.git
git checkout 71688d00813d6ba9dfdd70a811b06d0b99bdaf56
bash autogen.sh && ./configure && make && make install


And it works.
_________________
Foo.
Back to top
View user's profile Send private message
Sakarias
n00b
n00b


Joined: 12 May 2007
Posts: 28

PostPosted: Sun Feb 24, 2013 9:08 pm    Post subject: Reply with quote

KaZeR wrote:
Same here!

I temporarily solved the problem by downgrading my client's xvdr plugin :

Code:

emerge --unmerge xbmc-xvdr-plugin
git clone git://github.com/pipelka/xbmc-addon-xvdr.git
git checkout 71688d00813d6ba9dfdd70a811b06d0b99bdaf56
bash autogen.sh && ./configure && make && make install


And it works.


Problem is vdr-xvdr no xbmc-addon-xvdr.
Or little spelling mistake?
Did you mean

Code:
 git clone git://github.com/pipelka/vdr-plugin-xvdr.git?

How i can compile it? I like see TV with XBMC and i need working
vdr-xvdr plugin. VDR works.
_________________
---
Sakarias
Back to top
View user's profile Send private message
Nokai001
n00b
n00b


Joined: 25 Sep 2007
Posts: 28

PostPosted: Wed Feb 27, 2013 4:26 pm    Post subject: Reply with quote

Same here
emerge it. Wait for error and then copy it manuel:
cp /var/tmp/portage/media-plugins/vdr-xvdr-9999/image/var/tmp/portage/media-plugins/vdr-xvdr-9999/work/vdr-xvdr-plugin/libvdr-xvdr.so.1.7.33 /usr/lib/vdr/plugins/libvdr-xvdr.so.1.7.33
Back to top
View user's profile Send private message
ralf_bruno
n00b
n00b


Joined: 27 Feb 2013
Posts: 4
Location: ZH/CH

PostPosted: Wed Feb 27, 2013 7:30 pm    Post subject: Reply with quote

Same here, just copy libvdr-xvdr.so does not work. VDR complains about wrong patchlevel

So waiting is the message til it's fixed.
Back to top
View user's profile Send private message
Sakarias
n00b
n00b


Joined: 12 May 2007
Posts: 28

PostPosted: Wed Feb 27, 2013 8:07 pm    Post subject: Reply with quote

Nokai001 wrote:
Same here
emerge it. Wait for error and then copy it manuel:
cp /var/tmp/portage/media-plugins/vdr-xvdr-9999/image/var/tmp/portage/media-plugins/vdr-xvdr-9999/work/vdr-xvdr-plugin/libvdr-xvdr.so.1.7.33 /usr/lib/vdr/plugins/libvdr-xvdr.so.1.7.33


/etc/vdr/plugins/xvdr/ options?
/etc/conf.d/vdr.plugins i add xvdr

restart vdr /etc/init.d/vdr restart

and not work. Need some file more?
I try with vdr-1.7.31 and 17.36
what version you used?
_________________
---
Sakarias
Back to top
View user's profile Send private message
ralf_bruno
n00b
n00b


Joined: 27 Feb 2013
Posts: 4
Location: ZH/CH

PostPosted: Thu Feb 28, 2013 6:57 pm    Post subject: Reply with quote

Ok. i'am running media-video/vdr-1.7.25. Vdr works, but not vdr-xvdr. using amielke-overlay.

I do not want to chance vdr.

Any solution? Any hints. Thank you.
Back to top
View user's profile Send private message
KaZeR
Apprentice
Apprentice


Joined: 04 Feb 2004
Posts: 270
Location: Au fond, à droite.

PostPosted: Fri Mar 01, 2013 3:07 pm    Post subject: Reply with quote

Sakarias wrote:

Problem is vdr-xvdr no xbmc-addon-xvdr.
Or little spelling mistake?
Did you mean

Code:
 git clone git://github.com/pipelka/vdr-plugin-xvdr.git?

How i can compile it? I like see TV with XBMC and i need working
vdr-xvdr plugin. VDR works.



I did mean xbmc-addon-xvdr :)

On my side it was an upgrade issue : i was running vdr-xvdr and xbmc-addon-xvdr for quite some time, i update my xbmc+vdr client (xbmc-12 fixes the youtube plugin crashes) and it upgraded my xbmc-addon-xvdr to use the protocol version 5:
https://github.com/pipelka/xbmc-addon-xvdr/commit/a9bf5b8d5f0c6a649e6e20d60b5a447f663579b5

In that case you have to upgrade your vdr-xvdr to at least https://github.com/pipelka/vdr-plugin-xvdr/commit/22b556c960770e55f9d6e1412a54b26fd91f9c35 I believe, but the compilation fails.

So, if you can't upgrade the server (vdr-xvdr) the solution is to downgrade the client, that's what i did and it worked.
_________________
Foo.
Back to top
View user's profile Send private message
ralf_bruno
n00b
n00b


Joined: 27 Feb 2013
Posts: 4
Location: ZH/CH

PostPosted: Fri Mar 01, 2013 4:57 pm    Post subject: Reply with quote

Thanks for your advice.

Using VDR as Server. As a client i use a raspberry pi with openelec installed. so i need to upgrade vdr-xvdr. Otherwise i cannot connect from my pi. So your solution might not work for me.
Back to top
View user's profile Send private message
Sakarias
n00b
n00b


Joined: 12 May 2007
Posts: 28

PostPosted: Fri Mar 08, 2013 7:58 pm    Post subject: Reply with quote

I compile vdr-plugin-xvdr from source

Code:
git clone -b master-pre-vdr-1.7.34 https://github.com/pipelka/vdr-plugin-xvdr.git


I edit little Makefile. VDRDIR = /usr/include/vdr and compile work now.

I copy libvdr-xvdr.so to /usr/lib/vdr/plugins
and config-files to /etc/vdr/plugins/xvdr.

vdr in now 1.7.31 from vdr-devel overlay.
_________________
---
Sakarias
Back to top
View user's profile Send private message
ralf_bruno
n00b
n00b


Joined: 27 Feb 2013
Posts: 4
Location: ZH/CH

PostPosted: Sat Mar 09, 2013 11:50 am    Post subject: Reply with quote

Thanks, i it works now for me too :D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum