Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
HPLIP Plug-in Install Succeed, but User says "Not installed"
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
cctsurf
n00b
n00b


Joined: 12 Oct 2006
Posts: 70

PostPosted: Sat Feb 23, 2013 5:18 am    Post subject: HPLIP Plug-in Install Succeed, but User says "Not insta Reply with quote

I've been googling all over the universe on this, I wanted to scan today, (I don't do it that often) and it seems that there is something wrong with my hplip configuration. As root, the plug-in installs correctly, as a user, however, it doesn't seem to be installed.
One very notable error I'm getting when I run hp-plugin is:
Code:
error: PolicyKit support requires DBUS or PolicyKit support files missing

Does anybody know what this means (and how to fix it?)

Below is the output from hp-check -t:
Code:

hp-check -t
Saving output in log file: /home/james/Downloads/Temp/hp-check.log

HP Linux Imaging and Printing System (ver. 3.13.2)
Dependency/Version Check Utility ver. 15.1

Copyright (c) 2001-13 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Note: hp-check can be run in three modes:
1. Compile-time check mode (-c or --compile): Use this mode before compiling the HPLIP supplied tarball (.tar.gz or .run) to determine if the proper dependencies are
installed to successfully compile HPLIP.                                                                                                                             
2. Run-time check mode (-r or --run): Use this mode to determine if a distro supplied package (.deb, .rpm, etc) or an already built HPLIP supplied tarball has the   
proper dependencies installed to successfully run.                                                                                                                   
3. Both compile- and run-time check mode (-b or --both) (Default): This mode will check both of the above cases (both compile- and run-time dependencies).           

Check types:                                                                                                                                                         
a. EXTERNALDEP - External Dependencies                                                                                                                               
b. GENERALDEP - General Dependencies (required both at compile and run time)                                                                                         
c. COMPILEDEP - Compile time Dependencies                                                                                                                           
d. [All are run-time checks]                                                                                                                                         
PYEXT SCANCONF QUEUES PERMISSION                                                                                                                                     

Status Types:
    OK
    MISSING       - Missing Dependency or Permission or Plug-in
    INCOMPAT      - Incompatible dependency-version or Plugin-version

/Xlib:  extension "RANDR" missing on display ":0".
-Xlib:  extension "RANDR" missing on display ":0".
warning: gentoo-2.2 version is not supported. Using gentoo-any versions dependencies to verify and install...

---------------
| SYSTEM INFO |
---------------

 Kernel: 3.8.0-gentoo #1 SMP PREEMPT Wed Feb 20 17:12:13 CST 2013 GNU/Linux
 Host: Dunamai
 Proc: 3.8.0-gentoo #1 SMP PREEMPT Wed Feb 20 17:12:13 CST 2013 GNU/Linux
 Distribution: gentoo 2.2

-----------------------
| HPLIP CONFIGURATION |
-----------------------

HPLIP-Version: HPLIP 3.13.2
HPLIP-Home: /usr/share/hplip
warning: HPLIP-Installation: Auto installation is not supported for gentoo distro  2.2 version

Current contents of '/etc/hp/hplip.conf' file:
# hplip.conf.  Generated from hplip.conf.in by configure.

[hplip]
version=3.13.2

[dirs]
home=/usr/share/hplip
run=/var/run
ppd=/usr/share/ppd/HP
ppdbase=/usr/share/ppd
doc=/usr/share/doc/hplip-3.13.2-r1
html=/usr/share/doc/hplip-3.13.2-r1/html
icon=/usr/share/applications
cupsbackend=/usr/libexec/cups/backend
cupsfilter=/usr/libexec/cups/filter
drv=/usr/share/cups/drv/hp
bin=/usr/bin

# Following values are determined at configure time and cannot be changed.
[configure]
network-build=yes
libusb01-build=no
pp-build=no
gui-build=yes
scanner-build=yes
fax-build=yes
dbus-build=yes
cups11-build=no
doc-build=no
shadow-build=no
hpijs-install=no
foomatic-drv-install=no
foomatic-ppd-install=no
foomatic-rip-hplip-install=no
hpcups-install=yes
cups-drv-install=yes
cups-ppd-install=no
internal-tag=3.13.2
restricted-build=no
ui-toolkit=qt4
qt3=no
qt4=yes
policy-kit=yes
hpijs-only-build=no
lite-build=no
udev-acl-rules=no
udev_sysfs_rules=no
hpcups-only-build=no
hpijs-only-build=no


Current contents of '/var/lib/hp/hplip.state' file:
Plugins are not installed. Could not access file: Permission denied

Current contents of '~/.hplip/hplip.conf' file:
[settings]
systray_visible = 0
systray_messages = 2

[last_used]
device_uri = "hp:/net/HP_LaserJet_4100_Series?ip=10.133.7.101"
printer_name =
working_dir = .

[commands]
scan = /usr/bin/xsane -V %SANE_URI%

[refresh]
rate = 30
enable = false
type = 1

[polling]
enable = false
interval = 5
device_list =

[fax]
voice_phone =
email_address =

[installation]
date_time = 02/22/2013 22:53:48
version = 3.13.2

[upgrade]
latest_available_version = 3.13.2
notify_upgrade = false
last_upgraded_time = 1361561209.27165
pending_upgrade_time = 0


 <Package-name>        <Package-Desc>      <Required/Optional> <Min-Version> <Installed-Version> <Status>   <Comment>

--------------------------
|  External Dependencies |
--------------------------

 gs                   Ghostscript               REQUIRED        7.05            9.06            OK         -
 network              Network-wget              OPTIONAL        -               1.14            OK         -
 dbus                 DBus                      REQUIRED        -               1.6.8           OK         -
 scanimage            Shell-Scanning            OPTIONAL        1.0             1.0.23          OK         -
 policykit            Admin-Policy-framework    OPTIONAL        -               0.110           OK         -
Xlib:  extension "RANDR" missing on display ":0".
Xlib:  extension "RANDR" missing on display ":0".
 xsane                SANE-GUI                  OPTIONAL        0.9             0.998           OK         -
 cups                 CUPS                      REQUIRED        1.1             1.6.1           OK         'CUPS Scheduler is running'

-------------------------
|  General Dependencies |
-------------------------

 reportlab            Python-PDF-Lib            OPTIONAL        2.0             2.6             OK         -
 libcrypto            OpenSSL-Crypto-Lib        REQUIRED        -               1.0.1           OK         -
 pil                  Python-Image-Lib          OPTIONAL        -               1.1.7           OK         -
 pyqt4-dbus           PyQt4-DBUS                REQUIRED        4.0             4.9.6           OK         -
 libjpeg              JPEG-Lib                  REQUIRED        -               -               OK         -
 libpthread           POSIX-Threads-Lib         REQUIRED        -               2.16            OK         -
 python-dbus          Python-DBUS               REQUIRED        0.80.0          1.1.1           OK         -
 python-devel         Python-SDK                REQUIRED        2.2             2.7.3           OK         -
 pyqt4                Python-Qt4                REQUIRED        4.0             4.9.6           OK         -
 cups-devel           CUPS-SDK                  REQUIRED        -               1.6.1           OK         -
 sane-devel           SANE-SDK                  REQUIRED        -               1.0.23          OK         -
 libusb               USB-Lib                   REQUIRED        -               1.0             OK         -
 sane                 Scan-Lib                  REQUIRED        -               1.0.23          OK         -
 cups-image           CUPS-Image-Lib            REQUIRED        -               1.6.1           OK         -
 libnetsnmp-devel     SNMP-Networking-SDK       REQUIRED        5.0.9           5.7.2           OK         -
 python-xml           Python-XML-Lib            REQUIRED        -               2.1.0           OK         -
 python-notify        Desktop-notifications     OPTIONAL        -               -               OK         -

------------------------------
|  Compile Time Dependencies |
------------------------------

 gcc                  gcc-Compiler              REQUIRED        -               4.6.3           OK         -
 libtool              Build-tools               REQUIRED        -               2.4.2           OK         -
 make                 GNU-Build-tools           REQUIRED        3.0             3.82            OK         -

----------------------
|  Python Extentions |
----------------------

 cupsext              CUPS-Extension            REQUIRED        -               3.13.2          OK         -
 pcardext             PhotoCard-Extension       REQUIRED        -               3.13.2          OK         -
 hpmudext             IO-Extension              REQUIRED        -               3.13.2          OK         -

-----------------------
|  Scan Configuration |
-----------------------

 hpaio                HPLIP-SANE-Backend        REQUIRED        -               3.13.2          OK         'hpaio found in /etc/sane.d/dll.conf'
 scanext              Scan-SANE-Extension       REQUIRED        -               3.13.2          OK         -

------------------------------
| DISCOVERED SCANNER DEVICES |
------------------------------

device `hpaio:/net/HP_LaserJet_M1536dnf_MFP?zc=NPI6A6CF5' is a Hewlett-Packard HP_LaserJet_M1536dnf_MFP all-in-one


--------------------------
| DISCOVERED USB DEVICES |
--------------------------

No devices found.

---------------------------------
| INSTALLED CUPS PRINTER QUEUES |
---------------------------------

 
HP_Color_LaserJet_4700
----------------------
Type: Printer
Device URI: hp:/net/HP_Color_LaserJet_4700?zc=NPI6591CF
PPD: /etc/cups/ppd/HP_Color_LaserJet_4700.ppd
PPD Description: HP Color LaserJet 4700 Postscript (recommended)
Printer status: printer HP_Color_LaserJet_4700 is idle.  enabled since Fri 22 Feb 2013 01:45:09 PM CST
Communication status: Good

HP_LaserJet_4100
----------------
Type: Printer
Device URI: hp:/net/HP_LaserJet_4100_Series?ip=10.133.7.101
PPD: /etc/cups/ppd/HP_LaserJet_4100.ppd
PPD Description: HP LaserJet 4100 Series v.3010.107 Postscript (recommended)
Printer status: printer HP_LaserJet_4100 is idle.  enabled since Fri 22 Feb 2013 01:45:06 PM CST
Communication status: Good

HP_LaserJet_M1536dnf_MFP
------------------------
Type: Printer
Device URI: hp:/net/HP_LaserJet_M1536dnf_MFP?zc=NPI6A6CF5
PPD: /etc/cups/ppd/HP_LaserJet_M1536dnf_MFP.ppd
PPD Description: HP LaserJet M1536dnf MFP Postscript (recommended)
Printer status: printer HP_LaserJet_M1536dnf_MFP is idle.  enabled since Fri 22 Feb 2013 01:38:25 PM CST
error: Required plug-in status: Not installed
Communication status: Good

HP_LaserJet_M1536dnf_MFP_fax
----------------------------
Type: Fax
Device URI: hpfax:/net/HP_LaserJet_M1536dnf_MFP?zc=NPI6A6CF5
PPD: /etc/cups/ppd/HP_LaserJet_M1536dnf_MFP_fax.ppd
PPD Description: HP Fax2 hpcups
Printer status: printer HP_LaserJet_M1536dnf_MFP_fax is idle.  enabled since Fri 22 Feb 2013 01:38:07 PM CST
error: Required plug-in status: Not installed
Communication status: Good


--------------
| PERMISSION |
--------------

groups          user-groups                    Required        -        -        OK       lp wheel floppy uucp audio cdrom video games cdrw usb lpadmin portage wireshark james scanner plugdev realtime vboxusers

 
-----------
| SUMMARY |
-----------

Missing Required Dependencies
-----------------------------
None

Missing Optional Dependencies
-----------------------------
None


Plug-in Status
--------------
error: Plug-ins need to be installed

Total Errors: 2
Total Warnings: 0

Re-run 'hp-doctor' command to prompt and fix the issues.


In Case you're wondering, hp-doctor doesn't help.
Thanks in advance,
James
Back to top
View user's profile Send private message
cctsurf
n00b
n00b


Joined: 12 Oct 2006
Posts: 70

PostPosted: Sun Feb 24, 2013 5:41 am    Post subject: BUG: HPLIP 3.13.2 fails to scan: "Plugin not installed& Reply with quote

Further Diagnosis:
Downgraded to hplip 3.12.10a, and it works now. It really seems to be a bug in 3.13.2... I guess I should report it.
Here's the really interesting part: hp-check comes up with the same error: error: Required plug-in status: Not installed, but now the scanner works fine...
Back to top
View user's profile Send private message
pickd.mask
n00b
n00b


Joined: 02 Aug 2011
Posts: 6

PostPosted: Sun Feb 24, 2013 4:20 pm    Post subject: Reply with quote

same thing here.

when downgraded to 3.12.10a hplip works flawlessly fine.
thanX for this topic - worked as easy solution to me.

3.13.2 is buggy for sure.

P.S.:Portage 2.1.11.52 (default/linux/x86/13.0/desktop/kde, gcc-4.6.3, glibc-2.16.0, 3.8.0 i686)
Back to top
View user's profile Send private message
cctsurf
n00b
n00b


Joined: 12 Oct 2006
Posts: 70

PostPosted: Sun Feb 24, 2013 7:12 pm    Post subject: Reply with quote

I filed a bug report
458976
Back to top
View user's profile Send private message
regaleali
n00b
n00b


Joined: 14 Jan 2005
Posts: 31
Location: Switzerland

PostPosted: Tue Feb 26, 2013 5:48 pm    Post subject: Re: HPLIP Plug-in Install Succeed, but User says "Not i Reply with quote

Had the same problem. Looking at the output from hp-check -t I found:

Quote:

Code:

hp-check -t
...
Current contents of '/var/lib/hp/hplip.state' file:
Plugins are not installed. Could not access file: Permission denied



/var/lib/hp actually has permissions 644 after the upgrade to 3.13.2

Changing it manually to 755 (sudo chmod 755 /var/lib/hp) solved the problem for me.
Back to top
View user's profile Send private message
cryptosteve
Veteran
Veteran


Joined: 04 Jan 2004
Posts: 1088
Location: Buchholz/GER

PostPosted: Tue Feb 26, 2013 6:02 pm    Post subject: Reply with quote

Whoops, I have 0644 here also.

Thanks for that hint ..
_________________
- born to create drama -
cryptosteve - gpg: 0x9B6C7E15
CS Virtual Travel Bug: VF6G5D
Back to top
View user's profile Send private message
FroL_Onn
n00b
n00b


Joined: 20 Oct 2013
Posts: 23

PostPosted: Sun Oct 20, 2013 6:27 am    Post subject: Re: HPLIP Plug-in Install Succeed, but User says "Not i Reply with quote

regaleali wrote:
Had the same problem. Looking at the output from hp-check -t I found:

Quote:

Code:

hp-check -t
...
Current contents of '/var/lib/hp/hplip.state' file:
Plugins are not installed. Could not access file: Permission denied



/var/lib/hp actually has permissions 644 after the upgrade to 3.13.2

Changing it manually to 755 (sudo chmod 755 /var/lib/hp) solved the problem for me.

Thank you so much!
Changing it with #chmod -R 755 /var/lib/hp made my printer work with hplip 3.13.9
I had the following problem:
My HP printer stopped working after upgrading of hplip from 3.12.10a to 3.13.9
I had the error messages in cups error_log:
Code:
(/usr/libexec/cups/filter/hpcups) stopped with status 1.
(/usr/libexec/cups/filter/gstoraster) stopped with status 13.

Downgrading solved the problem, but it is not an appropriate solution, right?
Googling didn't help, and now finally I have the solution! Thanks!
Back to top
View user's profile Send private message
gustafson
Guru
Guru


Joined: 12 Aug 2004
Posts: 410

PostPosted: Mon Dec 08, 2014 6:41 pm    Post subject: Reply with quote

Thanks! chmod did it for me too.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum