Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Paludis: failed SHA512 on all packages
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
are
Apprentice
Apprentice


Joined: 03 Jan 2006
Posts: 180

PostPosted: Sat Feb 23, 2013 1:05 am    Post subject: Paludis: failed SHA512 on all packages Reply with quote

Dear All,

since the last upgrade paludis/cave fails verification of all files, e.g.
Code:
Checking 'google-chrome-beta_25.0.1364.97-r183676_amd64.deb'... failed SHA512
Checking 'google-chrome-libudev-0.13.1-amd64.tar.xz'... failed SHA512


I deleted the content of /var/paludis/dist and resynched several times already, nothing helped. Furthermore PORTAGE works at the same time well with the same packages/manifests.

Please do you have any idea?

Best regards!
Back to top
View user's profile Send private message
are
Apprentice
Apprentice


Joined: 03 Jan 2006
Posts: 180

PostPosted: Tue Feb 26, 2013 4:19 am    Post subject: Reply with quote

Update on that: I solved it partially by re-installing paludis using portage:
Code:

emerge paludis


After re-installing paludis/cave and sha512-verification worked again -- until I did a new
Code:

cave resolve installed-packages -x


which broke sha512-verification again! :evil:
Back to top
View user's profile Send private message
Hypnos
Advocate
Advocate


Joined: 18 Jul 2002
Posts: 2869
Location: Omnipresent

PostPosted: Tue Feb 26, 2013 5:39 am    Post subject: Reply with quote

FWIW, I cannot reproduce your problem -- the checksums are found valid on my machine with paludis-1.0.0 .

You might want to ask the Paludis developers.
_________________
Personal overlay | Simple backup scheme
Back to top
View user's profile Send private message
are
Apprentice
Apprentice


Joined: 03 Jan 2006
Posts: 180

PostPosted: Sat Apr 06, 2013 9:35 am    Post subject: Reply with quote

The problem still exists, even after installing paludis-1.2.0.

If I build paludis with "emerge -1 paludis", it it will work and after I can build all other packages with"cave resolve ...".
If I build paludis with "cave resolve paludis -x1", it will work BUT AFTER I can not build anything with "cave resolve ..." as check-sums are found invalid.
Back to top
View user's profile Send private message
Hypnos
Advocate
Advocate


Joined: 18 Jul 2002
Posts: 2869
Location: Omnipresent

PostPosted: Sat Apr 06, 2013 10:42 am    Post subject: Reply with quote

Hmmm ... I am also using paludis-1.2.0, which was installed using paludis-1.0.0 -- no problems.

Of course, your choice of package manager should have no effect on the function of the package that was installed with it. All Portage and Paludis do are calculate package dependencies, then execute some scripts with some additional sanity checks. Your bug is very strange.

If you are serious about solving the problem you should inquire to the Paludis developers.
_________________
Personal overlay | Simple backup scheme
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum