Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[RESOLVED] Lyx - Problem with umlauts
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
FRIGN
n00b
n00b


Joined: 12 Jan 2013
Posts: 23
Location: Germany

PostPosted: Fri Feb 22, 2013 7:15 pm    Post subject: [RESOLVED] Lyx - Problem with umlauts Reply with quote

Good evening,

having been using Lyx for quite a while and getting used to it more and more, I am somewhat disturbed by a small problem with entering German umlauts into the editor.
Using a German keyboard, I set my XkbLayout to "de" in the xorg.conf-file and it works flawlessly. Every program, reaching from console to browser handle umlauts properly on keystroke.
Using Lyx, however, I am unfortunately forced to enter umlauts by typing "Ctrl + {ö,ä,ü}", as just pressing the umlaut-key does not work.

I would be really pleased to get some input from you; maybe one of you had a similar problem using this software.

Some info:
I am using xf86-input-mouse and -keyboard instead of evdev; switching to either of both doesn't solve the problem.
USE-flags for xorg-server (1.13.2.901): ipv6, nptl, suid, xorg
USE-flags for lyx (2.0.5): X debug latex svg LINGUAS="en"

If you need more, just let me know!
I am looking forward to your input.


Last edited by FRIGN on Sat Mar 02, 2013 2:27 pm; edited 1 time in total
Back to top
View user's profile Send private message
bec
Apprentice
Apprentice


Joined: 30 Sep 2004
Posts: 153
Location: Cali - Colombia

PostPosted: Mon Feb 25, 2013 10:13 pm    Post subject: Reply with quote

Hello FRIGN,

Have you tested activating utf8 enconding in the document settings?
_________________
abe
Back to top
View user's profile Send private message
FRIGN
n00b
n00b


Joined: 12 Jan 2013
Posts: 23
Location: Germany

PostPosted: Sat Mar 02, 2013 2:29 pm    Post subject: Resolved Reply with quote

bec wrote:
Hello FRIGN,

Have you tested activating utf8 enconding in the document settings?


Thanks for the suggestion, even though the problem existed in another place: My LANG-globvar was not set and Keyboard-input defaulted to the POSIX-locale, which does not handle direct umlaut-input (but only Ctrl+Umlaut and Ctrl+Shift+Umlaut).
Manually exporting the LANG-variable to en_US.iso88591 in bashrc resolves this problem.

I marked this thread as RESOLVED.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum