Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Postfix not appending domain to outgoing emails
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
alexjplant
n00b
n00b


Joined: 14 Feb 2013
Posts: 3

PostPosted: Thu Feb 21, 2013 8:06 pm    Post subject: Postfix not appending domain to outgoing emails Reply with quote

Last night I got Postfix working pretty much perfectly. I started poking around webmin afterwards and enabled canonical mapping so that I could change my email to something more friendly than username@fqdn. When I did this, however, it threw a wrench in the works and stopped transporting mail altogether. I disabled mapping in webmin but now all outgoing emails are lacking a domain name, so instead of an email being from ajplant@fqdn.blah they are from ajplant@ . I have checked main.cf for any hints of rewriting still being enabled and there are none. Anyone have any ideas as to why this is suddenly not working?
_________________
"There iz no spoon."

-The Matricks
Back to top
View user's profile Send private message
John R. Graham
Administrator
Administrator


Joined: 08 Mar 2005
Posts: 7938
Location: Somewhere over Atlanta, Georgia

PostPosted: Thu Feb 21, 2013 8:24 pm    Post subject: Reply with quote

What does
Code:
hostname --fqdn
show? (Feel free to be circumspect. I just want to know if your system knows its fully qualified domain name.)

- John
_________________
I can confirm that I have received between 0 and 999 National Security Letters.
Back to top
View user's profile Send private message
alexjplant
n00b
n00b


Joined: 14 Feb 2013
Posts: 3

PostPosted: Thu Feb 21, 2013 8:29 pm    Post subject: Reply with quote

it shows my FQDN... xx.yy.com. I also tried manually specifying the outbound mail domain and that didn't work either. I'm fairly sure this is Postfix-related but I could be wrong.
_________________
"There iz no spoon."

-The Matricks
Back to top
View user's profile Send private message
gentoo_ram
Guru
Guru


Joined: 25 Oct 2007
Posts: 398
Location: San Diego, California USA

PostPosted: Fri Feb 22, 2013 1:25 am    Post subject: Reply with quote

Typically, the e-mail address as shown to the recipient is set by your mail client. Not the MTA on any server. The MTA may set addresses in the envelope, but users won't see that.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum