Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
paxutils blocker
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
sgarcia
Apprentice
Apprentice


Joined: 21 May 2003
Posts: 249
Location: Bakersfield, CA

PostPosted: Thu Feb 21, 2013 7:43 pm    Post subject: paxutils blocker Reply with quote

I'm having trouble doing a system update.

For some time I've been getting a message at update time:

Code:

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

app-misc/pax-utils:0

  (app-misc/pax-utils-0.6::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (app-misc/pax-utils-0.5::gentoo, installed) pulled in by
    <app-misc/pax-utils-0.6 required by (sys-kernel/genkernel-3.4.45::gentoo, installed)

It appears that the system wants to upgrade pax-utils to 0.6, but genkernel doesn't like anything newer than 0.5. As near as I can can tell (using -pDuvt) nothing really *needs* 0.6, so I've been letting that slide.

Now, it won't proceed beyond that point. I decided to mask '=app-misc/pax-utils-0.6' to eliminate the conflict. Once I do that, the "52 upgrades, 1 in new slot" that were ready to be emerged *all* vanish. No errors, just nothing left in the emerge list:
Code:
These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! The following installed packages are masked:
- media-gfx/picasa-3.0.0.57.4402.0_beta::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Pacho Ramos <pacho@gentoo.org> (10 Feb 2013)
# Upstream dropped support for linux time ago (#434390),
# possible security issues (#360539). You can use Windows
# version with PlayOnLinux. Removal in a month.

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


Surely *everything* doesn't depend on paxutils? What else might be going on?
_________________
Ignorance killed the cat. Curiosity was framed.
Back to top
View user's profile Send private message
nanoczar
Apprentice
Apprentice


Joined: 10 Dec 2002
Posts: 189
Location: Henderson, TN

PostPosted: Sat Apr 06, 2013 5:49 pm    Post subject: Reply with quote

Did you ever resolve this without masking pax-utils? I hate masking things to take care of dependencies...but if that's what we have to do then I'll pull the trigger.
_________________
Don't fight the LaTeX. WORK with the LaTeX!! Become one with the LaTeX!!! - JIC
Back to top
View user's profile Send private message
_artem_
n00b
n00b


Joined: 07 Aug 2012
Posts: 4

PostPosted: Thu Apr 11, 2013 8:31 am    Post subject: Reply with quote

omg gentoo still can't resolve this issue...
I had to mask pax-utils 0.6... but then pax-utils 0.7 was released... but the issue is still there...........

Code:
[ebuild     U  ] app-misc/pax-utils-0.6 [0.5] USE="-python%"

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

app-misc/pax-utils:0

  (app-misc/pax-utils-0.6::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (app-misc/pax-utils-0.5::gentoo, installed) pulled in by
    <app-misc/pax-utils-0.6 required by (sys-kernel/genkernel-3.4.45::gentoo, installed)


[ebuild     U  ] app-misc/pax-utils-0.7 [0.5] USE="-python%"

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

app-misc/pax-utils:0

  (app-misc/pax-utils-0.5::gentoo, installed) pulled in by
    <app-misc/pax-utils-0.6 required by (sys-kernel/genkernel-3.4.45::gentoo, installed)

  (app-misc/pax-utils-0.7::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)


removed genkernel, installed pax-utils 0.7, emerging genkernel again...

Code:
[~] $ e genkernel
Calculating dependencies... done!
[ebuild     UD ] app-misc/pax-utils-0.5 [0.7]
[ebuild  N     ] sys-kernel/genkernel-3.4.45  USE="crypt -cryptsetup (-ibm) (-selinux)"
[blocks B      ] =app-misc/pax-utils-0.5 ("=app-misc/pax-utils-0.5" is blocking sys-kernel/genkernel-3.4.45)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-kernel/genkernel-3.4.45::gentoo, ebuild scheduled for merge) pulled in by
    genkernel

  (app-misc/pax-utils-0.5::gentoo, ebuild scheduled for merge) pulled in by
    >=app-misc/pax-utils-0.1.17 required by (sys-apps/portage-2.1.11.60::gentoo, installed)
    app-misc/pax-utils required by @selected
    <app-misc/pax-utils-0.6 required by (sys-kernel/genkernel-3.4.45::gentoo, ebuild scheduled for merge)
    >=app-misc/pax-utils-0.2.1 required by (sys-kernel/genkernel-3.4.45::gentoo, ebuild scheduled for merge)


removed both (pax-utils and genkernel), emerging genkernel (even if 0.6 and 0.7 aren't masked)...
Code:
~] $ e genkernel             
Calculating dependencies... done!
[ebuild  N     ] app-misc/pax-utils-0.5  USE="-caps"
[ebuild  N     ] sys-kernel/genkernel-3.4.45  USE="-crypt -cryptsetup (-ibm) (-selinux)"
[blocks B      ] =app-misc/pax-utils-0.5 ("=app-misc/pax-utils-0.5" is blocking sys-kernel/genkernel-3.4.45)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-kernel/genkernel-3.4.45::gentoo, ebuild scheduled for merge) pulled in by
    genkernel

the only way is to mask 0.6 and 0.7 that sucks my dear gentoo.. that just sucks
why is the shit moved to portage tree if it's a blocker...
Back to top
View user's profile Send private message
TomWij
Developer
Developer


Joined: 04 Jul 2012
Posts: 1546

PostPosted: Thu Apr 11, 2013 8:54 am    Post subject: Reply with quote

It's right there in your output in your first post:

Quote:
<app-misc/pax-utils-0.6 required by (sys-kernel/genkernel-3.4.45::gentoo, installed)


If you use genkernel, you'll want to mask newer versions of pax-utils for now; until the relevant bug is resolved, that's when they will remove that requirement.

https://bugs.gentoo.org/show_bug.cgi?id=450688
Back to top
View user's profile Send private message
_artem_
n00b
n00b


Joined: 07 Aug 2012
Posts: 4

PostPosted: Thu Apr 11, 2013 9:47 am    Post subject: Reply with quote

TomWij wrote:
It's right there in your output in your first post:

Quote:
<app-misc/pax-utils-0.6 required by (sys-kernel/genkernel-3.4.45::gentoo, installed)


If you use genkernel, you'll want to mask newer versions of pax-utils for now; until the relevant bug is resolved, that's when they will remove that requirement.

https://bugs.gentoo.org/show_bug.cgi?id=450688


I use genkernel only for generating initrams: sudo genkernel --install initramfs
I compile kernel myself from gentoo-sources with my previous config ( `
Code:
sudo cp /usr/src/{linux,linux-LATEST_VERSION_HERE}/.config && cd /usr/src/linux-LATEST_VERSION_HERE && sudo make && sudo make modules_install && sudo cp arch/x86_64/.../bzImage /boot/kernel-LATEST_VERSION_HERE-gentoo
` )
and then `
Code:
sudo rm /usr/src/linux && sudo ln -s /usr/src/{linux-LATEST_VERSION_HERE,linux}
` and then `
Code:
sudo genkernel --install initramfs
` and `
Code:
sudo grub2-mkconfig -o /boot/grub2/grub.cfg
`

am I doing something wrong?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum