Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Nvidia drivers not working in X
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
Proficio41
n00b
n00b


Joined: 07 Dec 2012
Posts: 19

PostPosted: Tue Feb 19, 2013 10:53 am    Post subject: Nvidia drivers not working in X Reply with quote

Hi All,

I have a Lenovo T520 Notebook, with Intel I7 Integrated Graphics and Discrete NVIDIA® NVS 4200M (1GB VRAM ) with Optimus™ Technology Dedicated Graphics

I have successfully build Gentoo on the Intel Graphics side, however I want to switch to the Nvidia graphics (not using Optimus). (switching to graphics device in bios)

I have installed the native NVIDIA drivers and did the Kernel changes as describe in the Gentoo NVidia Wiki (http://en.gentoo-wiki.com/wiki/Nvidia)

But for some reason I can’t get the NVIDIA graphics to run, It boots up properly, even switching to high resolution in boot up. But exits with the following error when X starts.

I would appreciate it immensely if someone could assist me with this issue!

My Gentoo build:

Portage 2.1.11.50 (default/linux/amd64/13.0/no-multilib, gcc-4.6.3, glibc-2.15-r3, 3.6.11-gentoo x86_64)


My Xorg.config log error:


[ 442.495]
X.Org X Server 1.13.1
Release Date: 2012-12-13
[ 442.500] X Protocol Version 11, Revision 0
[ 442.502] Build Operating System: Linux 3.6.11-gentoo x86_64 Gentoo
[ 442.503] Current Operating System: Linux carla 3.6.11-gentoo #12 SMP Sun Feb 17 13:50:50 SAST 2013 x86_64
[ 442.504] Kernel command line: BOOT_IMAGE=/kernel-3.6.11-gentoo root=/dev/sda7 ro splash
[ 442.507] Build Date: 19 February 2013 05:15:40AM
[ 442.509]
[ 442.512] Current version of pixman: 0.28.0
[ 442.517] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[ 442.517] Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 442.526] (==) Log file: "/var/log/Xorg.0.log", Time: Tue Feb 19 05:31:39 2013
[ 442.528] (==) Using config file: "/etc/X11/xorg.conf"
[ 442.530] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[ 442.530] (==) ServerLayout "Layout0"
[ 442.530] (**) |-->Screen "Screen0" (0)
[ 442.530] (**) | |-->Monitor "Monitor0"
[ 442.530] (**) | |-->Device "Device0"
[ 442.530] (**) |-->Input Device "Keyboard0"
[ 442.530] (**) |-->Input Device "Mouse0"
[ 442.530] (==) Automatically adding devices
[ 442.530] (==) Automatically enabling devices
[ 442.530] (==) Automatically adding GPU devices
[ 442.530] (WW) The directory "/usr/share/fonts/TTF/" does not exist.
[ 442.530] Entry deleted from font path.
[ 442.530] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[ 442.530] Entry deleted from font path.
[ 442.530] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[ 442.530] Entry deleted from font path.
[ 442.530] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[ 442.530] Entry deleted from font path.
[ 442.530] (Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[ 442.530] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[ 442.530] Entry deleted from font path.
[ 442.530] (Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[ 442.530] (==) FontPath set to:
/usr/share/fonts/misc/
[ 442.530] (==) ModulePath set to "/usr/lib64/xorg/modules"
[ 442.530] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[ 442.530] (WW) Disabling Keyboard0
[ 442.530] (WW) Disabling Mouse0
[ 442.530] (II) Loader magic: 0x807be0
[ 442.530] (II) Module ABI versions:
[ 442.530] X.Org ANSI C Emulation: 0.4
[ 442.530] X.Org Video Driver: 13.1
[ 442.530] X.Org XInput driver : 18.0
[ 442.530] X.Org Server Extension : 7.0
[ 442.530] (II) config/udev: Adding drm device (/dev/dri/card0)
[ 442.532] (--) PCI:*(0:1:0:0) 10de:1057:17aa:21cf rev 161, Mem @ 0xf2000000/16777216, 0xe0000000/268435456, 0xf0000000/33554432, I/O @ 0x00005000/128, BIOS @ 0x????????/524288
[ 442.532] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[ 442.533] Initializing built-in extension Generic Event Extension
[ 442.534] Initializing built-in extension SHAPE
[ 442.535] Initializing built-in extension MIT-SHM
[ 442.535] Initializing built-in extension XInputExtension
[ 442.536] Initializing built-in extension XTEST
[ 442.537] Initializing built-in extension BIG-REQUESTS
[ 442.538] Initializing built-in extension SYNC
[ 442.538] Initializing built-in extension XKEYBOARD
[ 442.539] Initializing built-in extension XC-MISC
[ 442.540] Initializing built-in extension XINERAMA
[ 442.540] Initializing built-in extension XFIXES
[ 442.541] Initializing built-in extension RENDER
[ 442.542] Initializing built-in extension RANDR
[ 442.543] Initializing built-in extension COMPOSITE
[ 442.543] Initializing built-in extension DAMAGE
[ 442.544] Initializing built-in extension MIT-SCREEN-SAVER
[ 442.544] Initializing built-in extension DOUBLE-BUFFER
[ 442.545] Initializing built-in extension RECORD
[ 442.546] Initializing built-in extension DPMS
[ 442.546] Initializing built-in extension X-Resource
[ 442.547] Initializing built-in extension XVideo
[ 442.547] Initializing built-in extension XVideo-MotionCompensation
[ 442.548] Initializing built-in extension XFree86-VidModeExtension
[ 442.548] Initializing built-in extension XFree86-DGA
[ 442.549] Initializing built-in extension XFree86-DRI
[ 442.549] Initializing built-in extension DRI2
[ 442.549] (II) LoadModule: "glx"
[ 442.550] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[ 442.556] (II) Module glx: vendor="NVIDIA Corporation"
[ 442.556] compiled for 4.0.2, module version = 1.0.0
[ 442.556] Module class: X.Org Server Extension
[ 442.556] (II) NVIDIA GLX Module 304.64 Tue Oct 30 11:18:32 PDT 2012
[ 442.556] Loading extension GLX
[ 442.556] (II) LoadModule: "nvidia"
[ 442.556] (II) Loading /usr/lib64/xorg/modules/drivers/nvidia_drv.so
[ 442.659] (II) Module nvidia: vendor="NVIDIA Corporation"
[ 442.659] compiled for 4.0.2, module version = 1.0.0
[ 442.659] Module class: X.Org Video Driver
[ 442.688] (II) NVIDIA dlloader X Driver 304.64 Tue Oct 30 10:59:51 PDT 2012
[ 442.688] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[ 442.688] (--) using VT number 7

[ 442.696] (II) Loading sub module "fb"
[ 442.696] (II) LoadModule: "fb"
[ 442.696] (II) Loading /usr/lib64/xorg/modules/libfb.so
[ 442.710] (II) Module fb: vendor="X.Org Foundation"
[ 442.710] compiled for 1.13.1, module version = 1.0.0
[ 442.710] ABI class: X.Org ANSI C Emulation, version 0.4
[ 442.710] (II) Loading sub module "wfb"
[ 442.710] (II) LoadModule: "wfb"
[ 442.710] (II) Loading /usr/lib64/xorg/modules/libwfb.so
[ 442.722] (II) Module wfb: vendor="X.Org Foundation"
[ 442.722] compiled for 1.13.1, module version = 1.0.0
[ 442.722] ABI class: X.Org ANSI C Emulation, version 0.4
[ 442.723] (II) Loading sub module "ramdac"
[ 442.723] (II) LoadModule: "ramdac"
[ 442.723] (II) Module "ramdac" already built-in
[ 442.754] (**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
[ 442.754] (==) NVIDIA(0): RGB weight 888
[ 442.754] (==) NVIDIA(0): Default visual is TrueColor
[ 442.754] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[ 442.754] (**) NVIDIA(0): Enabling 2D acceleration
[ 442.904] (EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module. Please see the
[ 442.904] (EE) NVIDIA(0): system's kernel log for additional error messages and
[ 442.904] (EE) NVIDIA(0): consult the NVIDIA README for details.
[ 442.904] (EE) NVIDIA(0): *** Aborting ***
[ 442.904] (EE) NVIDIA(0): Failing initialization of X screen 0
[ 442.904] (II) UnloadModule: "nvidia"
[ 442.904] (II) UnloadSubModule: "wfb"
[ 442.904] (II) UnloadSubModule: "fb"
[ 442.904] (EE) Screen(s) found, but none have a usable configuration.
[ 442.904]
Fatal server error:
[ 442.904] no screens found
[ 442.904] (EE)
Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
[ 442.904] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[ 442.904] (EE)
[ 442.927] Server terminated with error (1). Closing log file.

Any help will be immensely appreciated!

Thanks
Back to top
View user's profile Send private message
mvaterlaus
Apprentice
Apprentice


Joined: 01 Oct 2010
Posts: 157
Location: Switzerland

PostPosted: Tue Feb 19, 2013 11:07 am    Post subject: Reply with quote

hi,
I think, this is your problem:
Code:
[ 442.904] (EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module. Please see the


Do you have selected the right kernel for build? Please compare the output of the following two commands:
Code:
uname -a
eselect kernel list


If they do not match, select the right kernel (the one you are at the moment). It is very important, that you do not have selected any in-kernel graphics driver (framebuffer drivers doesn't have anything to do with that). after that, select the right opengl interface:
Code:
 eselect opengl list


after that, your drivers should work. Maybe you should set VIDEO_CARDS="nvidia" in your make.conf and recompile all packages against the nvidia driver.
Back to top
View user's profile Send private message
Proficio41
n00b
n00b


Joined: 07 Dec 2012
Posts: 19

PostPosted: Tue Feb 19, 2013 11:20 am    Post subject: Reply with quote

Thank you very much for your quick response!

Quote:
My uname -a
Linux carla 3.6.11-gentoo #12 SMP Sun Feb 17 13:50:50 SAST 2013 x86_64 Intel(R) Core(TM) i7-2670QM CPU @ 2.20GHz GenuineIntel GNU/Linux


My eselect settings:
Quote:

carla X11 # eselect opengl list
Available OpenGL implementations:
[1] nvidia *
[2] xorg-x11

carla X11 # eselect opencl list
Available OpenCL implementations:
[1] nvidia *

carla X11 # eselect kernel list
Available kernel symlink targets:
[1] linux-2.6.32-openvz-053.5
[2] linux-3.5.7-gentoo
[3] linux-3.6.11-gentoo *




My Make.conf:
Quote:

CFLAGS="-O2 -march=native -mtune=native -msse -msse2 -msse3 -msse4.1 -msse4.2 -pipe"
CXXFLAGS="${CFLAGS}"
CHOST="x86_64-pc-linux-gnu"

# WARNING: Changing your CHOST is not something that should be done lightly.
# Please consult http://www.gentoo.org/doc/en/change-chost.xml before changing.

MAKEOPTS="-j9"

USE="sse sse2 sse3 ssse3 sse4_1 sse4_2 mmx X intel nvidia acpi alsa branding cups dvd ieee1394 usb xinerama xv vaapi dbus gtk"


INPUT_DEVICES="synaptics evdev"
VIDEO_CARDS="intel nvidia"
ALSA_CARDS="hda-intel"
ACCEPT_LICENSE="*"
FEATURES="parallel-fetch"

QEMU_SOFTMMU_TARGETS="i386 x86_64"
QEMU_USER_TARGETS="i386 x86_64"


GENTOO_MIRRORS="http://chi-10g-1-mirror.fastsoft.net/pub/linux/gentoo/gentoo-distfiles/"

SYNC="rsync://rsync.us.gentoo.org/gentoo-portage"



And I have rebuild the entire system (according to my knowledge) with the following command:

Quote:

emerge --update --deep --with-bdeps=y --newuse world && emerge --depclean && revdep-rebuild


And the problem still persist...any ideas or obvious mistakes? :?


Last edited by Proficio41 on Tue Feb 19, 2013 11:41 am; edited 2 times in total
Back to top
View user's profile Send private message
Proficio41
n00b
n00b


Joined: 07 Dec 2012
Posts: 19

PostPosted: Tue Feb 19, 2013 12:18 pm    Post subject: Nvidia drivers not working in X Reply with quote

One other problem I did notice, was that for some reason LSMOD shows both the Nvidia and Nouveau drivers in the kernel....is this normal or might this be the cause the issue??
Back to top
View user's profile Send private message
mir3x
Tux's lil' helper
Tux's lil' helper


Joined: 02 Jun 2012
Posts: 140

PostPosted: Tue Feb 19, 2013 9:09 pm    Post subject: Reply with quote

yeah, thats issue
1)u can blacklist nouveau via kernel command line ( in bootloader conf for grub2 -> /boot/grub/grub.conf ) or directly in grub
by adding modprobe.blacklist=nouveau

2)or by adding
blacklist nouveau to /etc/modprobe.d/nvidia.conf

3)or recompile kernel without nouveau :D

I always do point 3, so Im not 100% sure if points 1 and 2 will be working, but it should be -> fastest test to do it directly in grub
_________________
Installation aborted to prevent system self-destruction
Back to top
View user's profile Send private message
Proficio41
n00b
n00b


Joined: 07 Dec 2012
Posts: 19

PostPosted: Wed Feb 20, 2013 7:12 am    Post subject: Nvidia drivers not working in X Reply with quote

Thank You! It's working now! :lol:

For some reason I missed that I forgot to remove the Nouveau drivers from the kernel:
Quote:

Device Drivers --->
[*] Staging Drivers --->
< > Nouveau (nVidia) cards
Graphics Support --->
< > Direct Rendering Manager (XFree86 4.1.0 and higher DRI support) --->


After removing and recompiling, my Nvidia drivers works now and is about 10x faster (60fps to 590fps) in glxgears!


However I have one other question, for some reason the dpi/font of my GUI (Fluxbox) is now huge! Much bigger then when I'm using the Intel driver. (I did ensure that the resolution is still the same- nothing was changed in the GUI)

Can you think of any reason why?
Back to top
View user's profile Send private message
mir3x
Tux's lil' helper
Tux's lil' helper


Joined: 02 Jun 2012
Posts: 140

PostPosted: Wed Feb 20, 2013 8:20 am    Post subject: Reply with quote

Its probably about dpi, no idea where it is in fluxbox, in kde there is settings -> force dpi for fonts,
but probably u will have to change xorg.conf in monitor section
and add
Option "UseEdidDpi" "false"
Option "DPI" "96 x 96"


or maybe xrandr could change it -> xrandr --dpi 96

look there
https://wiki.archlinux.org/index.php/Xorg#Display_Size_and_DPI

( if u dont have xorg.conf -> u can generate it by nvidia-xconfig )

btw 590 fps in glxgears is deadly low ( i7 on software rendering maybe could get more :D, I think it should be about 10 000 fps, I have 7000 fps on GF 430GT, not sure but your card looks more powerful )
_________________
Installation aborted to prevent system self-destruction
Back to top
View user's profile Send private message
Proficio41
n00b
n00b


Joined: 07 Dec 2012
Posts: 19

PostPosted: Wed Feb 20, 2013 10:05 am    Post subject: Nvidia drivers not working in X Reply with quote

ThankYou mir3x!

Your advice on setting

Quote:

Option "UseEdidDpi" "false"
Option "DPI" "96 x 96"


in Xorg.conf worked great!

So my Nvidia setup seems complete and is working great!

The only concern I have now is that you mentioned my GLXGears of 590 is slow.... I actually forgot to change my eselect settings to:

Quote:

carla / #
eselect opengl list
Available OpenGL implementations:
[1] nvidia *
[2] xorg-x11


I changed from xorg-x11 to nvidia and now my glxgears is even slower, back to 59 fps!

Maybe I am still missing something?? :? Is there another setting to ensure that my X is using the Nvidia card completely?

.
Back to top
View user's profile Send private message
mir3x
Tux's lil' helper
Tux's lil' helper


Joined: 02 Jun 2012
Posts: 140

PostPosted: Wed Feb 20, 2013 10:14 am    Post subject: Reply with quote

hmm, you have set Vsync on probably ( check nvidia-settings and uncheck sync to vblank if checked )
If it will work, u might keep Vsync enabled if u are not going to play any demanding games.
_________________
Installation aborted to prevent system self-destruction
Back to top
View user's profile Send private message
Proficio41
n00b
n00b


Joined: 07 Dec 2012
Posts: 19

PostPosted: Wed Feb 20, 2013 10:24 am    Post subject: Nvidia drivers not working in X Reply with quote

Right again! 8)

In the Nvidia X Server Settings GUI I have switched OFF:

Quote:

Sync to VBlank
Allow Flipping


and GLXGears went from 60fps to 7030 fps!! :D

Thank you very much, appreciated your assistance with this!

.
Back to top
View user's profile Send private message
Joseph_sys
Advocate
Advocate


Joined: 08 Jun 2004
Posts: 2408
Location: Edmonton, AB

PostPosted: Fri Feb 22, 2013 6:38 am    Post subject: Re: Nvidia drivers not working in X Reply with quote

Proficio41 wrote:
Thank You! It's working now! :lol:

For some reason I missed that I forgot to remove the Nouveau drivers from the kernel:
Quote:

Device Drivers --->
[*] Staging Drivers --->
< > Nouveau (nVidia) cards
Graphics Support --->
< > Direct Rendering Manager (XFree86 4.1.0 and higher DRI support) --->


After removing and recompiling, my Nvidia drivers works now and is about 10x faster (60fps to 590fps) in glxgears!


However I have one other question, for some reason the dpi/font of my GUI (Fluxbox) is now huge! Much bigger then when I'm using the Intel driver. (I did ensure that the resolution is still the same- nothing was changed in the GUI)

Can you think of any reason why?


I have the same problem but your solution did not help, I still get a blank screen.
_________________
#Joseph
Back to top
View user's profile Send private message
Proficio41
n00b
n00b


Joined: 07 Dec 2012
Posts: 19

PostPosted: Fri Feb 22, 2013 8:47 am    Post subject: Nvidia drivers not working in X Reply with quote

Interesting. After doing the changes mir3x recommended my Nvidia setup was perfect. After removing the Vsync & Vblank

I get
Quote:

carla ~ # glxgears
50727 frames in 5.0 seconds = 10145.297 FPS
51721 frames in 5.0 seconds = 10344.085 FPS
51262 frames in 5.0 seconds = 10252.260 FPS


However, I never had a blank screen (my error was Xorg complaining about "no screens found" or something) When I removed the Nouveau support in the kernel and recompiled the kernel my Nvidia driver was working fine.

I did however find, I had to follow the following process to ensure everything worked:
Quote:

1. Removed All options in the kernel and recompiled ;I followed this guides process: http://wiki.gentoo.org/wiki/NVidia/nvidia-drivers
2. emerge nvidia-drivers
3. Changed my Video driver in the BIOS from Native (intel) to Discreet (nvidia)
4. lsmod (to ensure no other unnecessary driver like; Nouveau is present)
5. modprobe -r nvidia (just to be certain) :lol:
6. modprobe nvidia
7. lsmod (to ensure the driver is there)
8. run "nvidia-xconfig" (to build the correct xorg file)
9. startx


Although you your problem is different to mine, as mentioned I never had the blank screen.

However, I would look into 2 things, the Nvidia driver (ensure it is 100% correct 4 the card) and I would disable /etc/init.d/xdm stop and startx manually to ensure I can follow the errors.

I did find this post regarding black screens, http://forums.gentoo.org/viewtopic-t-785423.html

.
Back to top
View user's profile Send private message
Joseph_sys
Advocate
Advocate


Joined: 08 Jun 2004
Posts: 2408
Location: Edmonton, AB

PostPosted: Fri Feb 22, 2013 8:57 am    Post subject: Re: Nvidia drivers not working in X Reply with quote

Proficio41 wrote:

...
8. run "nvidia-xconfig" (to build the correct xorg file)
.


Where did you find "nvidia-xconfig" I don't have this file?
_________________
#Joseph
Back to top
View user's profile Send private message
mir3x
Tux's lil' helper
Tux's lil' helper


Joined: 02 Jun 2012
Posts: 140

PostPosted: Fri Feb 22, 2013 9:21 am    Post subject: Reply with quote

Its from nvidia-drivers, have u emerged that ( u might need add "tools" flag )? I feel that u r making jokes here :D

maybe betteer post : cat /var/log/Xorg.0.log | grep EE
_________________
Installation aborted to prevent system self-destruction
Back to top
View user's profile Send private message
Joseph_sys
Advocate
Advocate


Joined: 08 Jun 2004
Posts: 2408
Location: Edmonton, AB

PostPosted: Fri Feb 22, 2013 9:32 am    Post subject: Reply with quote

mir3x wrote:
Its from nvidia-drivers, have u emerged that ( u might need add "tools" flag )? I feel that u r making jokes here :D

maybe betteer post : cat /var/log/Xorg.0.log | grep EE


I wish I did make a joke :-/
but I have nvidia-drivers installed with flag "tools" but don't not have this binary:
x11-drivers/nvidia-drivers-304.64 USE="X acpi (multilib) tools -pax_kernel

Code:
 cat /var/log/Xorg.0.log | grep EE
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   288.401] Initializing built-in extension MIT-SCREEN-SAVER
[   313.863] (EE)
[   313.863] (EE) Backtrace:
[   313.863] (EE) 0: /usr/bin/X (xorg_backtrace+0x36) [0x5979d6]
[   313.863] (EE) 1: /usr/bin/X (0x400000+0x19b8c9) [0x59b8c9]
[   313.863] (EE) 2: /lib64/libpthread.so.0 (0x7fdb5cc20000+0x10810) [0x7fdb5cc30810]
[   313.863] (EE) 3: /lib64/libc.so.6 (0x7fdb5b880000+0x136284) [0x7fdb5b9b6284]
[   313.863] (EE) 4: /usr/lib64/xorg/modules/drivers/nvidia_drv.so (0x7fdb56fd8000+0x116fd3) [0x7fdb570eefd3]
[   313.863] (EE) 5: /usr/lib64/xorg/modules/drivers/nvidia_drv.so (0x7fdb56fd8000+0x1172ed) [0x7fdb570ef2ed]
[   313.863] (EE) 6: /usr/lib64/xorg/modules/drivers/nvidia_drv.so (0x7fdb56fd8000+0xab654) [0x7fdb57083654]
[   313.863] (EE) 7: /usr/lib64/xorg/modules/drivers/nvidia_drv.so (0x7fdb56fd8000+0xe64e1) [0x7fdb570be4e1]
[   313.863] (EE) 8: /usr/lib64/xorg/modules/drivers/nvidia_drv.so (0x7fdb56fd8000+0xb87ed) [0x7fdb570907ed]
[   313.863] (EE) 9: /usr/lib64/xorg/modules/drivers/nvidia_drv.so (0x7fdb56fd8000+0x55a3d2) [0x7fdb575323d2]
[   313.863] (EE) 10: /usr/bin/X (AddScreen+0x88) [0x439928]
[   313.864] (EE) 11: /usr/bin/X (InitOutput+0x3fc) [0x47d09c]
[   313.864] (EE) 12: /usr/bin/X (0x400000+0x280e3) [0x4280e3]
[   313.864] (EE) 13: /lib64/libc.so.6 (__libc_start_main+0xec) [0x7fdb5b8a24cc]
[   313.864] (EE) 14: /usr/bin/X (0x400000+0x27e09) [0x427e09]
[   313.864] (EE)
[   313.864] (EE) Segmentation fault at address 0x7fdb5d8b7ff0
[   313.864] (EE)
[   313.864] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[   313.864] (EE)

_________________
#Joseph


Last edited by Joseph_sys on Fri Feb 22, 2013 9:46 am; edited 2 times in total
Back to top
View user's profile Send private message
mir3x
Tux's lil' helper
Tux's lil' helper


Joined: 02 Jun 2012
Posts: 140

PostPosted: Fri Feb 22, 2013 9:34 am    Post subject: Reply with quote

U dont need that anyway.
try unmask newer drivers ?
_________________
Installation aborted to prevent system self-destruction
Back to top
View user's profile Send private message
Gusar
Advocate
Advocate


Joined: 09 Apr 2005
Posts: 2643
Location: Slovenia

PostPosted: Fri Feb 22, 2013 10:03 am    Post subject: Reply with quote

So, the outdated and useless nvidia-xconfig finally got removed. Great! Well, it would be great, but the ebuilds still reference it.

And FFS people, stop using glxgears as a benchmark!! Jeez. I wish someone removed that too!
Back to top
View user's profile Send private message
Joseph_sys
Advocate
Advocate


Joined: 08 Jun 2004
Posts: 2408
Location: Edmonton, AB

PostPosted: Fri Feb 22, 2013 10:24 am    Post subject: Reply with quote

mir3x wrote:
U dont need that anyway.
try unmask newer drivers ?


I tried nvidia-divers-310.19
It did not help:
Code:
cat /var/log/Xorg.0.log | grep EE
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  4291.232] Initializing built-in extension MIT-SCREEN-SAVER
[  4303.836] (EE) NVIDIA(GPU-0): EVO Push buffer channel allocation failed
[  4303.836] (EE)  *** Aborting ***
[  4303.836] (EE) NVIDIA(GPU-0): Failed to allocate EVO core DMA push buffer
[  4303.836] (EE)  *** Aborting ***
[  4303.836] (EE) NVIDIA(0): Failing initialization of X screen 0
[  4391.664] (EE) Screen(s) found, but none have a usable configuration.
[  4391.664] (EE)
[  4391.664] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[  4391.664] (EE)

_________________
#Joseph
Back to top
View user's profile Send private message
Proficio41
n00b
n00b


Joined: 07 Dec 2012
Posts: 19

PostPosted: Fri Feb 22, 2013 10:54 am    Post subject: Nvidia drivers not working in X Reply with quote

Just a question Joseph_sys, what card model is it you are using?
Back to top
View user's profile Send private message
mir3x
Tux's lil' helper
Tux's lil' helper


Joined: 02 Jun 2012
Posts: 140

PostPosted: Fri Feb 22, 2013 10:59 am    Post subject: Reply with quote

few lines before

Quote:
[ 4303.836] (EE) NVIDIA(GPU-0): EVO Push buffer channel allocation failed
[ 4303.836] (EE) *** Aborting ***
[ 4303.836] (EE) NVIDIA(GPU-0): Failed to allocate EVO core DMA push buffer
[ 4303.836] (EE) *** Aborting ***

would be helpful .

maybe u get message - NVIDIA: could not open the device file /dev/nvidia0 ?

havent u told us anything useful like using 2 xservers, or bumblebee ?

there is section Black/Blank screen when starting X
on http://en.gentoo-wiki.com/wiki/Nvidia
have u tried that ?

I suppose now u should have /opt/bin/nvidia-xconfig or /usr/bin/nvidia-xconfig
_________________
Installation aborted to prevent system self-destruction


Last edited by mir3x on Fri Feb 22, 2013 11:10 am; edited 2 times in total
Back to top
View user's profile Send private message
Joseph_sys
Advocate
Advocate


Joined: 08 Jun 2004
Posts: 2408
Location: Edmonton, AB

PostPosted: Fri Feb 22, 2013 11:01 am    Post subject: Re: Nvidia drivers not working in X Reply with quote

Proficio41 wrote:
Just a question Joseph_sys, what card model is it you are using?


According to lspic I have:
VGA compatible controller: NVIDIA Corporation GF116 [GeForce GTS 450] (rev a1)
_________________
#Joseph
Back to top
View user's profile Send private message
Joseph_sys
Advocate
Advocate


Joined: 08 Jun 2004
Posts: 2408
Location: Edmonton, AB

PostPosted: Fri Feb 22, 2013 11:34 am    Post subject: Reply with quote

mir3x wrote:
few lines before

Quote:
[ 4303.836] (EE) NVIDIA(GPU-0): EVO Push buffer channel allocation failed
[ 4303.836] (EE) *** Aborting ***
[ 4303.836] (EE) NVIDIA(GPU-0): Failed to allocate EVO core DMA push buffer
[ 4303.836] (EE) *** Aborting ***

would be helpful .

maybe u get message - NVIDIA: could not open the device file /dev/nvidia0 ?

havent u told us anything useful like using 2 xservers, or bumblebee ?

there is section Black/Blank screen when starting X
on http://en.gentoo-wiki.com/wiki/Nvidia
have u tried that ?

I suppose now u should have /opt/bin/nvidia-xconfig or /usr/bin/nvidia-xconfig


It looks like kernel-3.5.7 is not compatible with my my nvidia card
I downgraded the kernel to 3.1.6 and both (nvidia and xorg-x11) works with my nvida-driver-295.75 but after switching to kernel-3.5.7 the "X" will not start (I'm running xfce4)

Here is the log:
Code:
[   199.370] (II) NVIDIA(0): Creating default Display subsection in Screen section
   "Default Screen Section" for depth/fbbpp 24/32
[   199.370] (==) NVIDIA(0): Depth 24, (==) framebuffer bpp 32
[   199.370] (==) NVIDIA(0): RGB weight 888
[   199.370] (==) NVIDIA(0): Default visual is TrueColor
[   199.370] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[   199.370] (**) NVIDIA(0): Enabling 2D acceleration
[   209.298] (II) NVIDIA(GPU-0): Display (BenQ V2400W (DFP-1)) does not support NVIDIA 3D
[   209.298] (II) NVIDIA(GPU-0):     Vision stereo.
[   209.300] (II) NVIDIA(0): NVIDIA GPU GeForce GTS 450 (GF116) at PCI:1:0:0 (GPU-0)
[   209.300] (--) NVIDIA(0): Memory: 1048576 kBytes
[   209.300] (--) NVIDIA(0): VideoBIOS: 70.26.29.00.00
[   209.300] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[   209.300] (--) NVIDIA(0): Interlaced video modes are supported on this GPU
[   212.305] (--) NVIDIA(0): Connected display device(s) on GeForce GTS 450 at PCI:1:0:0
[   212.305] (--) NVIDIA(0):     BenQ V2400W (DFP-1)
[   212.305] (--) NVIDIA(0): BenQ V2400W (DFP-1): 165.0 MHz maximum pixel clock
[   212.305] (--) NVIDIA(0): BenQ V2400W (DFP-1): Internal Single Link TMDS
[   212.308] (**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
[   212.308] (**) NVIDIA(0):     device BenQ V2400W (DFP-1) (Using EDID frequencies has
[   212.308] (**) NVIDIA(0):     been enabled on all display devices.)
[   212.308] (WW) NVIDIA(0): The EDID for BenQ V2400W (DFP-1) contradicts itself: mode
[   212.308] (WW) NVIDIA(0):     "720x480" is specified in the EDID; however, the EDID's
[   212.308] (WW) NVIDIA(0):     valid HorizSync range (31.000-94.000 kHz) would exclude
[   212.308] (WW) NVIDIA(0):     this mode's HorizSync (15.7 kHz); ignoring HorizSync check
[   212.308] (WW) NVIDIA(0):     for mode "720x480".
[   212.310] (WW) NVIDIA(0): The EDID for BenQ V2400W (DFP-1) contradicts itself: mode
[   212.310] (WW) NVIDIA(0):     "720x480" is specified in the EDID; however, the EDID's
[   212.310] (WW) NVIDIA(0):     valid HorizSync range (31.000-94.000 kHz) would exclude
[   212.310] (WW) NVIDIA(0):     this mode's HorizSync (15.7 kHz); ignoring HorizSync check
[   212.310] (WW) NVIDIA(0):     for mode "720x480".
[   212.319] (II) NVIDIA(0): Assigned Display Device: DFP-1
[   212.319] (==) NVIDIA(0):
[   212.319] (==) NVIDIA(0): No modes were requested; the default mode "nvidia-auto-select"
[   212.319] (==) NVIDIA(0):     will be used as the requested mode.
[   212.319] (==) NVIDIA(0):
[   212.319] (II) NVIDIA(0): Validated modes:
[   212.319] (II) NVIDIA(0):     "nvidia-auto-select"
[   212.319] (II) NVIDIA(0): Virtual screen size determined to be 1920 x 1200
[   212.350] (--) NVIDIA(0): DPI set to (93, 95); computed from "UseEdidDpi" X config
[   212.350] (--) NVIDIA(0):     option
[   212.350] (--) Depth 24 pixmap format is 32 bpp
[   212.350] (II) NVIDIA: Using 3072.00 MB of virtual memory for indirect memory
[   212.350] (II) NVIDIA:     access.
[   212.353] (II) NVIDIA(0): ACPI: failed to connect to the ACPI event daemon; the daemon
[   212.353] (II) NVIDIA(0):     may not be running or the "AcpidSocketPath" X
[   212.353] (II) NVIDIA(0):     configuration option may not be set correctly.  When the
[   212.353] (II) NVIDIA(0):     ACPI event daemon is available, the NVIDIA X driver will
[   212.353] (II) NVIDIA(0):     try to use it to receive ACPI event notifications.  For
[   212.353] (II) NVIDIA(0):     details, please see the "ConnectToAcpid" and
[   212.353] (II) NVIDIA(0):     "AcpidSocketPath" X configuration options in Appendix B: X
[   212.353] (II) NVIDIA(0):     Config Options in the README.
[   215.359] (II) NVIDIA(0): Setting mode "nvidia-auto-select"
[   218.365]
Backtrace:
[   218.365] 0: /usr/bin/X (xorg_backtrace+0x28) [0x566728]
[   218.365] 1: /usr/bin/X (0x400000+0x16a569) [0x56a569]
[   218.366] 2: /lib64/libpthread.so.0 (0x7f497a628000+0x10810) [0x7f497a638810]
[   218.366] 3: /lib64/libc.so.6 (0x7f4979498000+0x136284) [0x7f49795ce284]
[   218.366] 4: /usr/lib64/xorg/modules/drivers/nvidia_drv.so (0x7f4974638000+0x10a67f) [0x7f497474267f]
[   218.366] 5: /usr/lib64/xorg/modules/drivers/nvidia_drv.so (0x7f4974638000+0x10a9cd) [0x7f49747429cd]
[   218.366] 6: /usr/lib64/xorg/modules/drivers/nvidia_drv.so (0x7f4974638000+0xa4994) [0x7f49746dc994]
[   218.366] 7: /usr/lib64/xorg/modules/drivers/nvidia_drv.so (0x7f4974638000+0xd7ec1) [0x7f497470fec1]
[   218.366] 8: /usr/lib64/xorg/modules/drivers/nvidia_drv.so (0x7f4974638000+0xb25fd) [0x7f49746ea5fd]
[   218.366] 9: /usr/lib64/xorg/modules/drivers/nvidia_drv.so (0x7f4974638000+0x4a52c2) [0x7f4974add2c2]
[   218.366] 10: /usr/bin/X (AddScreen+0x177) [0x435857]
[   218.366] 11: /usr/bin/X (InitOutput+0x29b) [0x471fdb]
[   218.366] 12: /usr/bin/X (0x400000+0x24803) [0x424803]
[   218.366] 13: /lib64/libc.so.6 (__libc_start_main+0xec) [0x7f49794ba4cc]
[   218.366] 14: /usr/bin/X (0x400000+0x24529) [0x424529]
[   218.366] Segmentation fault at address 0x7f497b2ffff0
[   218.366]
Fatal server error:
[   218.366] Caught signal 11 (Segmentation fault). Server aborting
[   218.366]
[   218.366]
Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
[   218.366] Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[   218.366]
[   218.368] Server terminated with error (1). Closing log file.

_________________
#Joseph
Back to top
View user's profile Send private message
Proficio41
n00b
n00b


Joined: 07 Dec 2012
Posts: 19

PostPosted: Fri Feb 22, 2013 12:51 pm    Post subject: Nvidia drivers not working in X Reply with quote

.

I have the same problem now. I have just updated (emerge-webrsync) and got the latest Kernel Linux 3.7.9-gentoo #2 SMP

After recompiling the new kernel, I couldn't modprobe-rebuild rebuild my Nvidia driver!
When modprobe-rebuild rebuild try and re-emerge the driver, compile fails on:

Quote:

*** Unable to determine the target kernel version. ***


Someone have an Idea why?

and I did eselect kernel to the latest kernel version.

I'm busy emerging the latest Nvidia Driver (beta) to see if does resolve the problem....

if not I'll revert back to the previous kernel 3.6.11 and stable Nvidia drivers that works :(



I do however have another irritating problem in the sense, since I have started using the nvidia drivers, my boot and terminal sessions seems to be running in 640x480 res.
Do you know of a way to fix this??


.
Back to top
View user's profile Send private message
Gusar
Advocate
Advocate


Joined: 09 Apr 2005
Posts: 2643
Location: Slovenia

PostPosted: Fri Feb 22, 2013 12:59 pm    Post subject: Reply with quote

I know the driver requires patching for 3.8, but maybe the same (or similar) patch is required for 3.7 too. Google is your friend.

For the console, there's (u)vesafb. May not give you the resolution you want though, modern cards in many cases don't have widescreen resolutions in their vbios.
Back to top
View user's profile Send private message
Proficio41
n00b
n00b


Joined: 07 Dec 2012
Posts: 19

PostPosted: Fri Feb 22, 2013 1:35 pm    Post subject: <SOLVED> Nvidia drivers not working in X Reply with quote

.

My Nvidia drivers are working with the following configuration: :D

Quote:

Linux carla 3.7.9-gentoo #2 SMP Fri Feb 22 11:53:47 SAST 2013 x86_64 Intel(R) Core(TM) i7-2670QM CPU @ 2.20GHz GenuineIntel GNU/Linux
Fri Feb 22 15:01:52 2013 >>> x11-drivers/nvidia-drivers-313.18


Do know at this stage the Nvidia drivers are still in beta!

From my side this was successfull.

Thanks for the assistance every one


.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum