Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Fluxbox & Slim: Failed to execute login command
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
Braindump
n00b
n00b


Joined: 16 Feb 2013
Posts: 14

PostPosted: Mon Feb 18, 2013 6:34 pm    Post subject: [SOLVED] Fluxbox & Slim: Failed to execute login command Reply with quote

Hello,

I have a problem with fluxbox and slim.
The login with my user account failed with error:
Slim: Failed to execute login command

I have no idea what the problem is. Could anybody help me?

Which files you need?

Best regards,
Braindump


Last edited by Braindump on Sun Feb 24, 2013 12:00 pm; edited 1 time in total
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5250

PostPosted: Mon Feb 18, 2013 8:21 pm    Post subject: Reply with quote

Open /etc/slim.conf. Uncomment this line:

Code:

login_cmd           exec /bin/bash -login ~/.xinitrc %session


and put

Code:

exec startfluxbox


in ~/.xinitrc.
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Pappy's Kernel Seeds: http://kernel-seeds.gentoostudio.org
Back to top
View user's profile Send private message
cach0rr0
Moderator
Moderator


Joined: 13 Nov 2008
Posts: 4121
Location: Houston, Republic of Texas

PostPosted: Wed Feb 20, 2013 7:19 am    Post subject: Reply with quote

funny enough, just did a fresh install on a new Thinkpad T420, fluxbox and slim as per usual
I'd forgotten the process, so i had to go through it again myself

it just took a)an appropriate slim.conf, b)setting XSESSION in /etc/env.d/90xsession

this is my slim.conf (with comments and blank lines stripped) if that helps

Code:

vunnable ~ # egrep -v '^(\#|$)' /etc/slim.conf
default_path        /bin:/usr/bin:/usr/local/bin
default_xserver     /usr/bin/X
xserver_arguments   -nolisten tcp -br -deferglyphs 16 vt07
halt_cmd            /sbin/shutdown -h now
reboot_cmd          /sbin/shutdown -r now
console_cmd         /usr/bin/xterm -C -fg white -bg black +sb -T "Console login" -e /bin/sh -c "/bin/cat /etc/issue; exec /bin/login"
xauth_path         /usr/bin/xauth
authfile           /var/run/slim.auth
numlock             off
login_cmd           exec /bin/bash -login /usr/share/slim/Xsession %session
sessionstart_cmd   /usr/bin/sessreg -a -l :0.0 %user
sessionstop_cmd     /usr/bin/sessreg -d -l :0.0 %user
daemon   yes
sessiondir           /etc/X11/Sessions
screenshot_cmd      import -window root /slim.png
welcome_msg         Welcome to %host
shutdown_msg       The system is halting...
reboot_msg         The system is rebooting...
current_theme       slim-gentoo-simple
lockfile            /var/run/slim.pid
logfile             /var/log/slim.log


and then /etc/env.d/90xsession containing:

Code:

XSESSION="fluxbox"


this is all it took to get me running. There were further tweaks, but no errors about failing to execute login command.

only real difference between mine and audiodef's bit above, he's using an .xinitrc found in a given user's home directory. I'm using that environment variable. They accomplish the same thing different ways. Well, mostly the same.

If you want every user to default to fluxbox, the /etc/env.d/90xsession route is the one to go
if you want to set window manager or desktop environment on a per user basis, the thing to do is create an .xinitrc in the home directory of every use r (for those desiring fluxbox, just contains exec startfluxbox), and put in the requisite startup commands for the desired desktop, and skip setting the env variable.

Some other subtle differences. But that's the gist of it. Set up XSESSION, or, create an .xinitrc
_________________
Lost configuring your system?
dump lspci -n here | see Pappy's guide | Link Stash
Back to top
View user's profile Send private message
Braindump
n00b
n00b


Joined: 16 Feb 2013
Posts: 14

PostPosted: Sun Feb 24, 2013 12:00 pm    Post subject: Reply with quote

thx.

that solve the problem.

BG
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum