Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
On XEN, can't boot dom0 after switching to gentoo-sources
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
syl22_00
n00b
n00b


Joined: 31 Aug 2011
Posts: 12

PostPosted: Mon Feb 18, 2013 2:10 am    Post subject: On XEN, can't boot dom0 after switching to gentoo-sources Reply with quote

Hi,

Following the udev upgrade requiring kernel 2.6.39+, I am trying to switch my gentoo server from using xen-sources to gentoo-sources as the XEN patches are now in the main sources. I have configured the kernel as documented on "Configuring Gentoo with Xen" and I am now able to have all domUs run the new kernel. Meanwhile, dom0 fails to boot with that kernel.

Boot fails fails saying something like "please append a correct root=" (It reboots right away, I barely have time to read). So I don't know if the issue comes from the grub entry or the kernel compilation parameters.

On grub this entry works fine (kernel is xen-sources):
root (hd0,1)
kernel /boot/xen.gz dom0_mem=4096M dom0_max_vcpus=1 dom0_vcpus_pin
module /boot/kernel-2.6.38-xen-dom0 root=/dev/sda6


This grub setting fails (kernel is gentoo-sources):
root (hd0,1)
kernel /boot/xen.gz dom0_mem=4096M dom0_max_vcpus=1 dom0_vcpus_pin
module /boot/kernel-3.6.11-gentoo root=/dev/sda6

Any clue of what I might be missing?
Back to top
View user's profile Send private message
BradN
Advocate
Advocate


Joined: 19 Apr 2002
Posts: 2379
Location: Wisconsin (USA)

PostPosted: Thu Feb 21, 2013 7:37 am    Post subject: Reply with quote

I might be stating the obvious, but have you made sure your SATA (i'm assuming) controller driver and filesystem driver are compiled in the kernel?

Otherwise can you boot with root in a ramdisk and make investigations as to why the hard drive partition isn't mounting?
Back to top
View user's profile Send private message
syl22_00
n00b
n00b


Joined: 31 Aug 2011
Posts: 12

PostPosted: Thu Feb 21, 2013 9:54 am    Post subject: Reply with quote

Thank you, I'm sorry and embarrassed, I indeed forgot to include drivers for my controller. Everything works well now, and xen on gentoo is becoming much easier to set up and maintain with gentoo-sources.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum