Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Configurar ATI-Radeon [solventado]
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
Luciernaga
Guru
Guru


Joined: 05 Apr 2006
Posts: 378
Location: LANDETE (Cuenca)

PostPosted: Sat Feb 16, 2013 9:10 am    Post subject: Configurar ATI-Radeon [solventado] Reply with quote

Ultimamente mi portátil se empeña en darme problemas, curiosamente solo con Gentoo ...
Veamos, trato de configurar la gráfica ATI Mobility Radeon HD 5650 con los drivers de Gentoo (emerge ati-drivers) y al configurarlos me da error ...
Ver el log ... http://pastebin.com/CK8SZgxt

Por supuesto que en make.conf tengo puesto VIDEO_CARDS="radeon" como mandan los cánones y el resto todo funciona como debe, pero no me arrancan las Xs ni con startx ni con kdm ...
Qué es lo que hago mal o lo que no tengo configurado correctamente?
Gracias
_________________
Soy como una diminuta luciérnaga, perdido en la inmensa oscuridad del universo.


Last edited by Luciernaga on Sun Feb 17, 2013 11:36 am; edited 1 time in total
Back to top
View user's profile Send private message
pelelademadera
Veteran
Veteran


Joined: 14 Jul 2008
Posts: 1054
Location: La Plata, Argentina

PostPosted: Sat Feb 16, 2013 12:50 pm    Post subject: Reply with quote

ati-drivers...
en video cards tenes que poner fglrx, el driver que estas emergiendo es el privativo de ati.

VIDEO_CARDS="fglrx"

o bien tendrias que emerger el driver libre usando radeon en VIDEO_CARDS
y emerge xf86-video-ati si no me equivoco

despues de eso recorda del eselect:
eselect opengl list
eselect opengl set #

saludos
_________________
el pelado de la gente
------
Los habitantes de las islas Malvinas lo llaman gentoo, nombre en el que se basa la distribución GNU/Linux Gentoo, cuyo objetivo es la optimización para conseguir más rendimiento y velocidad en la ejecución.
------
Back to top
View user's profile Send private message
papu
Guru
Guru


Joined: 25 Jan 2008
Posts: 390
Location: Sota algun pi de l'empordà

PostPosted: Sat Feb 16, 2013 10:23 pm    Post subject: Reply with quote

oficiales de ati que van actualmente incluso mejor que en windows(en opengl):
http://wiki.gentoo.org/wiki/Fglrx

libres de linux bastante inferiores en 3d:
http://wiki.gentoo.org/wiki/Radeon


yo uso los oficiales, si quieres los ultimos usa el overlay x11, no se si sabes usar overlays, si dices que usas los ati-drivers has de poner fglrx en lugar de radeon en el make.conf y volver a compilarlos junto al xorg-server y xorg-drivers.

ad1
_________________
--Intel i5 3570k --Asrock z77 ext. 4 --Skill 32GB dd3 --Radeon r9 270 --S.O Gentoo & Win 64bits
Back to top
View user's profile Send private message
Arctic
Apprentice
Apprentice


Joined: 04 Jul 2011
Posts: 178

PostPosted: Sat Feb 16, 2013 11:09 pm    Post subject: Reply with quote

Varias cosillas:

El driver que estas emergiendo es el opensource "radeon" el privativo es "fglrx"
Si emerges el driver opensource debes de insertar el firmware en el kernel ,como ventaja tiene que no tienes porque usar xorg.conf , un rendimiento en 2D mejor que el propietario y en 3D si usas la version inestable 3.8 del kernel junto con mesa 9.2 que se encuentra en el git de desarrollo de gento conseguiras un rendimiento 3D muy bueno.

En mi caso con kernel 3.7 y mesa 9 conseguia 1300.000 y con el mencionado arriba 2600.000 lo cual supone una mejora del 50% del rendimiento, con el driver de ati en mi caso no supero esos frames.

Otra opcion es usar el privativo fglrx, teniendo en cuenta que para las tarjetas r600 no funcionara con el ultimo xserver, si quieres usarlo, hay que hacer ciertos cambios en el kernel ,sino te dara error, para eso hay varias guias en el Wiki.


Un saludo
_________________
ln -s /user/artic /user/arctic
Back to top
View user's profile Send private message
papu
Guru
Guru


Joined: 25 Jan 2008
Posts: 390
Location: Sota algun pi de l'empordà

PostPosted: Sat Feb 16, 2013 11:32 pm    Post subject: Reply with quote

Arctic wrote:


Otra opcion es usar el privativo fglrx, teniendo en cuenta que para las tarjetas r600 no funcionara con el ultimo xserver, si quieres usarlo, hay que hacer ciertos cambios en el kernel ,sino te dara error, para eso hay varias guias en el Wiki.


Un saludo


a que xserver te refieres ¿a alguno que esta por salir? porque a mi me funciona perfectamente :)
_________________
--Intel i5 3570k --Asrock z77 ext. 4 --Skill 32GB dd3 --Radeon r9 270 --S.O Gentoo & Win 64bits
Back to top
View user's profile Send private message
Arctic
Apprentice
Apprentice


Joined: 04 Jul 2011
Posts: 178

PostPosted: Sun Feb 17, 2013 12:56 am    Post subject: Reply with quote

papu wrote:
Arctic wrote:


Otra opcion es usar el privativo fglrx, teniendo en cuenta que para las tarjetas r600 no funcionara con el ultimo xserver, si quieres usarlo, hay que hacer ciertos cambios en el kernel ,sino te dara error, para eso hay varias guias en el Wiki.


Un saludo


a que xserver te refieres ¿a alguno que esta por salir? porque a mi me funciona perfectamente :)


Me refiero a la rama 1.13 y siguientes.
Pero no es algo qu ediga yo, es que cuando emerges el driver privativo, te pone un aviso precisamente para que no te lleves sorpresas. Para usar el dirver privativo con una HD4000 por ejemplo debes de instalar un xorg 1.12 junto con los drivers legacy.

Salu2
_________________
ln -s /user/artic /user/arctic
Back to top
View user's profile Send private message
papu
Guru
Guru


Joined: 25 Jan 2008
Posts: 390
Location: Sota algun pi de l'empordà

PostPosted: Sun Feb 17, 2013 1:24 am    Post subject: Reply with quote

Arctic wrote:
papu wrote:
Arctic wrote:


Otra opcion es usar el privativo fglrx, teniendo en cuenta que para las tarjetas r600 no funcionara con el ultimo xserver, si quieres usarlo, hay que hacer ciertos cambios en el kernel ,sino te dara error, para eso hay varias guias en el Wiki.


Un saludo


a que xserver te refieres ¿a alguno que esta por salir? porque a mi me funciona perfectamente :)


Me refiero a la rama 1.13 y siguientes.
Pero no es algo qu ediga yo, es que cuando emerges el driver privativo, te pone un aviso precisamente para que no te lleves sorpresas. Para usar el dirver privativo con una HD4000 por ejemplo debes de instalar un xorg 1.12 junto con los drivers legacy.

Salu2


aja desconocia eso, lo que si se es que partir de la serie hd 5000, como es mi caso y por lo que veo tambíen del que ha escrito el post, no usa drivers legacy, yo estoy usando xorg-server-1.13.2 sin ningun problema.

http://i3.minus.com/ibuDlAMDIaIhdd.png


saludos, ad1
_________________
--Intel i5 3570k --Asrock z77 ext. 4 --Skill 32GB dd3 --Radeon r9 270 --S.O Gentoo & Win 64bits


Last edited by papu on Sun Feb 17, 2013 1:35 am; edited 2 times in total
Back to top
View user's profile Send private message
Arctic
Apprentice
Apprentice


Joined: 04 Jul 2011
Posts: 178

PostPosted: Sun Feb 17, 2013 1:34 am    Post subject: Reply with quote

papu wrote:
Arctic wrote:
papu wrote:
Arctic wrote:


Otra opcion es usar el privativo fglrx, teniendo en cuenta que para las tarjetas r600 no funcionara con el ultimo xserver, si quieres usarlo, hay que hacer ciertos cambios en el kernel ,sino te dara error, para eso hay varias guias en el Wiki.


Un saludo


a que xserver te refieres ¿a alguno que esta por salir? porque a mi me funciona perfectamente :)


Me refiero a la rama 1.13 y siguientes.
Pero no es algo qu ediga yo, es que cuando emerges el driver privativo, te pone un aviso precisamente para que no te lleves sorpresas. Para usar el dirver privativo con una HD4000 por ejemplo debes de instalar un xorg 1.12 junto con los drivers legacy.

Salu2


aja desconocia eso, lo que si se es que partir de la serie hd5000, como es mi caso y por lo que veo tambíen del que ha escrito el post, no usa drivers legacy, yo estoy usando xorg-server-1.13.2 sin ningun problema.


saludos, ad1


Si , por desgracia AMD ,ha dicho que la rama HD4000 e inferiores ya estan obsoletas y por lo tanto es un lastre tener que dar soporte a una gama tan amplia de dispositivos, que segun ellos además han conseguido el máximo rendimiento (supongo que esto ultimo los habran dicho en modo irónico)

Efectivamente el rendiento es 3D en algunas tarjetas es bueno e incluso excelente , lo peor viene del rendimiento 2D que es insufrible y donde nvidia la supera. Tampoco se han dignado en darnos aceleracion para flash salvo forzando vaapi con gnash, en fin que fabrican un hardware estupendo, pero con desembarcos como el de steam tienen que ponerse las pilas ,pues ya no hay disculpas .

Disculpa el rollo patatero.

Salu2
_________________
ln -s /user/artic /user/arctic
Back to top
View user's profile Send private message
papu
Guru
Guru


Joined: 25 Jan 2008
Posts: 390
Location: Sota algun pi de l'empordà

PostPosted: Sun Feb 17, 2013 1:41 am    Post subject: Reply with quote

hasta ahora creo que ni había legacy es decir no había la diferenciaion entre unos y otros, y desconocia que davan por culo con el xorg-server como siempre, pues menuda mierda, yo deje de usarlos amargado por ese tema hace un par de años.

y hace solo 1 mes y pico que puse los binarios por pura casualidad y en hd 5000 el aumento es bestial, el 2d pues no sabría decirte a mi me va igual que los xf86-video-ati solo que sin kms que tampoco hecho de menos la verdad, lo que estoy mirando es ver si puedo usar xf86-video-intel para aprovechar los de mi cpu intel junto a los fglrx, en laptops se puede pero en pcs normales no encontré información.

y tanta diferencia hay entre los xorg 1.12 y los 1.13? y se van a quedar en 1.12? eso no tendria ningun sentido vaya estupidez.
Diria mas que es un tema de kernel que de version xorg...mmm pero ni idea.

ad1
_________________
--Intel i5 3570k --Asrock z77 ext. 4 --Skill 32GB dd3 --Radeon r9 270 --S.O Gentoo & Win 64bits
Back to top
View user's profile Send private message
Arctic
Apprentice
Apprentice


Joined: 04 Jul 2011
Posts: 178

PostPosted: Sun Feb 17, 2013 2:03 am    Post subject: Reply with quote

papu wrote:
hasta ahora creo que ni había legacy es decir no había la diferenciaion entre unos y otros, y desconocia que davan por culo con el xorg-server como siempre, pues menuda mierda, yo deje de usarlos amargado por ese tema hace un par de años.

y hace solo 1 mes y pico que puse los binarios por pura casualidad y en hd 5000 el aumento es bestial, el 2d pues no sabría decirte a mi me va igual que los xf86-video-ati solo que sin kms que tampoco hecho de menos la verdad, lo que estoy mirando es ver si puedo usar xf86-video-intel para aprovechar los de mi cpu intel junto a los fglrx, en laptops se puede pero en pcs normales no encontré información.

y tanta diferencia hay entre los xorg 1.12 y los 1.13? y se van a quedar en 1.12? eso no tendria ningun sentido vaya estupidez.
Diria mas que es un tema de kernel que de version xorg...mmm pero ni idea.

ad1


Es debido a los cambios de ABI de xorg, al igual que los hay en el kernel, Ubuntu 12.04 LTS usa 1.12 junto con los drivers propietarios de ATI, pero si actualizas a la 12.10 pues te llevas el sorpreson salvo que metas un backport, ya ni te cuento en la 13.04, lo que si le salva es que al utilizar el escritorio 3D pues la carencia es menor, aunque como andes justito de frames puedes llegar a odiar a unity cuando cargues un shooter por ejemplo.
El driver opensource es muy bueno la verdad, apesar de tener trabas a cada paso estan haciendo un trabajo increible, sobretodo por parte de Marek Oslak que aún no tiene ni acabada la carrera, y ya hace magia con el codigo....... otro fastidio al usar los propitarios es que no tienes framebuffer decente, salvo que te arreisgues con Vesa por que el resto ya sabes que interfieren, no sigo porque sino................

Salu2
_________________
ln -s /user/artic /user/arctic
Back to top
View user's profile Send private message
papu
Guru
Guru


Joined: 25 Jan 2008
Posts: 390
Location: Sota algun pi de l'empordà

PostPosted: Sun Feb 17, 2013 9:45 am    Post subject: Reply with quote

Arctic wrote:

Es debido a los cambios de ABI de xorg, al igual que los hay en el kernel, Ubuntu 12.04 LTS usa 1.12 junto con los drivers propietarios de ATI, pero si actualizas a la 12.10 pues te llevas el sorpreson salvo que metas un backport, ya ni te cuento en la 13.04, lo que si le salva es que al utilizar el escritorio 3D pues la carencia es menor, aunque como andes justito de frames puedes llegar a odiar a unity cuando cargues un shooter por ejemplo.
El driver opensource es muy bueno la verdad, apesar de tener trabas a cada paso estan haciendo un trabajo increible, sobretodo por parte de Marek Oslak que aún no tiene ni acabada la carrera, y ya hace magia con el codigo....... otro fastidio al usar los propitarios es que no tienes framebuffer decente, salvo que te arreisgues con Vesa por que el resto ya sabes que interfieren, no sigo porque sino................

Salu2


no recuerdo detalles tecnicos de lo que es ABI, tendría que leerlo, entonces depende de los cambios ABI tanto en xorg como a nivel de kernel ¿no? los drivers non-legacy necesitan del gentoo-sources por tema de parches específicos.

lo que no entiendo es el no soporte minimo de las series HDxxxx , teniendo en cuenta los cambios internos a partir de hd7000 . De hecho tampoco esto da sentido a no soportar un rango mas elevado de tarjetas fuera de las hdxxxx.
http://en.wikipedia.org/wiki/Comparison_of_AMD_graphics_processing_units

el unico problema que hay si ciertamente tiene que ver con el framebuffer, usando binarios de ati sino activo en el kernel la opcion VEGA TEXT CONSOLE ( que solo va a 640 de resolucion) no sale nada en pantalla hasta que carga las X por lo tanto no puedoacceder a las tty fuera del entorno grafico. Suerte tenia esa opcion activada cuando realice los cambios en kernel para pasar de xf86-video-ati a ati-drivers y vi lo que pasaba sino aun estaria preocupado por ello.
http://i.minus.com/iFmvFMXwR4Dk2.png

Volveré a compilar el kernel ya que segun el wiki de gentoo con fglrx debería funcionar el framebuffer basico activando , <*> Support for frame buffer devices --->, quizas ahora ya funcione luego lo miro.

si el driver este libre ha mejorado mucho la verdad y esta activo ( durante un tiempo estubo muy parado) , ese Marek Olšák ¿es algun estudiante que ha decidido meterse en harina y no estaba antes?

saludos, ad1
_________________
--Intel i5 3570k --Asrock z77 ext. 4 --Skill 32GB dd3 --Radeon r9 270 --S.O Gentoo & Win 64bits
Back to top
View user's profile Send private message
Luciernaga
Guru
Guru


Joined: 05 Apr 2006
Posts: 378
Location: LANDETE (Cuenca)

PostPosted: Sun Feb 17, 2013 11:31 am    Post subject: Reply with quote

¡Uy! .. no era mi propósito encender una polémica pero a la vista está que tan solo pretendía poder ejecutar las Xs correctamente en mi portátil Toshiba Satellite Pro que, por cierto, solo lo había conseguido con el driver VESA ...
Gracias "pelela" por haberme indicado el camino a seguir ... aunque no exactamente, ya que tuve que hacer bastantes más cosas, pero al final lo conseguí ...
Veamos, en principio tuve que recompilar el núcleo para deshabilitar cualesquiera gráficas activadas y "habilitar" solamente ATI Radeon ...
Luego de cambiar en /etc/portage/make.conf la variable VIDEO_CARDS="radeon" por VIDEO_CARDS="fglrx" tuve que reemerger ati-drivers y xf86-video-ati que ya estaba instalado por omisión ... no sin antes agregar esta línea =x11-libs/libdrm-2.4.40 video_cards_radeon al fichero /etc/portage/package.use tal como se me solicitó en un mensaje en pantalla antes de reemerger los controladores ...
Por supuesto que antes de lanzar las Xs emití el comando eselect opengl set ati.
Ahora si que tengo a pleno rendimiento el escritorio KDE en mi portátil ...
Saludetes ;)
_________________
Soy como una diminuta luciérnaga, perdido en la inmensa oscuridad del universo.
Back to top
View user's profile Send private message
papu
Guru
Guru


Joined: 25 Jan 2008
Posts: 390
Location: Sota algun pi de l'empordà

PostPosted: Sun Feb 17, 2013 11:58 am    Post subject: Reply with quote

no es ninguna pelea al contrario este post me es de mucha utilidad ¿donde ves la pelea?

esto tuyo quizas me sirva aunque usas un portatil, yo quiero activar xf86-video-intel junto a ati-drivers.

porque emerges ¿ati-drivers y xf86-video-ati si solo usas fglrx? yo he pensado hacer eso para ver si puedo usar el framebuffer de los xf86-video-ati y dejar mi escritorio con fglrx... interesante.

porque has compilado ambos, que opciones tienes activadas en el nucleo podrias hacer una capturas de pantalla de tus opciones de Graphic support del kernel?
yo tengo asi:
http://i.minus.com/iR2TOrCmj92e7.png
http://i.minus.com/iFmvFMXwR4Dk2.png

¿que cpu usas?, ¿que framebuffer( el texto de inicio de carga del kernel usa tu resolucion nativa en las tty)?.... me interesa mucho, es complicado encontrar usuarios con grafica parecida en el foro y en castellano hablando de drivers de ati.

¿podrías entrar al canal de irc://adams.freenode.net/#Gentoo-Es ? ahi ando a ver si me pillas online...


saludos, ad1
_________________
--Intel i5 3570k --Asrock z77 ext. 4 --Skill 32GB dd3 --Radeon r9 270 --S.O Gentoo & Win 64bits
Back to top
View user's profile Send private message
Luciernaga
Guru
Guru


Joined: 05 Apr 2006
Posts: 378
Location: LANDETE (Cuenca)

PostPosted: Sun Feb 17, 2013 12:37 pm    Post subject: Reply with quote

Bien, amigo papu ... quiero dejar constancia de que en ningún momento he escrito "pelea", en cambio si he manifestado que no pretendía encender una "polémica" ... tal vez sí por los acontecimientos ... ¿vale?
Con polémica me refería a discusión, debate, diálogo, etc., ver ... http://es.wikipedia.org/wiki/Pol%C3%A9mica

En cuanto al hardware de referencia en este mi caso es el siguiente: http://www.toshiba.es/discontinued-products/satellite-pro-l670-147/
No es el único material del que dispongo ya que afortunadamente puedo permitirme usar una red local de 6 máquinas, de las cuales dos de ellas incorporan gráficas ATI distintas, mientras que el resto usan gráficas Nvidia de diferentes versiones; por otra parte conocido es que en Linux las nVidias son menos problemáticas que las ATI y tal vez con mejor rendimiento.

Todas mis máquinas (incluído el servidor) funcionan con Gentoo que es mi distro preferida, aunque también tengo instaladas otras, tales como Ubuntu Server, Debian, Slackware, FreeBSD, Mageia, y como no Windows ...

En cuanto al núcleo es el 3.6.11-gentoo y, por comodidad, lo compilo con genkernel ... ya sé que no es lo ideal y puede surgir algún problema imprevisto, pero que le vamos a hacer ... genkernel siempre se ha portado correctamente hasta el presente.

Tan pronto pueda agregaré las fotos o capturas de la compilación a este mensaje ...
Saludetes ;)
_________________
Soy como una diminuta luciérnaga, perdido en la inmensa oscuridad del universo.
Back to top
View user's profile Send private message
papu
Guru
Guru


Joined: 25 Jan 2008
Posts: 390
Location: Sota algun pi de l'empordà

PostPosted: Sun Feb 17, 2013 12:56 pm    Post subject: Reply with quote

Luciernaga wrote:
Bien, amigo papu ... quiero dejar constancia de que en ningún momento he escrito "pelea", en cambio si he manifestado que no pretendía encender una "polémica" ... tal vez sí por los acontecimientos ... ¿vale?
Con polémica me refería a discusión, debate, diálogo, etc., ver ... http://es.wikipedia.org/wiki/Pol%C3%A9mica

En cuanto al hardware de referencia en este mi caso es el siguiente: http://www.toshiba.es/discontinued-products/satellite-pro-l670-147/
No es el único material del que dispongo ya que afortunadamente puedo permitirme usar una red local de 6 máquinas, de las cuales dos de ellas incorporan gráficas ATI distintas, mientras que el resto usan gráficas Nvidia de diferentes versiones; por otra parte conocido es que en Linux las nVidias son menos problemáticas que las ATI y tal vez con mejor rendimiento.

Todas mis máquinas (incluído el servidor) funcionan con Gentoo que es mi distro preferida, aunque también tengo instaladas otras, tales como Ubuntu Server, Debian, Slackware, FreeBSD, Mageia, y como no Windows ...

En cuanto al núcleo es el 3.6.11-gentoo y, por comodidad, lo compilo con genkernel ... ya sé que no es lo ideal y puede surgir algún problema imprevisto, pero que le vamos a hacer ... genkernel siempre se ha portado correctamente hasta el presente.

Tan pronto pueda agregaré las fotos o capturas de la compilación a este mensaje ...
Saludetes ;)


si las polemicas son buenas aunque sean peleas o discusiones :) era un decir

aja da igual me interesa la configuracion de esa parte del kernel que tienes en tu genkernel y porque compilas en el portatil xf86-video-ati si estas usando ati-drivers, y si tus tty inicia en modo texto en resolucion nativa, de momento eso es lo más urgente :)

saludos, ad1
_________________
--Intel i5 3570k --Asrock z77 ext. 4 --Skill 32GB dd3 --Radeon r9 270 --S.O Gentoo & Win 64bits
Back to top
View user's profile Send private message
Arctic
Apprentice
Apprentice


Joined: 04 Jul 2011
Posts: 178

PostPosted: Sun Feb 17, 2013 1:19 pm    Post subject: Reply with quote

Me alegro de que solucionases el problema, no hay polémica ninguna, son cosas que siempre estuvieron ahi , el debatir es bueno sobre todo cuando alguien no sabe que driver usar o que tarjeta comprar.
El framebuffer de radeon es incompatible con el de ati, si lo compilas no carga o falla el 3D, algo parecido pasa con noveau y nvidia.
Marek Oslak es un desarrollador que lleva ya un tiempo, hay unos cuantos más solo que algunos por cuestiones de tiempo y dedicación aportan más o menos código, el desarrollo del radeon es constante, en todos los kernels aparecen mejoras, en el 3.6 hemos conseguido soporte GL 3.0 gracias a que Marek añadió MSAA y ahora se espera 3,3, hyper-Z, etc..... la aceleracion de video por gpu esta algo parada en UVD por problemas con la licencia y lo unico que hay es atraves de gallium y no creo que tengamos demasisado codigo, al menos en 2D con vsync activado el video 1080p va perfecto, cosa que con fglrx es imposible.

Puedes echar un vistazo a como va el desarrollo en :

http://www.x.org/wiki/RadeonFeature#fnref-dba36863c40391f87bf476875ea88e21c5b5174e


Puedes leer la wiki oficial de gentoo, la verdad es que tiene cosas muy interesantes, hay un articulo sobre radeon, en phoronix tambien salen bastantes articulos sobre radeon y su desarrollo y en este foro hay un par de hilos donde se habla más de lo mismo.


Salu2
_________________
ln -s /user/artic /user/arctic
Back to top
View user's profile Send private message
papu
Guru
Guru


Joined: 25 Jan 2008
Posts: 390
Location: Sota algun pi de l'empordà

PostPosted: Sun Feb 17, 2013 1:35 pm    Post subject: Reply with quote

Arctic wrote:
Me alegro de que solucionases el problema, no hay polémica ninguna, son cosas que siempre estuvieron ahi , el debatir es bueno sobre todo cuando alguien no sabe que driver usar o que tarjeta comprar.
El framebuffer de radeon es incompatible con el de ati, si lo compilas no carga o falla el 3D, algo parecido pasa con noveau y nvidia.
Marek Oslak es un desarrollador que lleva ya un tiempo, hay unos cuantos más solo que algunos por cuestiones de tiempo y dedicación aportan más o menos código, el desarrollo del radeon es constante, en todos los kernels aparecen mejoras, en el 3.6 hemos conseguido soporte GL 3.0 gracias a que Marek añadió MSAA y ahora se espera 3,3, hyper-Z, etc..... la aceleracion de video por gpu esta algo parada en UVD por problemas con la licencia y lo unico que hay es atraves de gallium y no creo que tengamos demasisado codigo, al menos en 2D con vsync activado el video 1080p va perfecto, cosa que con fglrx es imposible.

Puedes echar un vistazo a como va el desarrollo en :

http://www.x.org/wiki/RadeonFeature#fnref-dba36863c40391f87bf476875ea88e21c5b5174e


Puedes leer la wiki oficial de gentoo, la verdad es que tiene cosas muy interesantes, hay un articulo sobre radeon, en phoronix tambien salen bastantes articulos sobre radeon y su desarrollo y en este foro hay un par de hilos donde se habla más de lo mismo.


Salu2


con 2d te refieres a por ejemplo video? entiendo que tu usas hd4000 o eso me parecio entender, yo uso mplayer y el video va perfectamente sean bluerays o mkvs....hablo del monitor principal, yo tengo mi grafica conectada a la tv y al monitor y en linux no puedo usar de forma independiente la tv y el sonido por hdmi no va, para mi ese es el gran problema actual de linux el soporte de sonido, el video teniendo una 5000 hacia arriba al menos el opengl va mejor que en windows, otra cosa es que el soporte en el escritorio KDE el opengl sea mejor con los drivers libres pero en 3d puro, al estilo juegos, como ves en el enlace que puse de una demo 3d llamada valley es ya superior a windows 8 en opengl y comparado con dx11 practicamente igual.

se anula el framebufer usando ati y fglrx a la vez? entonces lo que hare sera activar el soporte para intel a ver si asi puedo usar el framebuffer de intel almenos para las tty fuera de X, en ese caso no se si hara falta que configure VIDEO_CARDS="fglrx" actual a VIDEO_CARDS="fglrx intel" y compilar xf86-video-ati, no creo que haga falta eso para usar el framebuffer en la carga del sistema...la mejor manera sera comprobarlo , que es lo que pienso hacer ahora mismo.


entro de phoronix pero mi nivel de ingles hace que sea muy pesado para mi leer y sobre todo cosas tecnicas me agotan y muchas veces las entiendo a medias pero suelo enteder bastante bien en general todo.



ad1
_________________
--Intel i5 3570k --Asrock z77 ext. 4 --Skill 32GB dd3 --Radeon r9 270 --S.O Gentoo & Win 64bits


Last edited by papu on Sun Feb 17, 2013 6:29 pm; edited 1 time in total
Back to top
View user's profile Send private message
papu
Guru
Guru


Joined: 25 Jan 2008
Posts: 390
Location: Sota algun pi de l'empordà

PostPosted: Sun Feb 17, 2013 3:49 pm    Post subject: Reply with quote

bueno no funciona lo que quiero hacer, pero almenos saber porque no me va el framebuffer con fglrx bueno va solo a 640 con las opciones VGA TEXT CONSOLE sino no sale letra alguna en las tty.

almenos conseguir usar el framebuffer para resolucion nativa de mi monitor con eso estaria contento, no pienso cambiar mis ati-drivers pq van actualmente de coña.

saludos, ad1
_________________
--Intel i5 3570k --Asrock z77 ext. 4 --Skill 32GB dd3 --Radeon r9 270 --S.O Gentoo & Win 64bits
Back to top
View user's profile Send private message
Luciernaga
Guru
Guru


Joined: 05 Apr 2006
Posts: 378
Location: LANDETE (Cuenca)

PostPosted: Sun Feb 17, 2013 5:04 pm    Post subject: Reply with quote

Quote:
... aja da igual me interesa la configuracion de esa parte del kernel que tienes en tu genkernel y porque compilas en el portatil xf86-video-ati si estas usando ati-drivers, y si tus tty inicia en modo texto en resolucion nativa, de momento eso es lo más urgente


Veamos: xf86-video-ati se instala al emerger las Xs (emerge xorg-x11) al igual que los demás controladores de video comunes, dado que mi intención es sacar el máximo rendimiento de la gráfica y antes de configurar las Xs (Xorg -configure) que con toda seguridad debería establecer la variable VIDEO_CARDS="vesa" en /etc/portage/make.conf pretendí emerger ati-drivers para poder lograr la máxima resolución de mi portátil (1600x900 pixels); mi error fue que preestablecia la variable VIDEO_CARDS="radeon" sin tener habilitado en el núcleo ATI Radeon, posteriormente y gracias a las indicaciones del amigo "pelela" descubrí el camino por el que tenía que transitar, como cito en mis anteriores mensajes; ver a continuación parte de la configuración del kernel ...

[IMG]http://img600.imageshack.us/img600/9470/instantnea1b.png[/IMG]

[IMG]http://img18.imageshack.us/img18/8342/instantnea2y.png[/IMG]

[IMG]http://img703.imageshack.us/img703/6118/instantnea3y.png[/IMG]

[IMG]http://img688.imageshack.us/img688/9105/instantnea4jb.png[/IMG]

No se si te puede servir visionar el archivo .CONFIG que de alguna manera lo pondría en Pastebin.
Saludetes ;)
_________________
Soy como una diminuta luciérnaga, perdido en la inmensa oscuridad del universo.
Back to top
View user's profile Send private message
papu
Guru
Guru


Joined: 25 Jan 2008
Posts: 390
Location: Sota algun pi de l'empordà

PostPosted: Sun Feb 17, 2013 5:27 pm    Post subject: Reply with quote

yo solo compilo lo estrictametne necesario:

entonces tu tienes compilados en el nucleo los drivers de ati radeon pero usas los binarios de ati en el gentoo y VIDEO_CARDS="fglrx", ¿entonces tu ordenador que framebuffer esta usando? porque Arctic comenta que son incompatibles. A mi no me va el framebuffer de ati por lo que veo entonces.


lo que haré sera compilar el framebuffer de radeon del nucleo a ver que pasa.

gracis por las fotos pero me interesa basicamente lo referente a tus framebuffers:
CONSOLE DISPLAY DRIVER SUPPORT y SUPPORT FOR FRAME BUFFER DEVICES.

te he preguntado varias veces a que resolucion te carga el linux , es decir el texto que sale cuando karga la imagen del kernel, no se si me entiendes no se como explicarlo, la secuencia de arranque que detecta tu hardware que sale por la tty en la pantalla .... ese texto que sale se ve a traves de los framebuffers el cual sino funciona no se ve nada por pantalla.

es tan compicado intentar explicar esto por escrito y encima en diferido :(
_________________
--Intel i5 3570k --Asrock z77 ext. 4 --Skill 32GB dd3 --Radeon r9 270 --S.O Gentoo & Win 64bits
Back to top
View user's profile Send private message
Luciernaga
Guru
Guru


Joined: 05 Apr 2006
Posts: 378
Location: LANDETE (Cuenca)

PostPosted: Sun Feb 17, 2013 6:01 pm    Post subject: Reply with quote

Escolte noi haviam si ara to deixo clar ...

[IMG]http://img824.imageshack.us/img824/7375/instantnea5.png[/IMG]

Esta se me habia pasado ... ¿vale?

Una vez configuradas las Xs correctamente con el controlador apropiado la resolución de pantalla debería estar al máximo, en este mi caso ya te lo he puesto antes que alcanza los 1600x900 pixeles la pantalla; en el reinicio de la máquina los alcanza sin problemas tanto en modo texto como en modo gráfico, veer la foto siguiente ...
[IMG]http://img203.imageshack.us/img203/7247/dsc3790800x600.jpg[/IMG]

Fins un'altre cop ... mister
_________________
Soy como una diminuta luciérnaga, perdido en la inmensa oscuridad del universo.
Back to top
View user's profile Send private message
papu
Guru
Guru


Joined: 25 Jan 2008
Posts: 390
Location: Sota algun pi de l'empordà

PostPosted: Sun Feb 17, 2013 6:08 pm    Post subject: Reply with quote

Luciernaga wrote:
Escolte noi haviam si ara to deixo clar ...

[IMG]http://img824.imageshack.us/img824/7375/instantnea5.png[/IMG]

Esta se me habia pasado ... ¿vale?

Una vez configuradas las Xs correctamente con el controlador apropiado la resolución de pantalla debería estar al máximo, en este mi caso ya te lo he puesto antes que alcanza los 1600x900 pixeles la pantalla; en el reinicio de la máquina los alcanza sin problemas tanto en modo texto como en modo gráfico, veer la foto siguiente ...
[IMG]http://img203.imageshack.us/img203/7247/dsc3790800x600.jpg[/IMG]

Fins un'altre cop ... mister


gracias, luego trasteo un rato más a ver si consigo algo.

adéu :D
_________________
--Intel i5 3570k --Asrock z77 ext. 4 --Skill 32GB dd3 --Radeon r9 270 --S.O Gentoo & Win 64bits
Back to top
View user's profile Send private message
Arctic
Apprentice
Apprentice


Joined: 04 Jul 2011
Posts: 178

PostPosted: Sun Feb 17, 2013 6:29 pm    Post subject: Reply with quote

Hagamos una prueba, carga un video 1080p preferiblemente vale 720p , da igual el reproductor vlc, mplayer, etc....... y fiajte en escenas rápidas o con movimientos laterales si aparece el efecto tearing ( una rayita que divida la imagen por el medio) , si no parece es que seguramente tengas activado vsync o desfragmentacion de pantalla, yo al activarlo tenia tirones puntales y video poco fluido.

Si tengo una HD4290 integrada , tambien he probado en su dia con una HD6870.

Un saludo
_________________
ln -s /user/artic /user/arctic
Back to top
View user's profile Send private message
papu
Guru
Guru


Joined: 25 Jan 2008
Posts: 390
Location: Sota algun pi de l'empordà

PostPosted: Sun Feb 17, 2013 8:10 pm    Post subject: Reply with quote

Arctic wrote:
Hagamos una prueba, carga un video 1080p preferiblemente vale 720p , da igual el reproductor vlc, mplayer, etc....... y fiajte en escenas rápidas o con movimientos laterales si aparece el efecto tearing ( una rayita que divida la imagen por el medio) , si no parece es que seguramente tengas activado vsync o desfragmentacion de pantalla, yo al activarlo tenia tirones puntales y video poco fluido.

Si tengo una HD4290 integrada , tambien he probado en su dia con una HD6870.

Un saludo


si con el drivers binario se ha de activar la vsync sino hace el tonto, pero bueno activandolo va bien el aumento de prestaciones respecto hace 3 años cuando me compre la tarjeta en 3d es enorme eso es bueno, y los libres tambien van mejorando pues mejor. Lo que no es normal es que haya 2 tipos de drivers es un poco ridículo el mundo de la informatica.
http://i.minus.com/iN4Na9lobZiuq.png


creo que abandono respecto al dichoso framebuffer solo me funciona con VGA TEXT CONSOLE(a 480x680), ¿es que no tiene framebuffer nativo (altra resolución) los catalyst? y abandono este post que ya esta solucionado y no viene al caso mi problema :)
¿tu no los usaste con la hd 6870 los catalyst por causalidad?

saludos, ad1

l
_________________
--Intel i5 3570k --Asrock z77 ext. 4 --Skill 32GB dd3 --Radeon r9 270 --S.O Gentoo & Win 64bits
Back to top
View user's profile Send private message
Arctic
Apprentice
Apprentice


Joined: 04 Jul 2011
Posts: 178

PostPosted: Sun Feb 17, 2013 10:17 pm    Post subject: Reply with quote

papu wrote:
Arctic wrote:
Hagamos una prueba, carga un video 1080p preferiblemente vale 720p , da igual el reproductor vlc, mplayer, etc....... y fiajte en escenas rápidas o con movimientos laterales si aparece el efecto tearing ( una rayita que divida la imagen por el medio) , si no parece es que seguramente tengas activado vsync o desfragmentacion de pantalla, yo al activarlo tenia tirones puntales y video poco fluido.

Si tengo una HD4290 integrada , tambien he probado en su dia con una HD6870.

Un saludo


si con el drivers binario se ha de activar la vsync sino hace el tonto, pero bueno activandolo va bien el aumento de prestaciones respecto hace 3 años cuando me compre la tarjeta en 3d es enorme eso es bueno, y los libres tambien van mejorando pues mejor. Lo que no es normal es que haya 2 tipos de drivers es un poco ridículo el mundo de la informatica.
http://i.minus.com/iN4Na9lobZiuq.png


creo que abandono respecto al dichoso framebuffer solo me funciona con VGA TEXT CONSOLE(a 480x680), ¿es que no tiene framebuffer nativo (altra resolución) los catalyst? y abandono este post que ya esta solucionado y no viene al caso mi problema :)
¿tu no los usaste con la hd 6870 los catalyst por causalidad?

saludos, ad1

l


Si use frambuffer , y tuve que usar el del proyecto de gentoo desarrollado por spock para no tener interferencias, los propietarios ninguno trae framebuffer, visita la web de spock que te dice como conseguir un bonito splash ;)

La vsync es vital en juegos y video para no tener desfragmentacion , lo que pasa es que come recursos de modo adicional.

Salu2
_________________
ln -s /user/artic /user/arctic
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum