Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[libstdc++] Problema con librería
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3  Next  
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
Theasker
l33t
l33t


Joined: 18 Nov 2006
Posts: 636
Location: Zaragoza (Spain)

PostPosted: Tue Feb 26, 2013 9:15 am    Post subject: Reply with quote

i92guboj wrote:
En principio no debería ser necesario re-emerger gcc, a no ser que se haya dañado con alguno de los experimentos que hemos hecho en este hilo ;)


De todas formas, mientras "haciamos" los experimentos estaba recompilandose gcc que ha durado menos de lo que esperaba (51 m) pero tampoco ha servido de nada
_________________
"Oigo y olvido. Veo y recuerdo. Hago y comprendo"
Back to top
View user's profile Send private message
i92guboj
Moderator
Moderator


Joined: 30 Nov 2004
Posts: 10127
Location: Córdoba (Spain)

PostPosted: Tue Feb 26, 2013 9:28 am    Post subject: Reply with quote

Theasker wrote:
i92guboj wrote:
En principio no debería ser necesario re-emerger gcc, a no ser que se haya dañado con alguno de los experimentos que hemos hecho en este hilo ;)


De todas formas, mientras "haciamos" los experimentos estaba recompilandose gcc que ha durado menos de lo que esperaba (51 m) pero tampoco ha servido de nada


El problema no está en tu gcc 4.6.3, seguramente está perfecto. Los programas enlazan con él durante la compilación. El problema viene en tiempo de ejecución, y es precisamente que buscan la libstdc++.so.6 de tu gcc 4.6.3, pero encuentran antes tu libstdc++.so.6 de gcc 4.5.x, que lógicamente no tiene la misma interfaz binaria y por tanto no funciona. Prueba lo que te digo arriba y a ver si hay suerte.
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
Theasker
l33t
l33t


Joined: 18 Nov 2006
Posts: 636
Location: Zaragoza (Spain)

PostPosted: Tue Feb 26, 2013 9:50 am    Post subject: Reply with quote

Pues ha funcionado.

Funciona eix, y los demás programas que no funcionaba por esa causa.

He recompilado libtool y al hacer un revdep-rebuild --library libstdc++.so.6 fallan las compilaciones.

¿qué debería recompilar ahora para acabar de arreglarlo todo?

Si he quitado esa "basura" remanente de un antiguo gcc, ¿qué más "basura" puedo tener?

Y lo que más me fastidia de todo esto, a parte de no haber podido conseguirlo arreglar yo sólo, es porqué ha podido suceder esto?

EDITO: Muchísimas gracias, ahora debería hacer un backup del sistema ahora que ... "por ahora" sigue funcionando
_________________
"Oigo y olvido. Veo y recuerdo. Hago y comprendo"
Back to top
View user's profile Send private message
i92guboj
Moderator
Moderator


Joined: 30 Nov 2004
Posts: 10127
Location: Córdoba (Spain)

PostPosted: Tue Feb 26, 2013 10:13 am    Post subject: Reply with quote

Theasker wrote:
Pues ha funcionado.

Funciona eix, y los demás programas que no funcionaba por esa causa.

He recompilado libtool y al hacer un revdep-rebuild --library libstdc++.so.6 fallan las compilaciones.

¿qué debería recompilar ahora para acabar de arreglarlo todo?


Habría que ver los fallos unos a uno. ¿Qué programas fallan al compilar? Por ejemplo, si eix funciona es porque en tiempo de compilación fue enlazado con la versión de libstdc++ que tienes ahora mismo (4.6.3).

También ten en cuenta que algunos programas pueden depende de la versión antigua de libstdc++, que no va en gcc sino en sys-libs/libstdc++-v3.

Quote:

Si he quitado esa "basura" remanente de un antiguo gcc, ¿qué más "basura" puedo tener?


Podría usar la salida de "equery f gcc" para ver los directorios de gcc que tiene número de versión, y eso te ayudará a ver donde puede haber restos de alguna otra versión. Pero es un trabajo tedioso. Mientras no de más problemas... Lo que sí debería mirar es tu /etc/ld.so.cache, y ver si ahí hay alguna ruta conflictiva todavía.


Quote:
Y lo que más me fastidia de todo esto, a parte de no haber podido conseguirlo arreglar yo sólo, es porqué ha podido suceder esto?


Esa es la pregunta del millón. Desde un bug en portage hasta una interrupción inesperada al emerger, rootkits, fallos inexplicables del sistema de archivos, paquetes instalados a mano... etc. Pero tampoco es tan raro que portage deje basura. Ten en cuenta que muchos archivos y symlinks son creados por procesos ajenos a portage (eselect, gcc-config, etc......).
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
Theasker
l33t
l33t


Joined: 18 Nov 2006
Posts: 636
Location: Zaragoza (Spain)

PostPosted: Tue Feb 26, 2013 10:26 am    Post subject: Reply with quote

la salida de equery f gcc es limpia y todo es 4.6.3

Code:
# ldconfig -p | grep libstdc++
   libstdc++.so.6 (libc6,x86-64) => /usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/libstdc++.so.6
   libstdc++.so.6 (libc6) => /usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/32/libstdc++.so.6
   libstdc++.so.5 (libc6,x86-64) => /usr/lib64/libstdc++.so.5
   libstdc++.so.5 (libc6) => /usr/lib32/libstdc++.so.5
   libstdc++.so (libc6,x86-64) => /usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/libstdc++.so
   libstdc++.so (libc6) => /usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/32/libstdc++.so


edito: Veo que aun sigue habíendo librerías antiguas

he empezado a intentar recompilar los paquetes que me dieron error al hacer el emerge -e world y el primero sigue dando errores (ya no he probado más):

Code:
# emerge baselayout
Calculating dependencies... done!

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) sys-apps/baselayout-2.1-r1
>>> Downloading 'http://distfiles.gentoo.org/distfiles/baselayout-2.1.tar.bz2'
--2013-02-26 11:22:47--  http://distfiles.gentoo.org/distfiles/baselayout-2.1.tar.bz2
Resolviendo distfiles.gentoo.org... 156.56.247.195, 216.165.129.135, 64.50.233.100, ...
Conectando con distfiles.gentoo.org[156.56.247.195]:80... conectado.
Petición HTTP enviada, esperando respuesta... 200 OK
Longitud: 40398 (39K) [application/x-tar]
Grabando a: “/usr/portage/distfiles/baselayout-2.1.tar.bz2”

100%[======================================>] 40.398      62,0KB/s   en 0,6s   

2013-02-26 11:22:47 (62,0 KB/s) - “/usr/portage/distfiles/baselayout-2.1.tar.bz2” guardado [40398/40398]

 * baselayout-2.1.tar.bz2 SHA256 SHA512 WHIRLPOOL size ;-) ...           [ ok ]
 * Your system profile has SYMLINK_LIB=yes, so that means you need to
 * have these paths configured as follows:
 * symlinks to 'lib64': /usr/lib
 * The ebuild will attempt to fix these, but only for trivial conversions.
 * If things fail, you will need to manually create/move the directories.

 * Converting /usr/lib from a dir to a symlink
 * ERROR: sys-apps/baselayout-2.1-r1 failed (setup phase):
 *   non-empty dir found where we needed a symlink: /usr/lib
 *
 * Call stack:
 *                  ebuild.sh, line  93:  Called pkg_setup
 *   baselayout-2.1-r1.ebuild, line  20:  Called multilib_layout
 *   baselayout-2.1-r1.ebuild, line  80:  Called die
 * The specific snippet of code:
 *                  die "non-empty dir found where we needed a symlink: ${prefix}lib"
 *
 * If you need support, post the output of `emerge --info '=sys-apps/baselayout-2.1-r1'`,
 * the complete build log and the output of `emerge -pqv '=sys-apps/baselayout-2.1-r1'`.
 * The complete build log is located at '/var/tmp/portage/sys-apps/baselayout-2.1-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-apps/baselayout-2.1-r1/temp/die.env'.
 * Working directory: '/var/tmp/portage/sys-apps/baselayout-2.1-r1'
 * S: '/var/tmp/portage/sys-apps/baselayout-2.1-r1/work/baselayout-2.1'

>>> Failed to emerge sys-apps/baselayout-2.1-r1, Log file:

>>>  '/var/tmp/portage/sys-apps/baselayout-2.1-r1/temp/build.log'


parece problemas con enlaces simbólicos y ... pensando .... no podría haber sido esto el primero problema que haya causado este tremendo lío?
_________________
"Oigo y olvido. Veo y recuerdo. Hago y comprendo"
Back to top
View user's profile Send private message
i92guboj
Moderator
Moderator


Joined: 30 Nov 2004
Posts: 10127
Location: Córdoba (Spain)

PostPosted: Tue Feb 26, 2013 3:15 pm    Post subject: Reply with quote

Si no recuerdo mal, libstdc++.so.5 es del paquete libstdc++-v3, que se habrá instalado como deendencia de algún paquete. En cualquier caso eso no supone un problema.

En cuanto al error sobre el symlink, no guarda relación con el problema anterior. Deberás seguir las instrucciones y crear el symlink, pero antes de eso deberás unir el contenido de ambos directorios. Obviamente no podrás mover libs que estés usando, así que tendrás que arrancar en runlevel 1 o desde un livecd.
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 898

PostPosted: Tue Feb 26, 2013 5:53 pm    Post subject: Reply with quote

Creo que deberías arreglar lo del enlace simbólico /lib->lib64:
http://forums.gentoo.org/viewtopic-t-899802-start-0.html
Back to top
View user's profile Send private message
Theasker
l33t
l33t


Joined: 18 Nov 2006
Posts: 636
Location: Zaragoza (Spain)

PostPosted: Tue Feb 26, 2013 7:47 pm    Post subject: Reply with quote

i92guboj wrote:
Si no recuerdo mal, libstdc++.so.5 es del paquete libstdc++-v3, que se habrá instalado como deendencia de algún paquete. En cualquier caso eso no supone un problema.

En cuanto al error sobre el symlink, no guarda relación con el problema anterior. Deberás seguir las instrucciones y crear el symlink, pero antes de eso deberás unir el contenido de ambos directorios. Obviamente no podrás mover libs que estés usando, así que tendrás que arrancar en runlevel 1 o desde un livecd.


Bueno me pongo al tema y gracias por la preocupación y por ayudarme a resolver el problema. También gracias a los demás por la ayuda.

Un saludo a tod@s
_________________
"Oigo y olvido. Veo y recuerdo. Hago y comprendo"
Back to top
View user's profile Send private message
Theasker
l33t
l33t


Joined: 18 Nov 2006
Posts: 636
Location: Zaragoza (Spain)

PostPosted: Wed Mar 13, 2013 9:00 am    Post subject: Reply with quote

i92guboj wrote:
Si no recuerdo mal, libstdc++.so.5 es del paquete libstdc++-v3, que se habrá instalado como deendencia de algún paquete. En cualquier caso eso no supone un problema.

En cuanto al error sobre el symlink, no guarda relación con el problema anterior. Deberás seguir las instrucciones y crear el symlink, pero antes de eso deberás unir el contenido de ambos directorios. Obviamente no podrás mover libs que estés usando, así que tendrás que arrancar en runlevel 1 o desde un livecd.


Siento reabrir este hilo que pensaba ya cerrado porque parecía que era fácil lo de hacer un simple enlace de /lib -> /lib64, pero hasta ahora como funcionaban las actualizaciónes y por falta de tiempo, no me había puesto a hacerlo.

Según pone en este hilo, que me pasa lo mismo, debería hacer el symlink pero ... después de arrancar un systemrescue para no estar usando ninguna librería (cosa lógica) como me había recomendado i92guboj, he visto que el enlace ya lo tenía creado en /
Code:

# ls -la /
total 144
drwxr-xr-x  24 root root  4096 mar 13 09:06 .
drwxr-xr-x  24 root root  4096 mar 13 09:06 ..
drwxr-xr-x   6 root root 32768 mar 11 20:00 backup
drwxr-xr-x   2 root root  4096 mar 11 21:50 bin
drwxr-xr-x   2 root root  4096 jun 15  2010 boot
drwxr-xr-x  15 root root  4420 mar 13 09:26 dev
drwxr-xr-x 118 root root 12288 mar 13 09:26 etc
drwxr-xr-x   2 root root  4096 jun 26  2010 gentoo32
drwxr-xr-x  10 root root  4096 nov  3 22:43 home
lrwxrwxrwx   1 root root     5 feb 25 21:35 lib -> lib64
drwxr-xr-x   3 root root  4096 mar  8 14:21 lib32
drwxr-xr-x  13 root root 12288 mar  8 15:32 lib64
drwx------   2 root root 16384 jun 13  2010 lost+found
drwxr-xr-x   2 root root  4096 mar 13 09:26 media
drwxr-xr-x  12 root root  4096 abr 20  2011 mnt
drwxr-xr-x  19 root root  4096 mar 12 08:57 opt
dr-xr-xr-x 148 root root     0 mar 13 09:25 proc
drwx------  13 root root  4096 mar 13 09:48 root
drwxr-xr-x  16 root root   480 mar 13 09:26 run
drwxr-xr-x   2 root root  4096 mar  8 14:22 sbin
dr-xr-xr-x  12 root root     0 mar 13 09:25 sys
drwxrwxrwt  10 root root  8192 mar 13 09:51 tmp
drwxr-xr-x   3 root root  4096 mar  1 21:11 u01
drwxr-xr-x  17 root root  4096 feb 24 21:45 usr
drwxr-xr-x  17 root root  4096 feb 25 00:14 var


aunque según el error de baselayout el enlace debería ser en /usr/lib no en /
Code:

# emerge baselayout
Calculating dependencies... done!

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) sys-apps/baselayout-2.1-r1
 * Adjusting permissions for FEATURES=ccache: '/var/tmp/ccache'
 * baselayout-2.1.tar.bz2 SHA256 SHA512 WHIRLPOOL size ;-) ...                                    [ ok ]
 * Your system profile has SYMLINK_LIB=yes, so that means you need to
 * have these paths configured as follows:
 * symlinks to 'lib64': /usr/lib
 * The ebuild will attempt to fix these, but only for trivial conversions.
 * If things fail, you will need to manually create/move the directories.

 * Converting /usr/lib from a dir to a symlink
 * ERROR: sys-apps/baselayout-2.1-r1 failed (setup phase):
 *   non-empty dir found where we needed a symlink: /usr/lib
 *
 * Call stack:
 *                  ebuild.sh, line  93:  Called pkg_setup
 *   baselayout-2.1-r1.ebuild, line  20:  Called multilib_layout
 *   baselayout-2.1-r1.ebuild, line  80:  Called die
 * The specific snippet of code:
 *                  die "non-empty dir found where we needed a symlink: ${prefix}lib"
 *
 * If you need support, post the output of `emerge --info '=sys-apps/baselayout-2.1-r1'`,
 * the complete build log and the output of `emerge -pqv '=sys-apps/baselayout-2.1-r1'`.
 * The complete build log is located at '/var/tmp/portage/sys-apps/baselayout-2.1-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-apps/baselayout-2.1-r1/temp/die.env'.
 * Working directory: '/var/tmp/portage/sys-apps/baselayout-2.1-r1'
 * S: '/var/tmp/portage/sys-apps/baselayout-2.1-r1/work/baselayout-2.1'

>>> Failed to emerge sys-apps/baselayout-2.1-r1, Log file:

>>>  '/var/tmp/portage/sys-apps/baselayout-2.1-r1/temp/build.log'


qué debería hacer para no cargarme el sistema, que visto lo visto, debo ser un patoso que me cargo todo, y ahora me destrozaría el tener que instalar todo de nuevo, no tengo tiempo de ponerme a reinstalar ... ni quiero, me encanta mi viejo gentoo.

¿ Sólo con esto bastaría ?

gracias muchas
_________________
"Oigo y olvido. Veo y recuerdo. Hago y comprendo"
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 898

PostPosted: Wed Mar 13, 2013 2:33 pm    Post subject: Reply with quote

Creo que tendrás que buscar todos los directorios que contengan un directorio llamado lib64 y en él crear el enlace simbólico lib->lib64.

Es posible que te encuentres casos en los que no puedas crearlo porque ya exista un directorio con ese nombre. Entonce tendrás que mover los archivos que contenga ese lib a lib64, eliminar ese lib y crear el enlace simbólico.

También puede ocurrir que al mover los archivos como te digo sobreescribas archivos existentes. Comprueba antes que no se trate de librerías fundamentales. Ante la duda muévelas con otro nombre.

Finalmente ejecuta
Code:
/sbin/ldconfig
Back to top
View user's profile Send private message
i92guboj
Moderator
Moderator


Joined: 30 Nov 2004
Posts: 10127
Location: Córdoba (Spain)

PostPosted: Wed Mar 13, 2013 3:05 pm    Post subject: Reply with quote

En r`imer lugar: backups, backups, backups.

En segundo, tendrás que mover los archivos de lib a lib64 y si hay conflictos, en principio darle prioridad al más moderno de los archivos. Cuando lib esté vacío lo borras y lo enlazas.

Por cierto, no se si es relevante, pero dices que has arrancado de un cd. Si ese es el caso y no has hecho chroot lo que estás viendo es el root del cd, no el tuyo.
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
Theasker
l33t
l33t


Joined: 18 Nov 2006
Posts: 636
Location: Zaragoza (Spain)

PostPosted: Wed Mar 13, 2013 8:14 pm    Post subject: Reply with quote

hombre, he hecho antes un

Code:
mount /dev/hda5 /mnt/gentoo/raiz
cd /mnt/gentoo/raiz
ls -la


Entonces lo primero, hacer un backup de todas las particiones por ejemplo con partimage, principalmente de / que es donde está el follón

Luego empezar con el directorio donde me da el error /usr/lib y

cp -a /usr/lib/* /usr/lib64/
mv /usr/lib /usr/lib.bak

reiniciar y ver si funciona algo y si funciona hacer /sbin/ldconfig

¿algo así sería el tema?

EDITO: Para mi que todo esto empezó con la actualización de los profiles, que cuando vino la new esa por eselect
Code:

# eselect news read 17
2013-02-10-new-13-profiles
  Title                     New 13.0 profiles and deprecation of 10.0 profiles
  Author                    Andreas K. Huettel <dilfridge@gentoo.org>
  Posted                    2013-02-10
  Revision                  1

We have generated a new set of profiles for Gentoo installation. These are now
called 13.0 instead of 10.0. Everyone should upgrade as soon as possible (but
please make sure sys-apps/portage is updated to current stable *before* you
switch profile).
This brings (nearly) no user-visible changes. Some new files have been added
to the profile directories that make it possible for the developers to do more
fine-grained use flag masking (see PMS-5 for the details), and this formally
requires a new profile tree with EAPI=5.


lo primero que hice fue mirar cómo lo tenía con un eselect profile list y no tenía ninguno seleccionado, puede que fuerda debido a la actualización entonces hice eselect profile set 3 que es [3] default/linux/amd64/13.0/desktop y al poco tiempo (en ese momento ya no le di más importancia) empezó todo. No se como he podido llegar a esto si yo núnca toco nada del sistema para que no pasen estas cosas.
_________________
"Oigo y olvido. Veo y recuerdo. Hago y comprendo"
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 898

PostPosted: Wed Mar 13, 2013 9:21 pm    Post subject: Reply with quote

Theasker wrote:
...
Luego empezar con el directorio donde me da el error /usr/lib y

cp -a /usr/lib/* /usr/lib64/
mv /usr/lib /usr/lib.bak

reiniciar y ver si funciona algo y si funciona hacer /sbin/ldconfig
...
Te falta crear el enlace simbólico después del mv
Code:
ln -s lib64 /usr/lib

Te recomiendo que hagas el /sbin/ldconfig antes de reiniciar.
Back to top
View user's profile Send private message
Theasker
l33t
l33t


Joined: 18 Nov 2006
Posts: 636
Location: Zaragoza (Spain)

PostPosted: Wed Mar 13, 2013 9:24 pm    Post subject: Reply with quote

¿haciendo un chroot no?, yo todo esto pensaba hacerlo arrancando desde un cd como systemrescue y montando únicamente la partición /, o ..... no?
_________________
"Oigo y olvido. Veo y recuerdo. Hago y comprendo"
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 898

PostPosted: Wed Mar 13, 2013 9:54 pm    Post subject: Reply with quote

Los comandos que has puesto antes y el que te he puesto para crear el enlace simbólico estan pensados para para que los ejecutes después del chroot.

Puedes hacer todo igual sin hacer chroot si en los comandos anteriores sustituyes /usr por /mnt/gentoo/raiz. Por ejemplo el cp quedaría
Code:
cp -a /mnt/gentoo/raiz/usr/lib/* /mnt/gentoo/raiz/usr/lib64
. Si lo haces así finaliza con
Code:
/sbin/ldconfig -r /mnt/gentoo/raiz
Back to top
View user's profile Send private message
Theasker
l33t
l33t


Joined: 18 Nov 2006
Posts: 636
Location: Zaragoza (Spain)

PostPosted: Wed Mar 13, 2013 9:58 pm    Post subject: Reply with quote

gracias, le echaré 2 coj*** y probaré, también haré antes un cp /usr /usr.bak para si sale algo mal no tener que restaurar el backup de la partición entero, ¿no?
_________________
"Oigo y olvido. Veo y recuerdo. Hago y comprendo"
Back to top
View user's profile Send private message
Theasker
l33t
l33t


Joined: 18 Nov 2006
Posts: 636
Location: Zaragoza (Spain)

PostPosted: Thu Mar 14, 2013 9:09 am    Post subject: Reply with quote

Hola de nuevo, estoy a mitad del proceso ...

no se muy bien que es lo que había pasado, pero prácticamente todo lo que había en /usr/lib no estaba en /usr/lib64, por lo que no he tenido que sobreescribir prácticamente nada.

lo he hecho sin hacer un chroot, pero .... ¿cómo hago el enlace ? ¿Sería algo así?

Code:
cd /mnt/gentoo/raiz/usr
ln -s lib64 lib


o

Code:
ln -s /mnt/gentoo/raiz/usr/lib64 /mnt/gentoo/raiz/usr/lib


¿o ahora ya da igual que lo haga arrancando de nuevo con mi sistema?

Edito: ah, y se me olvidaba

Code:
/sbin/ldconfig -r /mnt/gentoo/raiz

_________________
"Oigo y olvido. Veo y recuerdo. Hago y comprendo"
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 898

PostPosted: Thu Mar 14, 2013 1:20 pm    Post subject: Reply with quote

Theasker wrote:
Hola de nuevo, estoy a mitad del proceso ...

no se muy bien que es lo que había pasado, pero prácticamente todo lo que había en /usr/lib no estaba en /usr/lib64, por lo que no he tenido que sobreescribir prácticamente nada.

lo he hecho sin hacer un chroot, pero .... ¿cómo hago el enlace ? ¿Sería algo así?

Code:
cd /mnt/gentoo/raiz/usr
ln -s lib64 lib

Este comando si que servirá para crear el enlace.
También puedes hacer ln -s lib64 /mnt/gentoo/raiz/usr/lib sin hacer cd a ningún sitio en particular.

o

Code:
ln -s /mnt/gentoo/raiz/usr/lib64 /mnt/gentoo/raiz/usr/lib

Este comando no creará el enlace correctamente


¿o ahora ya da igual que lo haga arrancando de nuevo con mi sistema?
No. Crea el enlace antes de reiniciar.

Edito: ah, y se me olvidaba

Code:
/sbin/ldconfig -r /mnt/gentoo/raiz

Ejecutalo también antes de reiniciar.
Back to top
View user's profile Send private message
Theasker
l33t
l33t


Joined: 18 Nov 2006
Posts: 636
Location: Zaragoza (Spain)

PostPosted: Thu Mar 14, 2013 8:59 pm    Post subject: Reply with quote

bueno, después de hacer todo estoy mandando esto desde mi gentoo de siempre por lo que parece que ha salido todo bien :).

Gracias y ... ¿cómo puedo saber que está ahora todo bien?

he hecho un revdep-rebuild y tengo errores al compilar, pero lo más seguro que no sea de eso ya, y sean otros problemas o no, no lo se.

Yo os pongo lo que sale, que ya salia antes de arreglar esto, cosa que detecté al intentar instalar baselayout, al hacer un revdep-rebuild me salen estos errores para recompilar
Code:

 # revdep-rebuild
 * Configuring search environment for revdep-rebuild

 * Checking reverse dependencies
 * Packages containing binaries and libraries broken by a package update
 * will be emerged.

 * Collecting system binaries and libraries
 * Generated new 1_files.rr
 * Collecting complete LD_LIBRARY_PATH
 * Generated new 2_ldpath.rr
 * Checking dynamic linking consistency
[ 15% ]  *   broken /usr/bin/mediatomb (requires libavformat.so.53)
[ 46% ]  *   broken /usr/lib64/audacious/Input/ffaudio.so (requires libavcodec.so.53
libavformat.so.53)
[ 56% ]  *   broken /usr/lib64/gstreamer-0.10/libgstffmpeg.so (requires libavcodec.so.53
libavformat.so.53)
[ 57% ]  *   broken /usr/lib64/gstreamer-0.10/libgstpostproc.so (requires libavcodec.so.53)
[ 65% ]  *   broken /usr/lib64/libjavascriptcoregtk-1.0.so.0.13.4 (requires libicui18n.so.49
libicuuc.so.49)
[ 68% ]  *   broken /usr/lib64/libwebkitgtk-1.0.so.0.13.4 (requires libicui18n.so.49
libicuuc.so.49)
[ 100% ]                 
 * Generated new 3_broken.rr
 * Assigning files to packages
 *   /usr/bin/mediatomb -> net-misc/mediatomb
 *   /usr/lib64/audacious/Input/ffaudio.so -> media-plugins/audacious-plugins
 *   /usr/lib64/gstreamer-0.10/libgstffmpeg.so -> media-plugins/gst-plugins-ffmpeg
 *   /usr/lib64/gstreamer-0.10/libgstpostproc.so -> media-plugins/gst-plugins-ffmpeg
 *   /usr/lib64/libjavascriptcoregtk-1.0.so.0.13.4 -> net-libs/webkit-gtk
 *   /usr/lib64/libwebkitgtk-1.0.so.0.13.4 -> net-libs/webkit-gtk
 * Generated new 4_raw.rr and 4_owners.rr
 * Cleaning list of packages to rebuild
 * Generated new 4_pkgs.rr
 * Assigning packages to ebuilds
 * Generated new 4_ebuilds.rr
 * Evaluating package order
 * Generated new 5_order.rr
 * All prepared. Starting rebuild
emerge --complete-graph=y --oneshot --autounmask=n  media-plugins/audacious-plugins:0 media-plugins/gst-plugins-ffmpeg:0.10 net-libs/webkit-gtk:2 net-misc/mediatomb:0


como veis son problemas de /usr/lib64, aunque puede que no tenga nada que ver

y cuando intenta reinstalar el primero media-plugins/gst-plugins-ffmpeg sale esto:

Code:
# emerge gst-plugins-ffmpeg
Calculating dependencies... done!

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) media-plugins/gst-plugins-ffmpeg-0.10.13-r2
 * gst-ffmpeg-0.10.13.tar.bz2 SHA256 SHA512 WHIRLPOOL size ;-) ...                           [ ok ]
>>> Unpacking source...
>>> Unpacking gst-ffmpeg-0.10.13.tar.bz2 to /var/tmp/portage/media-plugins/gst-plugins-ffmpeg-0.10.13-r2/work
>>> Source unpacked in /var/tmp/portage/media-plugins/gst-plugins-ffmpeg-0.10.13-r2/work
>>> Preparing source in /var/tmp/portage/media-plugins/gst-plugins-ffmpeg-0.10.13-r2/work/gst-ffmpeg-0.10.13 ...
...
...
configure: Using system-installed FFMpeg code
configure: WARNING:
  ======================================================================
   WARNING: you have chosen to build gst-ffmpeg against a random
   external version of Libav instead of building it against the tested
   internal Libav snapshot that is included with gst-ffmpeg.

   This is a very bad idea.  So bad in fact that words cannot express
   just how bad it is.  Suffice to say that it is BAD.

   The GStreamer developers cannot and will not support a gst-ffmpeg
   built this way.  Any bug reports that indicate there is an external
   version of Libav involved will be closed immediately without further
   investigation.

   The reason such a setup can't be supported is that the Libav API
   and ABI is in constant flux, yet there aren't any official releases
   of the Libav library to develop against.  This makes it impossible
   to guarantee that gst-ffmpeg will work reliably, or even compile,
   with a randomly picked version Libav.  Even if gst-ffmpeg compiles
   and superficially appears to work fine against your chosen external
   Libav version, that might just not be the case on other systems, or
   even the same system at a later time, or when using decoders,
   encoders, demuxers or muxers that have not been tested.

   Please do not create or distribute binary packages of gst-Libav
   that link against an external ffmpeg. Thank you!
  ======================================================================
 
configure: creating ./config.status
..
...
gstffmpegprotocol.c:386:3: warning: excess elements in scalar initializer [enabled by default]
gstffmpegprotocol.c:386:3: warning: (near initialization for ‘gstpipe_protocol’) [enabled by default]
make[3]: *** [libgstffmpeg_la-gstffmpegprotocol.lo] Error 1
make[3]: se sale del directorio `/var/tmp/portage/media-plugins/gst-plugins-ffmpeg-0.10.13-r2/work/gst-ffmpeg-0.10.13/ext/ffmpeg'
make[2]: *** [all-recursive] Error 1
make[2]: se sale del directorio `/var/tmp/portage/media-plugins/gst-plugins-ffmpeg-0.10.13-r2/work/gst-ffmpeg-0.10.13/ext'
make[1]: *** [all-recursive] Error 1
make[1]: se sale del directorio `/var/tmp/portage/media-plugins/gst-plugins-ffmpeg-0.10.13-r2/work/gst-ffmpeg-0.10.13'
make: *** [all] Error 2
 * ERROR: media-plugins/gst-plugins-ffmpeg-0.10.13-r2 failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=media-plugins/gst-plugins-ffmpeg-0.10.13-r2'`,
 * the complete build log and the output of `emerge -pqv '=media-plugins/gst-plugins-ffmpeg-0.10.13-r2'`.
 * The complete build log is located at '/var/tmp/portage/media-plugins/gst-plugins-ffmpeg-0.10.13-r2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-plugins/gst-plugins-ffmpeg-0.10.13-r2/temp/environment'.
 * Working directory: '/var/tmp/portage/media-plugins/gst-plugins-ffmpeg-0.10.13-r2/work/gst-ffmpeg-0.10.13'
 * S: '/var/tmp/portage/media-plugins/gst-plugins-ffmpeg-0.10.13-r2/work/gst-ffmpeg-0.10.13'

>>> Failed to emerge media-plugins/gst-plugins-ffmpeg-0.10.13-r2, Log file:

>>>  '/var/tmp/portage/media-plugins/gst-plugins-ffmpeg-0.10.13-r2/temp/build.log'


también al hacer un emerge -uvaDN world e intentar actualizar midori:

Code:
riptcoregtk-1.0', '-lxml2']
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../x86_64-pc-linux-gnu/bin/ld: warning: libicui18n.so.49, needed by /usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libwebkitgtk-1.0.so, not found (try using -rpath or -rpath-link)
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../x86_64-pc-linux-gnu/bin/ld: warning: libicuuc.so.49, needed by /usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libwebkitgtk-1.0.so, not found (try using -rpath or -rpath-link)
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libwebkitgtk-1.0.so: undefined reference to `ubrk_first_49'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libwebkitgtk-1.0.so: undefined reference to `uset_close_49'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libwebkitgtk-1.0.so: undefined reference to `ucnv_cbFromUWriteBytes_49'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libwebkitgtk-1.0.so: undefined reference to `ucnv_cbFromUWriteUChars_49'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libwebkitgtk-1.0.so: undefined reference to `u_toupper_49'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libwebkitgtk-1.0.so: undefined reference to `ubrk_following_49'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libwebkitgtk-1.0.so: undefined reference to `ubrk_isBoundary_49'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libwebkitgtk-1.0.so: undefined reference to `u_charDirection_49'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libwebkitgtk-1.0.so: undefined reference to `uidna_IDNToASCII_49'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libwebkitgtk-1.0.so: undefined reference to `u_isprint_49'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libwebkitgtk-1.0.so: undefined reference to `usearch_setOffset_49'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libwebkitgtk-1.0.so: undefined reference to `ubrk_previous_49'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libwebkitgtk-1.0.so: undefined reference to `UCNV_FROM_U_CALLBACK_ESCAPE_49'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libjavascriptcoregtk-1.0.so: undefined reference to `ucol_close_49'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libwebkitgtk-1.0.so: undefined reference to `ubrk_preceding_49'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libwebkitgtk-1.0.so: undefined reference to `ubrk_open_49'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libjavascriptcoregtk-1.0.so: undefined reference to `udat_format_49'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libjavascriptcoregtk-1.0.so: undefined reference to `ucol_setAttribute_49'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libjavascriptcoregtk-1.0.so: undefined reference to `udat_open_49'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libwebkitgtk-1.0.so: undefined reference to `ucnv_setFromUCallBack_49'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libwebkitgtk-1.0.so: undefined reference to `u_foldCase_49'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libwebkitgtk-1.0.so: undefined reference to `u_getCombiningClass_49'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libwebkitgtk-1.0.so: undefined reference to `u_getIntPropertyValue_49'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libwebkitgtk-1.0.so: undefined reference to `UCNV_FROM_U_CALLBACK_SUBSTITUTE_49'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libwebkitgtk-1.0.so: undefined reference to `UCNV_TO_U_CALLBACK_SUBSTITUTE_49'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libwebkitgtk-1.0.so: undefined reference to `ucnv_toUnicode_49'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libwebkitgtk-1.0.so: undefined reference to `ucol_setStrength_49'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libjavascriptcoregtk-1.0.so: undefined reference to `u_strToUpper_49'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libwebkitgtk-1.0.so: undefined reference to `ubrk_next_49'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libwebkitgtk-1.0.so: undefined reference to `ucnv_countAvailable_49'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libjavascriptcoregtk-1.0.so: undefined reference to `ucol_open_49'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libwebkitgtk-1.0.so: undefined reference to `ubrk_close_49'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libwebkitgtk-1.0.so: undefined reference to `ubrk_current_49'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libjavascriptcoregtk-1.0.so: undefined reference to `u_strToLower_49'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libwebkitgtk-1.0.so: undefined reference to `u_isalnum_49'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libwebkitgtk-1.0.so: undefined reference to `ucol_getStrength_49'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libjavascriptcoregtk-1.0.so: undefined reference to `ucol_getLocaleByType_49'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libwebkitgtk-1.0.so: undefined reference to `unorm_quickCheck_49'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libwebkitgtk-1.0.so: undefined reference to `u_charType_49'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libwebkitgtk-1.0.so: undefined reference to `ubrk_setText_49'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libwebkitgtk-1.0.so: undefined reference to `uset_addRange_49'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libwebkitgtk-1.0.so: undefined reference to `ucnv_getStandardName_49'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libwebkitgtk-1.0.so: undefined reference to `usearch_setText_49'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libwebkitgtk-1.0.so: undefined reference to `usearch_getMatchedLength_49'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libwebkitgtk-1.0.so: undefined reference to `usearch_open_49'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libjavascriptcoregtk-1.0.so: undefined reference to `ucol_getAttribute_49'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libwebkitgtk-1.0.so: undefined reference to `u_tolower_49'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libwebkitgtk-1.0.so: undefined reference to `usearch_reset_49'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libwebkitgtk-1.0.so: undefined reference to `ucnv_setFallback_49'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libwebkitgtk-1.0.so: undefined reference to `uset_add_49'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libwebkitgtk-1.0.so: undefined reference to `ucnv_countAliases_49'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libjavascriptcoregtk-1.0.so: undefined reference to `udat_close_49'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libwebkitgtk-1.0.so: undefined reference to `ucnv_close_49'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libwebkitgtk-1.0.so: undefined reference to `usearch_next_49'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libwebkitgtk-1.0.so: undefined reference to `usearch_setPattern_49'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libwebkitgtk-1.0.so: undefined reference to `uset_contains_49'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libjavascriptcoregtk-1.0.so: undefined reference to `ucol_strcoll_49'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libwebkitgtk-1.0.so: undefined reference to `u_ispunct_49'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libwebkitgtk-1.0.so: undefined reference to `ucnv_setSubstChars_49'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libwebkitgtk-1.0.so: undefined reference to `ucnv_fromUnicode_49'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libwebkitgtk-1.0.so: undefined reference to `unorm_normalize_49'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libwebkitgtk-1.0.so: undefined reference to `ucnv_getAvailableName_49'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libwebkitgtk-1.0.so: undefined reference to `u_memcasecmp_49'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libwebkitgtk-1.0.so: undefined reference to `ucnv_setToUCallBack_49'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libwebkitgtk-1.0.so: undefined reference to `uset_openPattern_49'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libwebkitgtk-1.0.so: undefined reference to `ubrk_openRules_49'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libwebkitgtk-1.0.so: undefined reference to `ucnv_getAlias_49'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libwebkitgtk-1.0.so: undefined reference to `u_charMirror_49'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libjavascriptcoregtk-1.0.so: undefined reference to `u_strFoldCase_49'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libwebkitgtk-1.0.so: undefined reference to `ublock_getCode_49'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libwebkitgtk-1.0.so: undefined reference to `ubrk_last_49'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libwebkitgtk-1.0.so: undefined reference to `usearch_getCollator_49'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libwebkitgtk-1.0.so: undefined reference to `uset_addAll_49'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libwebkitgtk-1.0.so: undefined reference to `u_totitle_49'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libwebkitgtk-1.0.so: undefined reference to `ucnv_open_49'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libwebkitgtk-1.0.so: undefined reference to `ucnv_getName_49'
collect2: ld devolvió el estado de salida 1
Waf: Leaving directory `/var/tmp/portage/www-client/midori-0.4.9/work/midori-0.4.9/_build'
Build failed:  -> task failed (err #1):
   {task: cc_link main_2.o -> midori}
 * ERROR: www-client/midori-0.4.9 failed (compile phase):
 *   build failed
 *
 * Call stack:
 *     ebuild.sh, line   93:  Called src_compile
 *   environment, line 3020:  Called waf-utils_src_compile
 *   environment, line 3529:  Called die
 * The specific snippet of code:
 *       "${WAF_BINARY}" ${_mywafconfig} ${jobs} || die "build failed"
 *
 * If you need support, post the output of `emerge --info '=www-client/midori-0.4.9'`,
 * the complete build log and the output of `emerge -pqv '=www-client/midori-0.4.9'`.
 * The complete build log is located at '/var/tmp/portage/www-client/midori-0.4.9/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/www-client/midori-0.4.9/temp/environment'.
 * Working directory: '/var/tmp/portage/www-client/midori-0.4.9/work/midori-0.4.9'
 * S: '/var/tmp/portage/www-client/midori-0.4.9/work/midori-0.4.9'

>>> Failed to emerge www-client/midori-0.4.9, Log file:

>>>  '/var/tmp/portage/www-client/midori-0.4.9/temp/build.log'


Gracias de nuevo y a ver si al final poco a poco consigo arreglar ese desaguisado.
_________________
"Oigo y olvido. Veo y recuerdo. Hago y comprendo"
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 898

PostPosted: Thu Mar 14, 2013 11:56 pm    Post subject: Reply with quote

En el caso de gst-plugins-ffmpeg faltan líneas de la salida por consola para ver que error te da. Prueba a instalar o reinstalar ffmpeg.
Code:
emerge --oneshot media-video/ffmpeg virtual/ffmpeg


En el caso de midori te faltan las librerias de icu. Instala o reinstala.
Code:
emerge --oneshot dev-libs/icu
Back to top
View user's profile Send private message
Theasker
l33t
l33t


Joined: 18 Nov 2006
Posts: 636
Location: Zaragoza (Spain)

PostPosted: Fri Mar 15, 2013 7:43 am    Post subject: Reply with quote

En cuanto a gst-plugins-ffmpeg he reinstalado ffmpeg pero nada:

Quote:
# emerge gst-plugins-ffmpeg
Calculating dependencies... done!

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) media-plugins/gst-plugins-ffmpeg-0.10.13-r2
* gst-ffmpeg-0.10.13.tar.bz2 SHA256 SHA512 WHIRLPOOL size ;-) ... [ ok ]
>>> Unpacking source...
>>> Unpacking gst-ffmpeg-0.10.13.tar.bz2 to /var/tmp/portage/media-plugins/gst-plugins-ffmpeg-0.10.13-r2/work
>>> Source unpacked in /var/tmp/portage/media-plugins/gst-plugins-ffmpeg-0.10.13-r2/work
>>> Preparing source in /var/tmp/portage/media-plugins/gst-plugins-ffmpeg-0.10.13-r2/work/gst-ffmpeg-0.10.13 ...
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/media-plugins/gst-plugins-ffmpeg-0.10.13-r2/work/gst-ffmpeg-0.10.13 ...
* econf: updating gst-ffmpeg-0.10.13/config.guess with /usr/share/gnuconfig/config.guess
* econf: updating gst-ffmpeg-0.10.13/config.sub with /usr/share/gnuconfig/config.sub
./configure --prefix=/usr --build=x86_64-pc-linux-gnu --host=x86_64-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --libdir=/usr/lib64 --disable-dependency-tracking --with-system-ffmpeg --enable-orc
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking nano version... 0 (release)
checking whether to enable maintainer-specific portions of Makefiles... no
checking build system type... x86_64-pc-linux-gnu
checking host system type... x86_64-pc-linux-gnu
checking how to print strings... printf
checking for style of include used by make... GNU
checking for x86_64-pc-linux-gnu-gcc... x86_64-pc-linux-gnu-gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether x86_64-pc-linux-gnu-gcc accepts -g... yes
checking for x86_64-pc-linux-gnu-gcc option to accept ISO C89... none needed
checking dependency style of x86_64-pc-linux-gnu-gcc... none
checking for a sed that does not truncate output... /bin/sed
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for fgrep... /bin/grep -F
checking for ld used by x86_64-pc-linux-gnu-gcc... /usr/x86_64-pc-linux-gnu/bin/ld
checking if the linker (/usr/x86_64-pc-linux-gnu/bin/ld) is GNU ld... yes
checking for BSD- or MS-compatible name lister (nm)... /usr/bin/nm -B
checking the name lister (/usr/bin/nm -B) interface... BSD nm
checking whether ln -s works... yes
checking the maximum length of command line arguments... 1572864
checking whether the shell understands some XSI constructs... yes
checking whether the shell understands "+="... yes
checking how to convert x86_64-pc-linux-gnu file names to x86_64-pc-linux-gnu format... func_convert_file_noop
checking how to convert x86_64-pc-linux-gnu file names to toolchain format... func_convert_file_noop
checking for /usr/x86_64-pc-linux-gnu/bin/ld option to reload object files... -r
checking for x86_64-pc-linux-gnu-objdump... objdump
checking how to recognize dependent libraries... pass_all
checking for x86_64-pc-linux-gnu-dlltool... dlltool
checking how to associate runtime and link libraries... printf %s\n
checking for x86_64-pc-linux-gnu-ar... x86_64-pc-linux-gnu-ar
checking for archiver @FILE support... @
checking for x86_64-pc-linux-gnu-strip... x86_64-pc-linux-gnu-strip
checking for x86_64-pc-linux-gnu-ranlib... x86_64-pc-linux-gnu-ranlib
checking command to parse /usr/bin/nm -B output from x86_64-pc-linux-gnu-gcc object... ok
checking for sysroot... no
checking for x86_64-pc-linux-gnu-mt... no
checking for mt... no
checking if : is a manifest tool... no
checking how to run the C preprocessor... x86_64-pc-linux-gnu-gcc -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking for dlfcn.h... yes
checking for objdir... .libs
checking if x86_64-pc-linux-gnu-gcc supports -fno-rtti -fno-exceptions... no
checking for x86_64-pc-linux-gnu-gcc option to produce PIC... -fPIC -DPIC
checking if x86_64-pc-linux-gnu-gcc PIC flag -fPIC -DPIC works... yes
checking if x86_64-pc-linux-gnu-gcc static flag -static works... yes
checking if x86_64-pc-linux-gnu-gcc supports -c -o file.o... yes
checking if x86_64-pc-linux-gnu-gcc supports -c -o file.o... (cached) yes
checking whether the x86_64-pc-linux-gnu-gcc linker (/usr/x86_64-pc-linux-gnu/bin/ld -m elf_x86_64) supports shared libraries... yes
checking whether -lc should be explicitly linked in... no
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... yes
configure: Using GStreamer Libav source release as package name
configure: Using Unknown package origin as package origin
checking for x86_64-pc-linux-gnu-pkg-config... /usr/bin/x86_64-pc-linux-gnu-pkg-config
checking pkg-config is at least version 0.9.0... yes
checking whether byte ordering is bigendian... no
checking for x86_64-pc-linux-gnu-gcc... (cached) x86_64-pc-linux-gnu-gcc
checking whether we are using the GNU C compiler... (cached) yes
checking whether x86_64-pc-linux-gnu-gcc accepts -g... (cached) yes
checking for x86_64-pc-linux-gnu-gcc option to accept ISO C89... (cached) none needed
checking dependency style of x86_64-pc-linux-gnu-gcc... (cached) none
checking for x86_64-pc-linux-gnu-gcc option to accept ISO C99... -std=gnu99
checking for x86_64-pc-linux-gnu-gcc -std=gnu99 option to accept ISO Standard C... (cached) -std=gnu99
checking whether x86_64-pc-linux-gnu-gcc -std=gnu99 and cc understand -c and -o together... yes
checking for valgrind... no
checking whether to build gtk-doc documentation... no
checking for gtkdoc-check... /usr/bin/gtkdoc-check
configure: Looking for Python version >= 2.1
checking for python... /usr/bin/python
checking "/usr/bin/python":... okay
checking local Python configuration... looks good
checking whether to build plugin documentation... no (gtk-doc disabled or not available)
checking for cos in -lm... yes
checking for ANSI C header files... (cached) yes
checking for GST... yes
configure: using GStreamer tools in /usr/bin
configure: using GStreamer plug-ins in /usr/lib64/gstreamer-0.10
checking for GST_BASE... yes
checking for GST_PLUGINS_BASE... yes
configure: using GStreamer Base Plugins in /usr/lib64/gstreamer-0.10
checking for GST_CHECK... yes
configure: Using GStreamer Core Plugins in /usr/lib64/gstreamer-0.10
configure: Using GStreamer Base Plugins in /usr/lib64/gstreamer-0.10
checking for ORC... yes
checking for usable orcc... /usr/bin/orcc
configure: Using /usr/lib64/gstreamer-0.10 as the plugin install location
checking to see if compiler understands ... yes
checking to see if compiler understands -Wall... yes
checking to see if compiler understands -Wdeclaration-after-statement... yes
checking to see if compiler understands -Wvla... yes
checking to see if compiler understands -Wpointer-arith... yes
checking to see if compiler understands -Wmissing-declarations... yes
checking to see if compiler understands -Wmissing-prototypes... yes
checking to see if compiler understands -Wredundant-decls... yes
checking to see if compiler understands -Wundef... yes
checking to see if compiler understands -Wwrite-strings... yes
checking to see if compiler understands -Wformat-nonliteral... yes
checking to see if compiler understands -Wformat-security... yes
checking to see if compiler understands -Wold-style-definition... yes
checking to see if compiler understands -Winit-self... yes
checking to see if compiler understands -Wmissing-include-dirs... yes
checking to see if compiler understands -Waddress... yes
checking to see if compiler understands -Waggregate-return... yes
checking to see if compiler understands -Wno-multichar... yes
checking to see if compiler understands -Wnested-externs... yes
configure: set WARNING_CFLAGS to -Wall -Wdeclaration-after-statement -Wvla -Wpointer-arith -Wmissing-declarations -Wmissing-prototypes -Wredundant-decls -Wundef -Wwrite-strings -Wformat-nonliteral -Wformat-security -Wold-style-definition -Winit-self -Wmissing-include-dirs -Waddress -Waggregate-return -Wno-multichar -Wnested-externs
configure: set ERROR_CFLAGS to
checking for BZ2_bzlibVersion in -lbz2... yes
checking bzlib.h usability... yes
checking bzlib.h presence... yes
checking for bzlib.h... yes
checking for FFMPEG... yes
checking for POSTPROC... yes
checking for SWSCALE... yes
checking avi.h usability... no
checking avi.h presence... no
checking for avi.h... no
configure: Using system-installed FFMpeg code
configure: WARNING:
======================================================================
WARNING: you have chosen to build gst-ffmpeg against a random
external version of Libav instead of building it against the tested
internal Libav snapshot that is included with gst-ffmpeg.

This is a very bad idea. So bad in fact that words cannot express
just how bad it is. Suffice to say that it is BAD.

The GStreamer developers cannot and will not support a gst-ffmpeg
built this way. Any bug reports that indicate there is an external
version of Libav involved will be closed immediately without further
investigation.

The reason such a setup can't be supported is that the Libav API
and ABI is in constant flux, yet there aren't any official releases
of the Libav library to develop against. This makes it impossible
to guarantee that gst-ffmpeg will work reliably, or even compile,
with a randomly picked version Libav. Even if gst-ffmpeg compiles
and superficially appears to work fine against your chosen external
Libav version, that might just not be the case on other systems, or
even the same system at a later time, or when using decoders,
encoders, demuxers or muxers that have not been tested.

Please do not create or distribute binary packages of gst-Libav
that link against an external ffmpeg. Thank you!
======================================================================

configure: creating ./config.status
config.status: creating Makefile
config.status: creating common/Makefile
config.status: creating common/m4/Makefile
config.status: creating gst-ffmpeg.spec
config.status: creating ext/Makefile
config.status: creating ext/ffmpeg/Makefile
config.status: creating ext/libpostproc/Makefile
config.status: creating ext/libswscale/Makefile
config.status: creating gst-libs/Makefile
config.status: creating gst-libs/ext/Makefile
config.status: creating docs/Makefile
config.status: creating docs/version.entities
config.status: creating tests/Makefile
config.status: creating tests/check/Makefile
config.status: creating tests/files/Makefile
config.status: creating config.h
config.status: executing depfiles commands
config.status: executing libtool commands
configure: *** Orc acceleration enabled.

>>> Source configured.
>>> Compiling source in /var/tmp/portage/media-plugins/gst-plugins-ffmpeg-0.10.13-r2/work/gst-ffmpeg-0.10.13 ...
make -j2
make all-recursive
make[1]: se ingresa al directorio `/var/tmp/portage/media-plugins/gst-plugins-ffmpeg-0.10.13-r2/work/gst-ffmpeg-0.10.13'
Making all in ext
make[2]: se ingresa al directorio `/var/tmp/portage/media-plugins/gst-plugins-ffmpeg-0.10.13-r2/work/gst-ffmpeg-0.10.13/ext'
Making all in ffmpeg
make[3]: se ingresa al directorio `/var/tmp/portage/media-plugins/gst-plugins-ffmpeg-0.10.13-r2/work/gst-ffmpeg-0.10.13/ext/ffmpeg'
CC libgstffmpeg_la-gstffmpeg.lo
/bin/sh ../../libtool --silent --tag=CC --tag=disable-static --mode=compile x86_64-pc-linux-gnu-gcc -std=gnu99 -DHAVE_CONFIG_H -I. -I../.. -pthread -I/usr/include/gstreamer-0.10 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/libxml2 -I../../gst-libs -I../../gst-libs -pthread -I/usr/include/gstreamer-0.10 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/libxml2 -Wall -Wdeclaration-after-statement -Wvla -Wpointer-arith -Wmissing-declarations -Wmissing-prototypes -Wredundant-decls -Wundef -Wwrite-strings -Wformat-nonliteral -Wformat-security -Wold-style-definition -Winit-self -Wmissing-include-dirs -Waddress -Waggregate-return -Wno-multichar -Wnested-externs -march=nocona -O2 -pipe -c -o libgstffmpeg_la-gstffmpeg.lo `test -f 'gstffmpeg.c' || echo './'`gstffmpeg.c
CC libgstffmpeg_la-gstffmpegprotocol.lo
/bin/sh ../../libtool --silent --tag=CC --tag=disable-static --mode=compile x86_64-pc-linux-gnu-gcc -std=gnu99 -DHAVE_CONFIG_H -I. -I../.. -pthread -I/usr/include/gstreamer-0.10 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/libxml2 -I../../gst-libs -I../../gst-libs -pthread -I/usr/include/gstreamer-0.10 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/libxml2 -Wall -Wdeclaration-after-statement -Wvla -Wpointer-arith -Wmissing-declarations -Wmissing-prototypes -Wredundant-decls -Wundef -Wwrite-strings -Wformat-nonliteral -Wformat-security -Wold-style-definition -Winit-self -Wmissing-include-dirs -Waddress -Waggregate-return -Wno-multichar -Wnested-externs -march=nocona -O2 -pipe -c -o libgstffmpeg_la-gstffmpegprotocol.lo `test -f 'gstffmpegprotocol.c' || echo './'`gstffmpegprotocol.c
In file included from gstffmpegprotocol.c:34:0:
gstffmpeg.h:63:1: error: unknown type name ‘URLProtocol’
gstffmpeg.h:64:1: error: unknown type name ‘URLProtocol’
gstffmpegprotocol.c:49:22: error: unknown type name ‘URLContext’
gstffmpegprotocol.c:97:22: error: unknown type name ‘URLContext’
gstffmpegprotocol.c:137:22: error: unknown type name ‘URLContext’
gstffmpegprotocol.c:157:23: error: unknown type name ‘URLContext’
gstffmpegprotocol.c:182:22: error: unknown type name ‘URLContext’
gstffmpegprotocol.c:262:23: error: unknown type name ‘URLContext’
gstffmpegprotocol.c:291:1: error: unknown type name ‘URLProtocol’
gstffmpegprotocol.c:292:16: warning: initialization makes integer from pointer without a cast [enabled by default]
gstffmpegprotocol.c:292:16: warning: (near initialization for ‘gstreamer_protocol’) [enabled by default]
gstffmpegprotocol.c:292:16: error: initializer element is not computable at load time
gstffmpegprotocol.c:292:16: error: (near initialization for ‘gstreamer_protocol’)
gstffmpegprotocol.c:293:20: error: ‘gst_ffmpegdata_open’ undeclared here (not in a function)
gstffmpegprotocol.c:293:20: warning: excess elements in scalar initializer [enabled by default]
gstffmpegprotocol.c:293:20: warning: (near initialization for ‘gstreamer_protocol’) [enabled by default]
gstffmpegprotocol.c:294:20: error: ‘gst_ffmpegdata_read’ undeclared here (not in a function)
gstffmpegprotocol.c:294:20: warning: excess elements in scalar initializer [enabled by default]
gstffmpegprotocol.c:294:20: warning: (near initialization for ‘gstreamer_protocol’) [enabled by default]
gstffmpegprotocol.c:295:21: error: ‘gst_ffmpegdata_write’ undeclared here (not in a function)
gstffmpegprotocol.c:295:21: warning: excess elements in scalar initializer [enabled by default]
gstffmpegprotocol.c:295:21: warning: (near initialization for ‘gstreamer_protocol’) [enabled by default]
gstffmpegprotocol.c:296:20: error: ‘gst_ffmpegdata_seek’ undeclared here (not in a function)
gstffmpegprotocol.c:296:20: warning: excess elements in scalar initializer [enabled by default]
gstffmpegprotocol.c:296:20: warning: (near initialization for ‘gstreamer_protocol’) [enabled by default]
gstffmpegprotocol.c:297:21: error: ‘gst_ffmpegdata_close’ undeclared here (not in a function)
gstffmpegprotocol.c:297:21: warning: excess elements in scalar initializer [enabled by default]
gstffmpegprotocol.c:297:21: warning: (near initialization for ‘gstreamer_protocol’) [enabled by default]
gstffmpegprotocol.c:305:23: error: unknown type name ‘URLContext’
gstffmpegprotocol.c:333:23: error: unknown type name ‘URLContext’
gstffmpegprotocol.c:371:24: error: unknown type name ‘URLContext’
gstffmpegprotocol.c:380:1: error: unknown type name ‘URLProtocol’
gstffmpegprotocol.c:381:3: warning: initialization makes integer from pointer without a cast [enabled by default]
gstffmpegprotocol.c:381:3: warning: (near initialization for ‘gstpipe_protocol’) [enabled by default]
gstffmpegprotocol.c:381:3: error: initializer element is not computable at load time
gstffmpegprotocol.c:381:3: error: (near initialization for ‘gstpipe_protocol’)
gstffmpegprotocol.c:382:3: error: ‘gst_ffmpeg_pipe_open’ undeclared here (not in a function)
gstffmpegprotocol.c:382:3: warning: excess elements in scalar initializer [enabled by default]
gstffmpegprotocol.c:382:3: warning: (near initialization for ‘gstpipe_protocol’) [enabled by default]
gstffmpegprotocol.c:383:3: error: ‘gst_ffmpeg_pipe_read’ undeclared here (not in a function)
gstffmpegprotocol.c:383:3: warning: excess elements in scalar initializer [enabled by default]
gstffmpegprotocol.c:383:3: warning: (near initialization for ‘gstpipe_protocol’) [enabled by default]
gstffmpegprotocol.c:384:3: warning: excess elements in scalar initializer [enabled by default]
gstffmpegprotocol.c:384:3: warning: (near initialization for ‘gstpipe_protocol’) [enabled by default]
gstffmpegprotocol.c:385:3: warning: excess elements in scalar initializer [enabled by default]
gstffmpegprotocol.c:385:3: warning: (near initialization for ‘gstpipe_protocol’) [enabled by default]
gstffmpegprotocol.c:386:3: error: ‘gst_ffmpeg_pipe_close’ undeclared here (not in a function)
gstffmpegprotocol.c:386:3: warning: excess elements in scalar initializer [enabled by default]
gstffmpegprotocol.c:386:3: warning: (near initialization for ‘gstpipe_protocol’) [enabled by default]
make[3]: *** [libgstffmpeg_la-gstffmpegprotocol.lo] Error 1
make[3]: *** Se espera a que terminen otras tareas....
In file included from gstffmpeg.c:38:0:
gstffmpeg.h:63:1: error: unknown type name ‘URLProtocol’
gstffmpeg.h:64:1: error: unknown type name ‘URLProtocol’
In file included from gstffmpeg.c:39:0:
gstffmpegutils.h:90:26: warning: ‘enum SampleFormat’ declared inside parameter list [enabled by default]
gstffmpegutils.h:90:26: warning: its scope is only this definition or declaration, which is probably not what you want [enabled by default]
gstffmpeg.c: In function ‘gst_ffmpeg_avcodec_open’:
gstffmpeg.c:52:3: warning: ‘avcodec_open’ is deprecated (declared at /usr/include/libavcodec/avcodec.h:3569) [-Wdeprecated-declarations]
gstffmpeg.c: In function ‘gst_ffmpeg_av_find_stream_info’:
gstffmpeg.c:76:3: warning: ‘av_find_stream_info’ is deprecated (declared at /usr/include/libavformat/avformat.h:1446) [-Wdeprecated-declarations]
gstffmpeg.c: In function ‘plugin_init’:
gstffmpeg.c:154:3: warning: implicit declaration of function ‘av_register_protocol2’ [-Wimplicit-function-declaration]
gstffmpeg.c:154:3: warning: nested extern declaration of ‘av_register_protocol2’ [-Wnested-externs]
gstffmpeg.c:154:55: error: ‘URLProtocol’ undeclared (first use in this function)
gstffmpeg.c:154:55: note: each undeclared identifier is reported only once for each function it appears in
make[3]: *** [libgstffmpeg_la-gstffmpeg.lo] Error 1
make[3]: se sale del directorio `/var/tmp/portage/media-plugins/gst-plugins-ffmpeg-0.10.13-r2/work/gst-ffmpeg-0.10.13/ext/ffmpeg'
make[2]: *** [all-recursive] Error 1
make[2]: se sale del directorio `/var/tmp/portage/media-plugins/gst-plugins-ffmpeg-0.10.13-r2/work/gst-ffmpeg-0.10.13/ext'
make[1]: *** [all-recursive] Error 1
make[1]: se sale del directorio `/var/tmp/portage/media-plugins/gst-plugins-ffmpeg-0.10.13-r2/work/gst-ffmpeg-0.10.13'
make: *** [all] Error 2
* ERROR: media-plugins/gst-plugins-ffmpeg-0.10.13-r2 failed (compile phase):
* emake failed
*
* If you need support, post the output of `emerge --info '=media-plugins/gst-plugins-ffmpeg-0.10.13-r2'`,
* the complete build log and the output of `emerge -pqv '=media-plugins/gst-plugins-ffmpeg-0.10.13-r2'`.
* The complete build log is located at '/var/tmp/portage/media-plugins/gst-plugins-ffmpeg-0.10.13-r2/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/media-plugins/gst-plugins-ffmpeg-0.10.13-r2/temp/environment'.
* Working directory: '/var/tmp/portage/media-plugins/gst-plugins-ffmpeg-0.10.13-r2/work/gst-ffmpeg-0.10.13'
* S: '/var/tmp/portage/media-plugins/gst-plugins-ffmpeg-0.10.13-r2/work/gst-ffmpeg-0.10.13'

>>> Failed to emerge media-plugins/gst-plugins-ffmpeg-0.10.13-r2, Log file:

>>> '/var/tmp/portage/media-plugins/gst-plugins-ffmpeg-0.10.13-r2/temp/build.log'


y en cuanto a midori, sigue dando el mismo error, aun después de reinstalar dev-libs/icu

Igual habría que reinstalar las librerías de /usr/lib que he movido o qué? Porque supongo que un emerge -e world no haría nada, o si?

thx
_________________
"Oigo y olvido. Veo y recuerdo. Hago y comprendo"
Back to top
View user's profile Send private message
i92guboj
Moderator
Moderator


Joined: 30 Nov 2004
Posts: 10127
Location: Córdoba (Spain)

PostPosted: Fri Mar 15, 2013 11:47 am    Post subject: Reply with quote

Estos errores no tiene nada que ver con lo otro. En principio, creo que son bugs propios de esos paquetes. Yo probaría a buscar en bugs.gentoo.org a ver si hay algo parecido.
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
Theasker
l33t
l33t


Joined: 18 Nov 2006
Posts: 636
Location: Zaragoza (Spain)

PostPosted: Fri Mar 15, 2013 11:52 am    Post subject: Reply with quote

okis, vale pues, pues entonces cierro el hijo y muchísimas gracias por toda la ayuda.

Un saludo
_________________
"Oigo y olvido. Veo y recuerdo. Hago y comprendo"
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 898

PostPosted: Fri Mar 15, 2013 8:38 pm    Post subject: Reply with quote

La versión de gst-plugins-ffmpeg que estás intentando instalar es estable y veo muy raro que tenga bugs y menos en la fase de compilación. Creo que efectivamente el problema es consecuencia de la situación de tu sistema.

Si sigues sin solucionarlo, abre nuevos post adjuntando la información que te dicen los mensajes de error para que podamos ayudarte.
Back to top
View user's profile Send private message
Theasker
l33t
l33t


Joined: 18 Nov 2006
Posts: 636
Location: Zaragoza (Spain)

PostPosted: Fri Mar 15, 2013 9:26 pm    Post subject: Reply with quote

Muchísimas gracias pero os he hecho perder el tiempo ya mucho.

Voy a probar con un emerge -e world a ver si se "reparan" librerías o algo. Cada vez que pienso en instalar de nuevo gentoo se me revuelven las tripas, y no quiero darme por vencido.
_________________
"Oigo y olvido. Veo y recuerdo. Hago y comprendo"
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Goto page Previous  1, 2, 3  Next
Page 2 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum