Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] Cannot access the Hardware Clock via known method.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
devlaam
n00b
n00b


Joined: 22 Oct 2009
Posts: 49
Location: Alkmaar, Netherlands

PostPosted: Wed Feb 13, 2013 6:14 pm    Post subject: [Solved] Cannot access the Hardware Clock via known method. Reply with quote

After installation and compiling the genkernel 3.6.11 with (almost) the default config, like this
Code:
genkernel  --menuconfig --install all

i get:
Code:
Cannot access the Hardware Clock via any known method.

In the boot sequence. The only things i changed to the default config are
Code:
Processor family (Opteron/Athlon64/Hammer/K8)
Preemption Model (Voluntary Kernel Preemption (Desktop))
Timer frequency (250 HZ)

and i deactivated the file systems i do not need. The kernel itself works, btw, without any problems, and the boot sequence did not show any other errors.

Now, i have looked at some other threads here, but the do not seem to solve my case:
http://forums.gentoo.org/viewtopic-t-931142-start-0.html
http://forums.gentoo.org/viewtopic-p-6991198.html

The strange thing is that i have activated the RTC:
Code:
fret ruud # grep CONFIG_RTC /etc/kernels/kernel-config-x86_64-3.6.11-gentoo
CONFIG_RTC_LIB=y
CONFIG_RTC_CLASS=y
CONFIG_RTC_HCTOSYS=y
CONFIG_RTC_HCTOSYS_DEVICE="rtc0"
# CONFIG_RTC_DEBUG is not set
CONFIG_RTC_INTF_SYSFS=y
CONFIG_RTC_INTF_PROC=y
CONFIG_RTC_INTF_DEV=y
# CONFIG_RTC_INTF_DEV_UIE_EMUL is not set
# CONFIG_RTC_DRV_TEST is not set
# CONFIG_RTC_DRV_DS1307 is not set
# CONFIG_RTC_DRV_DS1374 is not set
# CONFIG_RTC_DRV_DS1672 is not set
# CONFIG_RTC_DRV_DS3232 is not set
# CONFIG_RTC_DRV_MAX6900 is not set
# CONFIG_RTC_DRV_RS5C372 is not set
# CONFIG_RTC_DRV_ISL1208 is not set
# CONFIG_RTC_DRV_ISL12022 is not set
# CONFIG_RTC_DRV_X1205 is not set
# CONFIG_RTC_DRV_PCF8563 is not set
# CONFIG_RTC_DRV_PCF8583 is not set
# CONFIG_RTC_DRV_M41T80 is not set
# CONFIG_RTC_DRV_BQ32K is not set
# CONFIG_RTC_DRV_S35390A is not set
# CONFIG_RTC_DRV_FM3130 is not set
# CONFIG_RTC_DRV_RX8581 is not set
# CONFIG_RTC_DRV_RX8025 is not set
# CONFIG_RTC_DRV_EM3027 is not set
# CONFIG_RTC_DRV_RV3029C2 is not set
CONFIG_RTC_DRV_CMOS=y
# CONFIG_RTC_DRV_DS1286 is not set
# CONFIG_RTC_DRV_DS1511 is not set
# CONFIG_RTC_DRV_DS1553 is not set
# CONFIG_RTC_DRV_DS1742 is not set
# CONFIG_RTC_DRV_STK17TA8 is not set
# CONFIG_RTC_DRV_M48T86 is not set
# CONFIG_RTC_DRV_M48T35 is not set
# CONFIG_RTC_DRV_M48T59 is not set
# CONFIG_RTC_DRV_MSM6242 is not set
# CONFIG_RTC_DRV_BQ4802 is not set
# CONFIG_RTC_DRV_RP5C01 is not set
# CONFIG_RTC_DRV_V3020 is not set

But it does not seem to work:
Code:
fret ruud # zgrep CONFIG_RTC /proc/config.gz
# CONFIG_RTC is not set
# CONFIG_RTC_CLASS is not set

Checking that the config is indeed copied:
Code:
fret ruud # md5sum /usr/src/linux/.config ; md5sum /etc/kernels/kernel-config-x86_64-3.6.11-gentoo
5eac857868287aeb19b30882353d8048  /usr/src/linux/.config
5eac857868287aeb19b30882353d8048  /etc/kernels/kernel-config-x86_64-3.6.11-gentoo

and used:
Code:
fret ruud # ls -la /usr/src/linux/.config
-rw-r--r-- 1 root root 95222 Feb 13 17:33 /usr/src/linux/.config
fret ruud # ls -la /boot/kernel-genkernel-x86_64-3.6.11-gentoo
-rw-r--r-- 1 root root 2647392 Feb 13 17:40 /boot/kernel-genkernel-x86_64-3.6.11-gentoo

I further tried to set in menuconfig
Code:
[*] HPET - High Precision Event Timer

but it did not make any difference.

What could be wrong here? (I have the feeling the symbol CONFIG_RTC itself is missing, but how is that possible.)


Last edited by devlaam on Thu Feb 14, 2013 10:48 pm; edited 2 times in total
Back to top
View user's profile Send private message
eyoung100
Veteran
Veteran


Joined: 23 Jan 2004
Posts: 1411

PostPosted: Wed Feb 13, 2013 10:45 pm    Post subject: Reply with quote

Try:
Code:
genkernel  --menuconfig --clean all

In menuconfig hit /
Search for CONFIG_RTC


and then
Code:

Device Drivers -->
[*]Character Devices -->
[*]Enhanced Real-Time Clock Support


--install is not a genkernel option btw...
_________________
The Birth and Growth of Science is the Death and Atrophy of Art -- Unknown
Registerd Linux User #363735
Adopt a Post | Strip Comments| Emerge Wrapper
Back to top
View user's profile Send private message
devlaam
n00b
n00b


Joined: 22 Oct 2009
Posts: 49
Location: Alkmaar, Netherlands

PostPosted: Wed Feb 13, 2013 11:10 pm    Post subject: Reply with quote

Interesting. the option you describe is only present if i disable
Code:
Device Drivers  --->
   [*] Real Time Clock  --->

This then also brings the CONFIG_RTC back.

I am compiling the kernel now, tomorrow w'll see if it works.

Quote:
--install is not a genkernel option btw...

Well i did not make it up myself, look at
http://www.gentoo.org/doc/en/handbook/handbook-amd64.xml?full=1
and search for '--install'. It does what it promises (install in boot) :-)

Thanks so far!
Back to top
View user's profile Send private message
devlaam
n00b
n00b


Joined: 22 Oct 2009
Posts: 49
Location: Alkmaar, Netherlands

PostPosted: Thu Feb 14, 2013 3:42 pm    Post subject: Reply with quote

Okay, this is driving me nuts! Changed as suggested, build the kernel and ... same problem!
So:
Code:
fret ruud # grep CONFIG_RTC /etc/kernels/kernel-config-x86_64-3.6.11-gentoo
CONFIG_RTC=y
# CONFIG_RTC_CLASS is not set

But:
Code:
fret ruud # zgrep CONFIG_RTC /proc/config.gz
# CONFIG_RTC is not set
# CONFIG_RTC_CLASS is not set

WTF: Why is This setting not Followed? I checked that the new kernel was indeed installed in boot, and i rebooted!
How can this be? I used this:
Code:
genkernel  --menuconfig --install --clean all

and subsequently changed the option. Must be some dependency:
Code:
Symbol: RTC [=y]
  │ Type  : tristate
  │ Prompt: Enhanced Real Time Clock Support (legacy PC RTC driver)
  │   Defined at drivers/char/Kconfig:285
  │   Depends on: !RTC_LIB [=n] && !PPC && !PARISC && !IA64 && !M68K && !SPARC && !FRV && !ARM && !SUPERH && !S390 && !AVR32 && !BLACKFIN && !UML
  │   Location:
  │     -> Device Drivers
  │       -> Character devices

but which one? I do not see an obvious candidate. Or is it IA64 (i am on amd64)?

I am getting the feeling building a Gentoo kernel clean out of the box is getting a more and more difficult task every year. The last nine or so times i tried (in approximately two years) only one of them was completely trouble free. And in one case i never got it running at all. And these were clean installs! (I stopped doing major upgrades some time ago since it was giving me to many problems.)
Back to top
View user's profile Send private message
Ant P.
Advocate
Advocate


Joined: 18 Apr 2009
Posts: 2342
Location: UK

PostPosted: Thu Feb 14, 2013 4:28 pm    Post subject: Reply with quote

devlaam wrote:
WTF: Why is This setting not Followed? I checked that the new kernel was indeed installed in boot, and i rebooted!

Did you observe the kernel being compiled after changing its config? Does the timestamp in `uname -a` match the time you ran genkernel?
Back to top
View user's profile Send private message
BillWho
Veteran
Veteran


Joined: 03 Mar 2012
Posts: 1600
Location: US

PostPosted: Thu Feb 14, 2013 6:58 pm    Post subject: Reply with quote

devlaam,

paste back ls -l /boot/ and uname -a
_________________
Good luck :wink:

Since installing gentoo, my life has become one long emerge :)
Back to top
View user's profile Send private message
devlaam
n00b
n00b


Joined: 22 Oct 2009
Posts: 49
Location: Alkmaar, Netherlands

PostPosted: Thu Feb 14, 2013 10:47 pm    Post subject: Reply with quote

Guys,

It seems i am getting to old for this kind of stuff .... :-(

Installing in /boot is fine, but if i forget to mount /boot that does not help a lot. I checked only if the build kernel was of later date than the config file, which was so. Of course i should also always check if that kernel is also running after boot. Sigh ....

The solution you presented works. Apologies for wasting your time!
Back to top
View user's profile Send private message
eyoung100
Veteran
Veteran


Joined: 23 Jan 2004
Posts: 1411

PostPosted: Wed Feb 27, 2013 7:42 pm    Post subject: Reply with quote

Just a side note here. If you plan to continue to use genkernel edit /etc/genkernel.conf, set MOUNT_BOOT=y
_________________
The Birth and Growth of Science is the Death and Atrophy of Art -- Unknown
Registerd Linux User #363735
Adopt a Post | Strip Comments| Emerge Wrapper
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum