Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Strano problema emerge
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
stifler83
Apprentice
Apprentice


Joined: 22 Oct 2010
Posts: 161
Location: Rome

PostPosted: Tue Feb 12, 2013 5:55 pm    Post subject: Strano problema emerge Reply with quote

Ciao ragazzi quando vado ad eseguire
Code:

emerge -uNDav @world

ottengo questo risultato:
Code:


These are the packages that would be merged, in order:

Calculating dependencies | * ERROR: app-emulation/qemu-1.2.2-r3 failed (depend phase):
 *   Invalid syntax of PYTHON_DEPEND: Unrecognized minimal version '2.4'
 *
 * Call stack:
 *              ebuild.sh, line 551:  Called source '/usr/portage/app-emulation/qemu/qemu-1.2.2-r3.ebuild'
 *   qemu-1.2.2-r3.ebuild, line  11:  Called inherit 'eutils' 'flag-o-matic' 'linux-info' 'toolchain-funcs' 'multilib' 'python' 'user' 'udev'
 *              ebuild.sh, line 286:  Called __qa_source '/usr/portage/eclass/python.eclass'
 *              ebuild.sh, line  80:  Called source '/usr/portage/eclass/python.eclass'
 *          python.eclass, line 579:  Called _python_parse_dependencies_in_old_EAPIs 'PYTHON_DEPEND' 'DEPEND RDEPEND'
 *          python.eclass, line 372:  Called _python_parse_versions_range '2:2.4' 'PYTHON_DEPEND' '_PYTHON_ATOMS'
 *          python.eclass, line 293:  Called die
 * The specific snippet of code:
 *                              die "Invalid syntax of ${input_variable}: Unrecognized minimal version '${minimal_version}'"
 *
 * If you need support, post the output of `emerge --info '=app-emulation/qemu-1.2.2-r3'`,
 * the complete build log and the output of `emerge -pqv '=app-emulation/qemu-1.2.2-r3'`.
 * Working directory: '/home/mauro'
 * S: '/var/tmp/portage/app-emulation/qemu-1.2.2-r3/work/qemu-1.2.2'
... done!
[ebuild     U  ] dev-libs/openssl-1.0.1d-r1 [1.0.1c] USE="(sse2) zlib -bindist -gmp -kerberos -rfc3779 -static-libs {-test} -vanilla" 4,356 kB


Avete qualche idea? ^^
Back to top
View user's profile Send private message
pierino_89
Guru
Guru


Joined: 03 Oct 2009
Posts: 444

PostPosted: Sun Feb 17, 2013 11:03 pm    Post subject: Reply with quote

Stai usando qualche overlay?
_________________
Linux registered user 461710
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1497
Location: Cosenza, Italy

PostPosted: Mon Feb 18, 2013 9:07 am    Post subject: Reply with quote

Probabilmente ha ragione lui:

http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/app-emulation/qemu/qemu-1.2.2-r3.ebuild?view=diff&r1=text&tr1=1.2&r2=text&tr2=1.1&diff_format=h
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum