Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Artifacts with xf86-video-intel after kernel update
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Tumanov
n00b
n00b


Joined: 24 Jul 2012
Posts: 14

PostPosted: Wed Feb 27, 2013 1:11 pm    Post subject: Artifacts with xf86-video-intel after kernel update Reply with quote

Hi, friends!
Recently I had some problems with xf86-video-intel-2.20.13, (artifacts in gtk applications in my KDE) and they were solved after updating to xf86-video-intel-2.20.14 and latter. These times I used kernel 3.5.7
Now, after updating to 3.7.9 kernel I see some artifact in scroll bar at thunderbird (not always - sometimes): with artifacts, and how it should be, in Libreoffice when saving documents (also not regularly (here).
Downgrading to xf86-video-intel-2.20.13 seams to solve these problems, but I get the same gtk issues like I had before this update

Could you help to solve this problem.
Thank you in advance!
Back to top
View user's profile Send private message
Tumanov
n00b
n00b


Joined: 24 Jul 2012
Posts: 14

PostPosted: Wed Feb 27, 2013 5:53 pm    Post subject: Reply with quote

PS changing flags from sna to -sna uxa glamor changed the situation. Now everything looks good.
Back to top
View user's profile Send private message
Tumanov
n00b
n00b


Joined: 24 Jul 2012
Posts: 14

PostPosted: Sat Mar 09, 2013 7:46 pm    Post subject: Reply with quote

But rendering now is very long... I came back to sna with these artifacts. Probably I should buy a new Notebook?! With intel HD Graphics...
Back to top
View user's profile Send private message
sitquietly
n00b
n00b


Joined: 23 Oct 2010
Posts: 35

PostPosted: Sat Mar 09, 2013 8:24 pm    Post subject: Re: Artifacts with xf86-video-intel after kernel update Reply with quote

Tumanov wrote:
Hi, friends!
Recently I had some problems with xf86-video-intel-2.20.13.....after updating to 3.7.9 kernel I see some artifact in scroll bar.....Could you help to solve this problem.


I haven't seen problems with xf86-video-intel-2.20.13, but have had problems with all higher versions on my ~amd64 installations:

I have repeatedly encountered artifacts in vlc (a large bar at the left of the display when using video crop) with unstable versions of xf86-video-intel 2.20.x where x>13 using the latest stable kernels from gentoo-sources. The same problems occur on my funtoo systems. I use sna acceleration*. All problems have been eliminated after switching to stable versions of video drivers on my otherwise unstable gentoo system. I have in my package.accept_keywords:
Code:

sys-kernel/gentoo-sources   -~amd64
x11-base/xorg-server   -~amd64
x11-drivers/xf86-video-intel   -~amd64
media-libs/mesa   -~amd64
www-client/firefox   -~amd64
# All of kde-base has been set for "reject unstable versions".  The command used:
# ls | sed "s|^|kde-base/|" | sed "s|/$| -~amd64|" >>/etc/portage/package.accept_keywords
kde-base/akonadi -~amd64
.....

This ~amd64 sandy bridge i5 installation has been working well with these few packages held at stable versions so I'll just dump this info into the thread for reference.

* p.s. I also enable the tearfree option in xorg.conf:
Code:


        Option      "AccelMethod"  "sna"
        Option      "TearFree"     "True"
        Identifier  "IntelVideo"
        Driver      "intel"


I get low cpu usage, tear-free, glass-smooth video playback with vlc and mplayer, and nice flawless graphics in KDE (composited) and xmonad (non-composited). Very happy. :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum