Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] kipi-plugins-3.0.0 fail to install
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Martux
Veteran
Veteran


Joined: 04 Feb 2005
Posts: 1731
Location: Mannheim, Germany

PostPosted: Mon Feb 11, 2013 10:39 am    Post subject: [SOLVED] kipi-plugins-3.0.0 fail to install Reply with quote

Hi guys. I had an issue with the KIPI-Plugins while updating to KDE-4.10.0. A day later kipi-plugins-3.0.0 came out, but they fail to install. Here is the output, it's not very meaninful to me:
Code:

/usr/bin/x86_64-pc-linux-gnu-ranlib ../../../lib/libHUpnpAv.a
make[2]: Leaving directory `/var/tmp/portage/media-plugins/kipi-plugins-3.0.0/work/kipi-plugins-3.0.0_build'
/usr/bin/cmake -E cmake_progress_report /var/tmp/portage/media-plugins/kipi-plugins-3.0.0/work/kipi-plugins-3.0.0_build/CMakeFiles  15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42
[ 94%] Built target HUpnpAv
make[1]: Leaving directory `/var/tmp/portage/media-plugins/kipi-plugins-3.0.0/work/kipi-plugins-3.0.0_build'
make: *** [all] Fehler 2
 * ERROR: media-plugins/kipi-plugins-3.0.0 failed (compile phase):
 *   emake failed
 *

Is this an error with GCC version x86_64-pc-linux-gnu-4.7.2 maybe?
_________________
"Coincidence is God's way of remaining anonymous."
Albert Einstein
"The road to success is always under construction"


Last edited by Martux on Mon Feb 11, 2013 11:53 pm; edited 1 time in total
Back to top
View user's profile Send private message
ulenrich
Veteran
Veteran


Joined: 10 Oct 2010
Posts: 1135

PostPosted: Mon Feb 11, 2013 11:20 am    Post subject: Reply with quote

@Martux, no I compiled successfully using gcc-4.7.2:
Code:
emerge -1 -p kipi-plugins

These are the packages that would be merged, in order:

Calculating dependencies  .... done!
[ebuild   R    ] media-plugins/kipi-plugins-3.0.0:4  USE="calendar crypt expoblending imagemagick mjpeg opengl panorama redeyes vkontakte (-aqua) -cdr -debug -gpssync -handbook -ipod -mediawiki -scanner" LINGUAS="de -ar -az -be -bg -bn -br -bs -ca -cs -csb -cy -da -el -en_GB -eo -es -et -eu -fa -fi -fo -fr -fy -ga -gl -ha -he -hi -hr -hsb -hu -id -is -it -ja -ka -kk -km -ko -ku -lb -lo -lt -lv -mi -mk -mn -ms -mt -nb -nds -ne -nl -nn -nso -oc -pa -pl -pt -pt_BR -ro -ru -rw -se -sk -sl -sq -sr -ss -sv -ta -te -tg -th -tr -tt -uk -uz -ven -vi -wa -xh -zh_CN -zh_HK -zh_TW -zu" 0 kB
Perhaps a USE flag of yours not working?
_________________
fun2gen2
Back to top
View user's profile Send private message
Martux
Veteran
Veteran


Joined: 04 Feb 2005
Posts: 1731
Location: Mannheim, Germany

PostPosted: Mon Feb 11, 2013 11:28 am    Post subject: Reply with quote

Thanks for the info. I have only standard USE flags enabled, way less than you:
Code:

[ebuild  N     ] media-plugins/kipi-plugins-3.0.0:4  USE="cdr imagemagick opengl (-aqua) -calendar -crypt -debug -expoblending -gpssync -handbook -ipod -mediawiki -mjpeg -panorama -redeyes -scanner -vkontakte"

What the heck is "HUpnpAv"?
_________________
"Coincidence is God's way of remaining anonymous."
Albert Einstein
"The road to success is always under construction"
Back to top
View user's profile Send private message
Martux
Veteran
Veteran


Joined: 04 Feb 2005
Posts: 1731
Location: Mannheim, Germany

PostPosted: Mon Feb 11, 2013 11:44 am    Post subject: Reply with quote

Just tried to rebuild net-libs/libupnp-1.6.18 prior to emerging kipi-plugins, as it's the only package related to UPNP, but to no avail...
_________________
"Coincidence is God's way of remaining anonymous."
Albert Einstein
"The road to success is always under construction"
Back to top
View user's profile Send private message
Linubie
Tux's lil' helper
Tux's lil' helper


Joined: 11 Jun 2004
Posts: 116

PostPosted: Mon Feb 11, 2013 11:46 am    Post subject: Reply with quote

Same Problem here with gcc version 4.6.3:

[ebuild U ~] media-plugins/kipi-plugins-3.0.0:4 [3.0.0_rc:4] USE="cdr crypt handbook imagemagick mjpeg opengl scanner (-aqua) -calendar -debug -expoblending -gpssync -ipod -mediawiki -panorama -redeyes -vkontakte" LINGUAS="de -ar -az -be -bg -bn -br -bs -ca -cs -csb -cy -da -el -en_GB -eo -es -et -eu -fa -fi -fo -fr -fy -ga -gl -ha -he -hi -hr -hsb -hu -id -is -it -ja -ka -kk -km -ko -ku -lb -lo -lt -lv -mi -mk -mn -ms -mt -nb -nds -ne -nl -nn -nso -oc -pa -pl -pt -pt_BR -ro -ru -rw -se -sk -sl -sq -sr -ss -sv -ta -te -tg -th -tr -tt -uk -uz -ven -vi -wa -xh -zh_CN -zh_HK -zh_TW -zu" 0 kB

[ 97%] /usr/bin/cmake -E cmake_progress_report /var/tmp/portage/media-plugins/kipi-plugins-3.0.0/work/kipi-plugins-3.0.0_build/CMakeFiles
^[[32mBuilding CXX object dlnaexport/extra/hupnp_av/CMakeFiles/HUpnpAv.dir/src/renderingcontrol/moc_hrenderingcontrol_service_p.o
^[[0mcd /var/tmp/portage/media-plugins/kipi-plugins-3.0.0/work/kipi-plugins-3.0.0_build/dlnaexport/extra/hupnp_av && /usr/bin/x86_64-pc-linux-gnu-g++ -D_BSD_SOURCE -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -DQT_NO_STL -DQT_NO_CA$
[ 97%] ^[[32mBuilding CXX object dlnaexport/extra/hupnp_av/CMakeFiles/HUpnpAv.dir/src/transport/moc_habstract_avtransport_service.o
^[[0mcd /var/tmp/portage/media-plugins/kipi-plugins-3.0.0/work/kipi-plugins-3.0.0_build/dlnaexport/extra/hupnp_av && /usr/bin/x86_64-pc-linux-gnu-g++ -D_BSD_SOURCE -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -DQT_NO_STL -DQT_NO_CA$
/usr/bin/cmake -E cmake_progress_report /var/tmp/portage/media-plugins/kipi-plugins-3.0.0/work/kipi-plugins-3.0.0_build/CMakeFiles
[ 97%] ^[[32mBuilding CXX object dlnaexport/extra/hupnp_av/CMakeFiles/HUpnpAv.dir/src/transport/moc_havtransport_adapter.o
^[[0mcd /var/tmp/portage/media-plugins/kipi-plugins-3.0.0/work/kipi-plugins-3.0.0_build/dlnaexport/extra/hupnp_av && /usr/bin/x86_64-pc-linux-gnu-g++ -D_BSD_SOURCE -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -DQT_NO_STL -DQT_NO_CA$
^[[31m^[[1mLinking CXX static library ../../../lib/libHUpnpAv.a
^[[0mcd /var/tmp/portage/media-plugins/kipi-plugins-3.0.0/work/kipi-plugins-3.0.0_build/dlnaexport/extra/hupnp_av && /usr/bin/cmake -P CMakeFiles/HUpnpAv.dir/cmake_clean_target.cmake
cd /var/tmp/portage/media-plugins/kipi-plugins-3.0.0/work/kipi-plugins-3.0.0_build/dlnaexport/extra/hupnp_av && /usr/bin/cmake -E cmake_link_script CMakeFiles/HUpnpAv.dir/link.txt --verbose=1
/usr/bin/x86_64-pc-linux-gnu-ar cr ../../../lib/libHUpnpAv.a CMakeFiles/HUpnpAv.dir/src/hav_devicemodel_creator.o CMakeFiles/HUpnpAv.dir/src/hupnpavinfo.o CMakeFiles/HUpnpAv.dir/src/hav_devicemodel_infoprovider.o CMakeFi$
/usr/bin/x86_64-pc-linux-gnu-ranlib ../../../lib/libHUpnpAv.a
make[2]: Leaving directory `/var/tmp/portage/media-plugins/kipi-plugins-3.0.0/work/kipi-plugins-3.0.0_build'
/usr/bin/cmake -E cmake_progress_report /var/tmp/portage/media-plugins/kipi-plugins-3.0.0/work/kipi-plugins-3.0.0_build/CMakeFiles 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41
[ 97%] Built target HUpnpAv
make[1]: Leaving directory `/var/tmp/portage/media-plugins/kipi-plugins-3.0.0/work/kipi-plugins-3.0.0_build'
make: *** [all] Fehler 2
^[[31;01m*^[[0m ERROR: media-plugins/kipi-plugins-3.0.0 failed (compile phase):
^[[31;01m*^[[0m emake failed
^[[31;01m*^[[0m
^[[31;01m*^[[0m If you need support, post the output of `emerge --info '=media-plugins/kipi-plugins-3.0.0'`,
^[[31;01m*^[[0m the complete build log and the output of `emerge -pqv '=media-plugins/kipi-plugins-3.0.0'`.
^[[31;01m*^[[0m The complete build log is located at '/var/tmp/portage/media-plugins/kipi-plugins-3.0.0/temp/build.log'.
^[[31;01m*^[[0m The ebuild environment file is located at '/var/tmp/portage/media-plugins/kipi-plugins-3.0.0/temp/environment'.
^[[31;01m*^[[0m Working directory: '/var/tmp/portage/media-plugins/kipi-plugins-3.0.0/work/kipi-plugins-3.0.0_build'
^[[31;01m*^[[0m S: '/var/tmp/portage/media-plugins/kipi-plugins-3.0.0/work/digikam-3.0.0/extra/kipi-plugins'
_________________
Mircosoft software is like having sex with a stranger, you always have to be careful not to get infected with something...
Back to top
View user's profile Send private message
Martux
Veteran
Veteran


Joined: 04 Feb 2005
Posts: 1731
Location: Mannheim, Germany

PostPosted: Mon Feb 11, 2013 11:47 am    Post subject: Reply with quote

I see. Will open a bug report. Will post ID here. Please subscribe there.

EDIT: Somebody already opened https://bugs.gentoo.org/show_bug.cgi?id=456672 to report the issue.
_________________
"Coincidence is God's way of remaining anonymous."
Albert Einstein
"The road to success is always under construction"
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5427

PostPosted: Mon Feb 11, 2013 12:01 pm    Post subject: Reply with quote

@Martux and Linubie: neither of you has provided a snippet of the build log containing the actual error.
Back to top
View user's profile Send private message
Helmering
n00b
n00b


Joined: 13 Dec 2011
Posts: 39
Location: Italy

PostPosted: Mon Feb 11, 2013 1:18 pm    Post subject: Reply with quote

Had the same problem here, simply resolved by a revdep-rebuild (issue with exiv)

Cheers Ralf
Back to top
View user's profile Send private message
Martux
Veteran
Veteran


Joined: 04 Feb 2005
Posts: 1731
Location: Mannheim, Germany

PostPosted: Mon Feb 11, 2013 3:25 pm    Post subject: Reply with quote

I do revdep-rebuild very regularly, didn't find or fix anything here. Remerging exiv2 libkexiv2 libupnp also didn't fix it.
@VoidMage: I posted my complete build.log in the buzilla thread. Thanks for the hint.
_________________
"Coincidence is God's way of remaining anonymous."
Albert Einstein
"The road to success is always under construction"
Back to top
View user's profile Send private message
Martux
Veteran
Veteran


Joined: 04 Feb 2005
Posts: 1731
Location: Mannheim, Germany

PostPosted: Mon Feb 11, 2013 11:51 pm    Post subject: Reply with quote

Re-emerging media-libs/glu solved the problem!
_________________
"Coincidence is God's way of remaining anonymous."
Albert Einstein
"The road to success is always under construction"
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum