Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Portage has Blocked Packages and Circular Dependencies.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Phredus
n00b
n00b


Joined: 07 Feb 2013
Posts: 37

PostPosted: Sun Feb 10, 2013 9:44 am    Post subject: Portage has Blocked Packages and Circular Dependencies. Reply with quote

Guys I am not a complete nubie but this problem is beating me up!!!
I need help please system beyond my repair expertise.
Have Blocked Packages and Circular Dependencies that I cant resolve, I've been at it for two weeks help please.
I have somewhat understand the problem but I don't know exactly how to implement the solution.

1 Which packages or/and dependencies do I Mask?
2 How do I mask the packages or/and dependencies to allow other to install?

Issue is with both Blocked Packages and Circular Dependencies.

Thank you for your help

[code:1:8259e2c547]root@gn2box>~ emerge --update --deep --autounmask-write --with-bdeps=y --newuse world
!!! Found 2 make.conf files, using both '/etc/make.conf' and '/etc/portage/make.conf'
Calculating dependencies... done!
[ebuild U ] sys-kernel/linux-headers-3.6 [3.1]
[ebuild U ] sys-libs/glibc-2.15-r3 [2.13-r4]
[ebuild U ] app-arch/xz-utils-5.0.4-r1 [5.0.3]
[ebuild U ] dev-libs/expat-2.1.0-r2 [2.0.1-r5] USE="unicode%*"
[ebuild N ] dev-python/python-exec-0.2 PYTHON_TARGETS="(jython2_5) (python2_5) (python2_6) (python2_7) (python3_1) (python3_2) (-pypy1_9) (-pypy2_0) (-python3_3)"
[ebuild U ] dev-libs/icu-49.1.2 [4.8.1-r2]
[ebuild U ] sys-devel/gnuconfig-20121010 [20110202]
[ebuild U ] app-misc/mime-types-9 [8]
[ebuild U ] sys-libs/timezone-data-2012f [2011n]
[ebuild U ] app-portage/portage-utils-0.10 [0.8]
[ebuild U ] app-text/poppler-data-0.4.5-r1 [0.4.4]
[ebuild U ] sys-devel/gcc-config-1.7.3 [1.4.1-r1]
[ebuild U ] sys-devel/binutils-config-3-r3 [2-r1]
[ebuild U ] dev-libs/libffi-3.0.11 [3.0.10]
[ebuild U ] dev-libs/libusb-1.0.9 [1.0.9_rc3]
[ebuild N ] dev-libs/libdaemon-0.14-r1 USE="-doc -examples -static-libs"
[ebuild U ] sys-devel/autoconf-wrapper-12 [10-r1]
[ebuild U ] sys-devel/automake-wrapper-7 [5]
[ebuild U ] dev-libs/libatomic_ops-7.2d [1.2-r1]
[ebuild R ] media-libs/libdiscid-0.2.2 USE="-static-libs%"
[ebuild N ] virtual/python-argparse-0 PYTHON_TARGETS="python2_7 python3_2 -jython2_5 (-pypy1_9) -python2_5 -python2_6 -python3_1 (-python3_3)"
[ebuild U ] net-misc/dhcpcd-5.6.4 [5.2.12]
[ebuild U ] media-sound/alsa-headers-1.0.25 [1.0.24]
[ebuild N ] media-libs/webrtc-audio-processing-0.1 USE="-static-libs"
[ebuild U ] net-libs/libasyncns-0.8-r2 [0.7]
[ebuild N ] dev-libs/json-c-0.9-r1 USE="-static-libs"
[ebuild U ] dev-util/boost-build-1.49.0 [1.46.1]
[ebuild N ] sys-auth/nss-myhostname-0.3
[ebuild N ] net-wireless/wireless-regdb-20110428-r1
[ebuild N ] sys-libs/mtdev-1.1.3 USE="-static-libs"
[ebuild N ] dev-util/cppunit-1.13.1 USE="-doc -examples -static-libs"
[ebuild N ] app-text/libexttextcat-3.4.0 USE="-static-libs"
[ebuild N ] dev-libs/libyaml-0.1.4 USE="-doc -examples -static-libs {-test}"
[ebuild U ] virtual/libffi-3.0.11 [0]
[ebuild U ] app-misc/pax-utils-0.4 [0.2.3]
[ebuild U ] net-misc/iputils-20121221 [20101006-r2] USE="-caps% -gnutls%"
[ebuild U ] app-arch/unzip-6.0-r3 [6.0-r1] USE="-natspec%"
[ebuild U ~] gnome-base/gnome-common-3.6.0 [3.1.0]
[ebuild U ] sys-devel/m4-1.4.16 [1.4.15]
[ebuild U ] app-arch/rpm2targz-9.0.0.5g [9.0.0.4g]
[ebuild U ] net-misc/mobile-broadband-provider-info-20120614 [20110511]
[ebuild U ~] x11-libs/gnome-pty-helper-0.34.2 [0.28.1] USE="hardened%*"
[ebuild U ~] media-libs/libquvi-scripts-0.4.11 [0.4.2]
[ebuild U ] app-arch/zip-3.0-r1 [3.0] USE="-natspec%"
[ebuild U ] dev-libs/mpfr-3.1.1 [3.0.1_p4] USE="-static-libs%"
[ebuild U ] dev-libs/libassuan-2.0.3 [2.0.1]
[ebuild U ] virtual/acl-0-r1 [0] USE="-static-libs%"
[ebuild U ] net-misc/rsync-3.0.9-r2 [3.0.8]
[ebuild U ] sys-libs/ncurses-5.9-r2 [5.9] USE="-tinfo%"
[ebuild N ] sys-apps/gptfdisk-0.8.4
[ebuild U ] dev-lang/lua-5.1.4-r8 [5.1.4-r4]
[ebuild U ] sys-apps/ed-1.6 [1.4]
[ebuild U ~] media-libs/libvpx-1.1.0 [0.9.6] USE="-sse4_1% -static-libs%"
[ebuild N ] media-libs/x264-0.0.20111220 USE="interlaced threads -10bit -custom-cflags -debug -pic -static-libs"
[ebuild N ] media-libs/xvid-1.3.2 USE="threads -examples -pic"
[ebuild U ~] app-crypt/p11-kit-0.14 [0.10]
[ebuild U ] app-text/libwpd-0.9.6 [0.9.4]
[ebuild U ] dev-libs/libburn-1.2.4 [1.0.0] USE="-cdio% -static-libs%"
[ebuild N ~] net-misc/npapi-sdk-0.27.2
[ebuild U ] sys-apps/baselayout-2.1-r1 [2.0.3]
[ebuild U ] x11-base/xorg-drivers-1.13 [1.11] VIDEO_CARDS="-modesetting% (-omap)"
[ebuild U ] sys-apps/debianutils-4.3.4 [3.4.4]
[ebuild N ~] dev-libs/gobject-introspection-common-1.34.2
[ebuild N ~] dev-libs/vala-common-0.18.1
[uninstall ] dev-lang/vala-0.12.1
[blocks b ] <dev-lang/vala-0.12.1-r1:0.12 ("<dev-lang/vala-0.12.1-r1:0.12" is blocking dev-libs/vala-common-0.18.1)
[ebuild U ] sys-apps/net-tools-1.60_p20120127084908 [1.60_p20110409135728] USE="-old-output%"
[ebuild U ] dev-libs/libtasn1-2.13 [2.9-r1]
[ebuild U ] sys-devel/autoconf-2.69 [2.68]
[ebuild U ] dev-perl/XML-Parser-2.410.0 [2.36-r1]
[ebuild U ] dev-lang/nasm-2.10.05 [2.09.08]
[ebuild U ] dev-perl/SGMLSpm-1.03-r6 [1.03-r5]
[ebuild U ] dev-libs/libical-0.48 [0.43] USE="-examples%"
[ebuild U ] net-misc/whois-5.0.15 [5.0.11]
[ebuild U ] app-crypt/mhash-0.9.9.9-r1 [0.9.9-r1] USE="-static-libs%"
[ebuild N ] perl-core/version-0.940.0
[ebuild N ] perl-core/Test-Harness-3.230.0
[ebuild N ] perl-core/Perl-OSType-1.2.0 USE="{-test}"
[ebuild N ] perl-core/JSON-PP-2.272.0
[ebuild N ] perl-core/CPAN-Meta-YAML-0.4.0
[ebuild N ] perl-core/ExtUtils-Manifest-1.580.0
[ebuild N ] perl-core/ExtUtils-Install-1.54
[ebuild N ] perl-core/ExtUtils-Command-1.170.0
[ebuild N ] perl-core/Test-Simple-0.980.0
[ebuild N ] perl-core/IO-1.25
[ebuild N ] virtual/perl-File-Temp-0.220.0-r2
[ebuild N ] virtual/perl-Digest-SHA-5.47
[ebuild N ] virtual/perl-Getopt-Long-2.380.0-r2
[ebuild N ] virtual/perl-version-0.940.0
[ebuild U ] virtual/perl-Scalar-List-Utils-1.230.0-r2 [1.230.0-r1]
[ebuild N ] virtual/perl-JSON-PP-2.272.0-r1
[ebuild N ] virtual/perl-CPAN-Meta-YAML-0.4.0
[ebuild N ~] dev-util/fix-la-relink-command-0.1.1
[ebuild U ] virtual/perl-Test-Harness-3.230.0-r3 [3.17]
[ebuild N ] virtual/perl-Perl-OSType-1.2.0-r1
[ebuild N ] virtual/perl-ExtUtils-Manifest-1.580.0-r1
[ebuild N ] virtual/perl-ExtUtils-Install-1.54
[ebuild N ] virtual/perl-ExtUtils-Command-1.170.0-r3
[ebuild N ] virtual/perl-Test-Simple-0.980.0-r2
[ebuild N ] virtual/perl-IO-1.25
[ebuild N ] perl-core/Module-Metadata-1.0.6
[ebuild N ] perl-core/Parse-CPAN-Meta-1.440.100
[ebuild N ] perl-core/Version-Requirements-0.101.20
[ebuild U ] virtual/perl-Digest-MD5-2.510.0-r2 [2.510.0-r1]
[ebuild N ] virtual/perl-Parse-CPAN-Meta-1.440.100-r2
[ebuild U ] dev-perl/Digest-HMAC-1.30.0 [1.01-r1]
[ebuild N ] virtual/perl-Module-Metadata-1.0.6
[ebuild N ] virtual/perl-Version-Requirements-0.101.20-r2
[ebuild U ] dev-perl/Authen-SASL-2.160.0 [2.150.0]
[ebuild N ] perl-core/ExtUtils-MakeMaker-6.620.0
[ebuild N ] virtual/perl-ExtUtils-MakeMaker-6.620.0
[ebuild N ] perl-core/CPAN-Meta-2.112.621
[ebuild N ] virtual/perl-CPAN-Meta-2.112.621
[ebuild U ] perl-core/Module-Build-0.380.0 [0.36.07]
[ebuild U ] virtual/perl-Module-Build-0.380.0-r2 [0.36.07]
[ebuild N ] dev-perl/XML-SAX-Base-1.80.0
[ebuild N ] sys-apps/hwids-20130114 USE="udev"
[uninstall ] sys-apps/usbutils-004
[blocks b ] <sys-apps/usbutils-005-r1 ("<sys-apps/usbutils-005-r1" is blocking sys-apps/hwids-20130114)
[ebuild U ] net-mail/mailbase-1.1 [1]
[ebuild N ] net-fs/cifs-utils-5.6-r1 USE="caps -ads -caps-ng -creds -upcall"
[ebuild U ] virtual/jdk-1.6.0-r1 [1.6.0]
[ebuild U ] x11-misc/xdg-utils-1.1.0_rc1_p20120319 [1.1.0_rc1_p20111003]
[ebuild U ] sys-apps/man-pages-3.45 [3.32]
[ebuild N ] virtual/shadow-0
[ebuild U ] dev-util/intltool-0.50.2 [0.50.0]
[ebuild N ] media-libs/glu-9.0.0 USE="(-multilib) -static-libs"
[ebuild U ] virtual/glu-9.0 [7.0]
[ebuild U ] app-text/docbook-xsl-stylesheets-1.77.1-r1 [1.76.1] USE="-ruby%"
[ebuild U ] app-text/build-docbook-catalog-1.19.1 [1.4]
[ebuild NS ] app-text/docbook-xml-dtd-4.2-r2 [4.1.2-r6, 4.3-r1, 4.4-r2, 4.5-r1]
[ebuild N ] virtual/freedesktop-icon-theme-0
[ebuild N ] virtual/awk-0
[ebuild N ] app-admin/eselect-ruby-20100603
[ebuild U ] app-text/mythes-1.2.3 [1.2.1]
[ebuild N ] app-admin/eselect-qtgraphicssystem-1.1.1
[ebuild U ~] dev-libs/glib-2.34.3 [2.30.2-r1] USE="(-fam*) -static-libs*"
[ebuild U ] dev-util/desktop-file-utils-0.21 [0.18]
[ebuild U ] media-libs/gexiv2-0.4.1 [0.3.1]
[ebuild U ] sys-apps/sed-4.2.1-r1 [4.2.1]
[ebuild U ~] x11-themes/gnome-icon-theme-symbolic-3.6.2 [3.2.2]
[ebuild U ~] dev-cpp/glibmm-2.34.1 [2.30.1]
[ebuild U ~] x11-themes/gnome-icon-theme-extras-3.6.2 [3.0.0]
[ebuild U ~] gnome-extra/gnome-user-docs-3.6.2 [3.2.1]
[ebuild U ] app-admin/logrotate-3.8.3 [3.8.1]
[ebuild U ] app-editors/vim-core-7.3.409 [7.3.266]
[ebuild U ] sys-devel/gettext-0.18.1.1-r3 [0.18.1.1-r1] USE="java%* -cvs% -git* -static-libs%"
[ebuild U ] sys-devel/make-3.82-r4 [3.82-r1]
[ebuild U ] sys-apps/findutils-4.4.2-r1 [4.4.2]
[ebuild U ] sys-apps/gawk-4.0.1 [3.1.8] USE="readline%*"
[ebuild U ] app-arch/gzip-1.5 [1.4]
[ebuild U ] sys-libs/e2fsprogs-libs-1.42 [1.41.14] USE="-static-libs%"
[ebuild U ] sys-process/psmisc-22.16 [22.14]
[ebuild U ] sys-apps/diffutils-3.2 [3.0]
[ebuild U ] app-arch/tar-1.26 [1.23-r2]
[ebuild U ] sys-devel/flex-2.5.37 [2.5.35_p10]
[ebuild U ] app-text/iso-codes-3.37 [3.30]
[ebuild U ] media-libs/libexif-0.6.21 [0.6.20]
[ebuild U ] sys-apps/mlocate-0.25 [0.24]
[ebuild U ] dev-perl/Locale-gettext-1.50.0 [1.05-r1]
[ebuild U ] app-text/opensp-1.5.2-r3 [1.5.2-r2]
[ebuild U ] dev-util/dialog-1.1.20120706 [1.1.20110707-r1]
[ebuild U ~] x11-themes/gnome-backgrounds-3.6.1 [3.2.0]
[ebuild U ] media-video/gnome-video-effects-0.4.0 [0.3.0]
[ebuild U ] dev-libs/libcdio-0.83 [0.82]
[ebuild NS ] dev-libs/libnl-3.2.14 [1.1-r2] USE="-doc -static-libs -utils"
[ebuild U ] sys-apps/help2man-1.40.11 [1.38.2]
[ebuild U ] dev-db/unixODBC-2.3.1 [2.3.0-r1]
[ebuild U ] sys-devel/automake-1.11.6 [1.11.1]
[ebuild U ] sys-libs/zlib-1.2.7 [1.2.5-r2] USE="minizip%* -static-libs%"
[ebuild U ] x11-proto/xproto-7.0.23-r1 [7.0.22]
[ebuild U ] x11-proto/xextproto-7.2.1 [7.2.0]
[ebuild U ] dev-db/sqlite-3.7.14.1 [3.7.7.1]
[ebuild U ] media-libs/alsa-lib-1.0.25-r1 [1.0.24.1]
[ebuild U ] x11-proto/inputproto-2.2 [2.0.2]
[ebuild U ] dev-libs/libgcrypt-1.5.0-r2 [1.4.6]
[ebuild U ] x11-proto/kbproto-1.0.6 [1.0.5]
[ebuild U ] dev-libs/nspr-4.9.4 [4.8.9]
[ebuild U ] x11-proto/randrproto-1.4.0 [1.3.2]
[ebuild U ] x11-libs/xtrans-1.2.7 [1.2.6]
[ebuild U ] x11-libs/libdrm-2.4.40 [2.4.27] USE="libkms*" VIDEO_CARDS="(-exynos) (-omap)"
[ebuild U ] x11-proto/fontsproto-2.1.2 [2.1.1]
[ebuild U ] app-text/libpaper-1.1.24-r1 [1.1.23]
[ebuild U ] x11-libs/pixman-0.28.0 [0.24.0] USE="-mmxext%"
[ebuild U ] x11-proto/recordproto-1.14.2 [1.14.1]
[ebuild U ] sys-libs/libcap-ng-0.6.6 [0.6.5] USE="-static-libs%"
[ebuild U ~] x11-themes/gnome-icon-theme-3.6.2 [3.2.1.2]
[ebuild U ] dev-lang/orc-0.4.16-r1 [0.4.14]
[ebuild U ] media-libs/libvorbis-1.3.3 [1.3.2]
[ebuild R ] app-text/hunspell-1.3.2-r3 LINGUAS="-is% -km% -pt_BR% -sq%"
[ebuild U ] media-fonts/font-util-1.3.0 [1.2.0]
[ebuild U ] x11-proto/scrnsaverproto-1.2.2 [1.2.1]
[ebuild U ] x11-proto/dri2proto-2.8 [2.6]
[ebuild U ] media-libs/libdvdcss-1.2.12 [1.2.11]
[ebuild U ] media-libs/libmad-0.15.1b-r7 [0.15.1b-r6] USE="-static-libs%"
[ebuild U ] dev-libs/libgamin-0.1.10-r3 [0.1.10-r2]
[ebuild N ] media-libs/opus-1.0.1 USE="-doc -static-libs"
[ebuild N ] media-libs/libsoundtouch-1.7.0 USE="-sse2 -static-libs"
[ebuild U ] media-sound/lame-3.99.5 [3.99.3]
[ebuild N ] dev-libs/nettle-2.5 USE="gmp"
[ebuild N ] media-libs/libsamplerate-0.1.7 USE="-sndfile"
[ebuild U ] media-libs/audiofile-0.3.4 [0.3.2]
[ebuild U ] media-libs/libraw-0.14.7 [0.14.5]
[ebuild U ] app-i18n/enca-1.13-r3 [1.13-r2]
[ebuild U ] dev-libs/boehm-gc-7.2d [7.1-r1] USE="-static-libs%"
[ebuild U ] dev-libs/iniparser-3.1 [3.0b-r1] USE="-doc% -examples% -static-libs%"
[ebuild U ] x11-proto/bigreqsproto-1.1.2 [1.1.1]
[ebuild U ] x11-proto/xf86dgaproto-2.1-r1 [2.1]
[ebuild U ] x11-proto/xf86rushproto-1.1.2-r1 [1.1.2]
[ebuild U ] x11-proto/xcmiscproto-1.2.2 [1.2.1]
[ebuild N ] dev-util/ragel-6.7-r1 USE="-vim-syntax"
[ebuild U ] net-libs/liblockfile-1.09 [1.08]
[ebuild U ] sys-boot/grub-0.97-r12 [0.97-r10]
[ebuild U ] media-libs/libpng-1.5.13-r1 [1.5.7]
[ebuild U ] x11-libs/libICE-1.0.8 [1.0.7]
[ebuild U ] dev-libs/nss-3.14.1 [3.13.1-r1]
[ebuild U ] sys-devel/binutils-2.22-r1 [2.21.1-r1] USE="cxx%*"
[ebuild U ] dev-libs/libpcre-8.30-r2 [8.12] USE="jit%* readline%* -pcre16%"
[ebuild U ] x11-libs/libXau-1.0.7 [1.0.6]
[ebuild U ] x11-libs/libXdmcp-1.1.1 [1.1.0]
[ebuild U ] x11-libs/libfontenc-1.1.1 [1.1.0]
[ebuild U ] sys-libs/cracklib-2.8.19 [2.8.16] USE="zlib%* -build% -static-libs%"
[ebuild U ] x11-libs/libpciaccess-0.13.1 [0.12.1]
[ebuild U ] sys-apps/file-5.11 [5.09]
[ebuild U ] net-libs/gnutls-2.12.20 [2.10.5] USE="nettle%* -pkcs11% -static-libs%"
[ebuild U ] sys-apps/pciutils-3.1.10 [3.1.7] USE="-static-libs%"
[blocks b ] <sys-apps/pciutils-3.1.9-r2 ("<sys-apps/pciutils-3.1.9-r2" is blocking sys-apps/hwids-20130114)
[ebuild U ] x11-misc/makedepend-1.0.4 [1.0.3]
[ebuild U ] dev-libs/libisofs-1.2.4 [1.0.0] USE="-static-libs%"
[ebuild N ] dev-libs/xapian-1.2.12 USE="brass chert inmemory sse2 -doc -sse -static-libs"
[ebuild N ] media-libs/libcdr-0.0.9 USE="-doc -static-libs"
[ebuild U ] dev-libs/hyphen-2.8.6 [2.8.3]
[ebuild U ] app-admin/gam-server-0.1.10-r1 [0.1.10]
[ebuild U ] mail-client/mailx-8.1.2.20050715-r6 [8.1.2.20050715-r3]
[ebuild NS ] sys-devel/gcc-4.6.3 [4.5.3-r1] USE="cxx fortran gtk mudflap nls nptl openmp (-altivec) -doc (-fixed-point) -gcj -graphite (-hardened) (-libssp) (-multilib) -multislot -nopie -nossp -objc -objc++ -objc-gc {-test} -vanilla"
[ebuild U ] sys-apps/grep-2.14 [2.9]
[ebuild N ] media-libs/jbig2dec-0.11-r1 USE="png -static-libs {-test}"
[ebuild N ~] app-text/qpdf-4.0.0 USE="-doc -examples -static-libs {-test}"
[ebuild N ] sys-apps/less-457 USE="pcre unicode"
[ebuild N ] sys-apps/paxctl-0.7-r2
[ebuild U ] dev-lang/swig-2.0.8 [2.0.2]
[ebuild U ] dev-lang/nacl-toolchain-newlib-0_p9093 [0_p7311]
[ebuild U ] media-sound/alsa-utils-1.0.25-r1 [1.0.24.2-r1] USE="(-selinux)"
[ebuild U ] app-laptop/radeontool-1.6.3 [1.5-r3]
[ebuild N ~] dev-libs/libpwquality-1.2.0-r2 USE="pam -python -static-libs" PYTHON_TARGETS="python2_7"
[ebuild NS ] sys-kernel/gentoo-sources-3.5.7 [3.1.10-r1] USE="symlink -build -deblob"
[ebuild U ] sys-libs/pam-1.1.6-r2 [1.1.5]
[ebuild U ] sys-apps/busybox-1.20.2 [1.19.3-r1] USE="static* -livecd% -math% -sep-usr% -systemd%"
[ebuild R ] x11-misc/xdg-user-dirs-0.14 USE="gtk%*"
[ebuild U ] app-office/libreoffice-l10n-3.6.4.3 [3.4.3-r3] LINGUAS="-am% -bn_IN% -gd% -lb% -om% -sa_IN% -si% -tt%"
[ebuild U ] sys-apps/coreutils-8.20 [8.14]
[uninstall ] app-misc/realpath-1.16
[blocks b ] app-misc/realpath ("app-misc/realpath" is blocking sys-apps/coreutils-8.20)
[ebuild U ] app-admin/eselect-1.3.1 [1.2.18]
[ebuild U ] app-admin/eselect-ctags-1.14 [1.13]
[ebuild U ] app-admin/eselect-opengl-1.2.6.1 [1.2.4]
[ebuild U ] x11-proto/glproto-1.4.16 [1.4.14-r1]
[blocks b ] <x11-proto/glproto-1.4.15-r1 ("<x11-proto/glproto-1.4.15-r1" is blocking app-admin/eselect-opengl-1.2.6.1)
[ebuild N ] app-admin/eselect-pinentry-0.3
[ebuild U ] dev-libs/openssl-1.0.1c [1.0.0g] USE="-vanilla%"
[ebuild U ] dev-lang/python-2.7.3-r2 [2.7.2-r3]
[ebuild NS ] dev-lang/python-3.2.3 [2.6.6-r2, 2.7.2-r3, 3.1.4-r3] USE="gdbm ncurses readline sqlite ssl threads (wide-unicode) xml -build -doc -examples -ipv6 -tk -wininst"
[ebuild U ] net-nds/openldap-2.4.30 [2.4.24] USE="syslog*"
[ebuild U ] net-misc/wget-1.14 [1.12-r3] USE="pcre%* zlib%* -gnutls% -uuid%"
[ebuild N ] dev-lang/ruby-1.8.7_p370 USE="berkdb gdbm ncurses readline ssl threads -debug -doc -examples -ipv6 -libedit -rubytests -socks5 -tk -xemacs"
[ebuild U ] dev-libs/libevent-2.0.21 [2.0.16]
[ebuild U ] dev-perl/Net-SSLeay-1.490.0 [1.360.0]
[ebuild U ] app-admin/apache-tools-2.2.23 [2.2.21]
[ebuild U ] dev-lang/python-2.6.8 [2.6.6-r2]
[ebuild U ] dev-libs/libxml2-2.8.0-r3 [2.7.8-r4] USE="-lzma%"
[ebuild U ] net-misc/curl-7.26.0 [7.24.0] CURL_SSL="nss%* -axtls% -cyassl% -gnutls% -openssl% -polarssl%"
[ebuild U ] dev-java/java-config-2.1.12-r1 [2.1.11-r3] PYTHON_TARGETS="python2_7%* python3_2%* (-pypy1_9) -python2_6% -python3_1% (-python3_3)"
[ebuild U #] dev-lang/spidermonkey-1.8.7-r3 [1.8.5-r1] USE="-jit% -minimal%"
[ebuild U ~] dev-util/gdbus-codegen-2.34.3 [2.30.2] PYTHON_TARGETS="python2_7%* python3_2%* -python2_5% -python2_6% -python3_1% (-python3_3)"
[ebuild U ] dev-python/setuptools-0.6.30-r1 [0.6.21] PYTHON_TARGETS="python2_7%* python3_2%* -python2_5% -python2_6% -python3_1%"
[ebuild U ~] dev-python/pygobject-2.28.6-r53 [2.28.6-r51] PYTHON_TARGETS="python2_7%* -python2_6%"
[ebuild U ~] dev-python/pyxdg-0.25 [0.19] USE="{-test%}" PYTHON_TARGETS="python2_7%* python3_2%* -pypy1_9% -python2_6% -python3_1%"
[ebuild U ] dev-lang/v8-3.14.5.3 [3.6.6.11]
[ebuild N ] dev-python/ply-3.4 USE="-examples"
[ebuild U ] dev-python/simplejson-2.6.2 [2.2.1]
[ebuild U ] sys-devel/llvm-3.1-r2 [2.9-r2] USE="-gold%"
[ebuild NS ] dev-python/beautifulsoup-4.1.3-r1 [3.2.0] USE="-doc {-test}" PYTHON_TARGETS="python2_7 python3_2 -python2_6 -python3_1 (-python3_3)"
[ebuild U ] sys-libs/tdb-1.2.10 [1.2.7-r1]
[ebuild U ] www-servers/apache-2.2.23 [2.2.21-r1]
[ebuild U ] app-portage/gentoolkit-0.3.0.7 [0.3.0.4-r5]
[ebuild U ] x11-misc/shared-mime-info-1.0 [0.90]
[ebuild U ] x11-proto/xcb-proto-1.8 [1.6-r2]
[ebuild U ] dev-libs/libxslt-1.1.28 [1.1.26-r2]
[ebuild U ] dev-util/itstool-1.2.0 [1.1.1]
[ebuild U ] net-libs/neon-0.29.6-r2 [0.29.6]
[blocks b ] <net-libs/neon-0.29.6-r1 ("<net-libs/neon-0.29.6-r1" is blocking dev-libs/openssl-1.0.1c)
[ebuild U ] dev-perl/XML-SAX-0.990.0 [0.16]
[blocks b ] <dev-perl/XML-SAX-0.990.0 ("<dev-perl/XML-SAX-0.990.0" is blocking dev-perl/XML-SAX-Base-1.80.0)
[ebuild U ] dev-libs/libcroco-0.6.5 [0.6.3]
[ebuild U ] dev-python/numpy-1.6.2 [1.6.0]
[ebuild U ~] net-libs/liboauth-0.9.7 [0.9.6]
[ebuild N ] dev-python/pycurl-7.19.0-r1 USE="ssl -examples" CURL_SSL="nss -gnutls -openssl"
[ebuild N ] dev-python/m2crypto-0.21.1 USE="-doc -examples"
[ebuild U ] net-dns/bind-tools-9.9.2 [9.8.1] USE="readline%*"
[ebuild U ] media-libs/libquvi-0.4.1 [0.4.0]
[ebuild N ~] dev-python/isodate-0.4.9
[ebuild N ] dev-python/bsddb3-5.3.0 USE="-doc"
[ebuild U ] dev-java/ant-core-1.8.4-r1 [1.8.1]
[ebuild U ] x11-libs/libxcb-1.9 [1.7]
[ebuild U ] app-text/gnome-doc-utils-0.20.10 [0.20.6]
[ebuild NS ~] dev-lang/vala-0.18.1 [0.12.1, 0.14.2] USE="vapigen {-test}"
[ebuild U ] media-libs/raptor-2.0.8 [2.0.4]
[ebuild U ] dev-perl/XML-LibXML-1.900.0 [1.70] USE="{-test%}"
[ebuild U ~] gnome-extra/yelp-xsl-3.6.1 [3.2.1]
[ebuild NS ] dev-lang/vala-0.16.1-r2 [0.12.1, 0.14.2] USE="vapigen {-test}"
[ebuild N ~] dev-python/rdflib-3.2.3 USE="berkdb sqlite -examples -mysql -redland {-test}"
[ebuild U ] dev-lang/vala-0.14.2-r2 [0.14.2]
[blocks b ] <dev-lang/vala-0.14.2-r2:0.14 ("<dev-lang/vala-0.14.2-r2:0.14" is blocking dev-libs/vala-common-0.18.1)
[ebuild U ] dev-python/lxml-3.0.1 [2.3.1] PYTHON_TARGETS="python2_7%* python3_2%* -python2_6% -python3_1% (-python3_3)"
[ebuild U ] x11-libs/libX11-1.5.0 [1.4.4]
[ebuild U ] dev-util/gtk-doc-1.18-r1 [1.18]
[ebuild U ~] app-text/yelp-tools-3.6.1 [3.2.1]
[ebuild N ] x11-libs/xpyb-1.3.1 USE="(-selinux) -static-libs"
[ebuild NS ~] dev-libs/libgee-0.8.3 [0.6.3] USE="-introspection"
[ebuild U ] dev-libs/rasqal-0.9.28 [0.9.27]
[ebuild U ] x11-libs/libXext-1.3.1 [1.3.0]
[ebuild U ] media-libs/freetype-2.4.11 [2.4.8] USE="-infinality%"
[ebuild U ] x11-libs/libXrender-0.9.7 [0.9.6]
[ebuild U ] x11-libs/libxkbfile-1.0.8 [1.0.7]
[ebuild U ] x11-misc/xkeyboard-config-2.7 [2.4.1-r3]
[ebuild U ] x11-apps/luit-1.1.1 [1.1.0]
[ebuild U ] x11-apps/xmodmap-1.0.7 [1.0.5]
[ebuild U ] dev-libs/redland-1.0.15 [1.0.14]
[ebuild U ] x11-libs/libXrandr-1.4.0 [1.3.2]
[ebuild U ] x11-libs/libXi-1.6.1 [1.4.3-r1]
[ebuild U ] x11-libs/libXinerama-1.1.2 [1.1.1]
[ebuild U ] x11-libs/libXcursor-1.1.13 [1.1.12]
[ebuild U ] x11-libs/libXv-1.0.7 [1.0.6]
[ebuild U ] x11-libs/libXft-2.3.1 [2.2.0]
[ebuild U ] x11-libs/libXxf86vm-1.1.2 [1.1.1]
[ebuild U ] x11-libs/libXfont-1.4.5-r1 [1.4.4] USE="bzip2%* truetype%*"
[ebuild U ] x11-apps/mkfontscale-1.1.0 [1.0.9-r1]
[ebuild U ] x11-libs/libXScrnSaver-1.2.2 [1.2.1]
[ebuild U ] x11-libs/libXres-1.0.6 [1.0.5]
[ebuild U ] x11-libs/libXtst-1.2.1 [1.2.0]
[ebuild U ] x11-apps/mkfontdir-1.0.7 [1.0.6]
[ebuild U ~] media-fonts/cantarell-0.0.12 [0.0.7]
[ebuild U ] x11-apps/xdpyinfo-1.3.0-r1 [1.3.0]
[ebuild N ] media-fonts/libertine-ttf-5.1.3.20110615 USE="X"
[ebuild N ] media-fonts/liberation-fonts-2.00.0-r1 USE="X -fontforge"
[ebuild U ~] dev-libs/gobject-introspection-1.34.2-r1 [1.30.0-r2] USE="-doctool%" PYTHON_SINGLE_TARGET="python2_7%*" PYTHON_TARGETS="python2_7%*"
[blocks b ] <dev-libs/gobject-introspection-1.32.0 ("<dev-libs/gobject-introspection-1.32.0" is blocking dev-libs/gobject-introspection-common-1.34.2)
[ebuild U ~] dev-libs/atk-2.6.0 [2.2.0]
[ebuild NS ~] media-libs/gstreamer-1.0.3 [0.10.35] USE="introspection nls orc {-test}"
[ebuild U ] media-libs/gstreamer-0.10.36 [0.10.35] USE="orc%*"
[ebuild U ~] gnome-base/gsettings-desktop-schemas-3.6.1 [3.2.0-r1] USE="introspection%*"
[ebuild U ~] dev-libs/json-glib-0.15.2 [0.14.2]
[ebuild U ] dev-libs/libgee-0.6.4 [0.6.3]
[ebuild U ~] x11-libs/libxklavier-5.3 [5.2]
[ebuild U ] media-libs/gst-plugins-base-0.10.36 [0.10.35]
[ebuild U ] media-libs/gst-plugins-ugly-0.10.19 [0.10.18] USE="nls%* orc%*"
[ebuild U ] media-libs/gst-plugins-good-0.10.31 [0.10.30] USE="nls%*"
[ebuild U ] media-libs/gst-plugins-bad-0.10.23-r1 [0.10.22] USE="nls%*"
[ebuild U ] media-plugins/gst-plugins-cdparanoia-0.10.36 [0.10.35]
[ebuild U ] media-plugins/gst-plugins-gio-0.10.36 [0.10.35]
[ebuild U ] media-plugins/gst-plugins-x-0.10.36 [0.10.35]
[ebuild U ] media-plugins/gst-plugins-xvideo-0.10.36 [0.10.35]
[ebuild U ] media-plugins/gst-plugins-ogg-0.10.36 [0.10.35]
[ebuild U ] media-plugins/gst-plugins-alsa-0.10.36 [0.10.35]
[ebuild U ] media-plugins/gst-plugins-vorbis-0.10.36 [0.10.35]
[ebuild U ] media-plugins/gst-plugins-faad-0.10.23 [0.10.22]
[ebuild U ] media-plugins/gst-plugins-lame-0.10.19 [0.10.18]
[ebuild N ] media-plugins/gst-plugins-soundtouch-0.10.23
[ebuild U ] media-plugins/gst-plugins-a52dec-0.10.19 [0.10.18]
[ebuild N ] media-plugins/gst-plugins-x264-0.10.19
[ebuild U ] media-plugins/gst-plugins-mpeg2dec-0.10.19 [0.10.18]
[ebuild U ] media-plugins/gst-plugins-dts-0.10.23 [0.10.22]
[ebuild U ] media-plugins/gst-plugins-dvdread-0.10.19 [0.10.18]
[ebuild U ] media-plugins/gst-plugins-mad-0.10.19 [0.10.18]
[ebuild U ] media-plugins/gst-plugins-flac-0.10.31 [0.10.30]
[ebuild U ] media-plugins/gst-plugins-resindvd-0.10.23 [0.10.22]
[ebuild N ] media-plugins/gst-plugins-xvid-0.10.23
[ebuild U ] x11-libs/xcb-util-0.3.9 [0.3.8]
[ebuild U ] x11-libs/xcb-util-wm-0.3.9 [0.3.8]
[ebuild U ] x11-libs/xcb-util-keysyms-0.3.9 [0.3.8]
[ebuild U ] x11-libs/xcb-util-image-0.3.9 [0.3.8]
[ebuild N ] dev-lang/ruby-1.9.3_p194-r1 USE="berkdb gdbm ncurses rdoc readline ssl yaml -debug -doc -examples -ipv6 -rubytests -socks5 -tk -xemacs"
[ebuild N ] dev-ruby/rubygems-1.8.24 USE="-server {-test}" RUBY_TARGETS="ruby18 ruby19 -jruby (-ree18)"
[ebuild N ] virtual/rubygems-4 RUBY_TARGETS="(ruby19)"
[ebuild N ] virtual/rubygems-1 RUBY_TARGETS="(ruby18)"
[ebuild N ] dev-ruby/rake-0.9.2.2 USE="-bash-completion -doc {-test}" RUBY_TARGETS="ruby18 ruby19 -jruby (-ree18)"
[ebuild N ] dev-ruby/racc-1.4.8 USE="-doc {-test}" RUBY_TARGETS="ruby18 ruby19 -jruby (-ree18)"
[ebuild N ] dev-ruby/json-1.6.7 USE="-doc {-test}" RUBY_TARGETS="ruby18 ruby19 -jruby (-ree18)"
[ebuild N ] dev-ruby/rdoc-3.12 USE="-doc {-test}" RUBY_TARGETS="ruby18 ruby19 -jruby (-ree18)"
[ebuild N ] media-libs/libjpeg-turbo-1.2.1 USE="java -static-libs"
[uninstall ] media-libs/jpeg-8d
[blocks b ] media-libs/jpeg:0 ("media-libs/jpeg:0" is blocking media-libs/libjpeg-turbo-1.2.1)
[ebuild U ] media-libs/tiff-4.0.2-r1 [3.9.5] USE="-lzma%"
[ebuild U ] media-libs/libgphoto2-2.4.14 [2.4.11-r1] CAMERAS="-tp6801%"
[ebuild U ] media-libs/libv4l-0.8.9 [0.8.5]
[ebuild U ~] x11-libs/gdk-pixbuf-2.26.5 [2.24.1]
[ebuild U ] www-client/links-2.7 [2.4-r2] USE="deprecated%* -lzma%"
[ebuild U ] media-libs/libwebp-0.2.1 [0.1.3] USE="-experimental%"
[ebuild U ] x11-libs/libnotify-0.7.5 [0.7.4-r1]
[ebuild U ] dev-libs/boost-1.49.0-r2 [1.46.1-r1]
[uninstall ] app-admin/eselect-boost-0.3
[blocks b ] app-admin/eselect-boost ("app-admin/eselect-boost" is blocking dev-libs/boost-1.49.0-r2)
[ebuild N ] sys-block/thin-provisioning-tools-0.1.5-r1
[ebuild N ] app-text/highlight-3.3 USE="-examples -qt4"
[ebuild U ] app-text/libwps-0.2.7 [0.2.4]
[ebuild N ] media-libs/libvisio-0.0.23 USE="-doc -static-libs"
[ebuild N ] dev-cpp/libcmis-0.2.3-r1 USE="-man -static-libs {-test}"
[ebuild U ] dev-util/mdds-0.6.1 [0.5.3-r1]
[ebuild N ] sys-apps/kmod-12-r1 USE="tools zlib -debug -doc -lzma -static-libs"
[uninstall ] sys-apps/module-init-tools-3.16-r1
[blocks b ] sys-apps/kmod ("sys-apps/kmod" is blocking sys-apps/module-init-tools-3.16-r1)
[blocks b ] sys-apps/module-init-tools ("sys-apps/module-init-tools" is blocking sys-apps/kmod-12-r1)
[ebuild N ] virtual/modutils-0
[ebuild N ] dev-util/gtk-builder-convert-2.24.11
[ebuild U ] x11-libs/qt-core-4.8.4 [4.7.4-r1] USE="-c++0x% -icu%"
[ebuild U ] x11-libs/qt-script-4.8.4 [4.7.4] USE="-c++0x%"
[blocks b ] <x11-libs/qt-script-4.8.4:4 ("<x11-libs/qt-script-4.8.4:4" is blocking x11-libs/qt-qt3support-4.8.4, x11-libs/qt-sql-4.8.4, x11-libs/qt-core-4.8.4, x11-libs/qt-svg-4.8.4, x11-libs/qt-test-4.8.4, x11-libs/qt-gui-4.8.4, x11-libs/qt-opengl-4.8.4, x11-libs/qt-dbus-4.8.4)
[ebuild U ] x11-libs/qt-test-4.8.4 [4.7.4] USE="-c++0x%"
[blocks b ] <x11-libs/qt-test-4.8.4:4 ("<x11-libs/qt-test-4.8.4:4" is blocking x11-libs/qt-qt3support-4.8.4, x11-libs/qt-sql-4.8.4, x11-libs/qt-core-4.8.4, x11-libs/qt-svg-4.8.4, x11-libs/qt-script-4.8.4, x11-libs/qt-gui-4.8.4, x11-libs/qt-opengl-4.8.4, x11-libs/qt-dbus-4.8.4)
[ebuild U ] x11-libs/qt-sql-4.8.4 [4.7.4] USE="-c++0x% -oci8%"
[blocks b ] <x11-libs/qt-sql-4.8.4:4 ("<x11-libs/qt-sql-4.8.4:4" is blocking x11-libs/qt-qt3support-4.8.4, x11-libs/qt-core-4.8.4, x11-libs/qt-svg-4.8.4, x11-libs/qt-test-4.8.4, x11-libs/qt-script-4.8.4, x11-libs/qt-gui-4.8.4, x11-libs/qt-opengl-4.8.4, x11-libs/qt-dbus-4.8.4)
[ebuild N ~] app-crypt/libsecret-0.12 USE="crypt introspection -debug {-test} -vala"
[ebuild U ] media-plugins/gst-plugins-meta-0.10-r8 [0.10-r6] USE="cdda%* x264%* xvid%* -http% -jack% -libass% -libvisual% -opus%"
[ebuild N ] net-wireless/crda-1.1.2-r3
[ebuild U ] dev-vcs/git-1.7.12.4 [1.7.3.4-r1] USE="gpg%* nls%* pcre%* python%* -highlight% {-test%}"
[ebuild U ] app-portage/layman-2.0.0 [1.4.1] USE="git*"
[ebuild U ] x11-libs/qt-dbus-4.8.4 [4.7.4] USE="-c++0x%"
[blocks b ] <x11-libs/qt-dbus-4.8.4:4 ("<x11-libs/qt-dbus-4.8.4:4" is blocking x11-libs/qt-qt3support-4.8.4, x11-libs/qt-sql-4.8.4, x11-libs/qt-core-4.8.4, x11-libs/qt-svg-4.8.4, x11-libs/qt-test-4.8.4, x11-libs/qt-script-4.8.4, x11-libs/qt-gui-4.8.4, x11-libs/qt-opengl-4.8.4)
[ebuild U ] x11-libs/qt-gui-4.8.4 [4.7.4-r1] USE="gif%* xv%* -c++0x%"
[blocks b ] <x11-libs/qt-gui-4.8.4:4 ("<x11-libs/qt-gui-4.8.4:4" is blocking x11-libs/qt-qt3support-4.8.4, x11-libs/qt-sql-4.8.4, x11-libs/qt-core-4.8.4, x11-libs/qt-svg-4.8.4, x11-libs/qt-test-4.8.4, x11-libs/qt-script-4.8.4, x11-libs/qt-opengl-4.8.4, x11-libs/qt-dbus-4.8.4)
[ebuild U ] x11-libs/qt-qt3support-4.8.4 [4.7.4] USE="-c++0x%"
[blocks b ] <x11-libs/qt-qt3support-4.8.4:4 ("<x11-libs/qt-qt3support-4.8.4:4" is blocking x11-libs/qt-sql-4.8.4, x11-libs/qt-core-4.8.4, x11-libs/qt-svg-4.8.4, x11-libs/qt-test-4.8.4, x11-libs/qt-script-4.8.4, x11-libs/qt-gui-4.8.4, x11-libs/qt-opengl-4.8.4, x11-libs/qt-dbus-4.8.4)
[ebuild U ] x11-libs/qt-svg-4.8.4 [4.7.4] USE="-c++0x%"
[blocks b ] <x11-libs/qt-svg-4.8.4:4 ("<x11-libs/qt-svg-4.8.4:4" is blocking x11-libs/qt-qt3support-4.8.4, x11-libs/qt-sql-4.8.4, x11-libs/qt-core-4.8.4, x11-libs/qt-test-4.8.4, x11-libs/qt-script-4.8.4, x11-libs/qt-gui-4.8.4, x11-libs/qt-opengl-4.8.4, x11-libs/qt-dbus-4.8.4)
[blocks b ] >x11-libs/qt-opengl-4.7.4-r9999 (">x11-libs/qt-opengl-4.7.4-r9999" is blocking x11-libs/qt-qt3support-4.7.4, x11-libs/qt-test-4.7.4, x11-libs/qt-svg-4.7.4, x11-libs/qt-sql-4.7.4, x11-libs/qt-core-4.7.4-r1, x11-libs/qt-gui-4.7.4-r1, x11-libs/qt-dbus-4.7.4, x11-libs/qt-script-4.7.4)
[ebuild U ] x11-libs/qt-opengl-4.8.4 [4.7.4] USE="-c++0x%"
[blocks b ] >x11-libs/qt-qt3support-4.7.4-r9999 (">x11-libs/qt-qt3support-4.7.4-r9999" is blocking x11-libs/qt-test-4.7.4, x11-libs/qt-svg-4.7.4, x11-libs/qt-sql-4.7.4, x11-libs/qt-core-4.7.4-r1, x11-libs/qt-opengl-4.7.4, x11-libs/qt-gui-4.7.4-r1, x11-libs/qt-dbus-4.7.4, x11-libs/qt-script-4.7.4)
[blocks b ] >x11-libs/qt-script-4.7.4-r9999 (">x11-libs/qt-script-4.7.4-r9999" is blocking x11-libs/qt-qt3support-4.7.4, x11-libs/qt-test-4.7.4, x11-libs/qt-svg-4.7.4, x11-libs/qt-sql-4.7.4, x11-libs/qt-core-4.7.4-r1, x11-libs/qt-opengl-4.7.4, x11-libs/qt-gui-4.7.4-r1, x11-libs/qt-dbus-4.7.4)
[blocks b ] >x11-libs/qt-sql-4.7.4-r9999 (">x11-libs/qt-sql-4.7.4-r9999" is blocking x11-libs/qt-qt3support-4.7.4, x11-libs/qt-test-4.7.4, x11-libs/qt-svg-4.7.4, x11-libs/qt-core-4.7.4-r1, x11-libs/qt-opengl-4.7.4, x11-libs/qt-gui-4.7.4-r1, x11-libs/qt-dbus-4.7.4, x11-libs/qt-script-4.7.4)
[blocks b ] >x11-libs/qt-test-4.7.4-r9999 (">x11-libs/qt-test-4.7.4-r9999" is blocking x11-libs/qt-qt3support-4.7.4, x11-libs/qt-svg-4.7.4, x11-libs/qt-sql-4.7.4, x11-libs/qt-core-4.7.4-r1, x11-libs/qt-opengl-4.7.4, x11-libs/qt-gui-4.7.4-r1, x11-libs/qt-dbus-4.7.4, x11-libs/qt-script-4.7.4)
[blocks b ] >x11-libs/qt-dbus-4.7.4-r9999 (">x11-libs/qt-dbus-4.7.4-r9999" is blocking x11-libs/qt-qt3support-4.7.4, x11-libs/qt-test-4.7.4, x11-libs/qt-svg-4.7.4, x11-libs/qt-sql-4.7.4, x11-libs/qt-core-4.7.4-r1, x11-libs/qt-opengl-4.7.4, x11-libs/qt-gui-4.7.4-r1, x11-libs/qt-script-4.7.4)
[blocks b ] <x11-libs/qt-opengl-4.8.4:4 ("<x11-libs/qt-opengl-4.8.4:4" is blocking x11-libs/qt-qt3support-4.8.4, x11-libs/qt-sql-4.8.4, x11-libs/qt-core-4.8.4, x11-libs/qt-svg-4.8.4, x11-libs/qt-test-4.8.4, x11-libs/qt-script-4.8.4, x11-libs/qt-gui-4.8.4, x11-libs/qt-dbus-4.8.4)
[blocks b ] >x11-libs/qt-core-4.7.4-r9999 (">x11-libs/qt-core-4.7.4-r9999" is blocking x11-libs/qt-qt3support-4.7.4, x11-libs/qt-test-4.7.4, x11-libs/qt-svg-4.7.4, x11-libs/qt-sql-4.7.4, x11-libs/qt-opengl-4.7.4, x11-libs/qt-gui-4.7.4-r1, x11-libs/qt-dbus-4.7.4, x11-libs/qt-script-4.7.4)
[blocks b ] >x11-libs/qt-gui-4.7.4-r9999 (">x11-libs/qt-gui-4.7.4-r9999" is blocking x11-libs/qt-qt3support-4.7.4, x11-libs/qt-test-4.7.4, x11-libs/qt-svg-4.7.4, x11-libs/qt-sql-4.7.4, x11-libs/qt-core-4.7.4-r1, x11-libs/qt-opengl-4.7.4, x11-libs/qt-dbus-4.7.4, x11-libs/qt-script-4.7.4)
[blocks b ] >x11-libs/qt-svg-4.7.4-r9999 (">x11-libs/qt-svg-4.7.4-r9999" is blocking x11-libs/qt-qt3support-4.7.4, x11-libs/qt-test-4.7.4, x11-libs/qt-sql-4.7.4, x11-libs/qt-core-4.7.4-r1, x11-libs/qt-opengl-4.7.4, x11-libs/qt-gui-4.7.4-r1, x11-libs/qt-dbus-4.7.4, x11-libs/qt-script-4.7.4)
[ebuild U ] x11-libs/cairo-1.10.2-r3 [1.10.2-r1]
[blocks b ] <x11-libs/cairo-1.10.2-r2 ("<x11-libs/cairo-1.10.2-r2" is blocking x11-libs/qt-core-4.8.4)
[ebuild U ~] dev-python/pycairo-1.10.0-r4 [1.10.0-r2] USE="xcb%*" PYTHON_TARGETS="python2_7%* python3_2%* -python2_6% -python3_1% (-python3_3)"
[ebuild U ~] dev-python/pygobject-3.4.2-r1 [3.0.3] PYTHON_TARGETS="python2_7%* python3_2%* -python2_6% -python3_1% (-python3_3)"
[ebuild U ] sys-apps/dbus-1.6.8 [1.4.16]
[ebuild U ] dev-libs/dbus-glib-0.100 [0.98]
[ebuild U ~] app-accessibility/at-spi2-core-2.6.3 [2.2.3]
[ebuild U ~] net-wireless/wpa_supplicant-2.0 [0.7.3-r5] USE="-ap% -p2p% (-selinux)"
[ebuild N ~] app-accessibility/at-spi2-atk-2.6.2 USE="{-test}"
[ebuild U ~] net-libs/telepathy-glib-0.20.1-r1 [0.16.4] PYTHON_TARGETS="python2_7%* -python2_5% -python2_6%"
[ebuild U ~] dev-python/dbus-python-1.1.1-r1 [0.84.0] PYTHON_TARGETS="python2_7%* python3_2%* -python2_6% (-python3_3)"
[ebuild U ~] dev-libs/gjs-1.34.0 [1.30.1]
[ebuild U ~] net-im/telepathy-logger-0.6.0 [0.2.12]
[ebuild U ~] dev-python/pyatspi-2.6.0-r1 [2.2.1] PYTHON_TARGETS="python2_7%* python3_2%* -python2_6% (-python3_3)"
[ebuild N ~] gnome-extra/zeitgeist-0.9.5 USE="dbus fts nls -extensions -icu -passiv -plugins -sql-debug"
[ebuild N ~] dev-libs/libzeitgeist-0.3.18 USE="-static-libs"
[ebuild U ~] net-print/cups-1.6.1 [1.5.0-r4] USE="-avahi% (-selinux) -systemd% -zeroconf%" LINGUAS="-ca%"
[ebuild N ~] net-print/cups-filters-1.0.25 USE="jpeg png tiff -perl -static-libs"
[ebuild N ] dev-python/pycups-1.9.62 USE="-doc -examples"
[ebuild U ~] x11-libs/gtk+-2.24.14 [2.24.9]
[blocks b ] <=x11-libs/gtk+-2.24.10:2 ("<=x11-libs/gtk+-2.24.10:2" is blocking dev-util/gtk-builder-convert-2.24.11)
[ebuild U ] app-crypt/pinentry-0.8.2 [0.8.0]
[blocks b ] <app-crypt/pinentry-0.8.0-r1 ("<app-crypt/pinentry-0.8.0-r1" is blocking app-admin/eselect-pinentry-0.3)
[ebuild U ] app-misc/geoclue-0.12.99 [0.12.0_p20110307] USE="-connman% -static-libs%"
[ebuild N ] dev-python/gnome-python-desktop-base-2.32.0
[ebuild U ] net-dialup/ppp-2.4.5-r3 [2.4.5-r1] USE="ipv6*"
[ebuild R ] app-text/gtkspell-2.0.16 USE="(-doc%)"
[ebuild U ] x11-libs/gtksourceview-2.10.5-r2 [2.10.5-r1]
[ebuild N ~] net-dns/avahi-0.6.31 USE="dbus gdbm gtk introspection -autoipd -bookmarks -doc -gtk3 -howl-compat -ipv6 -mdnsresponder-compat -mono -python -qt4 {-test} -utils"
[ebuild U ] gnome-extra/libgsf-1.14.23 [1.14.21] USE="introspection%*"
[ebuild U ] sys-apps/lshw-02.16b-r2 [02.15b]
[ebuild U ] app-crypt/gnupg-2.0.19 [2.0.17] USE="readline%* usb%*"
[ebuild U ] app-crypt/gpgme-1.3.2 [1.3.0-r1] USE="-static-libs%"
[ebuild NS ~] dev-libs/gmime-2.6.13 [2.4.31] USE="-doc -mono -static-libs"
[ebuild U ] x11-libs/libSM-1.2.1 [1.2.0]
[ebuild U ] x11-libs/libXt-1.1.3 [1.1.1]
[ebuild U ] x11-libs/libXmu-1.1.1 [1.1.0]
[ebuild U ] app-text/ghostscript-gpl-9.05-r1 [9.04-r4]
[ebuild U ] app-editors/vim-7.3.409 [7.3.266]
[ebuild U ] x11-libs/libXpm-3.5.10 [3.5.9]
[ebuild U ] dev-dotnet/libgdiplus-2.10.9 [2.10]
[ebuild U ] x11-libs/libXaw-1.0.11-r1 [1.0.9] USE="-deprecated%"
[ebuild U ] x11-apps/xauth-1.0.7 [1.0.6]
[ebuild U ] net-print/foomatic-filters-4.0.17 [4.0.9]
[ebuild U ] app-vim/gentoo-syntax-20120109 [20101212]
[ebuild U ] dev-lang/mono-2.10.9-r2 [2.10.5]
[ebuild U ] app-text/libspectre-0.2.7 [0.2.6]
[ebuild U ] x11-apps/xhost-1.0.5 [1.0.4]
[ebuild U ] x11-apps/xinit-1.3.2 [1.3.1-r1]
[ebuild U ] dev-dotnet/dbus-sharp-0.7.0-r1 [0.7.0]
[ebuild U ] dev-dotnet/taglib-sharp-2.1.0.0 [2.0.4.0]
[ebuild U ] x11-terms/xterm-285 [276]
[ebuild U ] net-misc/openssh-5.9_p1-r4 [5.8_p1-r1] USE="-bindist%"
[blocks b ] <net-misc/openssh-5.9_p1-r4 ("<net-misc/openssh-5.9_p1-r4" is blocking dev-libs/openssl-1.0.1c)
[ebuild U ~] gnome-base/libgnome-keyring-3.6.0 [3.2.2] USE="introspection%* -vala%"
[ebuild U ] media-libs/mesa-9.0.1 [7.11.2] USE="xorg%* -g3dvl% -gles1% -gles2% -r600-llvm-compiler% -vdpau% (-wayland) -xa% -xvmc%" VIDEO_CARDS="-i915% -i965% -r100% -r200% -r300% -r600% -radeonsi%"
[blocks b ] <media-libs/mesa-9 ("<media-libs/mesa-9" is blocking media-libs/glu-9.0.0)
[blocks b ] <media-libs/mesa-8.0.3-r1 ("<media-libs/mesa-8.0.3-r1" is blocking app-admin/eselect-opengl-1.2.6.1)
[ebuild U ] x11-base/xorg-server-1.13.1 [1.11.2-r2] USE="suid%* (-selinux)"
[ebuild U ] x11-drivers/xf86-input-mouse-1.8.1 [1.7.1]
[ebuild U ] x11-drivers/xf86-input-keyboard-1.6.2 [1.6.0]
[ebuild U ] x11-drivers/xf86-input-evdev-2.7.3 [2.6.0]
[ebuild U ] sys-fs/e2fsprogs-1.42 [1.41.14] USE="-static-libs%"
[ebuild U ] app-arch/libarchive-3.0.4-r1 [2.8.5] USE="e2fsprogs%* iconv%* -nettle%"
[ebuild U ] sys-block/parted-3.1 [3.0]
[ebuild U ] sys-kernel/genkernel-3.4.45 [3.4.20] USE="crypt%* -cryptsetup%"
[ebuild U ] dev-util/cmake-2.8.9 [2.8.6-r4]
[ebuild U ] app-text/poppler-0.20.5 [0.18.3]
[ebuild N ] media-gfx/graphite2-1.2.0 USE="-perl {-test}"
[ebuild U ] media-libs/taglib-1.8-r1 [1.7]
[ebuild NS ] media-libs/musicbrainz-5.0.1 [2.1.5, 3.0.2] USE="-examples {-test}"
[ebuild U ] media-libs/musicbrainz-3.0.3 [3.0.2]
[ebuild U ] net-libs/libproxy-0.4.10-r1 [0.4.7] USE="-spidermonkey% -webkit%"
[ebuild N ] dev-cpp/clucene-2.3.3.4-r4 USE="-debug -doc -static-libs"
[ebuild U ] sci-astronomy/stellarium-0.11.4a [0.11.1] USE="-debug%" LINGUAS="en%* -af% -ak% -am% -ar% -as% -ast% -az% -be% -bg% -bn% -br% -bs% -ca% -cs% -cy% -da% -de% -el% -en_CA% -en_GB% -en_US% -eo% -es% -et% -eu% -fa% -fi% -fil% -fr% -ga% -gd% -gl% -gu% -he% -hi% -hr% -hu% -hy% -ia% -id% -is% -it% -ja% -ka% -kk% -kn% -ko% -ky% -la% -lb% -lo% -lt% -lv% -mk% -ml% -mn% -mr% -ms% -mt% -nan% -nb% -nl% -nn% -pa% -pl% -pt% -pt_BR% -ro% -ru% -se% -si% -sk% -sl% -sq% -sr% -sv% -sw% -ta% -te% -tg% -th% -tl% -tr% -tt% -uk% -uz% -vi% -zh_CN% -zh_HK% -zh_TW% -zu%"
[ebuild N ~] media-libs/harfbuzz-0.9.10 USE="-static-libs"
[ebuild U ] media-plugins/gst-plugins-taglib-0.10.31 [0.10.30]
[ebuild U ~] net-libs/glib-networking-2.34.2 [2.30.2] USE="-smartcard% {-test%}"
[ebuild U ~] x11-libs/pango-1.32.5 [1.29.4]
[ebuild NS ~] media-libs/gst-plugins-base-1.0.3 [0.10.35] USE="X alsa introspection nls ogg orc pango theora vorbis"
[ebuild U ~] gnome-base/librsvg-2.36.4 [2.34.2] USE="-vala%"
[ebuild U ~] media-libs/cogl-1.12.2 [1.8.2] USE="opengl%* -gles2%"
[ebuild U ] mail-client/thunderbird-17.0.2 [9.0] USE="jit%* ldap%* minimal%* (-selinux)" LINGUAS="-ast% -hr% -hy_AM% -sr%"
[ebuild U ] www-client/seamonkey-2.15.1 [2.6.1] USE="gstreamer%* jit%* -system-jpeg%" LINGUAS="-uk% -zh_TW%"
[ebuild NS ~] media-libs/gst-plugins-good-1.0.5 [0.10.30] USE="nls orc"
[ebuild NS ~] media-libs/gst-plugins-ugly-1.0.3 [0.10.18] USE="nls orc"
[ebuild NS ~] media-libs/gst-plugins-bad-1.0.3 [0.10.22] USE="nls orc"
[ebuild U ] media-gfx/imagemagick-6.7.8.7 [6.7.1.0] USE="pango%* -corefonts* -postscript% {-test%}"
[ebuild NS ~] media-plugins/gst-plugins-cdparanoia-1.0.3 [0.10.35]
[ebuild NS ~] media-plugins/gst-plugins-flac-1.0.3 [0.10.30]
[ebuild NS ~] media-plugins/gst-plugins-mad-1.0.3 [0.10.18]
[ebuild NS ~] media-plugins/gst-plugins-faad-1.0.3 [0.10.22]
[ebuild NS ~] media-plugins/gst-plugins-dvdread-1.0.3 [0.10.18]
[ebuild N ~] media-plugins/gst-plugins-x264-1.0.3
[ebuild NS ~] media-plugins/gst-plugins-mpeg2dec-1.0.3 [0.10.18]
[ebuild NS ~] media-plugins/gst-plugins-dts-1.0.3 [0.10.22] USE="orc"
[ebuild NS ~] media-plugins/gst-plugins-a52dec-1.0.3 [0.10.18] USE="orc"
[ebuild NS ~] media-plugins/gst-plugins-resindvd-1.0.3 [0.10.22]
[ebuild NS ~] media-plugins/gst-plugins-jpeg-1.0.3 [0.10.30]
[ebuild N ~] media-plugins/gst-plugins-vpx-1.0.3
[ebuild NS ~] media-plugins/gst-plugins-taglib-1.0.3 [0.10.30]
[ebuild U ] media-gfx/inkscape-0.48.4 [0.48.2] USE="-postscript%"
[ebuild U ] sys-apps/openrc-0.11.8 [0.9.8.4] USE="-newnet% (-prefix)"
[blocks b ] <sys-apps/openrc-0.9.9 ("<sys-apps/openrc-0.9.9" is blocking sys-kernel/genkernel-3.4.45)
[blocks b ] <sys-apps/openrc-0.11.8 ("<sys-apps/openrc-0.11.8" is blocking sys-libs/pam-1.1.6-r2)
[blocks b ] <sys-apps/openrc-0.9.9.3 ("<sys-apps/openrc-0.9.9.3" is blocking sys-apps/net-tools-1.60_p20120127084908)
[blocks b ] <sys-apps/openrc-0.9.9 ("<sys-apps/openrc-0.9.9" is blocking sys-fs/udev-197-r4)
[blocks b ] <sys-apps/openrc-0.10.1 ("<sys-apps/openrc-0.10.1" is blocking sys-fs/lvm2-2.02.97-r1)
[ebuild U ] gnome-extra/polkit-gnome-0.105 [0.101-r1]
[ebuild U ] dev-libs/libgusb-0.1.4 [0.1.2] USE="introspection%* -vala%"
[ebuild U ~] net-libs/libsoup-2.40.2 [2.36.1-r1]
[ebuild U ~] net-libs/libsoup-gnome-2.40.2 [2.36.1]
[ebuild U ] net-libs/webkit-gtk-1.8.3-r200 [1.7.2-r200] USE="geoloc%* webgl*"
[ebuild N ] net-libs/gssdp-0.12.2.1 USE="gtk introspection"
[ebuild U ~] net-libs/rest-0.7.90 [0.7.12]
[ebuild N ~] sys-libs/libosinfo-0.2.2 USE="introspection vala {-test}"
[ebuild U ~] dev-libs/totem-pl-parser-3.4.3-r1 [2.32.6-r1] USE="crypt%* {-test%}"
[ebuild U ~] gnome-base/gconf-3.2.6 [3.2.3] USE="gtk%* -orbit*"
[ebuild U ] media-plugins/gst-plugins-gconf-0.10.31 [0.10.30]
[ebuild U ] x11-libs/goffice-0.8.17-r1 [0.8.17]
[ebuild U ~] media-libs/libcanberra-0.30-r1 [0.28-r5]
[ebuild U ] gnome-base/libgnome-2.32.1-r1 [2.32.1]
[ebuild U ] net-wireless/bluez-4.101-r5 [4.96] USE="readline%* (-selinux)" PYTHON_SINGLE_TARGET="python2_7%* -python2_6%" PYTHON_TARGETS="python2_7%* -python2_6%"
[ebuild U ] app-mobilephone/obex-data-server-0.4.6 [0.4.5]
[ebuild N ] net-libs/libpcap-1.3.0-r1 USE="bluetooth -canusb -ipv6 -netlink -static-libs"
[ebuild N ] net-analyzer/nmap-6.01 USE="gtk ssl -lua -ncat -ndiff -nmap-update -nping"
[ebuild U ~] gnome-base/dconf-0.14.1 [0.10.0] USE="{-test%}"
[ebuild U ~] gnome-base/libgnomekbd-3.6.0 [3.2.0-r1]
[ebuild U ~] net-wireless/gnome-bluetooth-3.6.1 [3.2.1]
[ebuild U ~] gnome-base/gnome-menus-3.6.2 [3.2.0.1-r1] PYTHON_TARGETS="python2_7%* -python2_6%"
[ebuild U ~] gnome-base/gnome-session-3.6.2-r2 [3.2.1-r1] USE="-debug% -gconf% -systemd%"
[ebuild U ~] dev-libs/libgweather-3.6.2 [3.2.1]
[ebuild NS ~] media-libs/clutter-gst-1.9.92 [1.4.6] USE="introspection -debug -examples"
[ebuild N ~] app-i18n/ibus-1.4.99.20121006 USE="X dconf gconf gtk gtk3 introspection nls python -deprecated {-test} -vala"
[ebuild U ] media-libs/libsdl-1.2.15-r2 [1.2.14-r6]
[ebuild U ~] app-text/evince-3.6.1 [3.2.1-r1] USE="postscript%*"
[ebuild U ~] sys-apps/accountsservice-0.6.30 [0.6.15] USE="-systemd% -vala%"
[ebuild U ~] x11-libs/vte-0.34.2 [0.30.1-r3]
[ebuild U ~] x11-libs/gtk+-3.6.3-r2 [3.2.3] USE="X%* (-egl) (-wayland)"
[ebuild U ~] gnome-base/gnome-desktop-3.6.2 [3.2.1]
[ebuild U ~] media-libs/clutter-1.12.2 [1.8.4] USE="gtk%* {-test%}"
[ebuild U ~] net-libs/webkit-gtk-1.10.2-r300 [1.7.2-r300] USE="geoloc%* webgl*"
[ebuild U ~] x11-libs/libwnck-3.4.4 [3.2.1] USE="-tools%"
[ebuild U ~] x11-themes/gnome-themes-standard-3.6.2 [3.2.1] USE="gtk%*"
[ebuild U ~] dev-libs/libpeas-1.6.2-r1 [1.2.0-r1] PYTHON_SINGLE_TARGET="python2_7%* -python2_6%" PYTHON_TARGETS="python2_7%* -python2_6%"
[ebuild U ~] gnome-extra/gucharmap-3.6.1 [3.2.2] USE="-vala%"
[ebuild U ~] games-board/aisleriot-3.2.3.2-r1 [3.2.2]
[ebuild U ] x11-misc/xdg-user-dirs-gtk-0.9 [0.8-r1]
[ebuild U ~] x11-libs/gtksourceview-3.6.2 [3.2.3]
[ebuild U ~] x11-misc/notification-daemon-0.7.6 [0.7.3]
[ebuild U ~] net-misc/vino-3.6.2-r1 [3.2.2]
[ebuild U ~] net-analyzer/gnome-nettool-3.2.0 [3.0.1]
[ebuild U ~] gnome-extra/gcalctool-6.6.2 [6.2.0]
[ebuild U ~] gnome-extra/gtkhtml-4.6.2 [4.2.3]
[ebuild U ~] dev-cpp/gtkmm-3.6.0 [3.2.0] USE="X%* (-aqua) (-wayland)"
[ebuild U ~] x11-terms/gnome-terminal-3.6.1-r2 [3.2.1]
[ebuild U ~] media-libs/clutter-gtk-1.4.2 [1.0.4]
[ebuild U ~] gnome-extra/zenity-3.6.0 [3.2.0] USE="{-test%}"
[ebuild U ~] gnome-extra/gnome-games-3.6.1-r1 [3.2.1-r1] USE="glchess*" PYTHON_TARGETS="python2_7%* -python2_6%"
[ebuild U ~] gnome-extra/gnome-system-monitor-3.6.1 [3.2.1] USE="-systemd%"
[ebuild U ~] app-accessibility/caribou-0.4.7 [0.4.1] PYTHON_TARGETS="python2_7%* -python2_6%"
[ebuild U ~] media-gfx/eog-3.6.2 [3.2.2]
[ebuild U ~] gnome-extra/yelp-3.6.2 [3.2.1]
[ebuild U ~] gnome-extra/gnome-screensaver-3.6.1 [3.2.0] USE="-systemd%"
[ebuild U ~] x11-libs/mx-1.4.7 [1.3.1]
[ebuild U ~] x11-wm/metacity-2.34.13 [2.34.1]
[ebuild U ~] x11-wm/mutter-3.6.2 [3.2.2] USE="-debug%"
[ebuild U ] media-libs/libchamplain-0.12.3 [0.12.1]
[ebuild U ~] net-libs/gnome-online-accounts-3.6.2 [3.2.1] USE="-kerberos%"
[ebuild N ~] net-libs/libzapojit-0.0.2 USE="introspection"
[ebuild U ~] gnome-base/nautilus-3.6.3 [3.2.1-r1] USE="-debug%"
[ebuild U ~] gnome-extra/sushi-3.6.1 [0.2.1] USE="-office%"
[ebuild U ~] app-arch/file-roller-3.6.3 [3.2.1]
[ebuild U ~] app-cdr/brasero-3.6.1 [3.2.0-r1]
[ebuild N ~] app-crypt/gcr-3.6.2 USE="introspection -debug {-test}"
[ebuild U ~] gnome-base/gnome-keyring-3.6.2 [3.2.2] USE="(-selinux)"
[blocks b ] <gnome-base/gnome-keyring-3.3 ("<gnome-base/gnome-keyring-3.3" is blocking app-crypt/gcr-3.6.2)
[ebuild U ~] dev-libs/libgdata-0.13.2-r2 [0.10.1]
[ebuild U ~] gnome-extra/evolution-data-server-3.6.3 [3.2.3] USE="vala* -api-doc-extras%"
[ebuild U ~] www-client/epiphany-3.6.1 [3.2.1] USE="jit%*"
[ebuild U ~] mail-client/evolution-3.6.3 [3.2.3]
[ebuild N ] dev-python/gnome-keyring-python-2.32.0 USE="-examples"
[ebuild U ~] app-crypt/seahorse-3.6.3 [3.2.2]
[ebuild U ] app-office/libreoffice-3.6.4.3 [3.4.3.2-r1] USE="cups%* webdav* -binfilterdebug% -jemalloc% -postgres%" LIBREOFFICE_EXTENSIONS="presenter-console%* presenter-minimizer%* -nlpsolver% -pdfimport% -scripting-beanshell% -scripting-javascript% -wiki-publisher%"
[blocks b ] <app-office/libreoffice-3.6 ("<app-office/libreoffice-3.6" is blocking app-office/libreoffice-l10n-3.6.4.3)
[ebuild U ] app-mobilephone/obexd-0.46 [0.42]
[ebuild N ~] app-admin/gnome-system-log-3.6.1
[ebuild N ~] media-gfx/gnome-font-viewer-3.6.1
[ebuild N ~] media-gfx/gnome-screenshot-3.6.1
[ebuild N ~] sys-apps/baobab-3.6.3
[ebuild N ~] gnome-extra/gnome-search-tool-3.6.0
[ebuild N ~] app-dicts/gnome-dictionary-3.6.0 USE="-debug -ipv6"
[uninstall ] gnome-extra/gnome-utils-3.2.1
[blocks b ] <gnome-extra/gnome-utils-3.4 ("<gnome-extra/gnome-utils-3.4" is blocking media-gfx/gnome-font-viewer-3.6.1, app-admin/gnome-system-log-3.6.1, app-dicts/gnome-dictionary-3.6.0, media-gfx/gnome-screenshot-3.6.1, gnome-extra/gnome-search-tool-3.6.0, sys-apps/baobab-3.6.3)
[ebuild U ~] gnome-extra/gnome-tweak-tool-3.6.1-r1 [3.2.2-r2] PYTHON_TARGETS="python2_7%* -python2_6%"
[ebuild U ] net-libs/libsocialweb-0.25.21 [0.25.20]
[ebuild U ~] dev-libs/folks-0.8.0 [0.6.6] USE="telepathy%* vala*"
[ebuild U ~] gnome-extra/gnome-contacts-3.6.2 [3.2.2] USE="-v4l%"
[ebuild NS ~] media-plugins/gst-plugins-v4l2-1.0.3 [0.10.30] USE="udev"
[ebuild U ~] media-video/cheese-3.6.2 [3.2.2] USE="-sendto% {-test%}"
[ebuild U ~] gnome-base/gnome-panel-3.6.2 [3.2.1]
[ebuild U ~] net-im/telepathy-mission-control-5.14.0-r1 [5.10.1] USE="-connman% -debug%"
[ebuild N ] app-misc/media-player-info-17
[ebuild N ] media-plugins/alsa-plugins-1.0.25-r1 USE="pulseaudio -debug -ffmpeg -jack -libsamplerate -speex"
[ebuild U ] media-sound/pulseaudio-2.1-r1 [0.9.22-r2] USE="gdbm%* gtk%* orc%* ssl%* webrtc-aec%* -equalizer% (-systemd) -xen%"
[ebuild U ] media-sound/mpg123-1.14.4 [1.13.2] USE="-int-quality%"
[ebuild NS ~] media-plugins/gst-plugins-pulse-1.0.3 [0.10.30]
[ebuild NS ~] media-plugins/gst-plugins-meta-1.0-r1 [0.10-r6] USE="X a52 aac alsa cdda dts dvd flac mp3 mpeg ogg pulseaudio vorbis x264 -dv -dvb -ffmpeg -http -jack -lame -libass -libvisual -mms -opus -oss -taglib -theora -v4l -vcd -vpx -wavpack"
[ebuild U ] net-libs/gtk-vnc-0.5.1 [0.5.0] USE="pulseaudio%*"
[ebuild U ~] net-misc/vinagre-3.6.2 [3.2.2] USE="-rdp% -spice%"
[ebuild U ~] media-video/totem-3.6.3-r1 [3.2.1] USE="-flash% {-test%} -zeitgeist%" PYTHON_SINGLE_TARGET="python2_7%* -python2_6%" PYTHON_TARGETS="python2_7%* -python2_6%"
[ebuild U ] media-plugins/gst-plugins-pulse-0.10.31 [0.10.30]
[ebuild U ] media-libs/libao-1.1.0-r1 [1.0.0-r1]
[ebuild U ] media-sound/orpheus-1.6-r2 [1.6-r1]
[ebuild U ~] media-sound/sound-juicer-3.5.1_pre20121231 [2.99.0_pre20111001] USE="flac%* vorbis%*"
[ebuild U ] dev-libs/libatasmart-0.19 [0.18]
[ebuild N ] sys-fs/cryptsetup-1.4.3 USE="nls udev (-selinux) -static -static-libs"
[ebuild U ~] gnome-base/gnome-applets-3.6.0-r1 [3.2.1] PYTHON_SINGLE_TARGET="python2_7%* -python2_6%" PYTHON_TARGETS="python2_7%* -python2_6%"
[ebuild U ~] media-gfx/shotwell-0.13.1-r2 [0.11.6] LINGUAS="-ar% -ast% -bg% -bn% -ca% -cs% -da% -de% -el% -en_GB% -es% -et% -eu% -fi% -fr% -gl% -he% -hi% -hr% -hu% -ia% -id% -it% -ja% -kk% -ko% -lt% -lv% -mk% -nb% -nl% -pa% -pl% -pt% -pt_BR% -ro% -ru% -sk% -sl% -sr% -sv% -ta% -ta_IN% -te% -te_IN% -th% -tr% -uk% -vi% -zh_CN% -zh_TW%"
[ebuild N ~] app-admin/openrc-settingsd-1.0.1 USE="-systemd"
[ebuild U ] net-print/cups-pk-helper-0.2.4 [0.2.1]
[ebuild N ] app-text/xmlto-0.0.24-r1 USE="-latex"
[ebuild U ~] app-editors/gedit-3.6.2-r1 [3.2.6] USE="-zeitgeist%" PYTHON_SINGLE_TARGET="python2_7%* -python2_6%"
_________________
“I refuse to answer that question on the grounds that I don't know the answer”
Back to top
View user's profile Send private message
phajdan.jr
Developer
Developer


Joined: 23 Mar 2006
Posts: 1767
Location: Poland

PostPosted: Sun Feb 10, 2013 10:27 am    Post subject: Re: Portage has Blocked Packages and Circular Dependencies. Reply with quote

Phredus wrote:
Code:
root@gn2box>~ emerge --update --deep --autounmask-write --with-bdeps=y --newuse world
!!! Found 2 make.conf files, using both '/etc/make.conf' and '/etc/portage/make.conf'


Please sort that out. I suggest making /etc/portage/make.conf the canonical copy and removing /etc/make.conf .

I don't see actual errors in the output you've posted. The "small b" blocks are resolved automatically by portage.
_________________
http://phajdan-jr.blogspot.com/
Back to top
View user's profile Send private message
Phredus
n00b
n00b


Joined: 07 Feb 2013
Posts: 37

PostPosted: Sun Feb 10, 2013 10:54 am    Post subject: Reply with quote

output got truncated sorry the error about Blocked Packages is at the end.
Code:
[ebuild  N    ~] app-admin/openrc-settingsd-1.0.1  USE="-systemd"
[ebuild     U  ] net-print/cups-pk-helper-0.2.4 [0.2.1]
[ebuild  N     ] app-text/xmlto-0.0.24-r1  USE="-latex"
[ebuild     U ~] app-editors/gedit-3.6.2-r1 [3.2.6] USE="-zeitgeist%" PYTHON_SINGLE_TARGET="python2_7%* -python2_6%" PYTHON_TARGETS="python2_7%* -python2_6%"
[ebuild     U ~] gnome-extra/gnome-power-manager-3.6.0 [3.2.1]
[ebuild  N    ~] sci-geosciences/geocode-glib-0.99.0  USE="introspection {-test}"
[ebuild  N     ] net-libs/gupnp-0.18.3  USE="introspection -connman -networkmanager"
[ebuild  N     ] net-libs/gupnp-igd-0.2.1  USE="introspection -python"
[ebuild     U  ] net-libs/libnice-0.1.3-r1 [0.1.0] USE="upnp*"
[ebuild  N    ~] media-plugins/gst-plugins-libnice-0.1.3-r100
[ebuild  N    ~] net-libs/farstream-0.2.2  USE="introspection -msn {-test} -upnp"
[ebuild  N    ~] net-libs/telepathy-farstream-0.6.0  USE="introspection -examples"
[ebuild     U ~] net-im/empathy-3.6.3 [3.2.2] USE="geocode%* gnome%*"
[ebuild     U  ] sys-auth/polkit-0.110 [0.102] USE="(-selinux) (-systemd)"
[ebuild     U  ] sys-power/upower-0.9.19 [0.9.13-r1] USE="(-systemd)"
[ebuild     U #] net-misc/networkmanager-0.9.7.995 [0.9.2.0-r2] USE="consolekit%* wext%* -modemmanager% -systemd% {-test%} -vala%"
[ebuild     U  ] gnome-extra/nm-applet-0.9.6.4 [0.9.2.0-r1] USE="-gconf%"
[ebuild  N     ] app-admin/system-config-printer-common-1.3.11-r1  USE="policykit -doc"
[ebuild  N     ] app-admin/system-config-printer-gnome-1.3.11  USE="gnome-keyring" LINGUAS="-ar -as -bg -bn -bn_IN -br -bs -ca -cs -cy -da -de -el -en_GB -es -et -fa -fi -fr -gu -he -hi -hr -hu -hy -id -is -it -ja -ka -kn -ko -lo -lv -mai -mk -ml -mr -ms -nb -nl -nn -or -pa -pl -pt -pt_BR -ro -ru -si -sk -sl -sr -sr@latin -sv -ta -te -th -tr -uk -vi -zh_CN -zh_TW"
[ebuild     U ~] app-misc/tracker-0.14.4 [0.12.9] USE="iso%* miner-fs%* -cue% (-eds*) -upnp-av% -xps%"
[ebuild     U ~] gnome-extra/nautilus-tracker-tags-0.14.4 [0.12.9]
[ebuild     U ~] gnome-extra/gnome-documents-3.6.2 [0.2.1]
[ebuild     U ~] x11-misc/colord-0.1.28 [0.1.16] USE="-extra-print-profiles% -systemd%"
[uninstall     ] media-gfx/shared-color-profiles-0.1.4
[blocks b      ] media-gfx/shared-color-profiles ("media-gfx/shared-color-profiles" is blocking x11-misc/colord-0.1.28)
[blocks b      ] >=x11-misc/colord-0.1.27 (">=x11-misc/colord-0.1.27" is blocking media-gfx/shared-color-profiles-0.1.4)
[ebuild  N     ] x11-libs/colord-gtk-0.1.24  USE="introspection -doc -vala"
[ebuild  N    ~] gnome-extra/gnome-color-manager-3.6.1  USE="-clutter (-packagekit) -raw"
[ebuild     U ~] gnome-base/gnome-settings-daemon-3.6.4 [3.2.2-r1] USE="i18n%* -systemd%" INPUT_DEVICES="-wacom%"
[ebuild     U  ] media-sound/banshee-2.4.1 [2.2.0-r1] USE="bpm%*"
[ebuild     U ~] gnome-base/gnome-control-center-3.6.3-r1 [3.2.2] USE="bluetooth%* gnome-online-accounts%* i18n%* -kerberos% -systemd% -v4l%" INPUT_DEVICES="-wacom%"
[ebuild     U  ] sys-auth/consolekit-0.4.5_p20120320-r1 [0.4.5-r1] USE="acl%* (-selinux)"
[ebuild     U ~] sys-auth/pambase-20120417-r1 [20101024-r2] USE="-systemd%"
[ebuild     U ~] gnome-base/gnome-shell-3.6.2-r1 [3.2.2.1] USE="i18n%* -systemd%" PYTHON_TARGETS="python2_7%* -python2_6%"
[ebuild     U ~] gnome-base/gdm-3.6.2 [3.2.1.1-r2] USE="ldap%* -audit% -plymouth% -systemd%"
[ebuild     U  ] app-admin/sudo-1.8.6_p3 [1.8.5_p2]
[ebuild  N     ] sys-fs/udev-init-scripts-22
[ebuild     U  ] sys-apps/util-linux-2.21.2 [2.19.1-r1] USE="udev%* -ddate% -static-libs%"
[ebuild     U  ] sys-apps/sysvinit-2.88-r3 [2.88-r2]
[blocks b      ] <sys-apps/sysvinit-2.88-r3 ("<sys-apps/sysvinit-2.88-r3" is blocking sys-apps/util-linux-2.21.2)
[ebuild     U  ] sys-fs/udev-197-r4 [164-r2] USE="acl%* gudev%* hwdb%* introspection%* keymap%* kmod%* openrc%* -doc% -static-libs%"
[blocks b      ] <sys-fs/udev-186 ("<sys-fs/udev-186" is blocking sys-fs/udev-init-scripts-22)
[blocks b      ] <sys-fs/udev-171-r9999[extras] ("<sys-fs/udev-171-r9999[extras]" is blocking sys-auth/consolekit-0.4.5_p20120320-r1)
[ebuild  NS    ] sys-fs/udisks-2.0.91 [1.0.4-r1] USE="crypt gptfdisk introspection -debug (-selinux) (-systemd)"
[ebuild     U ~] gnome-base/gvfs-1.14.2 [1.10.1] USE="gtk%* udisks%* -gdu* -systemd%"
[ebuild     U  ] x11-drivers/xf86-video-ati-7.0.0 [6.14.3] USE="udev%* (-glamor)"
[ebuild     U ~] gnome-base/gnome-core-libs-3.6.2 [3.2.1]
[ebuild     U  ] sys-fs/lvm2-2.02.97-r1 [2.02.73-r1] USE="thin%* udev%* -static* -static-libs%"
[blocks b      ] <sys-fs/lvm2-2.02.97-r1 ("<sys-fs/lvm2-2.02.97-r1" is blocking sys-fs/udev-197-r4)
[ebuild     U  ] media-gfx/gimp-2.6.12-r5 [2.6.11-r5] LINGUAS="-am% -ar% -ast% -az% -be% -bg% -ca% -ca@valencia% -cs% -da% -de% -dz% -el% -en_CA% -en_GB% -eo% -es% -et% -eu% -fa% -fi% -fr% -ga% -gl% -gu% -he% -hi% -hr% -hu% -id% -is% -it% -ja% -ka% -kk% -km% -kn% -ko% -lt% -lv% -mk% -ml% -mr% -ms% -my% -nb% -nds% -ne% -nl% -nn% -oc% -or% -pa% -pl% -pt% -pt_BR% -ro% -ru% -rw% -si% -sk% -sl% -sr% -sr@latin% -sv% -ta% -th% -tr% -tt% -uk% -vi% -xh% -yi% -zh_CN% -zh_HK% -zh_TW%"
[ebuild     U  ] www-client/chromium-24.0.1312.56 [16.0.912.77] USE="-custom-cflags% (-selinux) (-tcmalloc)" LINGUAS="-ms%"
[ebuild     U ~] gnome-base/gnome-core-apps-3.6.2 [3.2.1]
[ebuild     U ~] gnome-base/gnome-fallback-3.6.2 [3.2.1]
[ebuild     U ~] gnome-base/gnome-extra-apps-3.6.2 [3.2.1]
[ebuild     U ~] gnome-base/gnome-3.6.2 [3.2.1] USE="bluetooth%*"
[ebuild     U  ] sys-libs/talloc-2.0.7 [2.0.1-r2] USE="-python%"
[ebuild     U  ] net-fs/samba-3.6.9 [3.5.15] USE="-dmapi% (-selinux)"
[blocks B      ] net-fs/cifs-utils ("net-fs/cifs-utils" is blocking net-fs/samba-3.5.15)
[blocks B      ] <sys-apps/shadow-4.1.5-r1 ("<sys-apps/shadow-4.1.5-r1" is blocking sys-auth/pambase-20120417-r1)
[blocks B      ] <sys-libs/talloc-2.0.5 ("<sys-libs/talloc-2.0.5" is blocking sys-libs/talloc-2.0.7)
[blocks B      ] <net-fs/samba-3.6_rc1 ("<net-fs/samba-3.6_rc1" is blocking net-fs/cifs-utils-5.6-r1)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-libs/talloc-2.0.7::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-libs/talloc-2.0.5 required by (net-fs/samba-3.6.9::gentoo, ebuild scheduled for merge)

  (net-fs/cifs-utils-5.6-r1::gentoo, ebuild scheduled for merge) pulled in by
    net-fs/cifs-utils required by (net-fs/samba-3.6.9::gentoo, ebuild scheduled for merge)

  (sys-apps/shadow-4.1.4.3::gentoo, installed) pulled in by
    >=sys-apps/shadow-4.1 required by (virtual/shadow-0::gentoo, ebuild scheduled for merge)

  (sys-auth/pambase-20120417-r1::gentoo, ebuild scheduled for merge) pulled in by
    sys-auth/pambase required by (sys-apps/openrc-0.11.8::gentoo, ebuild scheduled for merge)
    sys-auth/pambase required by (app-admin/sudo-1.8.6_p3::gentoo, ebuild scheduled for merge)
    sys-auth/pambase[consolekit] required by (sys-auth/polkit-0.110::gentoo, ebuild scheduled for merge)
    sys-auth/pambase[consolekit] required by (gnome-base/gdm-3.6.2::gentoo, ebuild scheduled for merge)
    >=sys-auth/pambase-20081028 required by (net-misc/openssh-5.9_p1-r4::gentoo, ebuild scheduled for merge)
    sys-auth/pambase required by (sys-auth/polkit-0.110::gentoo, ebuild scheduled for merge)
    sys-auth/pambase required by (sys-libs/pam-1.1.6-r2::gentoo, ebuild scheduled for merge)
    >=sys-auth/pambase-20080219.1 required by (sys-apps/shadow-4.1.4.3::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked

root@gn2box>~

_________________
“I refuse to answer that question on the grounds that I don't know the answer”
Back to top
View user's profile Send private message
Phredus
n00b
n00b


Joined: 07 Feb 2013
Posts: 37

PostPosted: Sun Feb 10, 2013 11:10 am    Post subject: Reply with quote

Thank you so much for your quick reply phajdan.jr, I really am confused here.

In reply to your suggestion should I copy the contents of /etc/make.conf to /etc/portage/make.conf

Quote:
root@gn2box>~ vi /etc/make.conf
# These settings were set by the catalyst build script that automatically
# built this stage.
# Please consult /usr/share/portage/config/make.conf.example for a more
# detailed example.
CFLAGS="-O2 -march=i686 -pipe"
CXXFLAGS="${CFLAGS}"
# WARNING: Changing your CHOST is not something that should be done lightly.
# Please consult http://www.gentoo.org/doc/en/change-chost.xml before changing.
CHOST="i686-pc-linux-gnu"
MAKEOPTS="-j2"
GENTOO_MIRRORS="http://www.gtlib.gatech.edu/pub/gentoo ftp://ftp.gtlib.gatech.edu/pub/gentoo http://lug.mtu.edu/gentoo/ ftp://lug.mtu.edu/gentoo/ http://ftp.ucsb.edu/pub/mirrors/linux/gentoo/ ftp://ftp.ucsb.edu/pub/mirrors/linux/gentoo/"
SYNC="rsync://rsync.us.gentoo.org/gentoo-portage"
USE="symlink X gnome dbus samba smbsharemodes kerberos pam readline winbind -x python -qt4 -kde -evdev gtk gnome hal dvd cdda -udev alsa cdr sqlite static-libs"
ACCEPT_LICENSE="dlj-1.1"
VIDEO_CARDS="radeon"
USE_PYTHON="2.6 2.7 3.1"
INPUT_DEVICES="mouse keyboard"
LINGUAS="en"


#-----------------------------
XUSE="truetype X new-login xorg xscreensaver xv xcomposite xinerama opengl aiglx"
IMAGEUSE="jpeg gif tiff png svg pdf"
MEDIAUSE="alsa mad vidix asf win32codecs dvd mp4 aac cdda x264 xvid nsplugin mp3 real gstreamer"
GENERAL="samba java bzip2 symlink sqlite spell xml"
SYSTEM="hal fam dbus aoss threads"
NOTUSE="-arts -qt4 -ipv6"
KDEUSE="-kde -qt3"
GNOMEUSE="gtk cairo glitz gnome firefox"

USE="${NOTUSE} ${SYSTEM} ${GENERAL} ${IMAGEUSE} ${XUSE} ${KDEUSE} ${MEDIAUSE} ${GNOMEUSE}"
#------------------------------
source /var/lib/layman/make.conf
~


and

Quote:
root@gn2box>~ vi /etc/portage/make.conf
#USE="~x86introspection ipv6 python_single_target_python2_7 vala dconf libkms theora minizip bluetooth cdda gnome-keyring gtk http udisks -afp -archive -avahi -bluray -doc -fuse -gdu -gphoto2 -ios -samba -systemd -openrc bluetooth%* cdr cups extras fallback -accessibility bluetooth cdda gnome-keyring gtk http udisks -afp -archive -avahi -bluray -doc -fuse -gdu -gphoto2 -ios -samba -systemd udev X a52 aac acl acpi alsa berkdb bluetooth bluetooth%* branding bzip2 cairo cdda cdr cli colord consolekit cracklib crypt cups cxx dbus dconf dri dts dvd dvdr eds emboss encode evo exif extras fallback fam firefox flac fortran gdbm gif gnome gnome-keyring gnome-online-accounts gpm gstreamer gtk http iconv ipv6 jpeg lcms ldap libkms libnotify mad minizip mng modules mp3 mp4 mpeg mudflap nautilus ncurses nls nptl ogg opengl openmp pam pango pcre pdf png policykit ppds pulseaudio qt3support qt4 readline sdl session socialweb spell ssl startup-notification svg tcpd theora tiff truetype udev udisks unicode upower usb vala vorbis wxwidgets x264 x86 xcb xml xv xvid zlib ~x86introspection"
~

_________________
“I refuse to answer that question on the grounds that I don't know the answer”
Back to top
View user's profile Send private message
Napalm Llama
Guru
Guru


Joined: 04 Jun 2005
Posts: 520
Location: Swansea, UK

PostPosted: Sun Feb 10, 2013 7:33 pm    Post subject: Reply with quote

It looks like your /etc/portage/make.conf file contains only one line, commented out. Any line beginning with a # is a comment and gets ignored by Portage. Assuming you've accurately copied the entire contents of that file into your post, it should be safe to delete it and replace with the other, fuller one.
_________________
splig: amd64; nForce3; sata; GeForce 6600gt agp
muttley: EFIKA 5200B - PPC SoC :)

Registered Linux User #381314
# killall humans
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5428

PostPosted: Sun Feb 10, 2013 8:07 pm    Post subject: Reply with quote

On a semi-related note: the way you aggregate useflags is not correct - make.conf is exported verbatim by portage, so you're polluting your environment.
Back to top
View user's profile Send private message
Napalm Llama
Guru
Guru


Joined: 04 Jun 2005
Posts: 520
Location: Swansea, UK

PostPosted: Sun Feb 10, 2013 8:36 pm    Post subject: Reply with quote

It's quite a nice way of tidying it up though, isn't it? Do you know of a non-pollutey way of doing the same thing?
_________________
splig: amd64; nForce3; sata; GeForce 6600gt agp
muttley: EFIKA 5200B - PPC SoC :)

Registered Linux User #381314
# killall humans
Back to top
View user's profile Send private message
Hu
Watchman
Watchman


Joined: 06 Mar 2007
Posts: 8845

PostPosted: Sun Feb 10, 2013 10:35 pm    Post subject: Reply with quote

Napalm Llama wrote:
It's quite a nice way of tidying it up though, isn't it? Do you know of a non-pollutey way of doing the same thing?
As VoidMage said, that style pollutes the environment. I have seen people post build failures that are ultimately traced to environmental pollution from make.conf. I believe at least one of them was a failure because he had set SYSTEM= in make.conf, as shown above. If the flags must be split out over multiple lines, they should be grouped, with comments explaining them.

[Edit: rephrased the post to be less pointed. It was originally written as though Napalm Llama were directly advocating the pollution style, which is not the case.]


Last edited by Hu on Tue Feb 12, 2013 2:13 am; edited 1 time in total
Back to top
View user's profile Send private message
Napalm Llama
Guru
Guru


Joined: 04 Jun 2005
Posts: 520
Location: Swansea, UK

PostPosted: Mon Feb 11, 2013 6:41 pm    Post subject: Reply with quote

Phredus, do these things:

  • Delete your /etc/portage/make.conf (it has nothing useful in it)
  • Go into your /etc/make.conf
  • Take out all your XUSE, IMAGEUSE, MEDIAUSE etc. lines; you shouldn't set arbitrary variable names in that file
  • Take out both USE= lines (the one at the bottom and the one further up)
  • Create a new, blank USE entry and populate it with the bare minimum of flags.
  • Save the file.
  • Optionally move the file to /etc/portage/make.conf, as that is the new preferred location for it.


Hints:

  • Consult /usr/share/portage/config/make.conf.example (as suggested in the comments in /etc/make.conf)
  • If you set USE="something" and then, later on, set USE="something-else", the original USE will be overwritten. This is pointless; don't do it.
  • You don't need masses of USE flags. Most packages come with sensible defaults.
  • The USE flags you do have should be specific to your system and your needs. Here is a good example based on mine:
    USE="3dnow 3dnowext bash-completion bluetooth gnome -kde mmx mmxext sse sse2 xcomposite xinerama"
    Most of the flags are either telling packages which specific hardware features I want them to support (eg. sse2, xinerama, bluetooth) or tell them about my software configuration (eg. gnome -kde). I don't set much else in there, because I don't need to. Where a specific package has to have a specific USE flag, I set it just for that package using /etc/portage/package.use.
  • For a full list of possible USE flags, see here: http://www.gentoo.org/dyn/use-index.xml
  • For an idea what instruction sets your CPU supports, do this: grep flags /proc/cpuinfo


Perhaps one of you admins would know of a good source of documentation for further reading?
_________________
splig: amd64; nForce3; sata; GeForce 6600gt agp
muttley: EFIKA 5200B - PPC SoC :)

Registered Linux User #381314
# killall humans
Back to top
View user's profile Send private message
Phredus
n00b
n00b


Joined: 07 Feb 2013
Posts: 37

PostPosted: Tue Feb 12, 2013 2:09 am    Post subject: Reply with quote

I did as you suggested, I am not 100% comfortable with all the entries in the /etc/portage/make.conf file but have removes all the funky labels, moved the file, deleted the other and only have one now.
I un-installed samba and openssh, that has gotten rid of most of the block b errors.
Now I'm stuck here I un-installed sys-apps/shadow however when I run emerge it says that sys-apps/shadow is blocking sys-auth/pambase from installing (I am not familiar with sys-auth/pambase and afraid of what it will do to the system if I un-install it) here's the output:



Code:

root@gn2box>~ emerge --update --deep --with-bdeps=y --newuse world
Calculating dependencies... done!
[ebuild     U  ] sys-kernel/linux-headers-3.6 [3.1]
[ebuild     U  ] sys-libs/glibc-2.15-r3 [2.13-r4]
[ebuild     U  ] app-arch/xz-utils-5.0.4-r1 [5.0.3] USE="static-libs*"
[ebuild   R    ] app-arch/bzip2-1.0.6-r3  USE="static-libs*"
[ebuild     U  ] dev-libs/expat-2.1.0-r2 [2.0.1-r5] USE="static-libs* unicode%*"
[ebuild  N     ] dev-python/python-exec-0.2  PYTHON_TARGETS="(jython2_5) (python2_5) (python2_6) (python2_7) (python3_1) (python3_2) (-pypy1_9) (-pypy2_0) (-python3_3)"
[ebuild     U  ] dev-libs/icu-49.1.2 [4.8.1-r2] USE="static-libs*"
[ebuild     U  ] sys-devel/gnuconfig-20121010 [20110202]
[ebuild   R    ] sys-apps/tcp-wrappers-7.6-r8  USE="ipv6*"
[ebuild     U  ] app-misc/mime-types-9 [8]
[ebuild     U  ] sys-libs/timezone-data-2012f [2011n]
______________________________________________________________________________________________________________________________________________________________________

************Large middle portion of output text is intentionally left out to preven it from getting truncated and because it may be irrelevant.*********************
______________________________________________________________________________________________________________________________________________________________________

[ebuild     U  ] x11-drivers/xf86-video-ati-7.0.0 [6.14.3] USE="udev%* (-glamor)"
[ebuild     U  ] media-gfx/gimp-2.6.12-r5 [2.6.11-r5] USE="python*" LINGUAS="-am% -ar% -ast% -az% -be% -bg% -ca% -ca@valencia% -cs% -da% -de% -dz% -el% -en_CA% -en_GB% -eo% -es% -et% -eu% -fa% -fi% -fr% -ga% -gl% -gu% -he% -hi% -hr% -hu% -id% -is% -it% -ja% -ka% -kk% -km% -kn% -ko% -lt% -lv% -mk% -ml% -mr% -ms% -my% -nb% -nds% -ne% -nl% -nn% -oc% -or% -pa% -pl% -pt% -pt_BR% -ro% -ru% -rw% -si% -sk% -sl% -sr% -sr@latin% -sv% -ta% -th% -tr% -tt% -uk% -vi% -xh% -yi% -zh_CN% -zh_HK% -zh_TW%"
[ebuild     U  ] www-client/chromium-24.0.1312.56 [16.0.912.77] USE="kerberos* -custom-cflags% (-selinux) (-tcmalloc)" LINGUAS="-ms%"
[ebuild     U ~] gnome-base/gnome-core-apps-3.6.2 [3.2.1]
[ebuild     U ~] gnome-base/gnome-fallback-3.6.2 [3.2.1]
[ebuild     U ~] gnome-base/gnome-extra-apps-3.6.2 [3.2.1]
[ebuild     U ~] gnome-base/gnome-3.6.2 [3.2.1] USE="bluetooth%*"
[blocks B      ] <sys-apps/shadow-4.1.5-r1 ("<sys-apps/shadow-4.1.5-r1" is blocking sys-auth/pambase-20120417-r1)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-apps/shadow-4.1.4.3::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-apps/shadow-4.1 required by (virtual/shadow-0::gentoo, ebuild scheduled for merge)

  (sys-auth/pambase-20120417-r1::gentoo, ebuild scheduled for merge) pulled in by
    sys-auth/pambase required by (sys-apps/openrc-0.11.8::gentoo, ebuild scheduled for merge)
    sys-auth/pambase required by (app-admin/sudo-1.8.6_p3::gentoo, ebuild scheduled for merge)
    sys-auth/pambase[consolekit] required by (sys-auth/polkit-0.110::gentoo, ebuild scheduled for merge)
    sys-auth/pambase[consolekit] required by (gnome-base/gdm-3.6.2::gentoo, ebuild scheduled for merge)
    >=sys-auth/pambase-20081028 required by (net-misc/openssh-5.9_p1-r4::gentoo, ebuild scheduled for merge)
    sys-auth/pambase required by (sys-auth/polkit-0.110::gentoo, ebuild scheduled for merge)
    sys-auth/pambase required by (sys-libs/pam-1.1.6-r2::gentoo, ebuild scheduled for merge)
    >=sys-auth/pambase-20080219.1 required by (sys-apps/shadow-4.1.4.3::gentoo, ebuild scheduled for merge)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked

root@gn2box>~ emerge --unmerge sys-apps/shadow
 * This action can remove important packages! In order to be safer, use
 * `emerge -pv --depclean <atom>` to check for reverse dependencies before
 * removing packages.

--- Couldn't find 'sys-apps/shadow' to unmerge.

>>> No packages selected for removal by unmerge
root@gn2box>~

_________________
“I refuse to answer that question on the grounds that I don't know the answer”
Back to top
View user's profile Send private message
Napalm Llama
Guru
Guru


Joined: 04 Jun 2005
Posts: 520
Location: Swansea, UK

PostPosted: Wed Feb 13, 2013 8:27 pm    Post subject: Reply with quote

The version of pambase your system is trying to pull in is masked - the current stable version is 20101024-r2. Have you unmasked it somewhere?
_________________
splig: amd64; nForce3; sata; GeForce 6600gt agp
muttley: EFIKA 5200B - PPC SoC :)

Registered Linux User #381314
# killall humans
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum