Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Laptop is shutting off
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
bangerbros
n00b
n00b


Joined: 17 Apr 2012
Posts: 10

PostPosted: Sat Feb 09, 2013 8:46 pm    Post subject: Laptop is shutting off Reply with quote

Hi all, i got some troubles. My computer is always shutting off during an emerge or a kernel compilation.

I looked up to my temp during some emerge, and it's still under 70 C. The critic temp is fixed to 105 C. So i think it isn't a term issue.

I would like to see what it's going on just before the shutdown but i can't figure how. So i please you to help me.

My kernel version is 3.6.11, 64bits.

Thank you for your help.

My kernel config : http://bpaste.net/show/76283/
Back to top
View user's profile Send private message
PabloEsc
n00b
n00b


Joined: 24 Dec 2009
Posts: 39

PostPosted: Thu Feb 14, 2013 6:19 am    Post subject: Reply with quote

Look into various logs in /var/log to search for culprit.
In case of problems paste here what You think is relevant.
Back to top
View user's profile Send private message
bangerbros
n00b
n00b


Joined: 17 Apr 2012
Posts: 10

PostPosted: Sun Feb 17, 2013 12:41 pm    Post subject: Reply with quote

Hi, thank you for the reply

I checked /var/log/messages and i notices something weird

Quote:

Feb 15 19:42:52 diranna kernel: [ 0.244420] ACPI: Deprecated procfs I/F for AC is loaded, please retry with CONFIG_ACPI_PROCFS_POWER cleared
Feb 15 19:42:52 diranna kernel: [ 0.245242] ACPI: AC Adapter [ACAD] (off-line)
Feb 15 19:42:52 diranna kernel: [ 0.245481] input: Power Button as /devices/LNXSYSTM:00/device:00/PNP0C0C:00/input/input0
Feb 15 19:42:52 diranna kernel: [ 0.245562] ACPI: Power Button [PWRB]
Feb 15 19:42:52 diranna kernel: [ 0.245719] input: Lid Switch as /devices/LNXSYSTM:00/device:00/PNP0C0D:00/input/input1
Feb 15 19:42:52 diranna kernel: [ 0.245834] ACPI: Lid Switch [LID]
Feb 15 19:42:52 diranna kernel: [ 0.245986] input: Power Button as /devices/LNXSYSTM:00/LNXPWRBN:00/input/input2
Feb 15 19:42:52 diranna kernel: [ 0.246095] ACPI: Power Button [PWRF]
Feb 15 19:42:52 diranna kernel: [ 0.246362] ACPI: Requesting acpi_cpufreq
Feb 15 19:42:52 diranna kernel: [ 0.248859] Monitor-Mwait will be used to enter C-1 state
Feb 15 19:42:52 diranna kernel: [ 0.248867] Monitor-Mwait will be used to enter C-2 state
Feb 15 19:42:52 diranna kernel: [ 0.248872] Monitor-Mwait will be used to enter C-3 state
Feb 15 19:42:52 diranna kernel: [ 0.248877] tsc: Marking TSC unstable due to TSC halts in idle
Feb 15 19:42:52 diranna kernel: [ 0.248966] ACPI: acpi_idle registered with cpuidle
Feb 15 19:42:52 diranna kernel: [ 0.255090] thermal LNXTHERM:00: registered as thermal_zone0
Feb 15 19:42:52 diranna kernel: [ 0.255155] ACPI: Thermal Zone [THRM] (29 C)
Feb 15 19:42:52 diranna kernel: [ 0.255314] ACPI: Deprecated procfs I/F for battery is loaded, please retry with CONFIG_ACPI_PROCFS_POWER cleared
Feb 15 19:42:52 diranna kernel: [ 0.255406] ACPI: Battery Slot [BAT1] (battery absent)


Quote:

Feb 15 19:42:52 diranna kernel: [ 0.291292] ACPI Warning: 0x0000000000001c00-0x0000000000001c1f SystemIO conflicts with Region \_SB_.PCI0.SBUS.SMBI 1 (20120711/utaddress-251)
Feb 15 19:42:52 diranna kernel: [ 0.291464] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver


Quote:

Feb 15 19:42:52 diranna kernel: [ 0.568458] ACPI: Invalid Power Resource to register!


Quote:

Feb 15 23:40:59 diranna kernel: [ 0.046113] ACPI: Added _OSI(Processor Aggregator Device)
Feb 15 23:40:59 diranna kernel: [ 0.048943] ACPI: EC: Look up EC in DSDT
Feb 15 23:40:59 diranna kernel: [ 0.055931] [Firmware Bug]: ACPI: BIOS _OSI(Linux) query ignored


Quote:

Feb 16 08:29:27 diranna kernel: [ 0.175368] pci0000:00: ACPI _OSC support notification failed, disabling PCIe ASPM
Feb 16 08:29:27 diranna kernel: [ 0.175443] pci0000:00: Unable to request _OSC control (_OSC support mask: 0x08)


It's look something is going wrong with ACPI. [/quote]
Back to top
View user's profile Send private message
PabloEsc
n00b
n00b


Joined: 24 Dec 2009
Posts: 39

PostPosted: Mon Feb 18, 2013 8:36 am    Post subject: Reply with quote

I'd look into :
Code:
Deprecated procfs I/F for AC is loaded, please retry with CONFIG_ACPI_PROCFS_POWER cleared

and try to disable that kernel config option, build kernel and try with that.
Back to top
View user's profile Send private message
bangerbros
n00b
n00b


Joined: 17 Apr 2012
Posts: 10

PostPosted: Mon Feb 25, 2013 9:28 pm    Post subject: Reply with quote

Technician fixed my cpu fan, it wasn't spinning anymore. I did some tests, on Windows when the temp reachs 60~65 C, the fan starts, but in gentoo, i just hear it spinning a little bit and it doesn't start again since the shutting off. Bad kernel config ?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum