Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Wymusić na siłe flagę USE?
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish)
View previous topic :: View next topic  
Author Message
Xywa
l33t
l33t


Joined: 23 Jul 2005
Posts: 815
Location: /mnt/Gentoo/

PostPosted: Sat Feb 16, 2013 5:46 am    Post subject: Wymusić na siłe flagę USE? Reply with quote

Witam,

Mam pewien problem. Po dzisiejszym emerge --sync portage odcięło flagę ffmpeg z programu audacity-2.0.3 . Dzięki temu 'usprawnieniu' nie mogę wgrać pliku z filmem np. .MOV jak to czynłem kilkanaście godzin wcześniej. Probowałe zrobić nawet downgrade do Audacity 2.0.0 i ffmpeg nie ma :( Tzn. equery u w ogóle ne pokazuje a emerge -pv pokazuje w nawiasie (-ffmpeg).

Czy można jakoś wymusić, żeby mimo wszytsko skompilować Audacity z flagą ffmpeg, które przecież kompilowałem kilka dni wczesnie i dało radę (gdy zmieniałem ffmpeg na libav)? Przecież jak zaglądam do ebuilda Audacity to niby wsparcie dla dlagi ffmpeg jest.

Próbowalem # USE="ffmpeg" emerge audacity - ale nie pomogło.
Back to top
View user's profile Send private message
SlashBeast
Moderator
Moderator


Joined: 23 May 2006
Posts: 2799

PostPosted: Sat Feb 16, 2013 9:34 am    Post subject: Reply with quote

Za /var/portage/tree/profiles/base/package.use.mask:
Code:
# Alexis Ballier <aballier@gentoo.org> (15 Feb 2013)
# Needs a huge patch to build against recent releases of FFmpeg/libav.
# Mask it until upstream fixes it. Bug #417869
media-sound/audacity ffmpeg

_________________
BitBucket -- better-initramfs to address many usecases and linux's limitations.
Back to top
View user's profile Send private message
Xywa
l33t
l33t


Joined: 23 Jul 2005
Posts: 815
Location: /mnt/Gentoo/

PostPosted: Sat Feb 16, 2013 8:03 pm    Post subject: Reply with quote

SlashBeast wrote:
Za /var/portage/tree/profiles/base/package.use.mask:
Code:
# Alexis Ballier <aballier@gentoo.org> (15 Feb 2013)
# Needs a huge patch to build against recent releases of FFmpeg/libav.
# Mask it until upstream fixes it. Bug #417869
media-sound/audacity ffmpeg


Aaaaaaa...
To wszytsko wyjaśnia, dzięki za info.

Poradziłem sobie w inny sposób, audio wyciągam w kdenlive i potem już Audacity z nowym libsoxr śmiga.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum