Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[maj] conflits php [résolu partiellement]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
chris972
Tux's lil' helper
Tux's lil' helper


Joined: 02 Mar 2012
Posts: 97

PostPosted: Fri Feb 22, 2013 4:20 pm    Post subject: [maj] conflits php [résolu partiellement] Reply with quote

Bonjour,

Suite à importantes mises à jour sur un serveur perso, je me retrouve avec :
Code:
# emerge -DpuN world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] dev-lang/php-5.4.8

WARNING: One or more updates have been skipped due to a dependency conflict:

dev-lang/php:5.3

  (dev-lang/php-5.3.18::gentoo, ebuild scheduled for merge) conflicts with
    dev-lang/php[gd,imap,pdo,posix,session,sqlite,ssl,unicode,xml,zip,zlib,ldap,mysql] required by (www-apps/egroupware-1.8.004.20120613::gentoo, installed)

dev-lang/php:5.4

  (dev-lang/php-5.4.11-r2::gentoo, ebuild scheduled for merge) conflicts with
    <dev-lang/php-5.4.9[curl,gd,hash,json,mysql,pdo,simplexml,sqlite3,xmlwriter,zip] required by (www-apps/owncloud-4.5.7::gentoo, installed)

Et j'avoue ne pas y comprendre grand chose à ce qu'il réclame.
Déjà, c'est quand même bizarre qu'il veuille me réinstaller php-5.4.8 à chaque fois, et sans même indiquer la moindre raison (pas de maj, pas de newuse...)
Ensuite, autant je peux comprendre que egroupware pose des problèmes vu qu'il n'a pas été mis à jour depuis un bail, mais owncloud a été mis à jour dans portage aujourd'hui même.
En bidouillant un peu l'ebuild concernant les dépendances sqlite (puisqu'il semble que le noeud soit là, même si je ne sais même plus comment j'ai fait pour le déduire), je me retrouve dans la situation ou il me demande de démasquer (keywords) dev-lang/php-5.4.11-r2. Ce qui devient totalement incompréhensible pour moi.
Pourquoi veut-il installer cette version 5.4.11-r2 alors qu'elle n'est pas dans l'arbre stable gentoo ?
Ça me dépasse totalement ces messages, et vos explications seront les bienvenues.
Merci d'avance.


Last edited by chris972 on Tue Feb 26, 2013 3:28 pm; edited 1 time in total
Back to top
View user's profile Send private message
PabOu
Veteran
Veteran


Joined: 11 Feb 2004
Posts: 1073
Location: Hélécine - Belgium

PostPosted: Mon Feb 25, 2013 1:52 pm    Post subject: Reply with quote

Salut !

Tout d'abord pour dev-lang/php:5.4, c'est de la faute à www-apps/owncloud qui a des dépendances très particulières concernant php (tu peux le voir en éditant l'ebuild). En gros, avec tes useflags, il lui faut une version plus petite que php-5.4.9.

Ensuite, pour ce qui bloque l'emerge, dans la branche dev-lang/php:5.3, il te manque des useflags pour correspondre aux requirements de www-apps/egroupware... Essaye ceci :
Code:
echo "dev-lang/php gd imap pdo posix session sqlite ssl unicode xml zip zlib ldap mysql" >> /etc/portage/package.use

_________________
Mangez du poulet !
Back to top
View user's profile Send private message
chris972
Tux's lil' helper
Tux's lil' helper


Joined: 02 Mar 2012
Posts: 97

PostPosted: Mon Feb 25, 2013 2:16 pm    Post subject: Reply with quote

PabOu wrote:
Tout d'abord pour dev-lang/php:5.4, c'est de la faute à www-apps/owncloud qui a des dépendances très particulières concernant php (tu peux le voir en éditant l'ebuild). En gros, avec tes useflags, il lui faut une version plus petite que php-5.4.9.

Oui, supposons, et ?
Ceci dit, c'est la faute de owncloud (même si j'ai du mal à parler de faute. Il requiert tel ou tel use, oui, et alors ?) ou du packager de owncloud ?
La nuance est d'importance pour que je sache vers qui me tourner.
Et quand tu dis "avec TES useflags", de quel useflag parles-tu précisemment ? Parce que, si ça se trouve, c'est un choix que je peux modifier sans conséquence pour moi.
Enfin, comme je l'ai dit dans mon post initial, quand je bidouille l'ebuild de owncloud concernant les uses sqlite, il me réclame alors une version masquée de php:5.4. J'ai beau tourner ça dans tous les sens, ça ne me semble pas normal tout ça.

Quote:
Ensuite, pour ce qui bloque l'emerge, dans la branche dev-lang/php:5.3, il te manque des useflags pour correspondre aux requirements de www-apps/egroupware... Essaye ceci :
Code:
echo "dev-lang/php gd imap pdo posix session sqlite ssl unicode xml zip zlib ldap mysql" >> /etc/portage/package.use

Oui mais non, ça ne changera rien, car tous ces USES sont soit dans mes USES globaux, soit déjà affectés à php.
C'est bien pour ça que quand emerge me demande de recompiler php:5.4.8 (R), l n'indique AUCUNE raison; ni newuse, rien. Ça aussi je l'avais fait remarquer dans mon post initial, et ça non plus ça ne me semble pas normal.
Back to top
View user's profile Send private message
sebB
Apprentice
Apprentice


Joined: 02 Mar 2011
Posts: 195

PostPosted: Mon Feb 25, 2013 9:01 pm    Post subject: Reply with quote

Effectivement si on regarde l'ebuild, je ne comprends pas aussi pourquoi il faut démasque php.

J'ai fais une simulation si ca peut t'aider niveau use en ne mettant que ce qu'il me réclamait (je suis en stable).
Par contre il n'installe pas php-5.4.8 mais directement php-5.4.11

Code:
seb-PC seb # emerge -pv owncloud egroupware

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] dev-libs/oniguruma-5.9.2-r1  USE="-combination-explosion-check -crnl-as-line-terminator -static-libs" 528 kB
[ebuild  N     ] app-arch/cabextract-1.4  USE="-extra-tools" 218 kB
[ebuild  N     ] dev-libs/apr-1.4.5:1  USE="urandom uuid -doc -older-kernels-compatibility -static-libs" 738 kB
[ebuild  N     ] app-admin/webapp-config-1.50.16-r4  102 kB
[ebuild  N     ] dev-libs/libmcrypt-2.5.8-r2  1,304 kB
[ebuild  N     ] app-admin/eselect-php-0.6.2  2 kB
[ebuild  N     ] media-libs/t1lib-5.1.2:5  USE="X -doc -static-libs" 1,829 kB
[ebuild  N     ] media-fonts/corefonts-1-r4  USE="X" 3,843 kB
[ebuild  N     ] dev-db/mysql-init-scripts-2.0_pre1-r2  0 kB
[ebuild  N     ] dev-perl/Net-Daemon-0.480.0  29 kB
[ebuild  N     ] perl-core/Sys-Syslog-0.320.0  81 kB
[ebuild  N     ] net-libs/c-client-2007f-r4  USE="ipv6 pam ssl -chappa -doc -kerberos -static-libs -topal" 2,729 kB
[ebuild  N     ] virtual/cron-0  0 kB
[ebuild  N     ] dev-libs/apr-util-1.3.12:1  USE="berkdb gdbm ldap -doc -freetds -mysql -odbc -postgres -sqlite -static-libs" 594 kB
[ebuild  N     ] dev-perl/PlRPC-0.202.0  18 kB
[ebuild  N     ] virtual/perl-Sys-Syslog-0.320.0  0 kB
[ebuild  N     ] virtual/imap-c-client-1  USE="ssl" 0 kB
[ebuild  N     ] app-admin/apache-tools-2.2.23  USE="ssl" 5,357 kB
[ebuild  N     ] dev-perl/DBI-1.623.0  USE="{-test}" 583 kB
[ebuild  N     ] www-servers/apache-2.2.23:2  USE="ldap ssl -debug -doc (-selinux) -static -suexec -threads" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias -asis -auth_digest -authn_dbd -cern_meta -charset_lite -dbd -dumpio -ident -imagemap -log_forensic -proxy -proxy_ajp -proxy_balancer -proxy_connect -proxy_ftp -proxy_http -proxy_scgi -reqtimeout -substitute -version" APACHE2_MPMS="-event -itk -peruser -prefork -worker" 63 kB
[ebuild  N     ] virtual/httpd-cgi-0  0 kB
[ebuild  N     ] app-text/aspell-0.60.6.1  USE="nls" LINGUAS="fr -af -be -bg -br -ca -cs -cy -da -de -el -en -eo -es -et -fi -fo -ga -gl -he -hr -is -it -la -lt -nl -no -pl -pt -pt_BR -ro -ru -sk -sl -sr -sv -uk -vi" 1,835 kB
[ebuild  N     ] app-dicts/aspell-en-6.0.0  179 kB
[ebuild  N     ] app-dicts/aspell-fr-0.60  277 kB
[ebuild  N     ] dev-db/mysql-5.1.67  USE="berkdb community perl ssl -big-tables -cluster -debug -embedded -extraengine -latin1 -max-idx-128 -minimal -pbxt -profiling (-selinux) -static {-test} -xtradb" 26,055 kB
[ebuild  N     ] virtual/mysql-5.1  USE="-embedded -minimal -static" 0 kB
[ebuild  N     ] dev-perl/DBD-mysql-4.01.7  130 kB
[ebuild  N    ~] dev-lang/php-5.4.11-r2:5.4  USE="apache2 berkdb bzip2 cli crypt ctype curl exif fileinfo filter gd gdbm hash iconv imap ipv6 json ldap mysql nls pdo phar posix readline session simplexml spell sqlite ssl tokenizer truetype unicode xml xmlwriter zip zlib -bcmath -calendar -cdb -cgi -cjk -curlwrappers -debug -doc -embed -enchant -firebird -flatfile -fpm (-frontbase) -ftp -gmp -inifile -intl -iodbc -kerberos (-kolab) -ldap-sasl -libedit -mhash -mssql -mysqli -mysqlnd -oci8-instant-client -odbc -pcntl -pic -postgres -qdbm -recode (-selinux) -sharedmem -snmp -soap -sockets (-sybase-ct) -sysvipc -threads -tidy -wddx -xmlreader -xmlrpc -xpm -xsl" 10,893 kB
[ebuild  N     ] virtual/httpd-php-5.4-r1:5.4  0 kB
[ebuild  N     ] dev-php/jpgraph-3.0.7-r1  USE="examples truetype" 10,295 kB
[ebuild  N    ~] www-apps/owncloud-4.5.7:4.5.7  USE="curl sqlite -mysql -postgres -vhosts" 8,913 kB
[ebuild  N     ] dev-php/PEAR-PEAR-1.9.4  290 kB
[ebuild  N     ] dev-php/PEAR-Structures_Graph-1.0.4  30 kB
[ebuild  N     ] dev-php/PEAR-XML_Util-1.2.1-r2  18 kB
[ebuild  N     ] dev-php/PEAR-Archive_Tar-1.3.9  18 kB
[ebuild  N     ] dev-php/PEAR-Console_Getopt-1.3.1  5 kB
[ebuild  N     ] dev-php/pear-1.9.4  0 kB
[ebuild  N     ] dev-php/PEAR-Auth_SASL-1.0.6  9 kB
[ebuild  N     ] www-apps/egroupware-1.8.004.20120613:1.8.004.20120613  USE="jpgraph ldap mysql -gallery -postgres -vhosts" 10,289 kB

Total: 39 packages (39 new), Size of downloads: 87,238 kB


Package.use
Code:
>=dev-lang/php-5.4.11-r2:5.4 pdo sqlite gd zip mysql curl xmlwriter imap apache2
www-apps/egroupware mysql


T'as essayé en installant php-5.4.11 avant un emerge uDNv?
Back to top
View user's profile Send private message
chris972
Tux's lil' helper
Tux's lil' helper


Joined: 02 Mar 2012
Posts: 97

PostPosted: Mon Feb 25, 2013 9:09 pm    Post subject: Reply with quote

sebB wrote:
J'ai fais une simulation si ca peut t'aider niveau use en ne mettant que ce qu'il me réclamait (je suis en stable).
Par contre il n'installe pas php-5.4.8 mais directement php-5.4.11

Bizarre ce truc. Je vais étudier tes uses pour voir ou il peut y avoir différente significative.

Quote:
T'as essayé en installant php-5.4.11 avant un emerge uDNv?

Ben non, j'ai pas voulu démasquer... J'avais pas du tout envie après d'avoir X applis qui ne tournent plus ou mal. Bref, les effets de bord quoi.

Merci pour ton aide. Je me penche dessus dès que je peux.
Back to top
View user's profile Send private message
chris972
Tux's lil' helper
Tux's lil' helper


Joined: 02 Mar 2012
Posts: 97

PostPosted: Tue Feb 26, 2013 3:27 pm    Post subject: Reply with quote

Bon, j'ai commencé par virer egroupware. Je ne m'en sers pas, donc ça ne me manquera pas.
Et paf, plus de message concernant owncloud.
Je suppose, sans être sûr, que le fait de pouvoir mettre à jour php:5.3 en 5.3.18 après avoir viré egroupware doit le contenter quelque part.
Portage me laisse parfois très perplexe. Mais bon, on fait avec.
Mise à jour en cours, je verrai ensuite ce qu'il dit si je tente de réinstaller egroupware.

Merci pour votre aide qui m'a permis d'orienter mes investigations.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum