Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Conflict with perl-5.10.1 and perl-ExtUtils-Install-1.540.0
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
kami22
Tux's lil' helper
Tux's lil' helper


Joined: 14 Apr 2006
Posts: 110

PostPosted: Thu Jan 03, 2013 12:57 pm    Post subject: Conflict with perl-5.10.1 and perl-ExtUtils-Install-1.540.0 Reply with quote

Hi,

i am trying to emerge -uDN world. But i am always getting this conflict.

I dont know how to solve it. Because i want to use perl-5.16 and not perl-5.10.

Maybe someone can help me.

Cu kami

Code:
!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

sys-apps/hwids:0

  (sys-apps/hwids-20121119::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (sys-apps/hwids-20121203::gentoo, installed) pulled in by
    >=sys-apps/hwids-20121202.2 required by (net-wireless/bluez-4.101-r5::gentoo, ebuild scheduled for merge)

virtual/perl-ExtUtils-Install:0

  (virtual/perl-ExtUtils-Install-1.54::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (virtual/perl-ExtUtils-Install-1.540.0::gentoo, ebuild scheduled for merge) pulled in by
    >=virtual/perl-ExtUtils-Install-1.540.0 required by (perl-core/ExtUtils-MakeMaker-6.640.0::gentoo, ebuild scheduled for merge)

dev-lang/perl:0

  (dev-lang/perl-5.16.0::gentoo, installed) pulled in by
    =dev-lang/perl-5.16* required by (virtual/perl-libnet-1.220.0-r1::gentoo, installed)
    (and 12 more with the same problem)

  (dev-lang/perl-5.10.1::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-lang/perl-5.10.1 required by (virtual/perl-ExtUtils-Install-1.540.0::gentoo, ebuild scheduled for merge)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following keyword changes are necessary to proceed:
#required by perl-core/ExtUtils-MakeMaker-6.640.0, required by virtual/perl-ExtUtils-MakeMaker-6.640.0, required by dev-perl/Moose-2.60.400, required by perl-gcpan/P2P-Transmission-Remote-0.02, required by @selected, required by @world (argument)
=virtual/perl-ExtUtils-Manifest-1.610.0 ~amd64
#required by virtual/perl-ExtUtils-Manifest-1.610.0, required by perl-core/ExtUtils-MakeMaker-6.640.0, required by virtual/perl-ExtUtils-MakeMaker-6.640.0, required by dev-perl/Moose-2.60.400, required by perl-gcpan/P2P-Transmission-Remote-0.02, required by @selected, required by @world (argument)
=perl-core/ExtUtils-Manifest-1.610.0 ~amd64
#required by virtual/perl-ExtUtils-Install-1.540.0, required by perl-core/ExtUtils-MakeMaker-6.640.0, required by virtual/perl-ExtUtils-MakeMaker-6.640.0, required by dev-perl/Moose-2.60.400, required by perl-gcpan/P2P-Transmission-Remote-0.02, required by @selected, required by @world (argument)
=dev-lang/perl-5.10.1 ~amd64
#required by perl-core/ExtUtils-MakeMaker-6.640.0, required by virtual/perl-ExtUtils-MakeMaker-6.640.0, required by dev-perl/Moose-2.60.400, required by perl-gcpan/P2P-Transmission-Remote-0.02, required by @selected, required by @world (argument)
=virtual/perl-ExtUtils-Install-1.540.0 ~amd64

The following mask changes are necessary to proceed:
#required by virtual/perl-ExtUtils-Install-1.540.0, required by perl-core/ExtUtils-MakeMaker-6.640.0, required by virtual/perl-ExtUtils-MakeMaker-6.640.0, required by dev-perl/Moose-2.60.400, required by perl-gcpan/P2P-Transmission-Remote-0.02, required by @selected, required by @world (argument)
# /usr/portage/profiles/package.mask:
# Torsten Veller <tove@gentoo.org> (06 Jan 2011)
# Next step to remove old perl and libperl versions.
# Versions prior 5.12 are masked and will be removed when 5.14 is available.
# If you are a sparc-fbsd user and your only keyworded perl version was masked,
# test perl-5.12.2 and reply to bug 288028
# For other complaints go to bug 350785
=dev-lang/perl-5.10.1

NOTE: The --autounmask-keep-masks option will prevent emerge
      from creating package.unmask or ** keyword changes.

Use --autounmask-write to write changes to config files (honoring CONFIG_PROTECT).
Back to top
View user's profile Send private message
wmm
n00b
n00b


Joined: 26 Dec 2007
Posts: 16
Location: Bavaria, Germany

PostPosted: Thu Feb 07, 2013 10:54 pm    Post subject: Reply with quote

Hi,

I have the same problem at the moment and would like to know if you were able to resolve the problem?

My Perl dependency conflict is the same, but I removed all ~x86 from dev-lang/perl:
dev-lang/perl-5.12.4-r1::gentoo with ~dev-lang/perl-5.10.1, required by virtual/perl-ExtUtils-Install-1.540.0::gentoo, installed.

The question is, how do I get rid of the perl-5.10.1 version of perl?

I have tried to deactivate several perl related ~x86 in /etc/portage/package.keywords to force perl to only use stable version of perl but I don't dare to remove the perl version 5.10.1 and it's other dependent files by hand or to deinstall and then reinstall perl, as I do think perl could be system relevant and removing perl completely may destroy my system.

I also tried to remove the packages with
Code:
emerge v1a --depclean virtual/perl-ExtUtils-Install perl-core/ExtUtils-MakerMaker
but that ended in a circular dependency with no package removal.

I'd generally like to know how to manage these conflicts as I am working on a private list of system conflicts in Gentoo to help me manage reoccuring conflicts without having to ask questions all the time on the forum and without having to file bugs that aren't really bugs at all or have been resolved by someone else but search didn't reveal it to me, neither in the forum nor in the bugs.gentoo.org, mostly my finding the researched help using google, I also only found this related problem using google.

I also tried to apply the solutions mentioned in Bug #453268 but that didn't work either. Of course I did an emerge --sync and also tried --backtrack=30 and other values.

Any Ideas?
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5655

PostPosted: Fri Feb 08, 2013 3:20 am    Post subject: Reply with quote

Try emerging perl-core/ExtUtils-Install.
Though it wouldn't be surprising if the virtual could use a bump.
Back to top
View user's profile Send private message
wmm
n00b
n00b


Joined: 26 Dec 2007
Posts: 16
Location: Bavaria, Germany

PostPosted: Fri Feb 08, 2013 6:20 am    Post subject: Reply with quote

I'm sorry, but that doesn't work either.

To get any response from emerge at all, I called it
Code:
emerge -vuaDN1 perl-core/ExtUtils-Install
and then emerge outputs:

    ... WARNING: one or more updates have been skipped due to a dependency conflict:
    dev-lang/perl:0
    (dev-lang/perl-5.12.4-r1::gentoo, ebuild scheduled for merge) conflicts with
    ~dev-lang/perl-5.10.1 required by (virtual/perl-ExtUtils-Install-1.540.0::gentoo, installed)

    Nothing to merge... Auto-clean packages Yes/No?


I read over my post and was thinking about unmerging virtual/perl-ExtUtils-Install-1.540.0 without the use of depclean, just with the -C option.

But as I already said, I have killed my system in the past that way and I would like to avoid it this time.

Any more ideas?
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5655

PostPosted: Fri Feb 08, 2013 10:48 am    Post subject: Reply with quote

:roll: Start with 'emerge -1pv '>=dev-lang/perl-5.16.0' perl-core/ExtUtils-MakeMaker' and keep checking virtuals and adding packages to this line till you get a clean upgrade.
Back to top
View user's profile Send private message
wmm
n00b
n00b


Joined: 26 Dec 2007
Posts: 16
Location: Bavaria, Germany

PostPosted: Sat Feb 09, 2013 6:02 am    Post subject: Reply with quote

@VoidMage:
Another few questions which arose out of your last post:
1. I do want to have perl as stable release, is it possible to choose dev-lang/perl-5.14.0 instead, otherwise keyword ~x86 gets added to my keywords again?
2. I tried with dev-lang/perl-5.16.0 and got:
Code:

... slot conflict ...

dev-lang/perl:0
>=dev-lang/perl-5.16.2::gentoo, ebuild scheduled for merge) pulled in by
=dev-lang/perl-5.16* required by (virtual/per-Sys-Syslog-0290.0-r1::gentoo, installed)
(and 8 more with the same problems)

(dev-lang/perl-5.10.1::gentoo, installed) pulled in by
~dev-lang/perl-5.10.1 required by (virtual/perl-ExtUtils-Install-1.540.0::gentoo, installed)

It may be possible...


2.1. Do I need to add only the virtuals listed on the upper 5.16* part or additionally the virtuals listed in the 5.10* part?

3. Do I have to first upgrade with ~x86 to get rid of 5.10* and afterwards downgrade to stable x86 part?
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5655

PostPosted: Sat Feb 09, 2013 7:29 pm    Post subject: Reply with quote

OK, I'm so used to mixing, that I've failed to notice that you're on stable (thought it was simply "I didn't update in quite awhile" problem).

Change the line to 'emerge -1pv =dev-lang/perl-5.12.4-r2 perl-core/ExtUtils-MakeMaker' (as that seems to be the latest stable).
Back to top
View user's profile Send private message
wmm
n00b
n00b


Joined: 26 Dec 2007
Posts: 16
Location: Bavaria, Germany

PostPosted: Sun Feb 10, 2013 1:58 am    Post subject: Reply with quote

That's not quite right. Stable is my goal. Previuosly, I was on stable and used unstable to achieve an install, if stable refused to install. In the time that came, stable was almost allways associated with conflicts, therefore I preferred unstable installs. Now I'd like to go back to stable and remove unstable where ever possible.
I'm on unstable perl at the moment, trying to go to stable perl and stable anything and using unstable anything only for testing purposes or if stable install fails.

And I think I was misunderstood on the point about mixing things. Please reread my posting with my specific questions. Especially questions 2, 2.1 and 3.

Please read my question concerning the listed code segment again. My question there is:
I seem to have two perl versions installed, 5.10* and 5.16* being merged additionally as update.

I don't know how to bump a package to newer version, I thought that is only possible for the developers of the specific package.

You talked about emerging all virtuals that come round and my question in 2.1 is, all virtuals only mentioned in 5.16* package version or all virtuals mentioned in 5.10* as well. That I do need to know exactly.

Gentoo tells me that the two package versions can't stay on the system at the same time, tells me to mask out one of the versions. I don't know how to do that other than using or not using ~x86 keyword.

Question 3. tries to clear up things, do I need to install 5.16* to get rid of the old 5.10* and its' old dependencies and can I then downgrade to stable version or what can I do to clearly only have one stable perl version.

Please tell me what I must do exactly.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum