Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
zsh fails to complete emerge package names [solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
oneself
Tux's lil' helper
Tux's lil' helper


Joined: 02 Jul 2005
Posts: 98
Location: New York, NY

PostPosted: Wed Feb 06, 2013 4:22 pm    Post subject: zsh fails to complete emerge package names [solved] Reply with quote

Hi,

When I try to complete (hit TAB) after an "emerge" command, zsh does not seem to complete package names correctly.

For example:

Code:
$ emerge fire[TAB]
No matches for: `portage', `profile', `package', `category/package', or `corrections'


However, doing the same for eix, does work correctly:

Code:
$ eix fire[TAB]
package
firebird     fireflies    firefox      firefox-bin  firehol      firewalk     firewalld 


Even weirder, if I just hit TAB without putting anything after emerge, I get this:
Code:
$  emerge [TAB]
package
handbrake
category/package
media-video


It looks like the only package it can complete is "handbrake" and the only category is "media-video". That is truly strange.

Doing a failed match in eix shows the following matchers are used:
Code:
eix asdfsadfs[TAB]
No matches for: `package' or `corrections'


It looks like "package" is present in both commands, but emerge has more matchers. Not sure why those would get in the way.
Would anyone happen to know why this would be happening?

Also, where are these matchers defined?
_________________
There are 10 types of people, those who know binary and those who don't.


Last edited by oneself on Wed Feb 06, 2013 6:16 pm; edited 1 time in total
Back to top
View user's profile Send private message
poncho
n00b
n00b


Joined: 06 Mar 2011
Posts: 54

PostPosted: Wed Feb 06, 2013 5:09 pm    Post subject: Reply with quote

Probably this:
https://bugs.gentoo.org/show_bug.cgi?id=431958
Back to top
View user's profile Send private message
oneself
Tux's lil' helper
Tux's lil' helper


Joined: 02 Jul 2005
Posts: 98
Location: New York, NY

PostPosted: Wed Feb 06, 2013 6:15 pm    Post subject: Reply with quote

Thank you, that solved it.

I added the following link:

Code:
 ln -s /usr/share/portage/config/make.globals /etc/make.globals


And now it works.
_________________
There are 10 types of people, those who know binary and those who don't.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum