Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
gstreamer: noise/crackling when playing some mkvs
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 3982
Location: Irgendwo im Nirgendwo

PostPosted: Mon Feb 04, 2013 3:05 pm    Post subject: gstreamer: noise/crackling when playing some mkvs Reply with quote

Weird issue:
Some mkv files (ripped from DVDs I often watch) have problems with the sound. Sometimes it is only a slight crackling that lays over the sound, sometimes it is just constant noise.
To make it even worse it behaves differently when opening a file from the commandline or while the app is running: when "totem some_file.mkv" produces noise I simply need to reopen it using the file dialog and audio is fine.
But the funniest part: Using xnoise behaves the other way around:
A file that produced noise when opened with "totem some_file.mkv" will play fine with "xnoise some_file.mkv", but produce noise when opened with file dialog/from the library.
The majority of my files work just fine.

I also tried kde-base/dragon with phonon-gstreamer - same issue. phonon-sgtreamer uses gstreamer:0.10 while totem and xnoise use gstreamer:1.0.

mplayer works fine, same goes for vlc.
_________________
"der mac dennoch wesen geil"
Wolfram von Eschenbach, Parzival (Buch 1, Z. 7).
Ein frühes Statement gegen Windows.

My overlay
Back to top
View user's profile Send private message
lost+found
Guru
Guru


Joined: 15 Nov 2004
Posts: 429
Location: North~Sea~Coa~s~~t~~~

PostPosted: Mon Feb 04, 2013 8:01 pm    Post subject: Reply with quote

Hi,

If you use the Intel HD Audio driver, then you'll probably need to add this to the kernel line in grub.conf:
snd_hda_intel.position_fix=2

That solved it for me.
Back to top
View user's profile Send private message
aCOSwt
Moderator
Moderator


Joined: 19 Oct 2007
Posts: 2537
Location: Hilbert space

PostPosted: Mon Feb 04, 2013 9:49 pm    Post subject: Reply with quote

Could this https://bugs.gentoo.org/show_bug.cgi?id=401895 be related ?
Well... I mean my analysis that it would be a resampling problem.
_________________
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 3982
Location: Irgendwo im Nirgendwo

PostPosted: Tue Feb 05, 2013 1:02 pm    Post subject: Reply with quote

lost+found wrote:
snd_hda_intel.position_fix=2

Did not solve it for me :(
Quote:
Could this https://bugs.gentoo.org/show_bug.cgi?id=401895 be related

I don't think so, because that bug is about phonon, both vlc and gstreamer backend producing an initial crackling.
Also vlc works just fine here, it's only gstreamer that produces constant noise.
I will try an update to libav-9 in the hope it will fix this... (I know this WILL break other things)

// update: libav-9 did not change anything

// update 2: Well, at least gstreamer:1.0 is fixed, so totem works. I thought xnoise needs gstreamer:1,0, too, but it's 0.10...
So another downgrade of libav + rebuild of gst-plugins-ffmpeg, but no fix at all.
But I got a quite stupid warning, that building gst-ffmpeg against a random external version of libav is not supported an just BAD BAD BAD...
_________________
"der mac dennoch wesen geil"
Wolfram von Eschenbach, Parzival (Buch 1, Z. 7).
Ein frühes Statement gegen Windows.

My overlay
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 3982
Location: Irgendwo im Nirgendwo

PostPosted: Tue Feb 05, 2013 3:05 pm    Post subject: Reply with quote

libav-9 did not really fix it, seems that it did work just once, the next time the video had constant noise, again.

But it seems I found the root of all of this - pulseaudio...
I uninstalled pulseaudio, took away use=pulseaudio from gst-plugins-meta:0.10 and alsa-plugins and - bamm - perfect sound in xnoise :(
Pulseaudio drove me crazy in the past, and now it again took hours of my life. As gnome depends hard on pulseaudio it seems I have to uninstall it again.
(I tested pulse-2.1 and 3.0, just in case someone tells me pulse made great steps in recent versions and "is fixed" now...)
_________________
"der mac dennoch wesen geil"
Wolfram von Eschenbach, Parzival (Buch 1, Z. 7).
Ein frühes Statement gegen Windows.

My overlay
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum