Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
KDE - X won't start for normal user, only Fluxbox [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
boaglio
n00b
n00b


Joined: 14 May 2004
Posts: 60
Location: Sao Paulo - Brazil

PostPosted: Sat Jan 26, 2013 9:50 am    Post subject: KDE - X won't start for normal user, only Fluxbox [SOLVED] Reply with quote

Hi,

I' m not a Gentoo guru, but I really need some advice :D

The main problem is: startx (KDE) with normal user -> get X Segmentation fault (Details http://bpaste.net/show/72900/ )

startx with root -> works but I get strange errors like widget unable to start (even after rm -rf ~/.kde4 )

My versions:

:arrow: emerge info http://bpaste.net/show/72902/
:arrow: kernel 3.6.11-ck
:arrow: x11-base/xorg-server 1.13.1.901
:arrow: sys-fs/udev 197-r4
:arrow: kde-base/kde-meta 4.9.5
:arrow: x11-drivers/nvidia-drivers 313.18

What I have tried so far:

:arrow: startx KDE with a new normal user (same error)
:arrow: removed and installed kde-meta
:arrow: switch back to udev 171
:arrow: switch back to x11-base/xorg-server 1.13.1
:arrow: switch back to x11-drivers/nvidia-drivers 310.19


I 'm about to format and reinstall everything... it makes me nuts 8O


Last edited by boaglio on Fri Feb 01, 2013 1:42 am; edited 1 time in total
Back to top
View user's profile Send private message
billium
Apprentice
Apprentice


Joined: 22 Mar 2003
Posts: 175

PostPosted: Sat Jan 26, 2013 4:10 pm    Post subject: Reply with quote

May be quicker to do a memtest first before a re-install (I think it is always worth it for segfaults when nothing much has changed). :roll:
Back to top
View user's profile Send private message
boaglio
n00b
n00b


Joined: 14 May 2004
Posts: 60
Location: Sao Paulo - Brazil

PostPosted: Sat Jan 26, 2013 7:27 pm    Post subject: Reply with quote

billium wrote:
May be quicker to do a memtest first before a re-install (I think it is always worth it for segfaults when nothing much has changed). :roll:


I don't know, it is a very strange error.

I'm running now XFCE with a normal user, as just like Fluxbox or KDE, they all depend on Xorg... and according to my error log, it is a Xorg Segment Fault. 8O
Back to top
View user's profile Send private message
The Doctor
Veteran
Veteran


Joined: 27 Jul 2010
Posts: 1510

PostPosted: Sat Jan 26, 2013 9:25 pm    Post subject: Reply with quote

++ on memtest. This looks and tastes like a hardware problem.
_________________
First things first, but not necessarily in that order.
Back to top
View user's profile Send private message
boaglio
n00b
n00b


Joined: 14 May 2004
Posts: 60
Location: Sao Paulo - Brazil

PostPosted: Sun Jan 27, 2013 12:20 am    Post subject: Reply with quote

I've just run a memtest+ 4.20-r1 on my Kingstom 8Gb RAM, everything was 100% fine.
Back to top
View user's profile Send private message
cord
Apprentice
Apprentice


Joined: 28 Apr 2007
Posts: 204

PostPosted: Wed Jan 30, 2013 7:41 pm    Post subject: Reply with quote

Seems like the problem is in either hardware or proprietary nvidia driver.
Maybe you should try nouveau, hah?
Back to top
View user's profile Send private message
boaglio
n00b
n00b


Joined: 14 May 2004
Posts: 60
Location: Sao Paulo - Brazil

PostPosted: Fri Feb 01, 2013 1:41 am    Post subject: Reply with quote

Hi,

I solved this issue today by recompiling all kde packages and put my normal user inside root groups:

Code:
root@cascao ~ [23:40:57]> cat /etc/group | grep root | grep fb
root:x:0:root,fb
bin:x:1:root,bin,daemon,fb
daemon:x:2:root,bin,daemon,fb
sys:x:3:root,bin,adm,fb
adm:x:4:root,adm,daemon,fb
disk:x:6:root,adm,fb
wheel:x:10:root,fb
video:x:27:root,fb



I will give a try later on http://nouveau.freedesktop.org/ , thanks :D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum