Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] basic new settings for apache 2.4
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
Wallsandfences
Apprentice
Apprentice


Joined: 29 Mar 2010
Posts: 166

PostPosted: Wed Jan 30, 2013 4:39 pm    Post subject: [SOLVED] basic new settings for apache 2.4 Reply with quote

Since I upgraded my apache to 2.4 (from an ancient version) it does not start anymore. I figure I have an outdated config.

Code:
/etc/init.d/apache2 start
apache2         | * apache2 has detected an error in your setup:
apache2         |apache2: Syntax error on line 72 of /etc/apache2/httpd.conf: Cannot load modules/mod_authn_default.so into server: /usr/lib64/apache2/modules/mod_authn_default.so: cannot open shared object file: No such file or directory


I intend to start with a maiden configuration, httpd.conf is new, still I get this error. How to proceed?

Rüdiger


Last edited by Wallsandfences on Thu Jan 31, 2013 9:58 am; edited 1 time in total
Back to top
View user's profile Send private message
666threesixes666
Veteran
Veteran


Joined: 31 May 2011
Posts: 1242
Location: 42.68n 85.41w

PostPosted: Wed Jan 30, 2013 4:57 pm    Post subject: Reply with quote

id comment the mod_authn line for the time being to get it running first before you really fix the root of the problem.... mod_authn_default..so not found....

id run updatedb

then

locate mod_authn_default

if it finds the .so in another location, make ur config point to that location

or symlink to where config is looking

or just leave mod_authn commented and go about your day =D
Back to top
View user's profile Send private message
Wallsandfences
Apprentice
Apprentice


Joined: 29 Mar 2010
Posts: 166

PostPosted: Wed Jan 30, 2013 10:55 pm    Post subject: Reply with quote

This does not work, these modules are outdated, the question is, why apache2 still demands them.

Rüdiger
Back to top
View user's profile Send private message
666threesixes666
Veteran
Veteran


Joined: 31 May 2011
Posts: 1242
Location: 42.68n 85.41w

PostPosted: Wed Jan 30, 2013 11:14 pm    Post subject: Reply with quote

my best guess (as i cannot even find my httpd.conf right now) is that its script is referencing a directory like /etc/modules.d and modules.d has the old scripts requiring outdated modules. ill keep digging around for ya
Back to top
View user's profile Send private message
Wallsandfences
Apprentice
Apprentice


Joined: 29 Mar 2010
Posts: 166

PostPosted: Wed Jan 30, 2013 11:18 pm    Post subject: Reply with quote

some progress, but now it states:

Code:
etc/init.d/apache2 start
apache2         | * Caching service dependencies ...                                                                             [ ok ]
apache2         | * apache2 has detected an error in your setup:
apache2         |apache2: Syntax error on line 169 of /etc/apache2/httpd.conf: Syntax error on line 4 of /etc/apache2/modules.d/70_mod_php5.conf: Cannot load modules/libphp5.so into server: /usr/lib64/apache2/modules/libphp5.so: undefined symbol: unixd_config
apache2         | * ERROR: apache2 failed to start
Back to top
View user's profile Send private message
syn0ptik
Apprentice
Apprentice


Joined: 09 Jan 2013
Posts: 246

PostPosted: Thu Jan 31, 2013 12:44 am    Post subject: Reply with quote

there something wrong with php module, as it says
Code:
libphp5.so: undefined symbol: unixd_config

try rebuild this module
Back to top
View user's profile Send private message
666threesixes666
Veteran
Veteran


Joined: 31 May 2011
Posts: 1242
Location: 42.68n 85.41w

PostPosted: Thu Jan 31, 2013 1:38 am    Post subject: Reply with quote

mv ur modules.d or what ever apache_php5.so or what ever to apache_php5.so.backup what ever and see if it starts with out it.... i believe the file its calling up references the php5.so (and it needs to be rebuilt ultimately if you want to use it) but you still want to get the http running before you start adding complexity to it.

(or just change your line in your httpd.conf to read #Include /etc/apache2/modules.d/*.conf to omit any extra modules for the time being)
Back to top
View user's profile Send private message
Wallsandfences
Apprentice
Apprentice


Joined: 29 Mar 2010
Posts: 166

PostPosted: Thu Jan 31, 2013 9:44 am    Post subject: Reply with quote

I re-emerged php, ensured that the php-symlink (libphp5.so) is valid and get now:


Code:
/etc/init.d/apache2 start
apache2         | * apache2 has detected an error in your setup:
apache2         |AH00526: Syntax error on line 112 of /etc/apache2/modules.d/00_default_settings.conf:
apache2         |Invalid command 'Order', perhaps misspelled or defined by a module not included in the server configuration
apache2         | * ERROR: apache2 failed to start


The respective line is:


Code:
# We configure the "default" to be a very restrictive set of features.
<Directory />
   Options FollowSymLinks
   AllowOverride None
   Order deny,allow
   Deny from all
</Directory>
Back to top
View user's profile Send private message
Wallsandfences
Apprentice
Apprentice


Joined: 29 Mar 2010
Posts: 166

PostPosted: Thu Jan 31, 2013 9:49 am    Post subject: Reply with quote

oops, found that:

http://httpd.apache.org/docs/2.4/upgrading.html

so, please ignore all for now and i see if I can solve it. DONE
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum