Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
xp guest in vbox can not connect internet.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
waterloo2005
Apprentice
Apprentice


Joined: 26 Aug 2008
Posts: 248

PostPosted: Thu Mar 07, 2013 2:22 pm    Post subject: xp guest in vbox can not connect internet. Reply with quote

My kernel is gentoo-sources 3.7.10 .
Now every time I run xp guest in vbox, it says : finding an ethernet controller .
I open network connection in xp guest , there is nothing .
Now I use bridged adapter in vbox 4.2.8 .
Because I can not connect internet in xp guest , so I can not install the ethernet controller driver .

What is the matter ?
Thanks
_________________
i5-2450M, gnome, amd64
R,Mathematica,Emacs
Back to top
View user's profile Send private message
_______0
Guru
Guru


Joined: 15 Oct 2012
Posts: 521

PostPosted: Thu Mar 07, 2013 10:12 pm    Post subject: Reply with quote

wut??

VM's don't need adapters lol. Why no use qemu with virtio drivers? You get 10.0 Gps for free!!

Or are you trying passthrough? From your post is not entirely clear what you're trying to achieve.

The option:

-net nic,model=virtio
Back to top
View user's profile Send private message
waterloo2005
Apprentice
Apprentice


Joined: 26 Aug 2008
Posts: 248

PostPosted: Fri Mar 08, 2013 3:25 am    Post subject: Reply with quote

I choose 'bridged adapter' in network config setting of virtualbox-bin .
When I start xp guest in vbox, xp says it find an ethernet controller.
Now I can not connect xp guest to internet .
Thanks
_________________
i5-2450M, gnome, amd64
R,Mathematica,Emacs
Back to top
View user's profile Send private message
BillWho
Veteran
Veteran


Joined: 03 Mar 2012
Posts: 1600
Location: US

PostPosted: Fri Mar 08, 2013 5:41 am    Post subject: Reply with quote

waterloo2005,

Is Adapter Type set to Intel Pro/1000 MT Desktop (8254OEM) :?:

I experienced a similar problem after an update to vbox and changing the adapter type solved it.
_________________
Good luck :wink:

Since installing gentoo, my life has become one long emerge :)
Back to top
View user's profile Send private message
waterloo2005
Apprentice
Apprentice


Joined: 26 Aug 2008
Posts: 248

PostPosted: Fri Mar 08, 2013 7:36 am    Post subject: Reply with quote

BillWho wrote:
waterloo2005,

Is Adapter Type set to Intel Pro/1000 MT Desktop (8254OEM) :?:

I experienced a similar problem after an update to vbox and changing the adapter type solved it.


Thanks very much .
Another question : Why can not I use bridged adapter in vbox to make guest os to connect to internet ?
I have discussed the problem in http://forums.gentoo.org/viewtopic-t-949536-start-0-postdays-0-postorder-asc-highlight-.html .
But now I still fail .
How about you ?
_________________
i5-2450M, gnome, amd64
R,Mathematica,Emacs
Back to top
View user's profile Send private message
BillWho
Veteran
Veteran


Joined: 03 Mar 2012
Posts: 1600
Location: US

PostPosted: Fri Mar 08, 2013 2:39 pm    Post subject: Reply with quote

waterloo2005,

I looked through your thread and quite frankly I don't understand why you can't get a bridged connection. I'm using a bridged adapter here :?

As far as the need for sys-apps/usermode-utilities and net-misc/bridge-utils they're needed for advanced networking, not for bridged. I don't have them installed on this system.

I recall having the same problem as you're experiencing now when version app-emulation/virtualbox-4.2.6-r1 installed on Sat Feb 9 17:06:27 2013. Changing the adapter type fixed the problem.

I don't see any USE settings related to bridged networking either.

You might want to keep your eye on this bug https://bugs.gentoo.org/show_bug.cgi?id=453516 although it doesn't appear to be a high priority :(

If it helps, I do have these set, but I doubt it's related to your problem:

CONFIG_BRIDGE_NETFILTER=y
CONFIG_BRIDGE_NF_EBTABLES=m
CONFIG_BRIDGE_EBT_802_3=m
CONFIG_BRIDGE_EBT_VLAN=m
CONFIG_BRIDGE=m
CONFIG_BRIDGE_IGMP_SNOOPING=y
_________________
Good luck :wink:

Since installing gentoo, my life has become one long emerge :)
Back to top
View user's profile Send private message
waterloo2005
Apprentice
Apprentice


Joined: 26 Aug 2008
Posts: 248

PostPosted: Sat Mar 09, 2013 5:16 am    Post subject: Reply with quote

BillWho wrote:


CONFIG_BRIDGE_NETFILTER=y
CONFIG_BRIDGE_NF_EBTABLES=m
CONFIG_BRIDGE_EBT_802_3=m
CONFIG_BRIDGE_EBT_VLAN=m
CONFIG_BRIDGE=m
CONFIG_BRIDGE_IGMP_SNOOPING=y


I try above kernel config. But fail too.
I also try use kernel config of ubuntu12.04, that makes bridged adapter network config in vbox work.
But I do not how to find that critical item in kernel config.

Thanks
_________________
i5-2450M, gnome, amd64
R,Mathematica,Emacs
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum