Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
konwersja certyfikatu PKCS#12 do dofrmatu GnuPG
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish)
View previous topic :: View next topic  
Author Message
kermu
n00b
n00b


Joined: 30 May 2004
Posts: 50

PostPosted: Mon Jan 28, 2013 7:43 pm    Post subject: konwersja certyfikatu PKCS#12 do dofrmatu GnuPG Reply with quote

Nie mogę sobie poradzić z konwersją certyfikatu z formatu PKCS#12 do formatu GnuPg

Certyfikat został wyeksportowany do pliku backup.p12 z programu "mozilla firefox"
Próba zaimportowanie pod GnuPG zakończyła się niepowodzeniem:
~# gpgsm --import backup.p12
gpgsm: gpg-protect-tool: błąd podczas pytania o hasło: Brak aplikacji PKCS15
gpgsm: błąd uruchamiania ,,/usr/libexec/gpg-protect-tool'': kod wyjścia 2
gpgsm: całkowita liczba przetworzonych: 0

Nie mam pojęcia dlaczego gpgsm odwołuje się do aplikacji PKCS15
Wersja programu GnuPG to 2.0.19

Zauważyłem również że nie mogę sie skomunikować za pomocą pkcs15-tool
z kartą kryptograficzną CERTUM UNIZETO
~ # pkcs15-tool -L
Using reader with a card: Dell smart card reader keyboard 00 00
PKCS#15 binding failed: Unsupported card

~ # epm -ql opensc |grep -i pkcs15
/usr/bin/pkcs15-crypt
/usr/bin/pkcs15-init
/usr/bin/pkcs15-tool

~# epm -q opensc
opensc-0.12.2-r2

opensc-0.12.2-r2
~ # equery uses opensc
[ Searching for packages matching opensc... ]
[ Colour Code : set unset ]
[ Legend : Left column (U) - USE flags from make.conf ]
[ : Right column (I) - USE flags packages was installed with ]
[ Found these USE variables for dev-libs/opensc-0.12.2-r2 ]
U I
- - doc : Adds extra documentation (API, Javadoc, etc). It is recommended to enable per package instead of globally
- - libtool : Use sys-devel/libtool for dynamically loading libraries rather than the host libdl/dlopen helpers.
- - openct : Use dev-libs/openct (and CT-API) for accessing Smartcard hardware.
- + pcsc-lite : Use sys-apps/pcsc-lite (and PC/SC API) for accessing Smartcard hardware.
+ + readline : Enables support for libreadline, a GNU line-editing library that almost everyone wants
+ + ssl : Adds support for Secure Socket Layer connections
+ + zlib : Adds support for zlib (de)compression

Skomunikować z kartą udało mi się jedynie z wykorzystaniem "frmowego " sterownika

~ # pkcs11-tool --module ./libcryptoCertum3PKCS.so -O
Using slot 0 with a present token (0x1)
Public Key Object; RSA 1024 bits
label: .................
ID: 333335221b3d2817fb094528fe36216552c935
Usage: encrypt, verify, wrap
Public Key Object; RSA 1024 bits
label:
ID: 33338ef8c731c21d1cf8dbc0dda53abe987336b2
Usage: encrypt, verify, wrap
Public Key Object; RSA 1024 bits
label:
ID: 3333310ef015b66b7c1596fd3f5d90eaf9b6e080d
Usage: encrypt, verify, wrap
Certificate Object, type = X.509 cert
label: .................................
ID: 333f375221b3d2817fb094528fe36216552c935

ale z pomocą pkcs11-tool nie uda mi się chyba dokonać konwersji certyfikatu.

Jest mi to niezbędne do programu pocztowego claws-mail aby podpisywać wiadomości e-mail.

Czy ktoś ma jakieś doświadczenia w obsłudze kart krytograficznych CERTUM pod linuxem ?
Czy jest szansa że certyfikaty tam zapisane zobaczy "seahorse" ?

Pozdrawiam
Krzysztof
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum