Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
XFCE4 + optimus, error in intel driver
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
mel_82
Tux's lil' helper
Tux's lil' helper


Joined: 25 Oct 2004
Posts: 117
Location: Somewhere in Italy

PostPosted: Mon Jan 28, 2013 3:33 pm    Post subject: XFCE4 + optimus, error in intel driver Reply with quote

Hi all :)

I'm back to gentoo after a long time (4 years I guess)...
I'm doing a fresh new install and ?im having problem with the Nvidia Optimus.
I followed this guides to install XFCE4 and nvidia optmus.
When I log in into slim I get the following in the slim.log.

Code:

slim: Last login: Mon Jan 28 17:19:54 CET 2013 on :0.0
slim: consolekit support enabled
slim: initializing a consolekit session
slim: Dbus error: Unable to open session: Failed to connect to socket /var/run/dbus/system_bus_socket: No such file or directory
slim: console-kit-daemon not running?
arguments to ck_connector_get_cookie() were incorrect, assertion "connector != NULL" failed in file ck-connector.c line 583.
terminate called after throwing an instance of 'std::logic_error'
  what():  basic_string::_S_construct null not valid
12 XSELINUXs still allocated at reset
SCREEN: 0 objects of 248 bytes = 0 total bytes 0 private allocs
DEVICE: 0 objects of 96 bytes = 0 total bytes 0 private allocs
CLIENT: 0 objects of 184 bytes = 0 total bytes 0 private allocs
WINDOW: 0 objects of 72 bytes = 0 total bytes 0 private allocs
PIXMAP: 4 objects of 48 bytes = 192 total bytes 0 private allocs
GC: 4 objects of 88 bytes = 352 total bytes 0 private allocs
CURSOR: 0 objects of 8 bytes = 0 total bytes 0 private allocs
DBE_WINDOW: 0 objects of 24 bytes = 0 total bytes 0 private allocs
GLYPH: 0 objects of 24 bytes = 0 total bytes 0 private allocs
TOTAL: 8 objects, 544 bytes, 0 allocs
4 PIXMAPs still allocated at reset
PIXMAP: 4 objects of 48 bytes = 192 total bytes 0 private allocs
GC: 4 objects of 88 bytes = 352 total bytes 0 private allocs
CURSOR: 0 objects of 8 bytes = 0 total bytes 0 private allocs
DBE_WINDOW: 0 objects of 24 bytes = 0 total bytes 0 private allocs
GLYPH: 0 objects of 24 bytes = 0 total bytes 0 private allocs
TOTAL: 8 objects, 544 bytes, 0 allocs
4 GCs still allocated at reset
GC: 4 objects of 88 bytes = 352 total bytes 0 private allocs
CURSOR: 0 objects of 8 bytes = 0 total bytes 0 private allocs
DBE_WINDOW: 0 objects of 24 bytes = 0 total bytes 0 private allocs
GLYPH: 0 objects of 24 bytes = 0 total bytes 0 private allocs
TOTAL: 4 objects, 352 bytes, 0 allocs
1 DAMAGEs still allocated at reset
GLYPH: 0 objects of 24 bytes = 0 total bytes 0 private allocs
TOTAL: 0 objects, 0 bytes, 0 allocs
4 PICTUREs still allocated at reset
TOTAL: 0 objects, 0 bytes, 0 allocs
(EE)
(EE) Backtrace:
(EE) 0: /usr/bin/X (xorg_backtrace+0x34) [0x597124]
(EE) 1: /usr/bin/X (0x400000+0x19af59) [0x59af59]
(EE) 2: /lib64/libpthread.so.0 (0x7f31d5ae0000+0x10bf0) [0x7f31d5af0bf0]
(EE) 3: /usr/bin/X (CreatePicture+0x139) [0x510c29]
(EE) 4: /usr/lib64/xorg/modules/drivers/intel_drv.so (0x7f31d3313000+0x534c8) [0x7f31d33664c8]
(EE) 5: /usr/lib64/xorg/modules/drivers/intel_drv.so (0x7f31d3313000+0x2c3c9) [0x7f31d333f3c9]
(EE) 6: /usr/lib64/xorg/modules/drivers/intel_drv.so (0x7f31d3313000+0x4fa7d) [0x7f31d3362a7d]
(EE) 7: /usr/bin/X (0x400000+0xb246e) [0x4b246e]
(EE) 8: /usr/bin/X (0x400000+0x29b14) [0x429b14]
(EE) 9: /lib64/libc.so.6 (__libc_start_main+0xed) [0x7f31d478060d]
(EE) 10: /usr/bin/X (0x400000+0x29fd1) [0x429fd1]
(EE)
(EE) Segmentation fault at address 0x20

Fatal server error:
Caught signal 11 (Segmentation fault). Server aborting


I guess this may be a problem with the intel driver? Or is it about something else?
(I never installed slim before, nor optimus, so it may be something else, ask the log or conf, I'll paste them asap)

Here the logs :)

slim.log:
http://pastebin.com/v5dzNYQW

Xorg.0.log
http://pastebin.com/wP8wKMPr

Xorg.1.log
http://pastebin.com/RZhmGjAC
_________________
http://www.feelingsofgreatness.net


Last edited by mel_82 on Mon Jan 28, 2013 3:38 pm; edited 1 time in total
Back to top
View user's profile Send private message
mel_82
Tux's lil' helper
Tux's lil' helper


Joined: 25 Oct 2004
Posts: 117
Location: Somewhere in Italy

PostPosted: Mon Jan 28, 2013 3:34 pm    Post subject: Reply with quote

OT: I was slim in this avatar... 8O 8O :roll:
_________________
http://www.feelingsofgreatness.net
Back to top
View user's profile Send private message
mel_82
Tux's lil' helper
Tux's lil' helper


Joined: 25 Oct 2004
Posts: 117
Location: Somewhere in Italy

PostPosted: Mon Jan 28, 2013 3:47 pm    Post subject: Reply with quote

Code:
rc-update add /etc/init.d/dbus default


maybe just solved.
_________________
http://www.feelingsofgreatness.net
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum