Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] missing acl entries after udev-197-r4 upgrade
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
Veldrin
Veteran
Veteran


Joined: 27 Jul 2004
Posts: 1942
Location: Zurich, Switzerland

PostPosted: Mon Jan 28, 2013 11:31 am    Post subject: [SOLVED] missing acl entries after udev-197-r4 upgrade Reply with quote

dear forum,

using a fully unstable hardened system, I recently upgraded udev to 197-r4, and at least the sound cards and 3g modem seems to be missing the usual consolekit (?) related acl entries.
adding my user to the respective groups (audio for sound card, uucp for 3g modem) fixed the issue - at least temporarily.

I am using KDE (4.9.98/4.10_RC3) with the entire *kit (consolekit, polkit et all) stuff enabled.
Sound is (again) plain alsa, 3g modem is handled via networkmanager.


So the questions are:
Did someone else experience a similar behaviour?
Am I on the right track? or is this behaviour coming from somewhere else?
What are the downsides of removing *kit? What are the upsides?

Are the other aspects, I have not take into account?


I'll update the post later on with emerge --info - or any other information if required.


V.
_________________
read the portage output!
If my answer is too concise, ask for an explanation.


Last edited by Veldrin on Tue Jan 29, 2013 9:32 am; edited 1 time in total
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5655

PostPosted: Mon Jan 28, 2013 1:20 pm    Post subject: Reply with quote

Those entries come from consolekit now - the rules should be in /lib/udev/rules.d/70-udev-acl.rules.
Back to top
View user's profile Send private message
Veldrin
Veteran
Veteran


Joined: 27 Jul 2004
Posts: 1942
Location: Zurich, Switzerland

PostPosted: Mon Jan 28, 2013 1:50 pm    Post subject: Reply with quote

Thanks for the hint.
I'll have a look later on - once I am back home at my machine - and report back.
_________________
read the portage output!
If my answer is too concise, ask for an explanation.
Back to top
View user's profile Send private message
Veldrin
Veteran
Veteran


Joined: 27 Jul 2004
Posts: 1942
Location: Zurich, Switzerland

PostPosted: Tue Jan 29, 2013 9:32 am    Post subject: Reply with quote

It is working again.
I am not quite sure what I did, apart from a complete reboot.

As discussed here, I verified if the acl useflag had been set for consolekit, and it has been.

marking resolved.
_________________
read the portage output!
If my answer is too concise, ask for an explanation.
Back to top
View user's profile Send private message
ssuominen
Developer
Developer


Joined: 30 Sep 2005
Posts: 2133
Location: Finland

PostPosted: Tue Jan 29, 2013 2:37 pm    Post subject: Reply with quote

The udev-acl rules shipped with ConsoleKit are propably outdated for sys-fs/udev-197 and higher. I think I might need to backport some of the code that went in at the time udev-acl .rules file was renamed to be acl .rules from the old git before it was merged to systemd git.
This is my conclusion after reading git logs around the udev-acl code.
Back to top
View user's profile Send private message
John R. Graham
Administrator
Administrator


Joined: 08 Mar 2005
Posts: 7888
Location: Somewhere over Atlanta, Georgia

PostPosted: Sun Mar 10, 2013 8:54 pm    Post subject: Reply with quote

Moved from Kernel & Hardware to Duplicate Threads in favor of udev-197 and sound as requested by ssuominen.

- John
_________________
I can confirm that I have received between 0 and 999 National Security Letters.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum