Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
No audio over HDMI AMD
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
Tickeldi
n00b
n00b


Joined: 17 Mar 2009
Posts: 32
Location: Norddeutschland

PostPosted: Sun Jan 27, 2013 8:58 pm    Post subject: No audio over HDMI AMD Reply with quote

Hi folks. I've got this strange problem.

I don't hear a sound coming out of my TV when I connect it to my Laptop running Gentoo with a 3.6.11 Kernel. An HDMI cable is used. So no DVI Adapter but HDMI to HDMI. I am using radeon driver kms.
X Server 1.13.1 recognizes the screen and uses it beautifully to display my desktop.

Code:
 [*]   Build HDMI/DisplayPort HD-audio codec support

is set in the kernel.

Code:
# lspci
01:00.1 Audio device: Advanced Micro Devices [AMD] nee ATI RV710/730 HDMI Audio [Radeon HD 4000 series]


Code:
$ aplay -l
Karte 0: Intel [HDA Intel], Gerät 0: ALC888 Analog [ALC888 Analog]
  Sub-Geräte: 0/1
  Sub-Gerät #0: subdevice #0
Karte 0: Intel [HDA Intel], Gerät 1: ALC888 Digital [ALC888 Digital]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0
Karte 1: HDMI [HDA ATI HDMI], Gerät 3: HDMI 0 [HDMI 0]
  Sub-Geräte: 0/1
  Sub-Gerät #0: subdevice #0



So I try

Code:
# aplay -D plughw:1,3 /usr/share/sounds/warning.wav
Wiedergabe: WAVE '/usr/share/sounds/warning.wav' : Signed 16 bit Little Endian, Rate: 44100 Hz, stereo


It seems to play but I don't hear a thing.

I've set
/etc/default/grub
Quote:
GRUB_CMDLINE_LINUX_DEFAULT="radeon.audio=1"


I am using pulseaudio and emerged media-sound/pavucontrol
I've set the VLC Player to the HDMI output and the output is recognized (the blue bar represents the sound that is being put out) but I can't physically hear it.
http://i.imgur.com/yClHMmh.png

It works with windows so the hardware shouldn't be at fault.

Any ideas what's left to try?
_________________
"Linux basiert doch auf DOS oder nicht?" *schüttel*
Back to top
View user's profile Send private message
DaggyStyle
Advocate
Advocate


Joined: 22 Mar 2006
Posts: 4916

PostPosted: Mon Jan 28, 2013 6:06 am    Post subject: Reply with quote

HDMI/DisplayPort HD-audio codec support might not be enough, can you post the entire relevat alsa section?
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
ProjectFootball
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum