Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Trying to switch nouveau to nvidia
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
arty71
n00b
n00b


Joined: 27 Jan 2013
Posts: 8

PostPosted: Mon Feb 18, 2013 6:32 pm    Post subject: Trying to switch nouveau to nvidia Reply with quote

Hello all,

I have to start off by saying I am at a point in my linux knowledge where I am knowledgable enough to cause damage but not knowledgable enough to fix it alone.

I recently tried to install Steam on my amd64 box and I wanted to switch from the nouveau driver to the nvidia driver.

In the process I was updating the system and I had a failed update ( a perl script was failing). after looking in the forums, the suggestion was to run

Code:
perl-cleaner --all


I did this an now I am at a point where perl cannot update certain dependencies because

libdrm-2.4.42 requires
Code:
VIDEO_CARDS=nouveau


Code:
The following USE changes are necessary to proceed:
#requred by media-libs/mesa-9.0.1, required by media-libtxc_dxtn-1.0.1-r1, required by @selected, required by @world (argument)
>=x11-libs/libdrm-2.4.42 video_cards_nouveau



I am looking to use the nvidia drivers, does anyone have an idea?


Thank you!
Back to top
View user's profile Send private message
Gentoo64
n00b
n00b


Joined: 21 Oct 2011
Posts: 45
Location: ::

PostPosted: Mon Feb 18, 2013 7:31 pm    Post subject: Reply with quote

Set VIDEO_CARDS="nvidia" in make.conf, remove all the nouveau stuff from kernel, emerge -uDNav @world ; emerge -c
Add nvidia to the modules line in /etc/conf.d/modules.
Double check eselect opengl list is set to nvidia.
If X don't start run nvidia-xconfig as root to make an xorg.conf.
Back to top
View user's profile Send private message
arty71
n00b
n00b


Joined: 27 Jan 2013
Posts: 8

PostPosted: Mon Feb 18, 2013 10:37 pm    Post subject: Reply with quote

I am now getting an error with my x11-misc/xkeyboard-config-2.8

let me know if there is anything else I should post.

build.log http://pastebin.com/1d0y25af

emerge --info and emerge -pqv: http://pastebin.com/CjLhTx5Q

environement: http://pastebin.com/MATaUKGx

any thoughts could be very helpful.

Thank you!!


Last edited by arty71 on Mon Feb 18, 2013 10:45 pm; edited 1 time in total
Back to top
View user's profile Send private message
rorgoroth
Apprentice
Apprentice


Joined: 06 Aug 2012
Posts: 225
Location: England, UK

PostPosted: Mon Feb 18, 2013 10:43 pm    Post subject: Reply with quote

Can I suggest that you edit the above post and instead upload all that to pastebin or simmilar, that is an insane amount of text, even if it had of been placed in code tags.
Back to top
View user's profile Send private message
arty71
n00b
n00b


Joined: 27 Jan 2013
Posts: 8

PostPosted: Mon Feb 18, 2013 10:49 pm    Post subject: Reply with quote

I noticed it as soon a submitted it. Its all in pastebin now. Thanks!
Back to top
View user's profile Send private message
rorgoroth
Apprentice
Apprentice


Joined: 06 Aug 2012
Posts: 225
Location: England, UK

PostPosted: Mon Feb 18, 2013 11:01 pm    Post subject: Reply with quote

Code:
/usr/bin/xsltproc: error while loading shared libraries: libxml2.so.2: cannot open shared object file: No such file or directory

Do you have libxml2 installed?
Back to top
View user's profile Send private message
arty71
n00b
n00b


Joined: 27 Jan 2013
Posts: 8

PostPosted: Mon Feb 18, 2013 11:19 pm    Post subject: Reply with quote

Thats odd.

You are 100% right, but I had it installed the other day.

Thank you. I reinstalled it.
Back to top
View user's profile Send private message
rorgoroth
Apprentice
Apprentice


Joined: 06 Aug 2012
Posts: 225
Location: England, UK

PostPosted: Mon Feb 18, 2013 11:39 pm    Post subject: Reply with quote

I assume xkeyboard-config built correctly after installing? Good :D

Could you have removed libxml2 by accident at all? I notice you have xml USE flag set, so it should be pulled in and not be needed in your world set.
When you get done following Gentoo64's list to get fully updated and such take a look at the output of "emerge -pv --depclean libxml2" - if it returns a list and notifies you no packages are to be removed (which should be the case) you should be sure to remove libxml2 from your world file. You can do that manually or by "emerge --deselect libxml2".

Edit: Confused myself. That is for portage 2.2, if you arent using portage 2.2 then you can achieve the same to remove from world with "emerge -C libxml2" followed by "emerge -auvDN @world".
Back to top
View user's profile Send private message
arty71
n00b
n00b


Joined: 27 Jan 2013
Posts: 8

PostPosted: Tue Feb 19, 2013 4:03 am    Post subject: Reply with quote

** Editing still, accidentally hit submit **

I ran into this error running,

Code:
emerge -uDNav @world


The following packages left to update are

Code:



Calculating dependencies... done!
[ebuild     U  ] dev-libs/rasqal-0.9.29 [0.9.28] USE="crypt mhash pcre xml -doc -gmp -static-libs {-test}" 0 kB
[ebuild     U  ] dev-libs/dbus-glib-0.100.1 [0.100-r2] USE="-debug -doc -static-libs {-test}" 0 kB
[ebuild     U  ] media-video/ffmpeg-0.10.6 [0.10.3] USE="X aac alsa bzip2 encode hardcoded-tables mmx mp3 sdl truetype vorbis x264 xvid zlib -3dnow -3dnowext -aacplus (-altivec) -amr -avx -bindist -cdio (-celt) -cpudetection -debug -dirac -doc -faac -frei0r -gnutls -gsm -ieee1394 -jack -jpeg2k -libass -libv4l -mmxext -modplug (-neon) -network -openal -openssl -oss -pic -pulseaudio -rtmp -schroedinger -speex -ssse3 -static-libs {-test} -theora -threads -v4l -vaapi -vdpau (-vis) -vpx" FFTOOLS="aviocat cws2fws ffeval graph2dot ismindex pktdumper qt-faststart trasher" 0 kB
[ebuild     U  ] media-plugins/gst-plugins-meta-0.10-r8:0.10 [0.10-r7:0.10] USE="X a52 aac alsa cdda%* dts dvd flac mp3 mpeg ogg vorbis wavpack x264%* xv xvid%* -dv -dvb -ffmpeg -http -jack% -lame -libass% -libvisual -mms -musepack -opus% -oss -pulseaudio -taglib -theora -v4l -vcd -vpx" 0 kB
[ebuild     U  ] x11-libs/gtk+-2.24.16:2 [2.24.15:2] USE="cups introspection xinerama (-aqua) -debug -examples {-test} -vim-syntax" 0 kB
[ebuild     U  ] www-client/chromium-25.0.1364.84 [25.0.1364.68] USE="cups -bindist -custom-cflags -gnome -gnome-keyring -kerberos (-pulseaudio) (-selinux) (-system-ffmpeg) (-tcmalloc) {-test}" LINGUAS="am ar bg bn ca cs da de el en_GB es es_LA et fa fi fil fr gu he hi hr hu id it ja kn ko lt lv ml mr ms nb nl pl pt_BR pt_PT ro ru sk sl sr sv sw ta te th tr uk vi zh_CN zh_TW" 0 kB
[ebuild     U  ] dev-python/pygtk-2.24.0-r3:2 [2.24.0-r2:2] USE="-doc -examples {-test}" PYTHON_TARGETS="python2_7%* -python2_6%" 0 kB
[ebuild     U  ] dev-util/cmake-2.8.10.2-r2::kde [2.8.10.2-r1::gentoo] USE="ncurses qt4 -emacs {-test} -vim-syntax" 0 kB
[ebuild     U  ] app-misc/strigi-0.7.7-r2 [0.7.7] USE="dbus exif fam qt4 -clucene -debug -ffmpeg -hyperestraier -inotify (-log) {-test}" 0 kB
[ebuild     U  ] sys-auth/pambase-20120417-r2::kde [20101024-r2::gentoo] USE="(consolekit) cracklib sha512 -debug -gnome-keyring -minimal -mktemp -pam_krb5 -pam_ssh -passwdqc (-selinux) -systemd%" 0 kB
[ebuild     U  ] sys-apps/shadow-4.1.5.1-r1 [4.1.4.3] USE="acl%* cracklib nls pam -audit (-selinux) -skey -xattr%" 0 kB
[blocks b      ] <sys-apps/shadow-4.1.5-r1 ("<sys-apps/shadow-4.1.5-r1" is blocking sys-auth/pambase-20120417-r2)
[ebuild     U  ] net-libs/libpcap-1.3.0-r1 [1.3.0] USE="bluetooth ipv6 -canusb -netlink -static-libs" 0 kB
[ebuild     U  ] net-misc/openssh-6.1_p1-r1 [5.9_p1-r4] USE="X hpn ldap pam tcpd -X509 -bindist -kerberos -ldns% -libedit (-selinux) -skey -static" 0 kB
[ebuild     U  ] kde-misc/polkit-kde-kcmodules-0.98_pre20120917-r1:4 [0.98_pre20120917:4] USE="(-aqua) -debug" 0 kB
[ebuild  rR    ] net-libs/webkit-gtk-1.10.2-r300:3  USE="geoloc gstreamer introspection jit spell webgl (-aqua) -coverage -debug {-test}" 0 kB



Code:


Making all in utils
make[1]: Entering directory `/var/tmp/portage/dev-libs/rasqal-0.9.29/work/rasqal-0.9.29/utils'
x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I../src  -I/usr/include/raptor2   -I/include -I/usr/include/uuid   -I../src -DRASQAL_INTERNAL=1   -march=native -O2 -pipe -c roqet.c
/bin/sh ../libtool  --tag=CC   --mode=link x86_64-pc-linux-gnu-gcc  -march=native -O2 -pipe `/usr/bin/x86_64-pc-linux-gnu-pkg-config raptor2 --libs` -Wl,-O1 -Wl,--as-needed -o roqet roqet.o  ../src/librasqal.la
libtool: link: x86_64-pc-linux-gnu-gcc -march=native -O2 -pipe -Wl,-O1 -o .libs/roqet roqet.o  -lraptor2 -Wl,--as-needed ../src/.libs/librasqal.so
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../x86_64-pc-linux-gnu/bin/ld: warning: libicuuc.so.49, needed by /usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libraptor2.so, not found (try using -rpath or -rpath-link)
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../lib64/libraptor2.so: undefined reference to `unorm_quickCheck_49'
collect2: ld returned 1 exit status
make[1]: *** [roqet] Error 1
make[1]: Leaving directory `/var/tmp/portage/dev-libs/rasqal-0.9.29/work/rasqal-0.9.29/utils'
make: *** [all-recursive] Error 1
 * ERROR: dev-libs/rasqal-0.9.29 failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=dev-libs/rasqal-0.9.29'`,
 * the complete build log and the output of `emerge -pqv '=dev-libs/rasqal-0.9.29'`





During me running
Back to top
View user's profile Send private message
rorgoroth
Apprentice
Apprentice


Joined: 06 Aug 2012
Posts: 225
Location: England, UK

PostPosted: Tue Feb 19, 2013 9:08 am    Post subject: Reply with quote

Hmm, is icu installed?
# emerge -av1 icu


Edit: I've woken up properly now. You should have icu-50 so do what I asked above and install/check you have it installed, you may may need to rebuild raptor since it is looking for .so.49 rather then .so.50 - It may also be worth running revdep-rebuild.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum