Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Mate 1.4 install
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
roelof
Guru
Guru


Joined: 05 Feb 2009
Posts: 488

PostPosted: Sat Jan 26, 2013 12:53 pm    Post subject: Mate 1.4 install Reply with quote

Hello,

I did a emerge --mate install after all the steps described in the overlay manual.
But now I have Mate 1.2 instead of Mate 1.4

Is there a way I can upgrade to 1.4 ?

Roelof
Back to top
View user's profile Send private message
John R. Graham
Administrator
Administrator


Joined: 08 Mar 2005
Posts: 7663
Location: Somewhere over Atlanta, Georgia

PostPosted: Sat Jan 26, 2013 1:22 pm    Post subject: Reply with quote

Looking at the ebuild, they're both (1.2.2 and 1.4.0) just testing branch. Are you running testing branch or did you explicitly keyword them in /etc/portage/package.keywords? If the latter, could you post the file you put in there, please?

- John
_________________
This space intentionally left blank.
Back to top
View user's profile Send private message
roelof
Guru
Guru


Joined: 05 Feb 2009
Posts: 488

PostPosted: Sat Jan 26, 2013 1:28 pm    Post subject: Reply with quote

Helllo,

You can find the contents of /etc/portage/package.accept_keywords can be found here : http://bpaste.net/show/72915

Roelof
Back to top
View user's profile Send private message
John R. Graham
Administrator
Administrator


Joined: 08 Mar 2005
Posts: 7663
Location: Somewhere over Atlanta, Georgia

PostPosted: Sat Jan 26, 2013 1:50 pm    Post subject: Reply with quote

Big --autounmask-write user, are we? :wink: Come on! You've been around Gentoo long enough that you should know the material in the Working with Portage section of the Handbook, right?

The key lines from your /etc/portage/package.accept_keywords file are
Code:
#required by mate (argument)
=mate-base/mate-1.2.2 ~amd64
You can't upgrade to mate-1.4* because you haven't keyworded it; you only keyworded mate-1.2.2. The answer to your question is that you've installed the version you keyworded. If you want another version, then keyword it.

I'm presenting the answer this way in the spirit of teaching you to fish as opposed to handing you a fish. :wink:

- John
_________________
This space intentionally left blank.
Back to top
View user's profile Send private message
roelof
Guru
Guru


Joined: 05 Feb 2009
Posts: 488

PostPosted: Sat Jan 26, 2013 2:31 pm    Post subject: Reply with quote

Thanks,

Im now busy with this manually

But now I have a slot problem :
Code:

!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/glib:2

  (dev-libs/glib-2.34.3::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/glib-2.34:2 required by (mate-base/mate-desktop-1.4.2::mate-overlay, ebuild scheduled for merge)

  (dev-libs/glib-2.32.4-r1::gentoo, installed) pulled in by
    <dev-libs/glib-2.33:2 required by (dev-libs/gobject-introspection-1.32.1::gentoo, installed)


You right I have worked with Gentoo before but not the whole time. I have also tried other distro's but gentoo is I think my big love and I hope I stay here.

Roelof
Back to top
View user's profile Send private message
roelof
Guru
Guru


Joined: 05 Feb 2009
Posts: 488

PostPosted: Sat Jan 26, 2013 3:37 pm    Post subject: Reply with quote

solved it by unmerge gobject-introspection.

Roelof

Edit 1 : not solved when I do now emerge -p --update --deep --newuse world the same error appears.
Back to top
View user's profile Send private message
John R. Graham
Administrator
Administrator


Joined: 08 Mar 2005
Posts: 7663
Location: Somewhere over Atlanta, Georgia

PostPosted: Sat Jan 26, 2013 6:30 pm    Post subject: Reply with quote

See what depends on gobject-introspection:
Code:
equery depends gobject-introspection
and then perhaps what depends on that until you get to the bottom of which @world package needs it. The other possible solution is to see if a later (masked) version of gobject-introspection will use the later glib.

- John
_________________
This space intentionally left blank.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum