Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
xorg-server update problem [unsolved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
jonfr
l33t
l33t


Joined: 20 Jul 2003
Posts: 912
Location: Denmark

PostPosted: Wed Nov 21, 2012 1:10 am    Post subject: xorg-server update problem [unsolved] Reply with quote

I got this strange problem when trying to update my Gentoo Linux.

Quote:
WARNING: One or more updates have been skipped due to a dependency conflict:

x11-base/xorg-server:0

(x11-base/xorg-server-1.13.0-r1::gentoo, ebuild scheduled for merge) conflicts with
<x11-base/xorg-server-1.12.99[-minimal] required by (x11-drivers/xf86-video-virtualbox-4.1.22::gentoo, ebuild scheduled for merge)


I have unmerged xf86-video-virtualbox-4.1.22 for now. But it is still creating this issue. What is more strange is this update here.

Quote:
[ebuild U ] x11-base/xorg-server-1.12.4 [1.12.2] USE="ipv6 kdrive nptl udev xorg -dmx -doc -minimal (-selinux) -static-libs -tslib -xnest -xvfb" 5,318 kB


I am not sure if I should just ignore this issue and continue and hope for the best.

Thanks for the help.
Back to top
View user's profile Send private message
BillWho
Veteran
Veteran


Joined: 03 Mar 2012
Posts: 1600
Location: US

PostPosted: Wed Nov 21, 2012 1:33 am    Post subject: Reply with quote

jonfr,

I'm at x11-base/xorg-server-1.13.0-r1

Check with equery l -p xorg-server to see if it's masked on your end for some reason...
_________________
Good luck :wink:

Since installing gentoo, my life has become one long emerge :)
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 1667
Location: Berlin, Germany

PostPosted: Wed Nov 21, 2012 1:54 am    Post subject: Reply with quote

xf86-video-virtualbox-4.1.22 is not compatible with xorg-server-1.13, you need at least xf86-video-virtualbox-4.2.2. But that is normally no problem, portage will just skip this update for now.

A world update will pull in 4.1.22 again unless you remove virtualbox from VIDEO_CARDS and rebuild xorg-drivers.

To check if more packages depend on old xorg-server, run
Code:
# equery depends xorg-server
Back to top
View user's profile Send private message
jonfr
l33t
l33t


Joined: 20 Jul 2003
Posts: 912
Location: Denmark

PostPosted: Wed Nov 21, 2012 6:46 am    Post subject: Reply with quote

chithanh wrote:
xf86-video-virtualbox-4.1.22 is not compatible with xorg-server-1.13, you need at least xf86-video-virtualbox-4.2.2. But that is normally no problem, portage will just skip this update for now.

A world update will pull in 4.1.22 again unless you remove virtualbox from VIDEO_CARDS and rebuild xorg-drivers.

To check if more packages depend on old xorg-server, run
Code:
# equery depends xorg-server


I am using virtualbox. That is why I have it make.conf. This line here.


Code:
VIDEO_CARDS="nvidia v4l virtualbox"


Runnig your command gave me this list.

Code:
equery depends xorg-server
 * These packages depend on xorg-server:
app-admin/sabayon-2.30.1 (x11-base/xorg-server[kdrive])
dev-libs/glib-2.32.4-r1 (!prefix ? x11-base/xorg-server[xvfb])
dev-libs/libdbusmenu-qt-0.9.2 (!prefix ? x11-base/xorg-server[xvfb])
dev-libs/libunique-1.1.6-r1 (!prefix ? x11-base/xorg-server[xvfb])
dev-libs/libunique-3.0.2 (!prefix ? x11-base/xorg-server[xvfb])
dev-python/pygobject-2.28.6-r52 (!prefix ? x11-base/xorg-server[xvfb])
dev-python/pygobject-3.2.2 (!prefix ? x11-base/xorg-server[xvfb])
dev-python/pygtk-2.24.0-r2 (!prefix ? x11-base/xorg-server[xvfb])
dev-util/cmake-2.8.9 (!prefix ? x11-base/xorg-server[xvfb])
gnome-base/gnome-keyring-2.32.1-r1 (!prefix ? x11-base/xorg-server[xvfb])
gnome-base/gnome-vfs-2.24.4-r1 (!prefix ? x11-base/xorg-server[xvfb])
gnome-base/libbonoboui-2.24.5 (!prefix ? x11-base/xorg-server[xvfb])
gnome-base/libglade-2.6.4 (!prefix ? x11-base/xorg-server[xvfb])
gnome-base/libgnomecanvas-2.30.3 (!prefix ? x11-base/xorg-server[xvfb])
gnome-base/nautilus-2.32.2.1-r2 (!prefix ? x11-base/xorg-server[xvfb])
gnome-extra/evolution-data-server-2.32.3-r2 (!prefix ? x11-base/xorg-server[xvfb])
gnome-extra/gnome-games-2.28.2 (!prefix ? x11-base/xorg-server[xvfb])
gnome-extra/gnome-power-manager-2.32.0-r3 (!prefix ? x11-base/xorg-server[xvfb])
kde-base/keditbookmarks-4.8.5 (!prefix ? x11-base/xorg-server[xvfb])
kde-base/kmail-4.8.5-r1 (!prefix ? x11-base/xorg-server[xvfb])
kde-base/ksysguard-4.8.5 (!prefix ? x11-base/xorg-server[xvfb])
kde-base/ksystemlog-4.8.5 (!prefix ? x11-base/xorg-server[xvfb])
kde-base/systemsettings-4.8.5 (!prefix ? x11-base/xorg-server[xvfb])
media-gfx/gtkimageview-1.6.4 (!prefix ? x11-base/xorg-server[xvfb])
media-sound/clementine-1.0.1-r1 (!prefix ? x11-base/xorg-server[xvfb])
media-sound/rhythmbox-0.13.3 (!prefix ? x11-base/xorg-server[xvfb])
net-libs/glib-networking-2.32.3 (!prefix ? x11-base/xorg-server[xvfb])
net-libs/libktorrent-1.3.0 (!prefix ? x11-base/xorg-server[xvfb])
net-libs/telepathy-glib-0.18.1 (!prefix ? x11-base/xorg-server[xvfb])
net-libs/webkit-gtk-1.8.3-r200 (!prefix ? x11-base/xorg-server[xvfb])
net-libs/webkit-gtk-1.8.3-r300 (!prefix ? x11-base/xorg-server[xvfb])
sys-apps/dbus-1.6.8 (!prefix ? x11-base/xorg-server[xvfb])
www-client/chromium-24.0.1312.14 (!prefix ? x11-base/xorg-server[xvfb])
www-client/firefox-10.0.10 (!prefix ? x11-base/xorg-server[xvfb])
x11-base/xorg-x11-7.4-r2 (x11-base/xorg-server[-minimal])
x11-drivers/nvidia-drivers-304.64 (X ? <x11-base/xorg-server-1.13.99)
x11-drivers/xf86-input-evdev-2.7.0 (>=x11-base/xorg-server-1.10[udev])
                                   (x11-base/xorg-server[xorg])
x11-drivers/xf86-input-keyboard-1.6.1 (>=x11-base/xorg-server-1.6.3)
                                      (x11-base/xorg-server[xorg])
x11-drivers/xf86-input-mouse-1.7.2 (>=x11-base/xorg-server-1.5.99.901)
                                   (x11-base/xorg-server[xorg])
x11-drivers/xf86-video-v4l-0.2.0 (>=x11-base/xorg-server-1.0.99)
x11-libs/gtk+-2.24.12 (!prefix ? x11-base/xorg-server[xvfb])
x11-libs/gtk+-3.4.4 (!prefix ? x11-base/xorg-server[xvfb])
x11-libs/gtksourceview-2.10.5-r2 (!prefix ? x11-base/xorg-server[xvfb])


Using package.keywords gives me this error here.

Code:
WARNING: One or more updates have been skipped due to a dependency conflict:

x11-base/xorg-server:0

  (x11-base/xorg-server-1.13.0-r1::gentoo, ebuild scheduled for merge) conflicts with
    <x11-base/xorg-server-1.12.99[-minimal] required by (x11-drivers/xf86-video-virtualbox-4.1.22::gentoo, ebuild scheduled for merge)

x11-drivers/xf86-video-virtualbox:0

  (x11-drivers/xf86-video-virtualbox-4.2.2::gentoo, ebuild scheduled for merge) conflicts with
    ~x11-drivers/xf86-video-virtualbox-4.1.22 required by (app-emulation/virtualbox-guest-additions-4.1.22::gentoo, installed)


I think that I need to add virtualbox-guest-additions to my package.keywords file in order to fix this issue. I at least think so.
Back to top
View user's profile Send private message
solamour
Guru
Guru


Joined: 21 Dec 2004
Posts: 493
Location: San Diego, CA

PostPosted: Thu Jan 24, 2013 7:29 pm    Post subject: Reply with quote

I'm not in a hurry, so I'll just wait for "xf86-video-virtualbox-4.2.2" become stable. Then "xorg-server-1.13" will be pulled in, I believe.
__
sol
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum