Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Alsamixer doesn't save master level for normal user
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
AnonymousCloud
n00b
n00b


Joined: 17 Jan 2013
Posts: 10
Location: Milan - Italy

PostPosted: Thu Jan 24, 2013 2:05 pm    Post subject: Alsamixer doesn't save master level for normal user Reply with quote

Hi, I'm running Gentoo on VirtualBox and I have the following problem:

I installed alsa-utils, run alsamixer as root, unmuted Master & PCM, set 81% level
on both, exit and run alsactl store.

Everything worked when I tested as root:
# speaker-test -c 2

I switched now to normal user, checked I was part of the audio group, run
$ speaker-test -c 2
it worked on console but no sound at all.

Run alsamixer (as normal user) and Master level was set to 0 & muted.
Tried to unmute putting it at 81% but when I exit Master level settings are lost (only Master level, if I change anything else it's saved correctly).

When I got back to root and run alsamixer again, Master settings were lost as well.

So it looks I can change and save Master level as root but it's not kept whenever I access as normal user.

Just to add infos: system is barebone, I installed the base system, upgraded it and installed X plus pekwm, nothing else.

What am I doing wrong?
Thank's for helping.


Last edited by AnonymousCloud on Fri Jan 25, 2013 6:55 am; edited 6 times in total
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5256

PostPosted: Thu Jan 24, 2013 7:49 pm    Post subject: Reply with quote

Part of the sound group? There isn't a sound group - try adding your user to the audio group.
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Pappy's Kernel Seeds: http://kernel-seeds.org
Back to top
View user's profile Send private message
AnonymousCloud
n00b
n00b


Joined: 17 Jan 2013
Posts: 10
Location: Milan - Italy

PostPosted: Fri Jan 25, 2013 1:00 am    Post subject: Reply with quote

My fault, I intended "audio" and mistyped "sound" in the previous message .... editing it .... thank's for pointing it out.

EDIT: Double checked it and my user is in the audio group .... after many others tries the problem still persists.
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5256

PostPosted: Fri Jan 25, 2013 3:33 pm    Post subject: Reply with quote

Is alsasound started and in the default runlevel?
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Pappy's Kernel Seeds: http://kernel-seeds.org
Back to top
View user's profile Send private message
Knute
Guru
Guru


Joined: 28 Jun 2004
Posts: 362
Location: Fargo, ND

PostPosted: Fri Jan 25, 2013 8:28 pm    Post subject: Reply with quote

What does your /etc/conf.d/alsasound file look like?
_________________
Knute
----------
The human race has one really effective weapon, and that is laughter.
-- Mark Twain

If you want proof of that, take a look at windows sometime. :)
Back to top
View user's profile Send private message
AnonymousCloud
n00b
n00b


Joined: 17 Jan 2013
Posts: 10
Location: Milan - Italy

PostPosted: Fri Jan 25, 2013 10:14 pm    Post subject: Reply with quote

audiodef: Yes, it is:

# rc-status -a
Runlevel: default
virtualbox-guest-additions [ started ]
net.eth0 [ started ]
alsasound [ started ]
.......



Knute: Here it is:

# RESTORE_ON_START:
# Do you want to restore your mixer settings? If not, your cards will be
# muted.
# no - Do not restore state
# yes - Restore state

RESTORE_ON_START="yes"

# SAVE_ON_STOP:
# Do you want to save changes made to your mixer volumes when alsasound
# stops?
# no - Do not save state
# yes - Save state

SAVE_ON_STOP="yes"
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum