Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Mount Samsung Galaxy S3 in PTP Mode [solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
thunderfly81
n00b
n00b


Joined: 16 Jan 2013
Posts: 7

PostPosted: Wed Jan 16, 2013 2:18 pm    Post subject: Mount Samsung Galaxy S3 in PTP Mode [solved] Reply with quote

i cant mound my s3 in ptp mode ... here the outputs of lsusb and dmesg when i plugin the usb cable

Code:
GentooX1 dev # lsusb
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 004 Device 003: ID 13fe:5100 Kingston Technology Company Inc. Flash Drive
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 012: ID 04e8:6865 Samsung Electronics Co., Ltd GT-I9300 Phone [Galaxy S III] (PTP mode)
Bus 002 Device 004: ID 045e:0040 Microsoft Corp. Wheel Mouse Optical
Bus 002 Device 005: ID 046d:c316 Logitech, Inc. HID-Compliant Keyboard
GentooX1 dev #

Code:

GentooX1 dev # dmesg
[22908.527187] hub 2-1:1.0: state 7 ports 8 chg 0000 evt 0002
[22908.527489] hub 2-1:1.0: port 1, status 0100, change 0001, 12 Mb/s
[22908.527492] usb 2-1.1: USB disconnect, device number 12
[22908.527493] usb 2-1.1: unregistering device
[22908.527495] usb 2-1.1: unregistering interface 2-1.1:1.0
[22908.527531] usb 2-1.1: usb_disable_device nuking all URBs
[22908.631347] hub 2-1:1.0: debounce: port 1: total 100ms stable 100ms status 0x100
[22911.594939] hub 2-1:1.0: state 7 ports 8 chg 0000 evt 0002
[22911.595247] hub 2-1:1.0: port 1, status 0101, change 0001, 12 Mb/s
[22911.699124] hub 2-1:1.0: debounce: port 1: total 100ms stable 100ms status 0x101
[22911.710105] hub 2-1:1.0: port 1 not reset yet, waiting 10ms
[22911.772020] usb 2-1.1: new high-speed USB device number 13 using ehci_hcd
[22911.783004] hub 2-1:1.0: port 1 not reset yet, waiting 10ms
[22911.857507] usb 2-1.1: default language 0x0409
[22911.857856] usb 2-1.1: udev 13, busnum 2, minor = 140
[22911.857859] usb 2-1.1: New USB device found, idVendor=04e8, idProduct=6865
[22911.857860] usb 2-1.1: New USB device strings: Mfr=2, Product=3, SerialNumber=4
[22911.857861] usb 2-1.1: Product: SAMSUNG_Android
[22911.857862] usb 2-1.1: Manufacturer: SAMSUNG
[22911.857863] usb 2-1.1: SerialNumber: 4df113ec4cb55f2b
[22911.857942] usb 2-1.1: usb_probe_device
[22911.857945] usb 2-1.1: configuration #1 chosen from 1 choice
[22911.858128] usb 2-1.1: adding 2-1.1:1.0 (config #1, interface 0)
GentooX1 dev #



but how to mount ? where to find ? ... its not listed in /dev

thanks


[code]


Last edited by thunderfly81 on Wed Jan 23, 2013 10:49 pm; edited 1 time in total
Back to top
View user's profile Send private message
thunderfly81
n00b
n00b


Joined: 16 Jan 2013
Posts: 7

PostPosted: Tue Jan 22, 2013 11:15 am    Post subject: Reply with quote

no ideas ?
Back to top
View user's profile Send private message
slackline
Veteran
Veteran


Joined: 01 Apr 2005
Posts: 1328
Location: /uk/sheffield

PostPosted: Tue Jan 22, 2013 11:35 am    Post subject: Reply with quote

If its anything like the S2 then you might have a similar problem to the one I encountered.

Quote:

Upon initially connecting the Galaxy S II to my computer via USB and selecting Connect storage USB I found that after mounting it under GNU/Linux only the internal storage was detected and mountable (~12G out of the total 16Gb as some is reserved for installing applications, around 2Gb, and a bit for system stuff). How was I to use my nice new, formatted (via the phone) 16Gb micro-SD card?

Thanks to a friend the solution was straight-forward.

You need to enable the following items under your kernel…
Code:

Device-drivers --->
  MMC/SD/SDIO card support --->
    CONFIG_PCI_MMCONFIG=y
    CONFIG_MMC=y
    CONFIG_MMC_BLOCK=y
    CONFIG_MMC_BLOCK_MINORS=8
    CONFIG_MMC_BLOCK_BOUNCE=y
    CONFIG_MMC_SDHCI=m
    CONFIG_MMC_SDHCI_PCI=m
    CONFIG_MMC_RICOH_MMC=y
Device-drivers --->
  SCSI device support --->
    CONFIG_SCSI_MULTI_LUN=y


The key was to enable LUN support because the internal and micro-SD external storage are on different LUN's of the same SCSI device (USB devices are really spoofed as SCSI devices).

_________________
"Science is what we understand well enough to explain to a computer.  Art is everything else we do." - Donald Knuth
Back to top
View user's profile Send private message
thunderfly81
n00b
n00b


Joined: 16 Jan 2013
Posts: 7

PostPosted: Wed Jan 23, 2013 10:29 am    Post subject: Reply with quote

thx for the reply ... but its ([*] Probe all LUNs on each SCSI device) already set in my kernel (3.7.3-gentoo)


Code:
GentooX1 linux # grep "MULTI_LUN" .config
CONFIG_SCSI_MULTI_LUN=y
GentooX1 linux #


i havent any ideas ... it was working with a 3.6 kernel ... maybe ive to downgrade

thy anywhere
Back to top
View user's profile Send private message
slackline
Veteran
Veteran


Joined: 01 Apr 2005
Posts: 1328
Location: /uk/sheffield

PostPosted: Wed Jan 23, 2013 11:27 am    Post subject: Reply with quote

Hmm, strange.

How did you setup your .config for the new kernel? Did you copy it over and then use...

Code:

make silentoldconfig


This only then asks you questions about new features/changes in the configuration.

slack
_________________
"Science is what we understand well enough to explain to a computer.  Art is everything else we do." - Donald Knuth
Back to top
View user's profile Send private message
thunderfly81
n00b
n00b


Joined: 16 Jan 2013
Posts: 7

PostPosted: Wed Jan 23, 2013 12:57 pm    Post subject: Reply with quote

i copy the old config file from the older kernel and type "make menuconfig - make && make modules_install" ... after that i copy the new bzimage to /boot/grub/kernel-3.x.x and boot it from there

normal it worked without any problems ...

ill try to root my phone for USB MASS STORAGE function ... maybe it works then

thx for your answers


Last edited by thunderfly81 on Wed Jan 23, 2013 5:34 pm; edited 1 time in total
Back to top
View user's profile Send private message
slackline
Veteran
Veteran


Joined: 01 Apr 2005
Posts: 1328
Location: /uk/sheffield

PostPosted: Wed Jan 23, 2013 2:28 pm    Post subject: Reply with quote

Good luck with the rooting, I used the excellent tools from Chainfire to root my S3 (well worth bunging him a few quid for his apps, once you're rooted MobileOdin is a good option). See this thread on XDA

Consider using the 'make silentoldconfig' option when updating kernels, I used to use the method you describe, but found it a ballache trying to ensure I'd checked that everything I wanted was there. silentoldconfig seems to do this automagically, and at the same time you find out what the new features are. Usually there are only new features that actually require you to give some input when bumping 3.X, rarely between 3.3.X (i.e. minor versions).
_________________
"Science is what we understand well enough to explain to a computer.  Art is everything else we do." - Donald Knuth
Back to top
View user's profile Send private message
thunderfly81
n00b
n00b


Joined: 16 Jan 2013
Posts: 7

PostPosted: Wed Jan 23, 2013 6:38 pm    Post subject: Reply with quote

thx ... ill take a look at chainfire

now i know what my problem causes ... the new udev needs to
"Please re-emerge all packages on your system which install
* rules and helpers in /usr/lib/udev. They should now be in
* /lib/udev"

so after doing
Code:
emerge -av1 $(qfile -q -S -C /usr/lib/udev
my phone will connect with the pc in PTP mode =)

thy again for the answers

greetz
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum