Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
no screens found, intel xorg
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
luizm929
n00b
n00b


Joined: 26 Apr 2011
Posts: 18
Location: San Diego CA

PostPosted: Mon Jan 21, 2013 11:50 pm    Post subject: no screens found, intel xorg Reply with quote

Hi everybody, thanks in advance to anyone who can help me.
I installed new system on Lenovo Thinkpad x61s

I installed xorg and it would complain when trying to start as a regular user

Code:


startx



Fatal server error: cannot move old log file


So I did this
Code:


chmod 4711 /usr/bin/Xorg


After this I could start xorg with startx

I made some updates and now I get the following error in Xorg.0.log

Code:


[    33.862]
X.Org X Server 1.13.1
Release Date: 2012-12-13
[    33.862] X Protocol Version 11, Revision 0
[    33.862] Build Operating System: Linux 3.6.11-rt25 i686 Gentoo
[    33.862] Current Operating System: Linux Lucius 3.6.11-rt25 #6 SMP PREEMPT RT Mon Jan 21 13:16:23 MST 2013 i686
[    33.862] Kernel command line: root=/dev/sda3 rootfstype=ext4 raid=noautodetect video=intelfb
[    33.862] Build Date: 21 January 2013  01:27:24PM
[    33.862] 
[    33.862] Current version of pixman: 0.28.0
[    33.862]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[    33.863] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    33.863] (==) Log file: "/var/log/Xorg.0.log", Time: Mon Jan 21 15:11:16 2013
[    33.863] (==) Using config file: "/etc/X11/xorg.conf"
[    33.863] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    33.863] (==) ServerLayout "X.org Configured"
[    33.863] (**) |-->Screen "Screen0" (0)
[    33.863] (**) |   |-->Monitor "Monitor0"
[    33.864] (**) |   |-->Device "Card0"
[    33.864] (**) |-->Input Device "Mouse0"
[    33.864] (**) |-->Input Device "Keyboard0"
[    33.864] (==) Automatically adding devices
[    33.864] (==) Automatically enabling devices
[    33.864] (==) Automatically adding GPU devices
[    33.864] (WW) The directory "/usr/share/fonts/TTF/" does not exist.
[    33.864]    Entry deleted from font path.
[    33.864] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[    33.864]    Entry deleted from font path.
[    33.864] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[    33.864]    Entry deleted from font path.
[    33.864] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[    33.864]    Entry deleted from font path.
[    33.864]    (Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[    33.864] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[    33.864]    Entry deleted from font path.
[    33.864]    (Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[    33.864] (WW) The directory "/usr/share/fonts/TTF/" does not exist.
[    33.864]    Entry deleted from font path.
[    33.864] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[    33.864]    Entry deleted from font path.
[    33.864] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[    33.864]    Entry deleted from font path.
[    33.864] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[    33.864]    Entry deleted from font path.
[    33.864]    (Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[    33.864] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[    33.864]    Entry deleted from font path.
[    33.864]    (Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[    33.864] (**) FontPath set to:
   /usr/share/fonts/misc/,
   /usr/share/fonts/misc/
[    33.864] (**) ModulePath set to "/usr/lib/xorg/modules"
[    33.864] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[    33.864] (WW) Disabling Mouse0
[    33.864] (WW) Disabling Keyboard0
[    33.864] (II) Loader magic: 0x8228600
[    33.864] (II) Module ABI versions:
[    33.864]    X.Org ANSI C Emulation: 0.4
[    33.864]    X.Org Video Driver: 13.1
[    33.864]    X.Org XInput driver : 18.0
[    33.864]    X.Org Server Extension : 7.0
[    33.865] (II) config/udev: Adding drm device (/dev/dri/card0)
[    33.867] (--) PCI:*(0:0:2:0) 8086:2a02:17aa:20b5 rev 12, Mem @ 0xf8000000/1048576, 0xe0000000/268435456, I/O @ 0x00001800/8
[    33.867] (--) PCI: (0:0:2:1) 8086:2a03:17aa:20b5 rev 12, Mem @ 0xf8100000/1048576
[    33.867] (II) Open ACPI successful (/var/run/acpid.socket)
[    33.867] Initializing built-in extension Generic Event Extension
[    33.867] Initializing built-in extension SHAPE
[    33.867] Initializing built-in extension MIT-SHM
[    33.867] Initializing built-in extension XInputExtension
[    33.867] Initializing built-in extension XTEST
[    33.867] Initializing built-in extension BIG-REQUESTS
[    33.867] Initializing built-in extension SYNC
[    33.867] Initializing built-in extension XKEYBOARD
[    33.868] Initializing built-in extension XC-MISC
[    33.868] Initializing built-in extension XINERAMA
[    33.868] Initializing built-in extension XFIXES
[    33.868] Initializing built-in extension RENDER
[    33.868] Initializing built-in extension RANDR
[    33.868] Initializing built-in extension COMPOSITE
[    33.868] Initializing built-in extension DAMAGE
[    33.868] Initializing built-in extension MIT-SCREEN-SAVER
[    33.868] Initializing built-in extension DOUBLE-BUFFER
[    33.868] Initializing built-in extension RECORD
[    33.868] Initializing built-in extension DPMS
[    33.869] Initializing built-in extension X-Resource
[    33.870] Initializing built-in extension XVideo
[    33.871] Initializing built-in extension XVideo-MotionCompensation
[    33.873] Initializing built-in extension XFree86-VidModeExtension
[    33.874] Initializing built-in extension XFree86-DGA
[    33.875] Initializing built-in extension XFree86-DRI
[    33.876] Initializing built-in extension DRI2
[    33.876] (II) "glx" will be loaded. This was enabled by default and also specified in the config file.
[    33.876] (II) LoadModule: "glx"
[    33.876] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[    33.876] (II) Module glx: vendor="X.Org Foundation"
[    33.876]    compiled for 1.13.1, module version = 1.0.0
[    33.876]    ABI class: X.Org Server Extension, version 7.0
[    33.876] (==) AIGLX enabled
[    33.877] Loading extension GLX
[    33.877] (II) LoadModule: "intel"
[    33.877] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[    33.877] (II) Module intel: vendor="X.Org Foundation"
[    33.877]    compiled for 1.13.1, module version = 2.20.13
[    33.877]    Module class: X.Org Video Driver
[    33.877]    ABI class: X.Org Video Driver, version 13.1
[    33.877] (II) intel: Driver for Intel Integrated Graphics Chipsets: i810,
   i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G, 915G,
   E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM, Pineview G,
   965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33, GM45,
   4 Series, G45/G43, Q45/Q43, G41, B43, B43, Clarkdale, Arrandale,
   Sandybridge Desktop (GT1), Sandybridge Desktop (GT2),
   Sandybridge Desktop (GT2+), Sandybridge Mobile (GT1),
   Sandybridge Mobile (GT2), Sandybridge Mobile (GT2+),
   Sandybridge Server, Ivybridge Mobile (GT1), Ivybridge Mobile (GT2),
   Ivybridge Desktop (GT1), Ivybridge Desktop (GT2), Ivybridge Server,
   Ivybridge Server (GT2), Haswell Desktop (GT1), Haswell Desktop (GT2),
   Haswell Desktop (GT2+), Haswell Mobile (GT1), Haswell Mobile (GT2),
   Haswell Mobile (GT2+), Haswell Server (GT1), Haswell Server (GT2),
   Haswell Server (GT2+), Haswell SDV Desktop (GT1),
   Haswell SDV Desktop (GT2), Haswell SDV Desktop (GT2+),
   Haswell SDV Mobile (GT1), Haswell SDV Mobile (GT2),
   Haswell SDV Mobile (GT2+), Haswell SDV Server (GT1),
   Haswell SDV Server (GT2), Haswell SDV Server (GT2+),
   Haswell ULT Desktop (GT1), Haswell ULT Desktop (GT2),
   Haswell ULT Desktop (GT2+), Haswell ULT Mobile (GT1),
   Haswell ULT Mobile (GT2), Haswell ULT Mobile (GT2+),
   Haswell ULT Server (GT1), Haswell ULT Server (GT2),
   Haswell ULT Server (GT2+), Haswell CRW Desktop (GT1),
   Haswell CRW Desktop (GT2), Haswell CRW Desktop (GT2+),
   Haswell CRW Mobile (GT1), Haswell CRW Mobile (GT2),
   Haswell CRW Mobile (GT2+), Haswell CRW Server (GT1),
   Haswell CRW Server (GT2), Haswell CRW Server (GT2+),
   ValleyView PO board
[    33.878] (--) using VT number 7

[    34.000] (EE) No devices detected.
[    34.000]
Fatal server error:
[    34.000] no screens found
[    34.000] (EE)
Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
[    34.000] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[    34.000] (EE)



this is what I get with lspci
Code:


00:00.0 Host bridge: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub (rev 0c)
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (primary) (rev 0c)
00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (secondary) (rev 0c)
00:19.0 Ethernet controller: Intel Corporation 82566MM Gigabit Network Connection (rev 03)
00:1a.0 USB controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 (rev 03)
00:1a.7 USB controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 2 (rev 03)
00:1d.0 USB controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 (rev 03)
00:1d.7 USB controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev f3)
00:1f.0 ISA bridge: Intel Corporation 82801HEM (ICH8M-E) LPC Interface Controller (rev 03)
00:1f.1 IDE interface: Intel Corporation 82801HM/HEM (ICH8M/ICH8M-E) IDE Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation 82801HM/HEM (ICH8M/ICH8M-E) SATA Controller [AHCI mode] (rev 03)
00:1f.3 SMBus: Intel Corporation 82801H (ICH8 Family) SMBus Controller (rev 03)
03:00.0 Network controller: Intel Corporation PRO/Wireless 4965 AG or AGN [Kedron] Network Connection (rev 61)
05:00.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev ba)
05:00.1 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller (rev 04)
05:00.2 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 21)



This is what I get with emerge --info

Code:


Portage 2.1.11.31 (default/linux/x86/13.0/desktop, gcc-4.5.4, glibc-2.15-r3, 3.6.11-rt25 i686)
=================================================================
System uname: Linux-3.6.11-rt25-i686-Intel-R-_Core-TM-2_Duo_CPU_L7500_@_1.60GHz-with-gentoo-2.1
Timestamp of tree: Mon, 21 Jan 2013 04:45:01 +0000
ld GNU ld (GNU Binutils) 2.22
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.4, 4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.6 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -march=i686 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -march=i686 -pipe"
GENTOO_MIRRORS="http://www.gtlib.gatech.edu/pub/gentoo http://lug.mtu.edu/gentoo/ ftp://gentoo.netnitco.net/pub/mirrors/gentoo/source/ http://gentoo.netnitco.net http://gentoo.mirrors.pair.com/ http://mirrors.rit.edu/gentoo/ http://gentoo.mirrors.tds.net/gentoo http://ftp.ucsb.edu/pub/mirrors/linux/gentoo/"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync26.us.gentoo.org/gentoo-portage"
USE="3dnow X aac aalib alsa bindist cdr consolekit crypt css curl cxx dbus directfb dvd dvdr ffmpeg flac gif gpm grub jack java jpeg lash lock midi mmx mp3 mp4 mpeg mysql ncurses nls ogg opengl pam png policykit portaudio python session sqlite sse sse2 ssl startup-notification svg tcpd threads thunar tiff truetype udev udisks vcd vorbis wavpack win32codecs wxwindows x86 xorg" ALSA_PCM_PLUGINS="*" CURL_SSL="openssl" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse synaptics" KERNEL="linux" PYTHON_TARGETS="python2_7 python3_2" USERLAND="GNU" VIDEO_CARDS="intel" XFCE_PLUGINS="brightness menu trash clock"
USE_PYTHON="2.7 3.2"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS




Further info on my system:
I have modeset by default on the kernel
all things related to Graphics are built into the kernel (as opposed to built as modules)


I would really appreciate any help.
Back to top
View user's profile Send private message
CrankyPenguin
Apprentice
Apprentice


Joined: 19 Jun 2003
Posts: 238

PostPosted: Wed Jan 23, 2013 6:30 am    Post subject: Reply with quote

2 questions:

  • Did you create an xorg.conf, if so what is in it?
  • What does /var/log/Xorg.0.log say?

_________________
Linux, the OS for the obsessive-compulsive speed freak in all of us.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum