Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
How to set wifi with wep under wpa_supplicant(solved)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
pd1986
Guru
Guru


Joined: 19 Feb 2012
Posts: 303
Location: Paris

PostPosted: Sat Jun 01, 2013 11:37 am    Post subject: How to set wifi with wep under wpa_supplicant(solved) Reply with quote

I have a wifi network in my school encrypted by wep, I can have the internet in using wicd, But I would like to use wpa_supplicant. I set some lines in wpa_supplicant.conf but I don't have the internet. I can only connect the wifi spot with IP address like this "169.254.xx.xx", if I use wicd, the IP address would be like "192.168.xx.xx". So what should I do in wpa_supplicant.conf?

the current configuration is like this

network={
ssid="test"
key_mgmt=NONE
wep_key0="123456"
wep_tx_keyidx=0
}


Last edited by pd1986 on Sun Jun 02, 2013 5:30 pm; edited 1 time in total
Back to top
View user's profile Send private message
Etal
Veteran
Veteran


Joined: 15 Jul 2005
Posts: 1641

PostPosted: Sun Jun 02, 2013 4:39 pm    Post subject: Reply with quote

It's kinda hard to say what's wrong without knowing how exactly you connect to your school's network.

I suggest using the wpa_gui frontend, which should make it easier to experiment and see what exactly is happening. (Emerge wpa_supplicant with qt4 USE flag to get it). See here: https://wiki.gentoo.org/wiki/Wpa_supplicant#Using_wpa_gui
_________________
“And even in authoritarian countries, information networks are helping people discover new facts and making governments more accountable.”– Hillary Clinton, Jan. 21, 2010
Back to top
View user's profile Send private message
pd1986
Guru
Guru


Joined: 19 Feb 2012
Posts: 303
Location: Paris

PostPosted: Sun Jun 02, 2013 5:29 pm    Post subject: Reply with quote

Etal wrote:
It's kinda hard to say what's wrong without knowing how exactly you connect to your school's network.

I suggest using the wpa_gui frontend, which should make it easier to experiment and see what exactly is happening. (Emerge wpa_supplicant with qt4 USE flag to get it). See here: https://wiki.gentoo.org/wiki/Wpa_supplicant#Using_wpa_gui


Thanks. I solved the problem with wpa_gui, auth_alg=OPEN should be added.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum