Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
System frozen -- can't boot [UDEV] -- urgent
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Xploderman90
n00b
n00b


Joined: 27 Aug 2012
Posts: 20

PostPosted: Mon Jan 21, 2013 1:22 am    Post subject: System frozen -- can't boot [UDEV] -- urgent Reply with quote

Hi all.

After last system-update ( udev updated too ) i'm unable to boot up my system.
It's frozen during booting on line : "cannot start udev as udev-mount would not start".

Some lines above there is "CONFIG_DEVTMPFS=y is required in your kernel configuration".
The problem is i can't use rescue shell because mounts file system in read only mode and i can't do anything.

Please help me because i use this pc for job and today i have to do a heavy task, now i'm in panic!! (2:25 AM here)
Back to top
View user's profile Send private message
666threesixes666
Veteran
Veteran


Joined: 31 May 2011
Posts: 1235
Location: 42.68n 85.41w

PostPosted: Mon Jan 21, 2013 1:29 am    Post subject: Reply with quote

take another system and get unetbootin.... install gentoo image or ubuntu...

chroot, recompile kernel with old config.... find devtmpfs line and change it from not set to =y
Back to top
View user's profile Send private message
Xploderman90
n00b
n00b


Joined: 27 Aug 2012
Posts: 20

PostPosted: Mon Jan 21, 2013 1:31 am    Post subject: Reply with quote

Ok, it was my last resort..i see there is nothing else to do!!
Thanks, now i'll try and i'll let you know!!
Back to top
View user's profile Send private message
Jaglover
Advocate
Advocate


Joined: 29 May 2005
Posts: 4606
Location: Saint Amant, Acadiana

PostPosted: Mon Jan 21, 2013 1:37 am    Post subject: Reply with quote

Yea, you can remount rw and fix it.
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
albright
Advocate
Advocate


Joined: 16 Nov 2003
Posts: 2082
Location: Near Toronto

PostPosted: Mon Jan 21, 2013 1:42 am    Post subject: Reply with quote

yes, I had the same problem and luckily had a system rescue
cd so I could chroot in and recompile kernel

but what I didn't see is the WARNING about this when
the udev upgrade happened.

Can someone please point out the eselect news or udev
build message that reminded users *before* upgrading
udev that a kernel recompile would be necessary if
the until now unnecessary kernel option was not selected?

Because I would really like to think this was MY fault
and not some other moron's
_________________
.... there is nothing - absolutely nothing - half so much worth
doing as simply messing about with Linux ...
(apologies to Kenneth Graeme)
Back to top
View user's profile Send private message
666threesixes666
Veteran
Veteran


Joined: 31 May 2011
Posts: 1235
Location: 42.68n 85.41w

PostPosted: Mon Jan 21, 2013 1:50 am    Post subject: Reply with quote

ill expand on what i said, ubuntu would be easiest.... as it has tools like gedit and a gui to work with....

mkdir /mnt/gentoo
mount /dev/$YOURROOT /mnt/gentoo
mkdir /mnt/gentoo/boot
mount /dev/$YOURBOOT /mnt/gentoo/boot
mount -t proc none /mntgentoo/proc
mount --rbind /dev /mnt/gentoo/dev
chroot /mnt/gentoo /bin/bash

now your ready to start fixing....

cd /usr/src/linux
make clean && make distclean && make mrproper
#copy old config to clean kernel sources
cp /boot/config-3.7.1 /usr/src/linux/.config
nano /usr/src/linux/.config

scroll down to #DEV_TMP_FS OR WHAT EVER

its line 934 for me

CONFIG_UEVENT_HELPER_PATH="/sbin/hotplug"
CONFIG_DEVTMPFS=y
CONFIG_DEVTMPFS_MOUNT=y
CONFIG_STANDALONE=y
CONFIG_PREVENT_FIRMWARE_BUILD=y

set to look like that....

then....
make menuconfig
make && make modules_install

then copy your new kernel to where your old one was.....

cp arch/x86_64/boot/bzImage /boot/kernel-3.7.1

run lilo.... or grub (see the wiki script i just posted yesterday) to get your boot loader to install the new kernel....

reboot

&& god speed man

update to add grub2 automated installs via "grub" command
https://wiki.gentoo.org/wiki/GRUB2_Quick_Start#Automating_Installs
Back to top
View user's profile Send private message
Xploderman90
n00b
n00b


Joined: 27 Aug 2012
Posts: 20

PostPosted: Mon Jan 21, 2013 2:10 am    Post subject: Reply with quote

Phew, problem solved!!
Edited .config and added the param requested, then rebuilded kernel.

Now i have another problem with mysql (it seems something strange during update) but i'll open another thread for that!

Albright, i remember that there was a warning in messages after emerge world.

Thanks to all!
Back to top
View user's profile Send private message
666threesixes666
Veteran
Veteran


Joined: 31 May 2011
Posts: 1235
Location: 42.68n 85.41w

PostPosted: Mon Jan 21, 2013 2:18 am    Post subject: Reply with quote

ls /usr/portage/distfiles | grep mysql....

revert your version back.... or version completely forward....

see

http://forums.gentoo.org/viewtopic-t-948592-highlight-.html
Back to top
View user's profile Send private message
Xploderman90
n00b
n00b


Joined: 27 Aug 2012
Posts: 20

PostPosted: Mon Jan 21, 2013 2:24 am    Post subject: Reply with quote

Yeah, i was reading that thread!! Hehe you're anticipating me in all solutions!!now i'll get back to the last working version!!
Back to top
View user's profile Send private message
tryn
Apprentice
Apprentice


Joined: 21 Dec 2002
Posts: 264

PostPosted: Mon Jan 21, 2013 2:37 am    Post subject: Reply with quote

I emerged udev today and this showed up at the end of the emerge.

* DEVTMPFS is not set in this kernel. Udev will not run.
* Please check to make sure these options are set correctly.
* Failure to do so may cause unexpected problems.


So I rebuilt the kernel before restarting the computer.
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5406

PostPosted: Mon Jan 21, 2013 7:23 am    Post subject: Reply with quote

Editing kernel config manually is one of the worse ideas you could get.
It might work every now and then, but you'll get bitten by it eventually.
Back to top
View user's profile Send private message
modnaruved
n00b
n00b


Joined: 21 Mar 2011
Posts: 74

PostPosted: Mon Jan 21, 2013 1:38 pm    Post subject: Reply with quote

Ive get these rakes too and success solve it with chrooting by gentoo liveDVD "EOWE 2012"

This is very strange that emerge system not show any warning messages about post-install steps and requirements. After emerging many packages important summary messages not show. This is not normal behaviour.
Why emerge cant detect automatically necessary options in kernel?

At this moment many "noob-users" choice gentoo as very good and friendly distro. Perhaps, these rakes is awaiting new members...
I understand that nobody can provide stable system - but from other side some parts of gentoo system needs to be some improving.
Many beginnings from "noob" level but human factor is forever. More tests before stabilization is quite.

my make.conf options:
PORTAGE_ELOG_SYSTEM="save"
PORTAGE_ELOG_CLASSES="save_summary:log,warn,error,qa echo"

this is correct for display all warnings and post-install messages after emerge many packages?
Back to top
View user's profile Send private message
BasketCase
n00b
n00b


Joined: 02 Sep 2003
Posts: 65
Location: Orlando, FL

PostPosted: Mon Jan 21, 2013 8:59 pm    Post subject: Reply with quote

I had a similar issue when switching to devtmpfs. I am going to post it in here because this is the thread I found when I searched and because I have the answer....

I got some cryptic messages about device not found, /dev/tty* not being a character device, and urandom failing to start then the system just hung during bootup.

Turns out the problem was that I had defined /dev in /etc/fstab as a tmpfs so that I could restrain the size of it with the size= mount option. If you have such an entry in /etc/fstab it must be either removed or converted to devtmpfs.
Back to top
View user's profile Send private message
Aiken
Tux's lil' helper
Tux's lil' helper


Joined: 22 Jan 2003
Posts: 130
Location: Toowoomba/Australia

PostPosted: Mon Jan 21, 2013 11:05 pm    Post subject: Reply with quote

At least the fix for me was easy enough. Add init=/bin/bash to the kernel line in grub, mount / rw then recompile the kernel. The message had long scrolled off the screen and I would have expected if there was an update that would stop the computer from booting to either refuse to install or have a warning that a person could not miss.

What I don't get is with a populated /dev from when building the initial system image why the computer could not continue booting. Even without udev and devtmpfs my /dev already had all nodes needed to boot the computer normally.
_________________
Beware the grue.
Back to top
View user's profile Send private message
Jaglover
Advocate
Advocate


Joined: 29 May 2005
Posts: 4606
Location: Saint Amant, Acadiana

PostPosted: Mon Jan 21, 2013 11:18 pm    Post subject: Reply with quote

Aiken wrote:
At least the fix for me was easy enough. Add init=/bin/bash to the kernel line in grub, mount / rw then recompile the kernel.

Nah, too easy, look at this! (You gotta learn how to do stuff the hard way, borking the config by editing it by hand is a good idea, too.)
666threesixes666 wrote:
ill expand on what i said, ubuntu would be easiest.... as it has tools like gedit and a gui to work with....

mkdir /mnt/gentoo
mount /dev/$YOURROOT /mnt/gentoo
mkdir /mnt/gentoo/boot
mount /dev/$YOURBOOT /mnt/gentoo/boot
mount -t proc none /mntgentoo/proc
mount --rbind /dev /mnt/gentoo/dev
chroot /mnt/gentoo /bin/bash

now your ready to start fixing....

cd /usr/src/linux
make clean && make distclean && make mrproper
#copy old config to clean kernel sources
cp /boot/config-3.7.1 /usr/src/linux/.config
nano /usr/src/linux/.config

scroll down to #DEV_TMP_FS OR WHAT EVER

its line 934 for me

CONFIG_UEVENT_HELPER_PATH="/sbin/hotplug"
CONFIG_DEVTMPFS=y
CONFIG_DEVTMPFS_MOUNT=y
CONFIG_STANDALONE=y
CONFIG_PREVENT_FIRMWARE_BUILD=y

set to look like that....

then....
make menuconfig
make && make modules_install

then copy your new kernel to where your old one was.....

cp arch/x86_64/boot/bzImage /boot/kernel-3.7.1

run lilo.... or grub (see the wiki script i just posted yesterday) to get your boot loader to install the new kernel....

reboot

&& god speed man

update to add grub2 automated installs via "grub" command
https://wiki.gentoo.org/wiki/GRUB2_Quick_Start#Automating_Installs

_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
Duncan Mac Leod
Apprentice
Apprentice


Joined: 02 May 2004
Posts: 174
Location: Coburg, Bavaria, Germany

PostPosted: Mon Jan 21, 2013 11:38 pm    Post subject: Reply with quote

BasketCase wrote:
Turns out the problem was that I had defined /dev in /etc/fstab as a tmpfs so that I could restrain the size of it with the size= mount option. If you have such an entry in /etc/fstab it must be either removed or converted to devtmpfs.


What's the correct entry for /etc/fstab ??

I had this entry for a while:

udev /dev tmpfs size=10M,nr_inodes=4k 0 0

Unfortunately, the portage output says that I need to edit /etc/fstab - but it tells not WHAT to edit ???
Back to top
View user's profile Send private message
666threesixes666
Veteran
Veteran


Joined: 31 May 2011
Posts: 1235
Location: 42.68n 85.41w

PostPosted: Mon Jan 21, 2013 11:46 pm    Post subject: Reply with quote

my fstab does not have a /dev or /udev rule.....

/dev/sda1 /boot jfs noauto,noatime 1 2
/dev/sda5 / xfs noatime 0 1
/dev/sda6 none swap sw 0 0
/dev/sda7 /home xfs noatime 0 0
#/dev/cdrom /mnt/cdrom auto noauto, ro 0 0
#/dev/fd0 /mnt/floppy auto noauto 0 0

&&

some people use syslinux or lilo, thats a very specific solve for grub users....
Back to top
View user's profile Send private message
ssuominen
Developer
Developer


Joined: 30 Sep 2005
Posts: 2100
Location: Finland

PostPosted: Tue Jan 22, 2013 12:25 am    Post subject: Reply with quote

Duncan Mac Leod wrote:
BasketCase wrote:
Turns out the problem was that I had defined /dev in /etc/fstab as a tmpfs so that I could restrain the size of it with the size= mount option. If you have such an entry in /etc/fstab it must be either removed or converted to devtmpfs.


What's the correct entry for /etc/fstab ??

I had this entry for a while:

udev /dev tmpfs size=10M,nr_inodes=4k 0 0

Unfortunately, the portage output says that I need to edit /etc/fstab - but it tells not WHAT to edit ???


It does now. The warning got adjusted in Portage. It can't be "tmpfs" as it must be "devtmpfs". Or you can simply delete whole line -- works fine here without any /dev line.
Back to top
View user's profile Send private message
Duncan Mac Leod
Apprentice
Apprentice


Joined: 02 May 2004
Posts: 174
Location: Coburg, Bavaria, Germany

PostPosted: Tue Jan 22, 2013 12:42 am    Post subject: Reply with quote

During boot it says that CONFIG_DEVTMPFS is not set, BUT IT IS !!! DEFINTELY!!

Using Kernel 3.3.8 gentoo-sources - what went wrong ??
Back to top
View user's profile Send private message
ssuominen
Developer
Developer


Joined: 30 Sep 2005
Posts: 2100
Location: Finland

PostPosted: Tue Jan 22, 2013 12:45 am    Post subject: Reply with quote

Duncan Mac Leod wrote:
During boot it says that CONFIG_DEVTMPFS is not set, BUT IT IS !!! DEFINTELY!!

Using Kernel 3.3.8 gentoo-sources - what went wrong ??


I guess you should run something like 'make clean' in the kernel source tree before building it after setting CONFIG_DEVTMPFS using 'make menuconfig'
Then you verify you are actually using the correct kernel, like using `ls -l` and checking the time in /boot and then grub's config

It's something simple you did wrong, if the boot is telling it's missing, it most certainly is missing
Back to top
View user's profile Send private message
Duncan Mac Leod
Apprentice
Apprentice


Joined: 02 May 2004
Posts: 174
Location: Coburg, Bavaria, Germany

PostPosted: Tue Jan 22, 2013 12:50 am    Post subject: Reply with quote

It's the correct kernel, properly built!

It boots up, but with errors -> http://www.f-mail.eu/images/gentoo_error.jpg

and Network eth0 is missing!
Back to top
View user's profile Send private message
Duncan Mac Leod
Apprentice
Apprentice


Joined: 02 May 2004
Posts: 174
Location: Coburg, Bavaria, Germany

PostPosted: Tue Jan 22, 2013 12:52 am    Post subject: Reply with quote

devfs, udev and udev-mount are in runlevel sysinit - is this correct ?
Back to top
View user's profile Send private message
666threesixes666
Veteran
Veteran


Joined: 31 May 2011
Posts: 1235
Location: 42.68n 85.41w

PostPosted: Tue Jan 22, 2013 12:54 am    Post subject: Reply with quote

eth0 is missing because its /DEV/eth0..... your kernels not installed, or you changed your /boot/config and not your /usr/src/linux/.config or you edited your /usr/src/linux/.config and make clean && make depclean && make mrproper to remove the .config........ rebuild your kernel again.... if it fails, roll back your udev version using /etc/portage/package.accept_keywords file as described on the mysql problem link a few posts up i posted.....

your correct... the 3 are sysinit run levels


Last edited by 666threesixes666 on Tue Jan 22, 2013 12:56 am; edited 1 time in total
Back to top
View user's profile Send private message
ssuominen
Developer
Developer


Joined: 30 Sep 2005
Posts: 2100
Location: Finland

PostPosted: Tue Jan 22, 2013 12:55 am    Post subject: Reply with quote

Duncan Mac Leod wrote:
devfs, udev and udev-mount are in runlevel sysinit - is this correct ?


Yes, it's correct.
Back to top
View user's profile Send private message
ssuominen
Developer
Developer


Joined: 30 Sep 2005
Posts: 2100
Location: Finland

PostPosted: Tue Jan 22, 2013 12:56 am    Post subject: Reply with quote

Duncan Mac Leod wrote:
It's the correct kernel, properly built!

It boots up, but with errors -> http://www.f-mail.eu/images/gentoo_error.jpg

and Network eth0 is missing!


eth* would go away if you don't have the /etc/udev/rules.d/80-net-name-slot.rules, otherwise you propably just have wrongly configured kernel

and the CONFIG_DEVTMPFS check is reading /proc/filesystems of the running kernel, so it really can't be wrong


Last edited by ssuominen on Tue Jan 22, 2013 1:00 am; edited 2 times in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum