Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
What's going on with perl?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
peter4
Guru
Guru


Joined: 19 Jul 2005
Posts: 345
Location: Wroclaw, Poland

PostPosted: Sun Jan 20, 2013 11:25 pm    Post subject: What's going on with perl? Reply with quote

Code:
# emerge perl -pv

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] dev-lang/perl-5.16.1  USE="berkdb gdbm -debug -doc -ithreads" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB

WARNING: One or more updates have been skipped due to a dependency conflict:

dev-lang/perl:0

  (dev-lang/perl-5.16.2::gentoo, ebuild scheduled for merge) conflicts with
    dev-lang/perl[-build] required by (perl-core/Storable-2.390.0::gentoo, installed)
  (dev-lang/perl-5.16.2::gentoo, ebuild scheduled for merge) conflicts with
    dev-lang/perl[-build] required by (dev-perl/XML-Simple-2.200.0::gentoo, installed)
  (dev-lang/perl-5.16.2::gentoo, ebuild scheduled for merge) conflicts with
    dev-lang/perl[-build] required by (dev-perl/Encode-Locale-1.30.0::gentoo, installed)
  (dev-lang/perl-5.16.2::gentoo, ebuild scheduled for merge) conflicts with
    dev-lang/perl[-build] required by (media-libs/exiftool-9.120.0::gentoo, installed)
  (dev-lang/perl-5.16.2::gentoo, ebuild scheduled for merge) conflicts with
    dev-lang/perl[-build] required by (perl-core/File-Spec-3.330.0::gentoo, installed)
  (dev-lang/perl-5.16.2::gentoo, ebuild scheduled for merge) conflicts with
    dev-lang/perl[-build] required by (perl-core/IO-1.25::gentoo, installed)
  (dev-lang/perl-5.16.2::gentoo, ebuild scheduled for merge) conflicts with
    dev-lang/perl[-build] required by (dev-perl/Algorithm-Diff-1.190.200::gentoo, installed)
  (dev-lang/perl-5.16.2::gentoo, ebuild scheduled for merge) conflicts with
    dev-lang/perl[-build] required by (dev-perl/Unicode-Map-0.112.0::gentoo, installed)
  (dev-lang/perl-5.16.2::gentoo, ebuild scheduled for merge) conflicts with
    dev-lang/perl[-build] required by (perl-core/Digest-SHA-5.740.0::gentoo, installed)
  (dev-lang/perl-5.16.2::gentoo, ebuild scheduled for merge) conflicts with
    dev-lang/perl[-build] required by (dev-perl/IO-Socket-SSL-1.810.0::gentoo, installed)
  (dev-lang/perl-5.16.2::gentoo, ebuild scheduled for merge) conflicts with
    dev-lang/perl[-build] required by (perl-core/Compress-Raw-Zlib-2.59.0::gentoo, installed)
  (dev-lang/perl-5.16.2::gentoo, ebuild scheduled for merge) conflicts with
    dev-lang/perl[-build] required by (net-analyzer/net-snmp-5.7.2::gentoo, installed)
  (dev-lang/perl-5.16.2::gentoo, ebuild scheduled for merge) conflicts with
    dev-lang/perl[-build] required by (dev-perl/WWW-RobotRules-6.10.0::gentoo, installed)
  (dev-lang/perl-5.16.2::gentoo, ebuild scheduled for merge) conflicts with
    dev-lang/perl[-build] required by (dev-perl/glib-perl-1.262.0::gentoo, installed)
  (dev-lang/perl-5.16.2::gentoo, ebuild scheduled for merge) conflicts with
    dev-lang/perl[-build] required by (dev-perl/XML-LibXML-2.1.400::gentoo, installed)
  (dev-lang/perl-5.16.2::gentoo, ebuild scheduled for merge) conflicts with
    dev-lang/perl[-build] required by (dev-vcs/git-1.8.1.1::gentoo, installed)
  (dev-lang/perl-5.16.2::gentoo, ebuild scheduled for merge) conflicts with
    dev-lang/perl[-build] required by (perl-core/Compress-Raw-Bzip2-2.59.0::gentoo, installed)
  (dev-lang/perl-5.16.2::gentoo, ebuild scheduled for merge) conflicts with
    dev-lang/perl[-build] required by (dev-perl/gtk2-perl-1.244.0::gentoo, installed)
  (dev-lang/perl-5.16.2::gentoo, ebuild scheduled for merge) conflicts with
    dev-lang/perl[-build] required by (dev-perl/Error-0.170.190::gentoo, installed)
  (dev-lang/perl-5.16.2::gentoo, ebuild scheduled for merge) conflicts with
    dev-lang/perl[-build] required by (dev-perl/HTTP-Cookies-6.0.1::gentoo, installed)
  (dev-lang/perl-5.16.2::gentoo, ebuild scheduled for merge) conflicts with
    dev-lang/perl[-build] required by (dev-perl/HTTP-Date-6.20.0::gentoo, installed)
  (dev-lang/perl-5.16.2::gentoo, ebuild scheduled for merge) conflicts with
    dev-lang/perl[-build] required by (dev-perl/Pango-1.223.0::gentoo, installed)
  (dev-lang/perl-5.16.2::gentoo, ebuild scheduled for merge) conflicts with
    dev-lang/perl[-build] required by (dev-perl/HTML-Tagset-3.200.0::gentoo, installed)
  (dev-lang/perl-5.16.2::gentoo, ebuild scheduled for merge) conflicts with
    dev-lang/perl[-build] required by (dev-perl/HTTP-Message-6.60.0::gentoo, installed)
  (dev-lang/perl-5.16.2::gentoo, ebuild scheduled for merge) conflicts with
    dev-lang/perl[-build] required by (dev-perl/HTTP-Daemon-6.10.0::gentoo, installed)
  (dev-lang/perl-5.16.2::gentoo, ebuild scheduled for merge) conflicts with
    dev-lang/perl[-build] required by (dev-perl/File-DesktopEntry-0.40.0::gentoo, installed)
  (dev-lang/perl-5.16.2::gentoo, ebuild scheduled for merge) conflicts with
    dev-lang/perl[-build] required by (dev-perl/LWP-MediaTypes-6.20.0::gentoo, installed)
  (dev-lang/perl-5.16.2::gentoo, ebuild scheduled for merge) conflicts with
    dev-lang/perl[-build] required by (dev-perl/File-BaseDir-0.30.0::gentoo, installed)
  (dev-lang/perl-5.16.2::gentoo, ebuild scheduled for merge) conflicts with
    dev-lang/perl[-build] required by (dev-perl/URI-1.600.0::gentoo, installed)
  (dev-lang/perl-5.16.2::gentoo, ebuild scheduled for merge) conflicts with
    dev-lang/perl[-build] required by (dev-perl/Crypt-RC4-2.020.0::gentoo, installed)
  (dev-lang/perl-5.16.2::gentoo, ebuild scheduled for merge) conflicts with
    dev-lang/perl[-build] required by (dev-perl/XML-Parser-2.410.0-r1::gentoo, installed)
  (dev-lang/perl-5.16.2::gentoo, ebuild scheduled for merge) conflicts with
    dev-lang/perl[-build] required by (dev-perl/LWP-Protocol-https-6.30.0::gentoo, installed)
  (dev-lang/perl-5.16.2::gentoo, ebuild scheduled for merge) conflicts with
    dev-lang/perl[-build] required by (dev-perl/Spreadsheet-ParseExcel-0.590.0::gentoo, installed)
  (dev-lang/perl-5.16.2::gentoo, ebuild scheduled for merge) conflicts with
    dev-lang/perl[-build] required by (dev-perl/IO-stringy-2.110.0::gentoo, installed)
  (dev-lang/perl-5.16.2::gentoo, ebuild scheduled for merge) conflicts with
    dev-lang/perl[-build] required by (dev-perl/File-Listing-6.40.0::gentoo, installed)
  (dev-lang/perl-5.16.2::gentoo, ebuild scheduled for merge) conflicts with
    dev-lang/perl[-build] required by (dev-perl/Net-HTTP-6.50.0::gentoo, installed)
  (dev-lang/perl-5.16.2::gentoo, ebuild scheduled for merge) conflicts with
    dev-lang/perl[-build] required by (media-video/ripwrap-0.20::sunrise, installed)
  (dev-lang/perl-5.16.2::gentoo, ebuild scheduled for merge) conflicts with
    dev-lang/perl[-build] required by (dev-perl/HTML-Parser-3.690.0::gentoo, installed)
  (dev-lang/perl-5.16.2::gentoo, ebuild scheduled for merge) conflicts with
    dev-lang/perl[-build] required by (dev-perl/Text-Unidecode-0.40.0::gentoo, installed)
  (dev-lang/perl-5.16.2::gentoo, ebuild scheduled for merge) conflicts with
    dev-lang/perl[-build] required by (dev-perl/Net-SSLeay-1.490.0::gentoo, installed)
  (dev-lang/perl-5.16.2::gentoo, ebuild scheduled for merge) conflicts with
    dev-lang/perl[-build] required by (dev-perl/XML-SAX-0.990.0::gentoo, installed)
  (dev-lang/perl-5.16.2::gentoo, ebuild scheduled for merge) conflicts with
    dev-lang/perl[-build] required by (dev-perl/Authen-SASL-2.160.0::gentoo, installed)
  (dev-lang/perl-5.16.2::gentoo, ebuild scheduled for merge) conflicts with
    dev-lang/perl[-build] required by (dev-perl/File-MimeInfo-0.160.0::gentoo, installed)
  (dev-lang/perl-5.16.2::gentoo, ebuild scheduled for merge) conflicts with
    dev-lang/perl[-build] required by (dev-vcs/subversion-1.7.7::gentoo, installed)
  (dev-lang/perl-5.16.2::gentoo, ebuild scheduled for merge) conflicts with
    dev-lang/perl[-build] required by (dev-perl/DateManip-6.370.0::gentoo, installed)
  (dev-lang/perl-5.16.2::gentoo, ebuild scheduled for merge) conflicts with
    dev-lang/perl[-build] required by (dev-perl/Unicode-EastAsianWidth-1.330.0::gentoo, installed)
  (dev-lang/perl-5.16.2::gentoo, ebuild scheduled for merge) conflicts with
    dev-lang/perl[-build] required by (dev-perl/XML-NamespaceSupport-1.110.0::gentoo, installed)
  (dev-lang/perl-5.16.2::gentoo, ebuild scheduled for merge) conflicts with
    dev-lang/perl[-build] required by (dev-perl/XML-SAX-Base-1.80.0::gentoo, installed)
  (dev-lang/perl-5.16.2::gentoo, ebuild scheduled for merge) conflicts with
    dev-lang/perl[-build] required by (dev-perl/TimeDate-1.200.0::gentoo, installed)
  (dev-lang/perl-5.16.2::gentoo, ebuild scheduled for merge) conflicts with
    dev-lang/perl[-build] required by (perl-core/Scalar-List-Utils-1.270.0::gentoo, installed)
  (dev-lang/perl-5.16.2::gentoo, ebuild scheduled for merge) conflicts with
    dev-lang/perl[-build] required by (dev-perl/libintl-perl-1.210.0::gentoo, installed)
  (dev-lang/perl-5.16.2::gentoo, ebuild scheduled for merge) conflicts with
    dev-lang/perl[-build] required by (dev-perl/Digest-Perl-MD5-1.800.0::gentoo, installed)
  (dev-lang/perl-5.16.2::gentoo, ebuild scheduled for merge) conflicts with
    dev-lang/perl[-build] required by (dev-perl/HTTP-Negotiate-6.0.1::gentoo, installed)
  (dev-lang/perl-5.16.2::gentoo, ebuild scheduled for merge) conflicts with
    dev-lang/perl[-build] required by (perl-core/IO-Compress-2.59.0::gentoo, installed)
  (dev-lang/perl-5.16.2::gentoo, ebuild scheduled for merge) conflicts with
    dev-lang/perl[-build] required by (dev-perl/Digest-HMAC-1.30.0::gentoo, installed)
  (dev-lang/perl-5.16.2::gentoo, ebuild scheduled for merge) conflicts with
    dev-lang/perl[-build] required by (dev-perl/Net-SMTP-SSL-1.10.0::gentoo, installed)
  (dev-lang/perl-5.16.2::gentoo, ebuild scheduled for merge) conflicts with
    dev-lang/perl[-build] required by (dev-perl/Cairo-1.102.0::gentoo, installed)
  (dev-lang/perl-5.16.2::gentoo, ebuild scheduled for merge) conflicts with
    dev-lang/perl[-build] required by (perl-core/Time-Local-1.230.0::gentoo, installed)
  (dev-lang/perl-5.16.2::gentoo, ebuild scheduled for merge) conflicts with
    dev-lang/perl[-build] required by (dev-perl/IO-HTML-0.40.0::gentoo, installed)
  (dev-lang/perl-5.16.2::gentoo, ebuild scheduled for merge) conflicts with
    dev-lang/perl[-build] required by (perl-core/Digest-MD5-2.520.0::gentoo, installed)
  (dev-lang/perl-5.16.2::gentoo, ebuild scheduled for merge) conflicts with
    dev-lang/perl[-build] required by (dev-perl/libwww-perl-6.40.0::gentoo, installed)
  (dev-lang/perl-5.16.2::gentoo, ebuild scheduled for merge) conflicts with
    dev-lang/perl[-build] required by (dev-perl/OLE-StorageLite-0.190.0::gentoo, installed)
  (dev-lang/perl-5.16.2::gentoo, ebuild scheduled for merge) conflicts with
    dev-lang/perl[-build] required by (perl-core/Encode-2.470.0::gentoo, installed)
  (dev-lang/perl-5.16.2::gentoo, ebuild scheduled for merge) conflicts with
    dev-lang/perl[-build] required by (dev-perl/Text-CSV_XS-0.950.0::gentoo, installed)
Back to top
View user's profile Send private message
mDup
n00b
n00b


Joined: 14 Apr 2006
Posts: 17

PostPosted: Mon Jan 21, 2013 1:24 am    Post subject: Reply with quote

similar issue here :oops:
Back to top
View user's profile Send private message
floppymaster
Developer
Developer


Joined: 07 Jul 2010
Posts: 217
Location: Detroit, MI, USA

PostPosted: Mon Jan 21, 2013 3:04 am    Post subject: Reply with quote

I have filed a bug.

https://bugs.gentoo.org/show_bug.cgi?id=453268
Back to top
View user's profile Send private message
mDup
n00b
n00b


Joined: 14 Apr 2006
Posts: 17

PostPosted: Mon Jan 21, 2013 7:49 pm    Post subject: Reply with quote

floppymaster wrote:
I have filed a bug.

https://bugs.gentoo.org/show_bug.cgi?id=453268


thanks, adding 'build' to IUSE seems to work.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum