Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Can't get vncviewer -via to work [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5251

PostPosted: Sun Jan 20, 2013 8:49 pm    Post subject: Can't get vncviewer -via to work [SOLVED] Reply with quote

I've been trying to use vncviewer with -via, but anything I try results in vncviewer spitting out a list of options. I've tried:

vncviewer -via (user)@(host_ip_address):(display_num) localhost
vncviewer -via (user)@(host_ip_address) localhost
vncviewer -via (host_ip_address) localhost

and various combinations. What am I missing? Unencrypted VNC (tigervnc on the remote machine) works, and I can ssh in to my remote machine.
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Pappy's Kernel Seeds: http://kernel-seeds.gentoostudio.org


Last edited by audiodef on Tue Jan 22, 2013 4:08 pm; edited 1 time in total
Back to top
View user's profile Send private message
Gusar
Advocate
Advocate


Joined: 09 Apr 2005
Posts: 2642
Location: Slovenia

PostPosted: Sun Jan 20, 2013 9:08 pm    Post subject: Reply with quote

If you're using tigervnc-1.2.0, there is no -via. It hasn't been implemented yet in the new fltk-based viewer. I know it's still listed in the manpage, but that's just because it's outdated. Upstream bug report: http://sourceforge.net/tracker/?func=detail&atid=1126848&aid=3588877&group_id=254363 <- status: patches welcome
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5251

PostPosted: Sun Jan 20, 2013 9:10 pm    Post subject: Reply with quote

Oh, OK. Thanks for the info. :)
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Pappy's Kernel Seeds: http://kernel-seeds.gentoostudio.org
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5251

PostPosted: Sun Jan 20, 2013 9:40 pm    Post subject: Reply with quote

If I choose to downgrade, does tigervnc need to be downgraded on both client and server machines? Because I downgraded on the client machine and I'm getting connection refused errors for -via.
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Pappy's Kernel Seeds: http://kernel-seeds.gentoostudio.org
Back to top
View user's profile Send private message
Gusar
Advocate
Advocate


Joined: 09 Apr 2005
Posts: 2642
Location: Slovenia

PostPosted: Sun Jan 20, 2013 9:45 pm    Post subject: Reply with quote

As far as I know -via is all client-side, the server shouldn't matter.
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5251

PostPosted: Sun Jan 20, 2013 10:24 pm    Post subject: Reply with quote

Ah, I forgot to add the display number to localhost. It works.

How would I configure tigervnc to not accept any connections that are not tunneled?
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Pappy's Kernel Seeds: http://kernel-seeds.gentoostudio.org
Back to top
View user's profile Send private message
Gusar
Advocate
Advocate


Joined: 09 Apr 2005
Posts: 2642
Location: Slovenia

PostPosted: Sun Jan 20, 2013 10:43 pm    Post subject: Reply with quote

There's an option for the server to listen only on localhost, "man Xvnc" is your friend.

Beyond that, just set the firewall to not let standard vnc ports through. The usual recommended firewall config is to block all inbound connections except specific (for example, ssh) ports, so if you use a config like that, you're already covered.
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5251

PostPosted: Mon Jan 21, 2013 1:39 am    Post subject: Reply with quote

Gotcha. All I had to do was put -localhost in VNC_OPTS in /etc/init.d/tigervnc.

Thanks for your help. :)

EDIT:

It keeps disconnecting, after which all further connections are refused unless I restart tigervnc. Another known issue?

Actually, now I'm seeing tigervnc failing to stop...
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Pappy's Kernel Seeds: http://kernel-seeds.gentoostudio.org
Back to top
View user's profile Send private message
Gusar
Advocate
Advocate


Joined: 09 Apr 2005
Posts: 2642
Location: Slovenia

PostPosted: Fri Jan 25, 2013 9:46 am    Post subject: Reply with quote

Weeeeeeee, -via has been added to tigervnc svn: http://thread.gmane.org/gmane.network.vnc.tigervnc.scm/1400

On Arch, I provide a svn PKGBUILD - https://aur.archlinux.org/packages/tigervnc-svn/ - I haven't bothered creating a live ebuild for gentoo.
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5251

PostPosted: Fri Jan 25, 2013 3:32 pm    Post subject: Reply with quote

Gusar wrote:
Weeeeeeee, -via has been added to tigervnc svn: http://thread.gmane.org/gmane.network.vnc.tigervnc.scm/1400



Nice!
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Pappy's Kernel Seeds: http://kernel-seeds.gentoostudio.org
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum