Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Nikon D7000 und Xfce4
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Erdie
Veteran
Veteran


Joined: 20 May 2004
Posts: 1674
Location: Heidelberg - Germany

PostPosted: Wed Apr 10, 2013 7:43 am    Post subject: Nikon D7000 und Xfce4 Reply with quote

Mein Nikon D7000 scheint kein Massenspeicherprotokoll zu haben. Im KDE erscheint ein Item mit dem Namen "Camera" aus dem ich den Inhalt der beiden Speicherkarten kopieren kann.

Im Xfce erscheint im Syslog eine Meldung über eine Art Camera device aber sonst tut sich nichts. Die Thunar media Plugins sind installiert. Gibt es eine simple Möglichkeit, das auch unter Xfce hinzubekommen, dass ich die Kamera auslesen kann?
Ich möchte kein Monstrum installieren, was die kdelibs als Abhängigkeit mitbring z. B. Digikam

Grüße
Erdie
_________________
Desktop Phenom II X4 8GB RAM, Asus GF 430 fanless. Sound RME Multiface + PCI + Cardbus, 2x RME Quadmic, 1x Behringer ADA8000.
2x IBM Thinkpad T60
Zotag Mag Mini Atom
Raspberry Pi
Back to top
View user's profile Send private message
firefly
Advocate
Advocate


Joined: 31 Oct 2002
Posts: 4113

PostPosted: Wed Apr 10, 2013 7:52 am    Post subject: Reply with quote

scheinbar hat thunar keinen support für MTP devices
_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.
Back to top
View user's profile Send private message
Erdie
Veteran
Veteran


Joined: 20 May 2004
Posts: 1674
Location: Heidelberg - Germany

PostPosted: Wed Apr 10, 2013 8:11 am    Post subject: Reply with quote

Gibt es denn sowas wie die kleinste (im Sinne von Bloatware) mögliche Lösung, die ich installieren können um wenigstens einen Datentransfer zu erreichen?

Man kann einen Cardreader nehmen .. ja .. aber die Nikon hat 2 SD Slots, da wird das schon wieder etwas umständlich.

Danke und Grüße
Erdie
_________________
Desktop Phenom II X4 8GB RAM, Asus GF 430 fanless. Sound RME Multiface + PCI + Cardbus, 2x RME Quadmic, 1x Behringer ADA8000.
2x IBM Thinkpad T60
Zotag Mag Mini Atom
Raspberry Pi
Back to top
View user's profile Send private message
bell
Guru
Guru


Joined: 27 Nov 2007
Posts: 418

PostPosted: Wed Apr 10, 2013 8:23 am    Post subject: Reply with quote

Thunar nutzt gvfs und gvfs hat USE=gphoto2. Damit sollte es gehen.
Back to top
View user's profile Send private message
syn0ptik
Apprentice
Apprentice


Joined: 09 Jan 2013
Posts: 218

PostPosted: Wed Apr 10, 2013 9:00 am    Post subject: Reply with quote

Warum du hates gpicview?
Back to top
View user's profile Send private message
Erdie
Veteran
Veteran


Joined: 20 May 2004
Posts: 1674
Location: Heidelberg - Germany

PostPosted: Wed Apr 10, 2013 10:19 am    Post subject: Reply with quote

@bell: Danke, das werde ich probieren.
_________________
Desktop Phenom II X4 8GB RAM, Asus GF 430 fanless. Sound RME Multiface + PCI + Cardbus, 2x RME Quadmic, 1x Behringer ADA8000.
2x IBM Thinkpad T60
Zotag Mag Mini Atom
Raspberry Pi
Back to top
View user's profile Send private message
firefly
Advocate
Advocate


Joined: 31 Oct 2002
Posts: 4113

PostPosted: Wed Apr 10, 2013 3:49 pm    Post subject: Reply with quote

ansonsten würde noch folgendes in frage kommen (halt keine GUI ;))
Quote:
* sys-fs/mtpfs
Available versions: 1.0 ~1.1 {{debug mad}}
Homepage: http://www.adebenham.com/mtpfs/
Description: A FUSE filesystem providing access to MTP devices

_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.
Back to top
View user's profile Send private message
Erdie
Veteran
Veteran


Joined: 20 May 2004
Posts: 1674
Location: Heidelberg - Germany

PostPosted: Thu Apr 11, 2013 11:43 am    Post subject: Reply with quote

mtpfs funktioniert nicht:

Code:

Apr 11 13:40:01 ibmbook cron[19612]: (root) CMD (test -x /usr/sbin/run-crons && /usr/sbin/run-crons)
Apr 11 13:40:28 ibmbook kernel: fuse init (API version 7.20)
Apr 11 13:41:51 ibmbook kernel: usb 1-5: new high-speed USB device number 4 using ehci_hcd
Apr 11 13:41:51 ibmbook kernel: usb 1-5: New USB device found, idVendor=04b0, idProduct=0428
Apr 11 13:41:51 ibmbook kernel: usb 1-5: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Apr 11 13:41:51 ibmbook kernel: usb 1-5: Product: NIKON DSC D7000
Apr 11 13:41:51 ibmbook kernel: usb 1-5: Manufacturer: NIKON
Apr 11 13:41:51 ibmbook kernel: usb 1-5: SerialNumber: 000006461567
Apr 11 13:41:51 ibmbook mtp-probe: checking bus 1, device 4: "/sys/devices/pci0000:00/0000:00:1d.7/usb1/1-5"
Apr 11 13:41:51 ibmbook mtp-probe: bus: 1, device: 4 was not an MTP device


Bin mal extra nach hause gefahren um das auszuprobieren :(
_________________
Desktop Phenom II X4 8GB RAM, Asus GF 430 fanless. Sound RME Multiface + PCI + Cardbus, 2x RME Quadmic, 1x Behringer ADA8000.
2x IBM Thinkpad T60
Zotag Mag Mini Atom
Raspberry Pi
Back to top
View user's profile Send private message
Erdie
Veteran
Veteran


Joined: 20 May 2004
Posts: 1674
Location: Heidelberg - Germany

PostPosted: Thu Apr 11, 2013 5:00 pm    Post subject: Reply with quote

Die Kamera nutzt PTP. gphoto2 und gtkam haben das Problem gelöst.
_________________
Desktop Phenom II X4 8GB RAM, Asus GF 430 fanless. Sound RME Multiface + PCI + Cardbus, 2x RME Quadmic, 1x Behringer ADA8000.
2x IBM Thinkpad T60
Zotag Mag Mini Atom
Raspberry Pi
Back to top
View user's profile Send private message
Erdie
Veteran
Veteran


Joined: 20 May 2004
Posts: 1674
Location: Heidelberg - Germany

PostPosted: Fri Apr 12, 2013 8:11 am    Post subject: Reply with quote

Nachtrag zum Thema USE=gphotot2 und Thunar:
Ich konnte Thunar nicht dazu überreden, irgendwas Kameramäßiges über den Volman anzuzeigen trotz use flag. Daher habe ich gtkam installiert. Ist zwar nicht so elegant aber funktioniert.
_________________
Desktop Phenom II X4 8GB RAM, Asus GF 430 fanless. Sound RME Multiface + PCI + Cardbus, 2x RME Quadmic, 1x Behringer ADA8000.
2x IBM Thinkpad T60
Zotag Mag Mini Atom
Raspberry Pi
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum