Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] sys-apps/systemd-197
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
schmidicom
Veteran
Veteran


Joined: 09 Mar 2006
Posts: 1017
Location: Schweiz

PostPosted: Sun Jan 20, 2013 2:44 pm    Post subject: [solved] sys-apps/systemd-197 Reply with quote

Hallo,
ich versuche gerade dieses ebuild (sys-apps/systemd-197) zu installieren und leider bricht es immer wieder an einer ganz bestimmten Stelle ab. Laut bugs.gentoo.org liegt es an der Datei "/etc/init.d/README" und das man diese nicht installieren soll.

Doch wie macht man das? Wie kann ich Portage auf einfach Weise sagen das es diese Datei ignorieren soll?
Das ganze ist ziemlich dringend da ohne dieses Update ein herunterfahren oder neustarten des Systems wohl keine sehr gute Idee wäre jetzt wo udev schon auf 197 ist.

https://bugs.gentoo.org/show_bug.cgi?id=453028
_________________
Mich braucht jeder. Zumindest behaupten viele, ich hätte gerade noch gefehlt. ;)
GPG: 0x54A19454 - Download | (0x5E2B12A0 ist veraltet)


Last edited by schmidicom on Sun Jan 20, 2013 7:23 pm; edited 1 time in total
Back to top
View user's profile Send private message
bell
Guru
Guru


Joined: 27 Nov 2007
Posts: 424

PostPosted: Sun Jan 20, 2013 4:23 pm    Post subject: Reply with quote

Ich würde es wie folgt versuchen:
Code:
rm /var/tmp/portage/sys-apps/systemd-197/image///etc/init.d/README
ebuild /usr/portage/sys-apps/systemd/systemd-197.ebuild merge
Back to top
View user's profile Send private message
schmidicom
Veteran
Veteran


Joined: 09 Mar 2006
Posts: 1017
Location: Schweiz

PostPosted: Sun Jan 20, 2013 7:22 pm    Post subject: Reply with quote

Ich habe inzwischen einfach eine angepasste Version von dem offiziellen ebuild in mein local overlay kopiert das die entsprechende Datei löscht bevor emerge das ganze installiert.

Aber trotzdem, Danke.
_________________
Mich braucht jeder. Zumindest behaupten viele, ich hätte gerade noch gefehlt. ;)
GPG: 0x54A19454 - Download | (0x5E2B12A0 ist veraltet)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum