Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
qemu-9999: 1.4.50@05499f4 running much slower than 1.2.50
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
jeffk
Guru
Guru


Joined: 13 Sep 2003
Posts: 587

PostPosted: Sun Feb 17, 2013 4:08 am    Post subject: qemu-9999: 1.4.50@05499f4 running much slower than 1.2.50 Reply with quote

I noticed today that my local ebuild of qemu-9999 had not pulled changes in quite some weeks. Found qemu-9999 in tree, switched to that. Emerged with use vars as follows, of which systemtapm virtfs usbredir are newly applied, they weren't present/used in my local qemu-9999:
Code:
: % sudo emerge qemu -pv
: [ebuild R *] app-emulation/qemu-9999 USE="aio alsa caps curl fdt jpeg ncurses
: opengl png pulseaudio python sasl seccomp spice systemtap threads tls usbredir
: uuid vde vhost-net virtfs vnc xattr -bluetooth -brltty -debug -doc -mixemu -rbd
: -sdl (-selinux) -smartcard -static -tci -xen -xfs" QEMU_SOFTMMU_TARGETS="x86_64
: -alpha -arm -cris -i386 -lm32 -m68k -microblaze -microblazeel -mips -mips64
: -mips64el -mipsel -or32 -ppc -ppc64 -ppcemb -s390x -sh4 -sh4eb -sparc -sparc64
: -unicore32 -xtensa -xtensaeb" QEMU_USER_TARGETS="-alpha -arm -armeb -cris -i386
: -m68k -microblaze -microblazeel -mips -mipsel -or32 -ppc -ppc64 -ppc64abi32
: -s390x -sh4 -sh4eb -sparc -sparc32plus -sparc64 -unicore32 -x86_64" 0 kB

Code:
: grep -i kvm kernel-config-x86_64-3.7.8-gentoo
: CONFIG_HAVE_KVM=y
: CONFIG_HAVE_KVM_IRQCHIP=y
: CONFIG_HAVE_KVM_EVENTFD=y
: CONFIG_KVM_APIC_ARCHITECTURE=y
: CONFIG_KVM_MMIO=y
: CONFIG_KVM_ASYNC_PF=y
: CONFIG_HAVE_KVM_MSI=y
: CONFIG_HAVE_KVM_CPU_RELAX_INTERCEPT=y
: CONFIG_KVM=m
: CONFIG_KVM_INTEL=m
: # CONFIG_KVM_AMD is not set

qemu git head is at commit 05499f4b9fd431631299dc1b70156dbc1fb4331.
Code:
: lsmod |grep kvm
: kvm_intel             115063  0
: kvm                   233708  1 kvm_intel

Windows XP HAL selected is:
Code:
: "ACPI Multiprocessor PC," ACPI APIC MP HAL (Halmacpi.dll)

qemu command line:
Code:
: sudo qemu-kvm -m 768 -hda windowsxp01.raw -daemonize -net nic,macaddr=52:54:00:12:34:56,model=virtio -net user -usbdevice tablet -vnc :1

My Windows XP VM is running noticeably slower with the new qemu build of 1.4.50 than before at 1.2.50. Its not quite so bad that I don't think hardware virtualization is used, but it's pretty close. I see window/menu redraws in progress. Two cores of my quad-core i5 were pegged (100.3% and 96%) by qemu, with nothing more going on in the VM other than a file transfer. At idle, VM CPU usage is 13-19%, host qemu process in top is about the same at 19%.

- Are any of the above use vars known risks to encounter a performance drop-off like this?

- Am I missing anything in kernel config and/or qemu startup params to avoid performance drop-off?

Thanks for any suggestions.

UPDATE:

After realizing that installing 16 pending windows updates were going to take hours, it was clear something wasn't right. I recompiled without the new use vars, and reemerged qemu-9999. There is no change, it still runs slow. So at least I can rule out the use var changes as causes:
Code:
: sudo emerge --unmerge usbredir systemtap
: grep qemu -A 1 /etc/portage/package.use
: app-emulation/qemu -sdl fdt qemu-ifup spice vde
: # systemtap tls usbredir virtfs
: sudo emerge qemu
Back to top
View user's profile Send private message
syn0ptik
Apprentice
Apprentice


Joined: 09 Jan 2013
Posts: 235

PostPosted: Sun Feb 17, 2013 4:57 am    Post subject: Reply with quote

qemu 1.2.2, everythings okay, but disk usage is slow. I use xfs for images, the images inside seems fragmented hardly.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum