Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Wykrywanie modemu Play ZTE MF631
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish) Instalacja i sprzęt
View previous topic :: View next topic  
Author Message
bimbarabam
n00b
n00b


Joined: 20 Dec 2012
Posts: 6

PostPosted: Sat Jan 19, 2013 12:44 pm    Post subject: Wykrywanie modemu Play ZTE MF631 Reply with quote

Witam!
Otóż od paru dni usiluje zmusic moje gentoo, zeby poprwanie wykrywalo moj modem. Problem jest taki ze jak widac z logow caly czas jest wykrywany jako pamiec masowa, anie jako modem. Wczesniej jeszcze byl wykrywany jako cd rom ale to udalo mi sie obejsc. Wszelkie opcje dotyczace obslugi modemow usb mam wkomplowane w jadro. Troche juz grzebalem w kernelu, ale nie moge dojsc do ładu z tym - nie mam w ogole w /dev zadnego urzadzenia w stylu ttyUSB, a tak powinien byc modem widoczny. Czy ktos z was mial moze podobnyproblem, alboo udało mu się poprawnie skonfigurować połączenie na tym modemie?

Code:
[ 2750.555360] ehci_hcd 0000:00:1d.7: GetStatus port:4 status 001005 0  ACK POWER sig=se0 PE CONNECT
[ 2750.606121] usb 2-4: new high-speed USB device number 6 using ehci_hcd
[ 2750.657346] ehci_hcd 0000:00:1d.7: port 4 reset complete, port enabled
[ 2750.657355] ehci_hcd 0000:00:1d.7: GetStatus port:4 status 001005 0  ACK POWER sig=se0 PE CONNECT
[ 2750.721626] usb 2-4: default language 0x0409
[ 2750.722878] usb 2-4: udev 6, busnum 2, minor = 133
[ 2750.722886] usb 2-4: New USB device found, idVendor=19d2, idProduct=0031
[ 2750.722892] usb 2-4: New USB device strings: Mfr=3, Product=2, SerialNumber=4
[ 2750.722898] usb 2-4: Product: ZTE WCDMA Technologies MSM
[ 2750.722903] usb 2-4: Manufacturer: ZTE,Incorporated
[ 2750.722909] usb 2-4: SerialNumber: MF6310ZTED010000
[ 2750.723137] usb 2-4: usb_probe_device
[ 2750.723143] usb 2-4: configuration #1 chosen from 1 choice
[ 2750.725501] usb 2-4: adding 2-4:1.0 (config #1, interface 0)
[ 2750.725605] usb 2-4: adding 2-4:1.1 (config #1, interface 1)
[ 2750.725697] usb 2-4: adding 2-4:1.2 (config #1, interface 2)
[ 2750.725753] usb-storage 2-4:1.2: usb_probe_interface
[ 2750.725765] usb-storage 2-4:1.2: usb_probe_interface - got id
[ 2750.725872] scsi8 : usb-storage 2-4:1.2
[ 2750.725962] usb 2-4: adding 2-4:1.3 (config #1, interface 3)
[ 2750.726066] hub 2-0:1.0: state 7 ports 6 chg 0000 evt 0010
[ 2751.729549] scsi 8:0:0:0: Direct-Access     ZTE      MMC Storage      2.31 PQ: 0 ANSI: 2
[ 2751.729741] sd 8:0:0:0: Attached scsi generic sg1 type 0
[ 2751.733022] sd 8:0:0:0: [sdb] Attached SCSI removable disk
Back to top
View user's profile Send private message
SlashBeast
Moderator
Moderator


Joined: 23 May 2006
Posts: 2831

PostPosted: Sat Jan 19, 2013 6:01 pm    Post subject: Reply with quote

Wiele modemow usb ma w sobie jakas pamiec badz slot na karty pamieci, sprawdz czy masz w kernelu CONFIG_SCSI_MULTI_LUN, sprawdz tez co mowi lsusb.
_________________
BitBucket -- better-initramfs
Back to top
View user's profile Send private message
bimbarabam
n00b
n00b


Joined: 20 Dec 2012
Posts: 6

PostPosted: Sun Jan 20, 2013 12:19 pm    Post subject: Reply with quote

Wkompilowałem tą opcję - jednak dalej to samo. a co do lsusb:
Code:
Bus 002 Device 008: ID 19d2:0031 ZTE WCDMA Technologies MSM MF110/MF627/MF636

Back to top
View user's profile Send private message
bimbarabam
n00b
n00b


Joined: 20 Dec 2012
Posts: 6

PostPosted: Sun Jan 20, 2013 7:16 pm    Post subject: Reply with quote

kwestia byla tego ze usb serial converter musialbyc jako modul w kernelu. Poszedlem troche dalej, jednak dalej sa problemy ale tym razem z PPP: w wvdial dostaje komunikat, ze pppd exit code = 1. Podejrzałem loga i tam zobaczyłem bląd
Code:
couldn't set tty to ppp discipline

Przeczytałem w necie, ze to podobno zalezy od opcji async serial cos tam w kernelu przy konfiguracji ppp, ale mam to jako moduł w kernelu więc powinno działać. Gdy próbuję zrobić modprobe ppp_generic dostaję błąd : "Error inserting ppp_generic ... invalid module format"[/code]
Back to top
View user's profile Send private message
canis_lupus
l33t
l33t


Joined: 22 Dec 2005
Posts: 746
Location: Kraków

PostPosted: Wed Jan 23, 2013 8:35 am    Post subject: Reply with quote

Mnie się tego modemu nie udało uruchomić. Polecam dowolne chyba huawei. Śmigają. Wbudowany dellowy też.
_________________
"I love you cię" Różyczko...
Fotografia ślubna
Back to top
View user's profile Send private message
regdos
n00b
n00b


Joined: 07 Nov 2007
Posts: 4

PostPosted: Sat Jan 26, 2013 6:09 pm    Post subject: Reply with quote

usb_modeswitch masz zainstalowane?
Back to top
View user's profile Send private message
bimbarabam
n00b
n00b


Joined: 20 Dec 2012
Posts: 6

PostPosted: Sun Jan 27, 2013 11:33 am    Post subject: Reply with quote

tak mam, tylko problemem chyba teraz jest wysypywanie sie ppp..
Back to top
View user's profile Send private message
regdos
n00b
n00b


Joined: 07 Nov 2007
Posts: 4

PostPosted: Sun Jan 27, 2013 4:14 pm    Post subject: Reply with quote

usb_modeswitch przełącza modem w tryb modemu i tworzone są odpowiednie porty dla połączenia? w dmesg powinno być to widać po włożeniu modemu do USB.

Jaki masz port modemu w wvdial do połączenia?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish) Instalacja i sprzęt All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum