Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emul-linux-x86-opengl blocks glu-9.0.0 [solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Oo.et.oO
Apprentice
Apprentice


Joined: 23 Apr 2002
Posts: 291
Location: burlington

PostPosted: Fri Jan 18, 2013 4:30 am    Post subject: emul-linux-x86-opengl blocks glu-9.0.0 [solved] Reply with quote

near as i can tell both are required. but i can't get either to update independently.

Code:
  (media-libs/glu-9.0.0::gentoo, ebuild scheduled for merge) pulled in by
    media-libs/glu required by (virtual/glu-9.0::gentoo, ebuild scheduled for merge)

  (app-emulation/emul-linux-x86-opengl-20121202-r1::gentoo, installed) pulled in by
    ~app-emulation/emul-linux-x86-opengl-20121202 required by (app-emulation/emul-linux-x86-qtlibs-20121202::gentoo, ebuild scheduled for merge)
    app-emulation/emul-linux-x86-opengl required by (app-emulation/emul-linux-x86-xlibs-20121202::gentoo, ebuild scheduled for merge)
    ~app-emulation/emul-linux-x86-opengl-20121202 required by (app-emulation/emul-linux-x86-gtklibs-20121202::gentoo, ebuild scheduled for merge)


Code:
equery d virtual/glu
 * These packages depend on virtual/glu:
dev-java/swt-3.5.2 (opengl ? virtual/glu)
dev-perl/PDL-2.4.3-r1 (opengl ? virtual/glu)
media-libs/freeglut-2.6.0 (virtual/glu)
media-libs/ftgl-2.1.3_rc5 (virtual/glu)
media-libs/libcaca-0.99_beta17 (opengl ? virtual/glu)
media-libs/libsdl-1.2.14-r6 (opengl ? virtual/glu)
media-libs/smpeg-0.4.4-r9 (opengl ? virtual/glu)
x11-libs/fox-1.6.40 (opengl ? virtual/glu)


Code:
equery d app-emulation/emul-linux-x86-opengl
 * These packages depend on app-emulation/emul-linux-x86-opengl:
app-emulation/emul-linux-x86-gtklibs-20110129 (~app-emulation/emul-linux-x86-opengl-20110129)
app-emulation/emul-linux-x86-xlibs-20110129 (app-emulation/emul-linux-x86-opengl)
net-im/skype-2.2.0.35-r1 (>=app-emulation/emul-linux-x86-opengl-20091231)


mesa-9.0.0 is contributing its fair share of confusion as well, but seems to be a secondary issue...

Code:
emerge --info
Portage 2.1.11.31 (!../usr/portage/profiles/default/linux/amd64/10.0/desktop, gcc-4.4.5, glibc-2.12.2, 2.6.37-gentoo-r4 x86_64)
=================================================================
System uname: Linux-2.6.37-gentoo-r4-x86_64-Intel-R-_Core-TM-_i3_CPU_540_@_3.07GHz-with-gentoo-2.0.3
Timestamp of tree: Wed, 16 Jan 2013 20:45:01 +0000
ld GNU ld (GNU Binutils) 2.21.1
ccache version 2.4 [enabled]
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.1-r1, 3.1.3-r1
dev-util/ccache:          2.4-r9
dev-util/cmake:           2.8.4-r1
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.8.3-r1
sys-apps/sandbox:         2.4
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:       2.21.1
sys-devel/gcc:            4.4.5
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82
sys-kernel/linux-headers: 2.6.36.1 (virtual/os-headers)
sys-libs/glibc:           2.12.2
Repositories: gentoo sunrise mozilla ibm-internal zugaina java-overlay x-erict
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=nocona -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=nocona -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS=""
FEATURES="assume-digests binpkg-logs candy ccache config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="ftp://gentoo.llarian.net/pub/gentoo ftp://mirrors.tera-byte.com/pub/gentoo ftp://ftp.ucsb.edu/pub/mirrors/linux/gentoo/"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp/"
PORTDIR="/mnt/raid/portage"
PORTDIR_OVERLAY="/var/lib/layman/sunrise /var/lib/layman/mozilla /var/lib/layman/ibm-internal-cvs /var/lib/layman/zugaina /var/lib/layman/java-overlay /mnt/raid/portage/local/erict"
SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage"
USE="X a52 aac aalib acl acpi afs aim alsa amarok amd64 apache2 apic apm arch_perfmon asf aspell automount avahi avi bash-completion beagle bluetooth branding bts bzip2 cairo cdda cdparanoia cdr clflush cli cmov consolekit constant_tsc cpudetection cracklib crypt cups cx16 cx8 cxx dbus de dga directfb divx dri ds_cpl dts dv dvd dvdnav dvdr dvdread emboss enca encode est evo evolution exif fam fame fbcon ffmpeg firefox flac fortran fpu ftp fxsr gdbm gdu gif gimp gimpprint glib gmedia gnome-keyring gphoto2 gpm gtk gtkhtml hal hddtemp ht iconv inotify ipod jabber java javascript joystick jpeg keyring kpathsea lahf_lm lame latex lcms ldap libcaca libnotify live lm lm_sensors loop-aes lzma lzo mad mca mce meanwhile mmap mmx mmx2 mmxext mng modules monitor mozilla mp2 mp3 mp4 mp4live mpeg mplayer msn msr mtrr mudflap multilib musepack musicbrainz mysql ncurses nptl nptlonly nsplugin nvidia nx offensive ogg opengl openmp oscar pae pam pango pat pbe pcre pda pdf pebs pge php plotutils pmu png pni policykit ppds pppd prediction pse pse36 pth pulseaudio qt3support qt4 quicktime readline realmedia rep_good rtc samba sdk sdl sensord sep session smp sound spell ss sse sse2 sse3 ssl ssse3 startup-notification subtitles svg syscall sysfs tcpd tetex theora threads tiff tivo tm tm2 truetype tsc udev unicode urandom usb v4l v4l2 vdpau vim-syntax vme vorbis wmf wmp x264 xanim xcb xine xml xorg xpm xprint xscreensaver xtpr xulrunner xv xvid xvmc yahoo zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIRC_DEVICES="atiusb" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" SANE_BACKENDS="genesys gt68xx" USERLAND="GNU" VIDEO_CARDS="vesa fbdev intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON


Last edited by Oo.et.oO on Thu Jan 24, 2013 4:19 pm; edited 1 time in total
Back to top
View user's profile Send private message
Oo.et.oO
Apprentice
Apprentice


Joined: 23 Apr 2002
Posts: 291
Location: burlington

PostPosted: Fri Jan 18, 2013 4:32 pm    Post subject: Reply with quote

in emul-linux-x86-opengl-20121202-r1.ebuild:
Code:
# https://bugs.gentoo.org/show_bug.cgi?id=445712
SRC_URI="${SRC_URI} https://dev.gentoo.org/~pacho/emul-linux-x86-${PV}/glu-9.0.0.tbz2"

DEPEND="app-admin/eselect-opengl
        >=app-admin/eselect-mesa-0.0.9"
RDEPEND=">=app-emulation/emul-linux-x86-xlibs-20100611
        !<app-emulation/emul-linux-x86-xlibs-20100611
        media-libs/mesa"


in glu-9.0.0.ebuild:
Code:
RDEPEND="${DEPEND}
        !<media-libs/mesa-9
        multilib? ( !app-emulation/emul-linux-x86-opengl )"


but i don't have multilib turned on. actually multilib isn't in IUSE in the ebuild :roll:
note the SRC_URI of emul-linux-x86-opengl = glu-9.0.0.tbz2
i put -multilib in package.use to no avail.
Back to top
View user's profile Send private message
Oo.et.oO
Apprentice
Apprentice


Joined: 23 Apr 2002
Posts: 291
Location: burlington

PostPosted: Fri Jan 18, 2013 5:24 pm    Post subject: Reply with quote

oh. multilib is forced on in my profile, i think...
Code:
[ebuild  N     ] media-libs/glu-9.0.0  USE="(multilib) -static-libs" 482 kB

note the (multilib)
this is with "media-libs/glu -multilib" in package.use and package.use.force
and grepping for multilib in my profile gives nothing:
Code:
grep -R multilib /etc/make.profile/*


from AMD64 FAQ: http://www.gentoo.org/doc/en/gentoo-amd64-faq.xml#multilib :
Quote:
What is multilib and how can I use it?

Every AMD64 processor is able to run 32bit code as well as 64bit code. However, when you have a 32bit application, you are unable to mix it with 64bit libraries or vice versa. You can, however, natively run 32bit applications if all shared libraries it needs are available as 32bit objects. You can choose whether you want multilib support or not by selecting the according profile. The default is a multilib-enabled profile.

Warning: Currently you cannot switch from a no-multilib to a multilib-enabled profile, so think over your decision twice before you use the no-multilib profile.


so what's up with this thread that says "oh, just turn off multilib for glu"?
mesa-9999 and libGLU split-out:
http://forums.gentoo.org/viewtopic-t-935230-start-0.html
Back to top
View user's profile Send private message
Oo.et.oO
Apprentice
Apprentice


Joined: 23 Apr 2002
Posts: 291
Location: burlington

PostPosted: Wed Jan 23, 2013 7:10 pm    Post subject: Reply with quote

aha! my portage isn't picking up package.use.force from /etc/portage
had to put it in /etc/make.profile/

and then to get glu to install it has to overwrite libs from emul-linux-x86-opengl:
Code:
 *    /usr/lib64/libGLU.so
 *    /usr/lib64/libGLU.so.1

so i needed to do:
Code:
FEATURES="-collision-protect" emerge -av1D virtual/glu


Last edited by Oo.et.oO on Wed Jan 23, 2013 7:51 pm; edited 1 time in total
Back to top
View user's profile Send private message
SmeeHee
n00b
n00b


Joined: 23 Jan 2013
Posts: 2

PostPosted: Wed Jan 23, 2013 7:38 pm    Post subject: Reply with quote

Oo.et.oO wrote:
aha! my portage isn't picking up package.use.force from /etc/portage
had to put it in /etc/make.profile/ :x


You just beat me to it.

I had the same issue until I ran eselect and selected a new profile, now the upgrade works fine.


Cheers,
SmeeHee
Back to top
View user's profile Send private message
Oo.et.oO
Apprentice
Apprentice


Joined: 23 Apr 2002
Posts: 291
Location: burlington

PostPosted: Wed Jan 23, 2013 7:56 pm    Post subject: Reply with quote

SmeeHee wrote:

I had the same issue until I ran eselect and selected a new profile, now the upgrade works fine.


is there a profile without multilib? did you have to force glu emerge to overwrite libs from emul-linux-x86-opengl ?

still seems like a bug or hard-blocker to me... or maybe some ebuilds need to be updated to depend upon glu and not mesa, or something?
Back to top
View user's profile Send private message
SmeeHee
n00b
n00b


Joined: 23 Jan 2013
Posts: 2

PostPosted: Wed Jan 23, 2013 8:05 pm    Post subject: Reply with quote

Oo.et.oO wrote:
SmeeHee wrote:

I had the same issue until I ran eselect and selected a new profile, now the upgrade works fine.


is there a profile without multilib? did you have to force glu emerge to overwrite libs from emul-linux-x86-opengl ?

still seems like a bug or hard-blocker to me... or maybe some ebuilds need to be updated to depend upon glu and not mesa, or something?


After days of removing packages and manually adding bits to portage [mask, use, keywords, unmask], I simply went back to the original files of everything and eselect a new profile.

When I ran eselect profile it didn't actually show any profile selected, but I assume it would have been a 2010 profile, I selected default/linux/amd64/13.0/desktop/kde and now all the emerge completes without any intervention.

I have not looked at what it changed, but it finally allowed me to emerge world without the blockers.

Cheers,
SmeeHee
Back to top
View user's profile Send private message
Oo.et.oO
Apprentice
Apprentice


Joined: 23 Apr 2002
Posts: 291
Location: burlington

PostPosted: Thu Jan 24, 2013 4:18 pm    Post subject: Reply with quote

thanks SmeeHee. still getting tons of blockers with udev, and some qt/kde stuff, but i think they are independent of this thread.
marking as solved.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum